[Ffmpeg-devel-irc] ffmpeg.log.20160119

burek burek021 at gmail.com
Wed Jan 20 02:05:01 CET 2016

[02:18:03 CET] <johnnny22-afk> for some reason, ffmpeg doesn't seem to like a url with https://www.ffmpeg.org/ffmpeg-protocols.html#async in it :o/   It says "Cannot open file 'async:http://host/file.m3u8'
[02:19:00 CET] <johnnny22-afk> though, i'm not even sure if it would async load the related ts segments.
[02:21:17 CET] <J_Darnley> Is that really the *only* line ffmpeg prints?
[02:23:13 CET] <johnnny22-afk> actually, it seems to work, just not in mplayer :P
[03:43:45 CET] <thereh> I have directory with music and when I open it on android phone in some media player the player shows some photo, so it contains inside mp3 file right ? so I decided to remove the photo and reencode all files with that command: "for i in *; do echo ffmpeg -i ${i} -ac 2 -ar 44100 -ab 128k -c:a libmp3lame -f mp3 "new_dir/${i%.*}.mp3"; done"   but when I open it again in media player on the phone it still shows the photo, so how to get rid of the photo ? should I
[03:45:16 CET] <c_14> add -vn
[03:46:05 CET] <thereh> by the way is there a way to extract photo from mp3 files with ffmpeg ?
[03:47:11 CET] <johnnny22-afk> I'm trying to copy a HLS to disk by using ffmpeg to consume the stream and record it to disk. I've set -codec copy   since I'm trying to just copy the segments as-is, but ffmpeg still seems to want to segment the files according to it's own rules. Is there a way to make it just consume and write as-is to disk without modifying the data ?
[03:47:30 CET] <johnnny22-afk> data = fileformat structure and timecodes.
[03:49:26 CET] <johnnny22-afk> timecodes = sometimes I get warning saying Non-monotonous DTS in output stream, which causes the output to be a/v out of sync.
[03:54:40 CET] <c_14> thereh: ffmpeg -i mp3 -c:v copy -frames:v 1 out.jpg
[03:55:51 CET] <c_14> johnnny22-afk: no
[03:56:17 CET] <c_14> ffmpeg interptrets HLS as a continuous stream
[03:56:20 CET] <DHE> johnnny22-afk: might try the -copyts option to preserve source timestamps. but that's only safe if you use mpegts as the output format.
[03:58:35 CET] <johnnny22-afk> I am outputing to .ts files, but the codec is h264
[03:59:35 CET] <johnnny22-afk> would i use the -copyts as a input or output param ?
[04:00:00 CET] <c_14> output
[04:06:42 CET] <johnnny22-afk> doesn't seem to help the yellow warning
[04:06:55 CET] <thereh> thanks
[05:36:46 CET] <ac_slater> hey all. I'm playing with adding a raspi2 encoder to ffmpeg. I've succeeded except ONE (hopefully) small issue. The data coming out of the encoder is YUV420 Packed Planar. Meaning each unit has all three channels - YUV YUV YUV YUV instead of YYYYY UUUUU VVVVV. The result is my output is REALLY green. Does anyone have any clues how to 'convert' this?
[06:30:10 CET] <johnnny22-afk> is there a command to see how much time has passed since the start of the encoding process, or display how much time it took to do the job once it's done ?
[06:34:04 CET] <ac_slater> johnnny22-afk: in linux, `time ffmpeg ...` will tell you the total time
[06:34:15 CET] <johnnny22-afk> oh
[06:34:37 CET] <ac_slater> johnnny22-afk: and when I encode with ffmpeg 2.8, I get the total encoded time
[06:34:44 CET] <ac_slater> do you want total elapsed time?
[06:34:50 CET] <johnnny22-afk> elapsed
[06:35:06 CET] <johnnny22-afk> sadly i'm on windows in this test case :P
[06:35:18 CET] <ac_slater> oh shit lol
[06:35:24 CET] <johnnny22-afk> hehehehehe i know i know
[06:35:27 CET] <ac_slater> I can't help there mate
[06:35:56 CET] <johnnny22-afk> if I can permit myself to run it on linux (gotta check bandwidth) it'll do :)
[06:35:59 CET] <johnnny22-afk> but thanks !:)
[06:40:04 CET] <johnnny22-afk> it'll probably be fine on my vm to test ;)
[06:40:19 CET] <johnnny22-afk> it's a -codec copy anyways ;)
[06:40:21 CET] <ac_slater> johnnny22-afk: good luck mate
[06:43:51 CET] <johnnny22-afk> thanks
[06:50:11 CET] <ac_slater> johnnny22-afk: do you happen to know anything about YUV?
[06:56:39 CET] <c_14> ac_slater: you'd probably have to add a new pixel format. You might want to ask in #ffmpeg-devel
[06:58:21 CET] <ac_slater> c_14: thanks mate
[09:19:15 CET] <thereh> if I want to make timelapse and shoot pictures with phone the format pictures are: "mjpeg, yuvj422p(pc, bt470bg), 1600x960 [SAR 1:1 DAR 5:3]" so if I want to assemble them all into a video should I change some parameters ? I think that "yuvj422p" is not appropriate for video is it ? should I use option "-pix_fmt yuv420p" ? will it change colors or it would be safe to use it ?
[09:19:50 CET] <fritsch> yuvj422p is depcreated
[09:19:58 CET] <fritsch> it's  a yuv422p with full range
[09:20:34 CET] <fritsch> so - check if it sws_scale auto detects the full range properly when you pass it yuvj422p as input
[09:20:37 CET] <Mavrik> But that wasn't the question :)
[09:20:50 CET] <fritsch> "would it be safe to use it?"
[09:20:52 CET] <fritsch> he asked
[09:20:54 CET] <fritsch> answer: no
[09:20:56 CET] <Mavrik> thereh, yeah, if you want the video to be playable everywhere, you should convert it to YUV420P
[09:21:13 CET] <Mavrik> Since that's the only format all players support for H.264 (I assume that's what you want)
[09:21:30 CET] <Mavrik> It might have a small effect on colors but nothing noticable by most people.
[09:21:42 CET] <fritsch> lol? you want to see the effect? I can show you
[09:21:54 CET] <Mavrik> *shrug*
[09:22:02 CET] <Mavrik> Doesn't matter since he doesn't have a choice now does it?
[09:22:15 CET] <fritsch> https://dl.dropboxusercontent.com/u/55728161/sws_wrong_range.jpg
[09:22:17 CET] <fritsch> he has
[09:22:21 CET] <fritsch> and that's what I told him
[09:22:27 CET] <Mavrik> You're talking about color range not pixel format.
[09:22:37 CET] <Mavrik> Which will be handled by ffmpeg when conversion is done.
[09:22:38 CET] <fritsch> https://dl.dropboxusercontent.com/u/55728161/sws_right.jpg
[09:22:47 CET] <fritsch> ffmpeg will spit out a fat warning
[09:22:48 CET] <Mavrik> And the output color flags will be set accordingly.
[09:22:56 CET] <fritsch> as yuvj422p is not supported anymore
[09:22:58 CET] <Mavrik> (you already see them being set properly by the bt420bg=
[09:23:06 CET] <Mavrik> Yes it's a warning.
[09:23:07 CET] <fritsch> it will tell you: "take great care if you have set the correct range"
[09:23:08 CET] <Mavrik> It still works.
[09:23:18 CET] <Mavrik> If you check the source of swscale.
[09:23:21 CET] <fritsch> I did
[09:23:27 CET] <Mavrik> It sets the range properly when it spews out the warning.
[09:23:29 CET] <fritsch> when I implemented kodi's ffmpeg picture veiwer
[09:23:46 CET] <fritsch> i just linked the result
[09:24:07 CET] <Mavrik> Yeah, you fucked up the display because you didn't read the color range status from video stream.
[09:24:13 CET] <fritsch> lol
[09:24:19 CET] <fritsch> ffmpeg did that
[09:24:20 CET] <Mavrik> So instead of fixing that you reranged the video.
[09:24:26 CET] <fritsch> not really
[09:24:39 CET] <Mavrik> Anyway, it's beside the point.
[09:24:39 CET] <fritsch> man, you don't know really what you are talking about - do you?
[09:25:22 CET] <fritsch> that being said: the way to go is: use yuv422p as input and ask the input media for its range and set sws_scale params accordingly
[09:26:35 CET] <thereh> so I want it in mpeg4 format, will that be the right command:
[09:26:37 CET] <thereh> cat {001..500}.jpg | ffmpeg -f image2pipe -vcodec jpg -r 25 -i - -vcodec mpeg4 -vb 1500k -pix_fmt yuv420p -y -f avi timelapse.avi
[09:26:54 CET] <Mavrik> thereh, you want libx264 (H.264) not mpeg4 (MPEG4-SP)
[09:27:10 CET] <Mavrik> There's pretty much no reason to use MPEG4 these days and it will look like ass :)
[09:27:18 CET] <Mavrik> thereh, also stuff it into a mp4 container not AVI
[09:27:30 CET] <Mavrik> AVI is... problematic when it comes to compatibility and timestamps.
[09:29:41 CET] <fritsch> Mavrik: i take it back - you were right. sws_scale asks handle_jpeg and ors a 1 if yuvj422p is found. Thanks.
[09:33:54 CET] <klejp> How does system wide settings work? The reason I ask is because I have youtube-dl and ffmpeg installed. By default youtube-dl has written the files as is, but once I captured my desktop with ffmpeg and wrote to file in the .mkv and now every file that youtube-dl downloads by default is converted to mkv from mp4. Does one instance of ffmpeg change the default settings of ffmpeg?
[09:34:44 CET] <Mavrik> fritsch, yep, if you were building the viewer you had to watch for that because you had to adjust colors to the screen. When transcoding the range just gets transferred and dumped to the player which then has to do  TheRightThing(tm) :)
[09:35:16 CET] <fritsch> yeah - I wanted to reduce the warnings - so I had to go the manual way
[09:35:26 CET] <fritsch> asked ffmpeg for the range of yuvj420p
[09:35:27 CET] <Mavrik> also the API to set color range is painful now.
[09:35:30 CET] <fritsch> got JPEG_RANGE
[09:35:41 CET] <Mavrik> I still keep using yuvj* formats until they throw them out -_-
[09:35:45 CET] <fritsch> then told swscale to use yuv420p as input but with jpeg_range
[09:35:53 CET] <Mavrik> klejp, uhh... there's really no systemwide ffmpeg settings per-se.
[09:35:56 CET] <klejp> I used this command once ffmpeg -f alsa -i pulse -f x11grab -s 1366x768 -i :0.0 output.mkv and that now forces me to use youtube-dl [video-url] -f mp4
[09:35:58 CET] <klejp> ok
[09:36:08 CET] <Mavrik> so I see no reason why youtube-dl would change its default :/
[09:36:18 CET] <Mavrik> ffmpeg is pretty much totally stateless, it doesn't save any settings anywhere
[09:36:24 CET] <klejp> hmm
[09:36:29 CET] <klejp> gremlins
[09:36:49 CET] <fritsch> Mavrik: https://github.com/xbmc/xbmc/blob/master/xbmc/guilib/FFmpegImage.cpp#L340 <- worked okayish
[09:37:06 CET] <Mavrik> Ah.
[09:37:38 CET] <fritsch> a bit much code to silence the sws_scale warning though
[09:37:47 CET] <fritsch> I admit
[09:39:05 CET] <klejp> Mavrik: is there a way to change the defaults in ffmpeg so that is write mp4 instead of mkv?
[09:39:22 CET] <klejp> I have tried capturing via ogg but the quality sucks
[09:39:36 CET] <Mavrik> klejp, there's no default as I said :/
[09:39:49 CET] <Mavrik> if you tell ffmpeg to save to file with name ".mkv" it'll be mkv.
[09:40:00 CET] <Mavrik> Go check why youtube-dl is saving to files with name mkv.
[09:40:05 CET] <klejp> I know, I still had some hopes that someone put some possibility somewhere in the code
[09:40:40 CET] <klejp> Yes I know explicitly telling it does it
[09:40:44 CET] <klejp> :)
[09:41:12 CET] <debianuser> klejp: Maybe it's just a coincidence? For example you were downloading .mp4 formats from youtube and this time you tried to download separate video+audio, so youtube-dl put it into mkv.
[09:41:13 CET] <klejp> Thanks for your help
[09:42:37 CET] <klejp> debianuser. Perhaps, but I have not changed anything in my settings. I just use the default i.e command [url] and all of a sudden it started creating separate files and then merging to mkv
[09:43:01 CET] <debianuser> klejp: I mean maybe it's not because of ffmpeg, but because of youtube or youtube-dl. You can check `youtube-dl --list-formats http://your-youtube-url` to see available formats for your video and can select some specific format with `youtube-dl --format 18 http://your-youtube-url`
[09:43:29 CET] <klejp> debianuser: yes but I had to start sorting out the problem somewhere
[09:43:40 CET] <klejp> ffmpeg forum was the first place
[09:44:06 CET] <klejp> Like Dr Watson I am beaten by Sherlock Holmes everytime
[09:44:19 CET] <debianuser> Usually there're many different formats, and .mp4 is just one of them. :)
[09:45:18 CET] <klejp> I know, but by default the best are always downloaded and that is 720p mp4 not converting to mkv:)
[09:45:51 CET] <klejp> thanks everyone. I will check out what the -dl IRC can do for me.
[10:09:02 CET] <rektimus> if i do ffmpeg -i file1.mkv -c:v copy -c:a ac3 -b:a 640K file2.mkv
[10:09:09 CET] <rektimus> subtitles will be converted from srt to ass
[10:09:13 CET] <rektimus> and sometimes not
[10:09:16 CET] <rektimus> anyone know why?
[10:09:59 CET] <pzich> Maybe use -scodec copy too?
[10:10:35 CET] <rektimus> im going to going forward
[10:10:39 CET] <rektimus> i just dont get why its random
[10:11:45 CET] <pzich> no idea, are you sure the formats were exactly the same?
[10:12:55 CET] <rektimus> do you mean am i sure it was srt in all of them originally?
[10:13:24 CET] <rektimus> its 3 movies and i used mediainfo to check them all, mkv/h264/dca/srt
[10:13:49 CET] <rektimus> 2 of them were autoconverted to ass
[10:13:51 CET] <rektimus> one wasnt
[10:14:02 CET] <pzich> ¯\_(Ä)_/¯
[10:17:24 CET] <rektimus> yeah idk either
[10:23:40 CET] <chinmay_> hey everyone.
[10:24:01 CET] <chinmay_> i am trying to make a video from series of jpg images using ffmpeg
[10:24:50 CET] <pzich> what do you have so far?
[10:25:20 CET] <chinmay_> earlier i was using the libx264 video codec.
[10:25:41 CET] <chinmay_> ffmpeg -r 60 -i snaps/%d.jpg -c:v libx264 -crf 18 video.mp4
[10:26:05 CET] <chinmay_> i was using this command. this indeed gives me a video with an FPS of 60 and proper codec.
[10:26:33 CET] <chinmay_> when i see video properties, i can see codec info and even after that using -metadata i am able to specify metadata for the video.
[10:27:01 CET] <chinmay_> but now i want small file sizes and want to use H265 codec.
[10:27:16 CET] <chinmay_> so i changed the command to: ffmpeg -r 60 -i snaps/%d.jpg -c:v libx265 -crf 18 video.mp4
[10:27:46 CET] <chinmay_> this gives me the video but in properties, there is no codec info and no metadata.
[10:28:33 CET] <pzich> the video you get back plays? or no?
[10:28:49 CET] <chinmay_> yes it plays.
[10:29:29 CET] <chinmay_> but the videos which i am rendering, metadata information is necessary for their use.
[10:30:26 CET] <chinmay_> wait, i will pastebin the exact command and output.
[10:30:43 CET] <pzich> great
[10:31:05 CET] <pzich> Also, I don't know much about metadata, but it looks like it may be manually setable like this: http://unix.stackexchange.com/a/248711
[10:32:25 CET] <chinmay_> http://pastebin.com/t8PbDfqd
[10:33:22 CET] <chinmay_> http://imgur.com/dPILtDu
[10:33:28 CET] <chinmay_> i get this in properties.
[10:33:37 CET] <chinmay_> on the other hand, when i use libx264,
[10:34:24 CET] <chinmay_> i get this http://imgur.com/Q25utKa
[10:35:36 CET] <chinmay_> have a look at the Video section in both images. i just changed the codec in the command.
[10:35:51 CET] <chinmay_> and i am performing this on a series of jpg images.
[10:37:30 CET] <pzich> Unfortunately I don't know how to help. Do you need x265? I haven't used it.
[10:38:12 CET] <chinmay_> yes, i need x265.
[10:38:22 CET] <chinmay_> it will give a smaller file size with good quality.
[10:38:40 CET] <Mavrik> Right.
[10:38:45 CET] <chinmay_> http://www.bbc.co.uk/rd/blog/2016/01/h-dot-265-slash-hevc-vs-h-dot-264-slash-avc-50-percent-bit-rate-savings-verified
[10:38:54 CET] <chinmay_> i am following this article.
[10:39:04 CET] <Mavrik> Instead of that silly idea you should rather use a slower preset on libx264 and change CRF to something less insane, like 20 or 22 :)
[10:39:52 CET] <pzich> and have a lot more compatibility with 264
[10:40:20 CET] <chinmay_> i know that but doing that makes the video quality poor.
[10:40:33 CET] <iive> huh?
[10:41:12 CET] <chinmay_> okay. i will use x264
[10:41:14 CET] <chinmay_> thanks guys
[12:20:24 CET] <ented> Hello everyone.
[12:25:04 CET] <ented> I want to put AVPacket* to the queue should I put them with av_packet_move_ref() ? I have suspicion that when I put packet to array and av_read_frame .
[12:25:28 CET] <ented> It screws up old one.
[12:30:13 CET] <ented> I want to built packet queue to prepare feed for decoder. I am using std::vector<AVPacket*> as storage. Is it good idea to use av_packet_move_ref to new value and push that value to the vector?
[12:31:07 CET] <Mavrik> But you already have a pointer, what would be the point_
[12:31:08 CET] <Mavrik> ?
[12:40:09 CET] <ented> I am using single AVFrame packet and then I read it in the loop, will new av_read_frame would not overwrite everything? : http://pastebin.com/UzLwAb9m
[13:00:10 CET] <andrew2> Hi. I've got a question regarding the lens correction video filter. I'm using the following CLI options http://pastebin.com/Xyac5udg and it works but results in a green outer boarder. Is there a way to set this boarder to black?
[13:36:41 CET] <rektimus> what would i do to convert srt/ass to MPEG-4 Timed Text
[13:36:54 CET] <rektimus> -c:s ?
[13:37:28 CET] <furq> -c:s mov_text
[13:39:21 CET] <rektimus> thanks furq
[15:44:44 CET] <k_sze> Is it generally ok to av_frame_unref an AVFrame even if the corresponding AVCodecContext.refcounted_frames is 0?
[15:45:16 CET] <k_sze> Or to av_frame_unref an AVFrame multiple times?
[16:00:52 CET] <shincodex> uint16_t WN;
[16:01:01 CET] <shincodex> what do you suppose WN stands for?
[16:05:58 CET] <J_Darnley> word number?
[16:10:18 CET] <shincodex> its located in libgps gps.h
[16:10:36 CET] <shincodex> called Week Number within a unioned struct C code has extern cpluspluss
[16:10:41 CET] <shincodex> Its conflicting with something somehwere.
[16:18:45 CET] <J_Darnley> Perhaps you should put the exact error message somewhere along with some context if you want help from others.
[16:19:02 CET] <shincodex> Negative
[16:19:09 CET] <shincodex> problem is solved already
[16:19:18 CET] <J_Darnley> good
[16:19:25 CET] <shincodex> im printing it several channels to beat on bad dev work
[16:19:36 CET] <shincodex> windows forever
[16:19:38 CET] <shincodex> woo
[18:08:37 CET] <jonascj> Hi all. Anyone running 13 nightlies on Nexus 4 (mako)? I've been folllowing the forum on Nexus 4 (release and development), and they have been reporting various problems. Is it usable yet?
[18:23:09 CET] <Mavrik> uh?
[18:28:37 CET] <xintox> can anyone play any of these streams?
[18:28:49 CET] <xintox> http://tvecnbc-i.akamaihd.net/hls/live/218213/cnbcx/2b441e919c72a0831918016f43e27d61/master.m3u8?hdnea=st=1453221190~exp=1453257190~acl=/*~hmac=a59196786eef2f24fbbd07c9f2654d431ae06856681edd342b0fa1a46ffb441c
[18:29:10 CET] <xintox> i can't figure out how to construct an ffmpeg command that will play one of these streams
[18:29:32 CET] <xintox> ffmpeg -i '<stream-2560000k>' -c copy out.m3u8
[18:29:39 CET] <xintox> i always get 403 forbidden
[18:30:05 CET] <xintox> but if i open the manifest in safari it plays fine
[18:46:15 CET] <Kota> So, I've a question
[18:46:37 CET] <Kota> I have a .mkv file with a VP9 video stream and two audio streams, along with two .ass files.
[18:46:52 CET] <Kota> What's the best way to insert the subtitle streams to the video?
[18:48:45 CET] <furq> ffmpeg -i src.mkv -i src1.ass -i src2.ass -map 0 -map 1 -map 2 -c copy dest.mkv
[18:50:29 CET] <Kota> Ah, thank you. I appreciate it.
[18:50:37 CET] <Kota> Still trying to learn all the ins and outs of ffmpeg
[18:50:59 CET] <furq> it would work without -map if the mkv wasn't dual audio
[18:51:05 CET] <Kota> Is there a way to do it at the same time I'm transcoding my video?
[18:51:37 CET] <furq> just add -i src.ass -c:s copy to your ffmpeg command
[18:51:55 CET] <Kota> So...let me try
[18:52:54 CET] <Kota> E:\>ffmpeg -i "concat:VTS_02_1.VOB|VTS_02_2.VOB" -i SubsSigns.ass -i Subs.ass -c:s copy -map 0:v -map 0:a -c:v libvpx-vp9 -b:v 1M -threads 8 -speed 4 -tile-columns 6 -frame-parallel 1 -auto-alt-ref 1 -lag-in-frames 25 -c:a libopus -b:a 128k -vf yadif -pass 2 Milk_01-deinterlaced.mkv
[18:52:55 CET] <Kota> ?
[18:53:19 CET] <furq> if you're using -map then you probably need -map 1 -map 2 as well
[18:54:16 CET] <Kota> E:\>ffmpeg -i "concat:VTS_02_1.VOB|VTS_02_2.VOB" -i SubsSigns.ass -i Subs.ass -map 1 -map 2 -c:s copy -map 0:v -map 0:a -c:v libvpx-vp9 -b:v 1M -threads 8 -speed 4 -tile-columns 6 -frame-parallel 1 -auto-alt-ref 1 -lag-in-frames 25 -c:a libopus -b:a 128k -vf yadif -pass 2 Milk_01-deinterlaced.mkv
[18:54:17 CET] <Kota> ?
[18:54:30 CET] <furq> you probably want those after the existing -map calls but it's your choice
[18:54:38 CET] <Kota> Okay.
[18:55:03 CET] <furq> output streams are written in the order in which -map is called
[18:55:08 CET] <Kota> I'll admit my knowledge of ffmpeg is pretty...uh, haphazard
[18:55:12 CET] <Kota> Ah.
[18:55:38 CET] <furq> also you can probably replace -map 0:v -map 0:a with -map 0
[18:55:40 CET] <Kota> Is there a way to choose a subtitle stream to be automatically selected on playback? They call it making one default, right?
[18:55:48 CET] <furq> -map 0 will use all streams from input 0
[18:56:01 CET] <Kota> Okay.
[18:56:30 CET] <Kota> E:\>ffmpeg -i "concat:VTS_02_1.VOB|VTS_02_2.VOB" -i SubsSigns.ass -i Subs.ass -c:s copy -map 0 -map 1 -map 2 -c:v libvpx-vp9 -b:v 1M -threads 8 -speed 4 -tile-columns 6 -frame-parallel 1 -auto-alt-ref 1 -lag-in-frames 25 -c:a libopus -b:a 128k -vf yadif -pass 2 Milk_01-deinterlaced.mkv
[18:56:59 CET] <furq> i don't think there's a way to set the default subtitle track tag in mkv
[18:57:40 CET] <furq> iirc you can do it inplace with mkvpropedit
[18:57:59 CET] <Kota> I've got mkvtoolnix installed, so I should have that
[18:58:03 CET] <Kota> Don't think I have it in path though
[19:10:56 CET] <beastwick987> Hi! I am trying to compile the most recent FFMPEG with QuickSync support on Linux. I've install libmfx from lu-zero/mfx_dispatch and from what I understand I don't need the Intel Media SDK because libva is sufficient. Here is my pastebin with what I did and the errors: http://pastebin.com/iZPfpaMD
[19:25:21 CET] <Kota> (furq) Apparently the command doesn't like -map 0
[19:25:31 CET] <Kota> I have to use -map v:0 -map a:0
[20:22:48 CET] <Kota> Hmm
[20:22:56 CET] <Kota> Using that command, I lose the second audio stream
[21:26:25 CET] <digidog> okaayyy ... just to be sure, and no, I don't want to wake up the dragon ... but can somebody please confirm for me that when I run sudo apt-get install ffmpeg on Debian testing I am definitely get the original FFmpeg. Do you know what I mean?
[21:26:56 CET] <furq> yes you do
[21:27:09 CET] <digidog> furq: puhhh, thank you ... no I am better
[21:27:27 CET] <furq> libav-masquerading-as-ffmpeg is only in wheezy
[21:27:55 CET] <digidog> For a moment I wasn't sure because I remember exactly about that trap you mention
[21:28:12 CET] <digidog> furq++
[21:28:14 CET] <digidog> thank you
[21:28:28 CET] <furq> fyi libav's version numbering is different so you can easily tell
[21:28:57 CET] <digidog> furq: yeah I was comparing that too but still, how knows ... best is to ask in the ffmpeg irc, right? ;)
[21:29:57 CET] <digidog> furq: and sorry for touching this ... I needed to be sure. thanks a million.
[21:33:39 CET] <digidog> furq: do you rather recommend to build from source or to use the debian package before reporting on possible issues?
[21:40:44 CET] <thebombzen> digidog: the ffmpeg devs always recommend building from git master to test bugs
[21:41:59 CET] <digidog> thebombzen: hey :) thank you for taking the time to inform. good to know.
[21:42:50 CET] <phoracek> hi guys, i'm new to ffmpeg. is there any chance to control filters live from SuperCollider or any other live coding software?
[21:46:05 CET] <Betablocker> isnt super collider for sound ?
[21:48:18 CET] <phoracek> it is, but i'd like to just control filter parameters from there (synchronized with sound for example)
[21:49:08 CET] <Betablocker> what filter parameters do you think of ?
[21:50:42 CET] <phoracek> anything from here https://ffmpeg.org/ffmpeg-filters.html#Video-Filters is it possible to have ffmpeg player running and just enable or disable filters from command line?
[21:51:18 CET] <phoracek> i should read some docs first, i was just like 'wow, this is a cool tool'
[21:51:37 CET] <Betablocker> this is a good idea :)
[21:52:26 CET] <Betablocker> i dont understand "ffmpeg player"
[21:52:47 CET] <Betablocker> never heard of that tool &.
[21:52:55 CET] <furq> ffplay?
[21:53:12 CET] <Betablocker> never used that the last 10 years - to be honest
[21:53:18 CET] <phoracek> :D sorry, to be honest i have a very vague idea about what ffmpeg really is.
[21:54:06 CET] <phoracek> i'm looking for a tool for live video handling (filters, effects, rgb magic) which could be used together with supercollider
[21:54:48 CET] <phoracek> i like GEM plugin for pure data, but i want to code it. sorry this for off topic
[21:54:57 CET] <Betablocker> if you are familar with software development you could try to dev it phoracek
[21:55:07 CET] <Betablocker> +i
[21:55:38 CET] <phoracek> the another channel? i'll give it a try, but first some docs. i'm sorry for impulsive reaction
[21:55:58 CET] <Betablocker> no problem :)
[21:56:29 CET] <Betablocker> furq:  & https://ffmpeg.org/ffplay.html it exists :D omg &
[21:57:08 CET] <Betablocker> using ffmpeg for such a long time and never stop learning :)
[22:24:30 CET] <asdas> hi
[22:24:37 CET] <asdas> Can anybody help me with compiling ffmpeg with flags?
[22:25:12 CET] <asdas> I'm trying to disable the security buffer overflow check, using GS- and Gs-, but the ./configure decides it shouldn't work. I'm using MSVC as compiler and msys
[22:27:19 CET] <J_Darnley> So what's your configure line and what does config.log say about them?
[22:27:55 CET] <asdas> ./configure --enable-asm --enable-yasm --disable-ffserver --disable-avdevice --disable-doc --disable-ffplay --disable-ffprobe --disable-ffmpeg --enable-static --disable-shared --disable-bzlib --disable-libopenjpeg --disable-iconv --disable-zlib --prefix=/c/ffmpeg --toolchain=msvc --arch=i386 --extra-cflags="/GS- /Gs- -MD" --extra-ldflags="/NODEFAUL
[22:27:56 CET] <asdas> TLIB:libcmt"
[22:28:37 CET] <J_Darnley> Please use a pastebin like site for the log.
[22:29:07 CET] <asdas> alright
[22:31:31 CET] <asdas> http://pastebin.com/twbszT9D
[22:31:43 CET] <asdas> config doesn't mind it, but the make does
[22:32:12 CET] <asdas> it tries to read C:/msys64/GS- and C:/msys64/Gs-
[22:32:24 CET] <asdas> even though, /GS- and /Gs- are supposed to be flags.
[22:34:07 CET] <J_Darnley> Is that shell doing something tricky?
[22:34:16 CET] <J_Darnley> What if you change the / for -
[22:34:17 CET] <J_Darnley> ?
[22:34:44 CET] <asdas> well it ends up compiling, but then it just ignores it and the buffer overflow check gets added anyways
[22:37:26 CET] <J_Darnley> Yes because that poor program seems to ignore things it doesn't understand
[22:38:08 CET] <asdas> msvc does understand it
[22:38:14 CET] <asdas> it works fine if i do it e.g. via cmd.exe
[22:38:20 CET] <asdas> and use the /GS- flag manually there
[22:38:26 CET] <asdas> then the program gets compiled without the buffer overflow check
[22:38:38 CET] <asdas> but if I try to use the same flag in this big ffmpeg compiling setup, it doesn't
[22:39:01 CET] <J_Darnley> I don't even speak German or MSVC and I can see that cl is ignoring things it doesn't understand
[22:39:33 CET] <asdas> yea, its ignoring it, because it ends up as C:/msys64/GS
[22:39:37 CET] <asdas> it should be /GS-
[22:39:57 CET] <asdas> http://i.imgur.com/6D3x7Oe.png
[22:40:20 CET] <J_Darnley> Unknown things should be errors!
[22:40:51 CET] <asdas> I know dude, but I don't write C:/mysys64/GS-
[22:40:52 CET] <J_Darnley> I will blame your shell for unhelpfully translating the "file" /GS into its Windows path
[22:40:57 CET] <asdas> :(
[22:41:14 CET] <furq> 21:34:16 ( J_Darnley) What if you change the / for -
[22:41:15 CET] <J_Darnley> Which is why I said "What if you change the / for -"
[22:41:17 CET] <furq> did this actually happen yet
[22:41:54 CET] <asdas> can you recommend me any other shell besides msys
[22:42:04 CET] <drv> you can cross-compile from cygwin
[22:42:12 CET] Action: J_Darnley always uses Cygwin
[22:42:17 CET] <drv> (it even has mingw-w64 packages)
[22:42:24 CET] <furq> won't that have the exact same problem
[22:42:28 CET] <J_Darnley> No
[22:42:33 CET] <furq> unless you mean using mingw instead of msvc
[22:42:40 CET] <furq> in which case you can do that from msys too
[22:42:41 CET] <J_Darnley> It won't translate filenames for native programs
[22:42:55 CET] <drv> only the msys shell does the braindead /path -> C:/mingw/path translation
[22:43:06 CET] <asdas> this is so annoying, I wish someone would have just uploaded avcodec.lib/avutil.lib in statically linked somewhere
[22:43:14 CET] <furq> are you sure it doesn't work with -Gs-
[22:43:19 CET] <asdas> yea
[22:43:36 CET] <furq> those are normally interchangeable on windows but i have no idea what msvc does
[22:44:07 CET] <J_Darnley> Oh my.  What's this I've found?  http://ffmpeg.zeranoe.com/builds/
[22:44:17 CET] <asdas> I saw that too
[22:44:21 CET] <asdas> They aren't statically linked
[22:44:27 CET] <asdas> They still require the avcodec.dll etc
[22:44:38 CET] <J_Darnley> oh
[22:45:26 CET] <furq> i take it you mean the libs and not the binaries
[22:45:31 CET] <asdas> yea
[22:45:33 CET] <asdas> .lib files
[00:00:00 CET] --- Wed Jan 20 2016

More information about the Ffmpeg-devel-irc mailing list