[Ffmpeg-devel-irc] ffmpeg.log.20160120

burek burek021 at gmail.com
Thu Jan 21 02:05:01 CET 2016

[01:09:45 CET] <johnnny22-afk> ffmpeg really seems to need improvements on HLS streams
[01:10:44 CET] <rektimus> why
[01:11:03 CET] <johnnny22-afk> well, humm, lemme think.
[01:11:17 CET] <johnnny22-afk> in general it's fine, dont get me wrong.
[01:12:09 CET] <johnnny22-afk> i know it's a bit of a cheap shot to say it needs improvements : P
[01:13:21 CET] <rektimus> yeah but you havent said how it needs improvement
[01:13:39 CET] <johnnny22-afk> things I would imagine being improved, and then again, maybe i'm wrong in suggesting that such improvements should be in ffmpeg and not the player, but since my knowledge about where to draw the line between the player vs the library is sparse, I'm going to put them out here.
[01:14:01 CET] <johnnny22-afk> regarding the player, it also affect ffplay, so I assume it's related to the library.
[01:21:48 CET] <johnnny22-afk> on a LIVE HLS stream (with no #EXT-X-ENDLIST yet) playback always start at the edge/end of the stream (3 segments from the end, I assume). Using the -live_start_index 0 does indeed permit to start at the 1st available segment within that m3u8 playlist, fine fine. But now comes the tricky part--> Seeking within the list of available segments should be possible, either by segment jumps or by
[01:21:48 CET] <johnnny22-afk> timecode if possible. I did notice that ffplay does seem to be able to seek 'forward' in such a stream, but 'backward' it seems to seek forward a tiny bit everytime it's attempted.
[01:21:58 CET] <J_Darnley> The best improvement: delete all streaming-related code
[01:22:30 CET] <johnnny22-afk> If the HLS does have a #EXT-X-ENDLIST, seeking backward does seem to work in ffplay.
[01:22:56 CET] <furq> J_Darnley: don't make me have to use vlc
[01:23:09 CET] <furq> i'm pretty sure the geneva convention forbids it
[01:24:07 CET] <J_Darnley> It should be cut out from VLC too for streaming is cancer.
[01:24:13 CET] <johnnny22-afk> And in all cases, if it's over the internet, I feel like seeking causes ffplay to attempt at loading every single segments that follows or precedes sequentially to fine the timecode it attempted to seek at.
[01:25:00 CET] <furq> if there was no streaming when why would vlc even exist
[01:25:03 CET] <johnnny22-afk> thus, seeking 10 minutes forward, causes every single segments that follows to be downloaded and processed, until it reaches the right one and then starts playing from there on.
[01:25:17 CET] <johnnny22-afk> PS: VLC doesn't handle this whole thing any better.. :P
[01:25:41 CET] <johnnny22-afk> I haven't even seen a way to ask VLC to start at the 1st segments on a m3u8 that doesn't have a #EXT-X-ENDLIST yet.
[01:26:05 CET] <johnnny22-afk> haven't seen = doesn't seem to be in their code.
[01:26:29 CET] <johnnny22-afk> so that's it. my take on possible improvements to HLS
[01:26:49 CET] <johnnny22-afk> to take or throw away, i don't really care, just sharing my experiences :)
[01:28:16 CET] <johnnny22-afk> And I'm bringing all this up, because it would be nice to see those things improved somehow, but i'm not 100% sure how much is affected by ffmpeg or the player that uses it (ex: mplayer).
[01:28:19 CET] <furq> isn't there some kind of bug tracker for feature requests
[01:29:16 CET] <johnnny22-afk> Also, mpeg-dash is probably in the works or maybe completed (no clue) and the mechanisms are probably very similar. Thinking there might be things to be taken from the  mpeg-dash code to put into the hls code ;)
[01:30:30 CET] <johnnny22-afk> there probably is :P   I've only taken the time to bring this up to the vlc bug tracker about a month ago, since that was where I was investigating my options at the time. But now i'm back to mplayer as my best choice player and thus ffmpeg is not far :)
[01:31:02 CET] <johnnny22-afk> I guess I'll have to generate a feature request.
[01:33:34 CET] <johnnny22-afk> regarding mpeg-dash, at least maybe keep those types of improvements/use-cases to not create the same issues in mpeg-dash :)
[01:34:38 CET] <Krish> Hi, could someone help me to compile libx264 in windows 10 x64. I know its not exactly ffmpeg topic, but since im not getting any support from them Im asking here.
[01:36:43 CET] <J_Darnley> I saw your email and the reply.  The solution was "use another shell".
[01:37:47 CET] <rektimus> lol
[01:37:56 CET] <rektimus> is he trying to use msvc++?
[01:38:04 CET] <furq> jimmy d bringing the pain
[01:38:18 CET] Action: J_Darnley goes to find a weblink
[01:38:52 CET] <J_Darnley> https://mailman.videolan.org/pipermail/x264-devel/2016-January/011554.html
[01:39:04 CET] <Krish> @Darnley - is that to me? I am absolutely clueless about linux/bash. I'm trying to create a Winrt component. I was able to successfully compile ffmpeg based on the steps provided
[01:39:26 CET] <J_Darnley> Yes
[01:39:50 CET] <J_Darnley> I am completely clueless about MSVC.
[01:40:03 CET] <Krish> :(
[01:40:03 CET] <J_Darnley> I don't know why the shell matters.
[01:40:07 CET] <rektimus> if you want to make a windows binary only
[01:40:09 CET] <rektimus> dont use msvc
[01:40:19 CET] <rektimus> if you really want an msvc binary
[01:40:19 CET] <rektimus> glwt
[01:40:30 CET] <Krish> glwt?
[01:40:33 CET] <J_Darnley> I guess it doesn't show the host correctly
[01:40:36 CET] <rektimus> good luck with that
[01:40:51 CET] <Krish> lol got it
[01:40:56 CET] <rektimus> its doable im sure
[01:40:58 CET] <rektimus> just not easy
[01:41:06 CET] <rektimus> not as easy as cygwin
[01:41:12 CET] <J_Darnley> The reply to your email suggests that using "MinGW-w64" will work
[01:41:21 CET] <furq> ^
[01:41:25 CET] Action: J_Darnley dropped several words
[01:41:33 CET] <J_Darnley> The reply to your email suggests that using the "MinGW-w64" shell will work
[01:41:38 CET] <rektimus> theres already windows x64 binaries
[01:41:43 CET] <Krish> yes I am already using that as part of the ffmpeg compilation process for win 10
[01:41:44 CET] <rektimus> why do you need to make a custom one
[01:42:09 CET] <J_Darnley> No doubt because he wants to embed in some other program and violate the license
[01:42:09 CET] <Krish> I need the win 10 x64 dll and lib with libx264 enabled
[01:42:10 CET] <furq> the msys shell is for compiling binaries for msys, i.e. that require msys.dll
[01:42:21 CET] <furq> use the mingw shell if you want to compile regular windows binaries
[01:42:34 CET] <furq> there should be shortcuts to both in your root msys2 dir
[01:42:43 CET] <Krish> no mate, I am trying to add some feature to FFMPEGInterop microsoft github project
[01:42:57 CET] <Krish> I am tring to enable libx264 for ffmpeg
[01:43:01 CET] <Krish> thats all
[01:43:20 CET] <Krish> the project currently supports only decoding not encoding
[01:44:09 CET] <Krish> hope u get me
[01:45:15 CET] <J_Darnley> I understand mostof the words
[01:46:01 CET] <Krish> If you see this link you'll get it : https://trac.ffmpeg.org/wiki/CompilationGuide/WinRT
[01:46:25 CET] <Krish> this tells me how to compile ffmpeg for Win 10 RT
[01:46:59 CET] <Krish> but this dont have libx264. When i tried --enable-libx264 I got the error "libx264 could not be found"
[01:47:16 CET] Action: J_Darnley is shocked!
[01:47:20 CET] <furq> if only anyone had some suggestions about how to fix it
[01:47:43 CET] <Krish> then I hgot to know that this is an external library and I need to first compile libx264 and then enable it.
[01:49:27 CET] <Krish> So I followed this: https://trac.ffmpeg.org/wiki/How%20to%20quickly%20compile%20libx264
[01:50:58 CET] <Krish> Where my problem started. I says "Unknown system msys-pc,edit the configure"
[01:51:26 CET] <Krish> which brings me here
[01:54:04 CET] <J_Darnley> Did you read the reply to your email?
[01:57:32 CET] <Krish> in the ffmpeg mailman?
[01:59:24 CET] <Krish> I dont see anything from your name there. Only one Moritz has replied sayng he cant see the error I mentioned in the source
[02:00:02 CET] <rektimus> <furq> the msys shell is for compiling binaries for msys, i.e. that require msys.dll
[02:00:02 CET] <rektimus> <furq> use the mingw shell if you want to compile regular windows binaries
[02:00:02 CET] <rektimus> <furq> there should be shortcuts to both in your root msys2 dir
[02:00:18 CET] <rektimus> <J_Darnley> The reply to your email suggests that using the "MinGW-w64" shell will work
[02:00:35 CET] <furq> 00:38:52 ( J_Darnley) https://mailman.videolan.org/pipermail/x264-devel/2016-January/011554.html
[02:00:38 CET] <furq> you forgot that one
[02:00:47 CET] <rektimus> lol
[02:00:55 CET] <furq> so in other words, it's a mystery
[02:00:57 CET] <rektimus> tl;dr
[02:00:58 CET] <rektimus> <Krish> Where my problem started. I says "Unknown system msys-pc,edit the configure"
[02:01:02 CET] <rektimus> dont use msys!
[02:01:51 CET] <Krish> but thats what ffmpeg wiki says. and ffmpeg compiled just fine for win 10.
[02:02:12 CET] <rektimus> wikis arent always right
[02:02:19 CET] <rektimus> especially when you want to do something different
[02:02:43 CET] <furq> the ffmpeg wiki says to use the msys shell for ffmpeg
[02:02:46 CET] <furq> it doesn't say to use it for libx264
[02:03:26 CET] <furq> which is good because i heard a rumour that it won't work and you have to use the mingw shell
[02:04:24 CET] <Krish> ok got bits of it
[02:07:09 CET] <Krish> and Darnley saw your reply. Thank you.I dont now the command to execute msys from mingw. let me check though
[02:07:31 CET] <furq> if you meant make then it's mingw32-make
[02:07:57 CET] <Krish> no, he adviced me to start MSYS2 using the MinGW-w64
[02:08:04 CET] <Krish> and then try
[02:18:06 CET] <Krish> Nope, still the same error. This is what I tried, opened Mingw-w64 shell in admin mode and ran /c/msys64/msys2_shell.bat
[02:18:29 CET] <Krish> which opened Msys2, then I tried ./Configure --enable-shared
[02:18:39 CET] <J_Darnley> Why did you do that second thing?
[02:19:25 CET] <Krish> you asked me to open MSYS2 from Mingw64. Generally for ffmpeg I open this from VS command prompt
[02:19:29 CET] <J_Darnley> No
[02:19:34 CET] <J_Darnley> None of us did
[02:19:47 CET] <Krish> I mean not you, the mail reply
[02:19:49 CET] <J_Darnley> Oh wait yes the email does
[02:19:54 CET] Action: J_Darnley leaves
[02:21:22 CET] <Krish> let me try directly from mingw64 as furq suggested
[02:23:13 CET] <Krish> well :) ./configure successfully executed
[02:23:32 CET] <Krish> just hit make. I'll update you the result
[02:24:08 CET] <Krish> failed with this error
[02:24:09 CET] <Krish> libx264.a(cpu.o):cpu.c:(.text+0x631): undefined reference to `pthread_num_proces                                                   sors_np'
[02:24:09 CET] <Krish> libx264.a(cpu.o):cpu.c:(.text+0x631): relocation truncated to fit: R_X86_64_PC32                                                    against undefined symbol `pthread_num_processors_np'
[02:24:09 CET] <Krish> collect2: error: ld returned 1 exit status
[02:24:09 CET] <Krish> Makefile:202: recipe for target 'x264.exe' failed
[02:24:09 CET] <Krish> make: *** [x264.exe] Error 1
[02:38:30 CET] <iive> Krish: relocation errors are common when you mix PIC and non-PIC 64bit code
[02:39:17 CET] <iive> since there is no speed penalty on 64bit, it is recommended to always compile 64bit code with PIC
[02:44:08 CET] <Krish> could you please give me the command for compiling with PIC in 64 bit code for mingw w64
[02:44:52 CET] <iive> do you run configure?
[02:45:04 CET] <iive> it should have pic option
[02:45:48 CET] <iive> e.g. --enable-pic
[02:46:24 CET] <Krish> got it
[02:46:26 CET] <Krish> its there
[02:46:34 CET] <Krish> i'll give it a try
[02:48:16 CET] <Krish> tried with --enable-pic option
[02:48:18 CET] <Krish> same error
[02:49:02 CET] <iive> i'm out of ideas...
[02:49:10 CET] <iive> try with --disable-pic
[02:49:22 CET] <iive> and don't forget to do `make distclean`
[02:49:33 CET] <iive> before configure... just in case
[02:50:17 CET] <Krish> no such option for disable-pic
[02:53:41 CET] <Krish> anyways thanks man for trying to help :)
[02:53:58 CET] <Krish> i'll continue to try few things
[02:54:54 CET] <iive> Krish: i guess you could try to disable theading... it would make x264 slow...
[02:55:12 CET] <Krish> ok let me try that
[02:55:38 CET] <iive> i see that there is --enable-win32thread ... looks like that might work for you.
[02:55:52 CET] <iive> sorry gtg
[02:56:00 CET] <iive> good luck :)
[03:42:04 CET] <brotherBox> hi guys. i'd like to record a skype call on linux with the video, hopefully limited to the video window, and the audio, both my microphone input as well as what my speakers would put out. i have looked things up a bit but found no way that does not involve messing with sound devices. is there a ffmpeg preset that does it all for me already? if not, how can i achieve what im out to do?
[03:43:27 CET] <waressearcher2> brotherBox: hallo und herzlich willkommen
[03:43:41 CET] <brotherBox> guten morgen haha
[03:43:47 CET] <brotherBox> but lets restrict ourselves to english
[03:46:50 CET] <c_14> brotherBox: there's no easy way. You'll have to capture the screen https://trac.ffmpeg.org/wiki/Capture/Desktop and audio https://trac.ffmpeg.org/wiki/Capture/ALSA
[03:46:56 CET] <c_14> You can also capture audio using pulse
[03:47:45 CET] <brotherBox> i cant believe nobody has put out a recipe for that
[03:51:36 CET] <rektimus> http://www.webupd8.org/2014/03/automatically-record-skype-calls-linux-skype-call-recorder.html
[03:51:40 CET] <rektimus> you mean like this?
[03:52:37 CET] <rektimus> http://unix.stackexchange.com/questions/11702/how-to-record-skype-video-calls-on-linux
[03:52:45 CET] <rektimus> This command will capture your full desktop: So use this command, whenever you want to record skype-conversation ( or anything else )
[03:52:46 CET] <rektimus> ffmpeg -f x11grab -s wxga -r 25 -i :0.0 -sameq /tmp/out.mpg
[03:53:15 CET] <rektimus> to record a specific window with recordmydesktop, use "xwininfo" to get the window id, then with recordmydesktop use the "--windowid" parameter
[03:53:18 CET] <c_14> oh boy
[03:53:24 CET] <c_14> how old is that command
[03:53:28 CET] <c_14> never use -sameq
[03:53:45 CET] <rektimus> 	
[03:53:45 CET] <rektimus> edited Jun 13 '11 at 10:07
[03:53:57 CET] <c_14> yeah
[03:54:21 CET] <rektimus> but anyways yeah
[03:54:25 CET] <rektimus> install recordmydesktop
[03:54:29 CET] <rektimus> and pipe its grab to ffmpeg
[04:02:11 CET] <arcetera> ffmpeg instantly segfaults, even when run without arguments. Tried both from version 2.8.4 and git.
[04:02:23 CET] <arcetera> What am I doing wrong here
[04:02:31 CET] <arcetera> like
[04:02:38 CET] <arcetera> no error messages, no nothing, just insta segfault
[04:02:52 CET] <c_14> Did you build it yourself? Is it from distro repos? What distro?
[04:03:03 CET] <arcetera> CRUX 3.2
[04:03:09 CET] <arcetera> built from ports
[04:03:56 CET] <c_14> Can you build with debug symbols and provide a backtrace?
[04:04:06 CET] <arcetera> I have no idea how to do that
[04:04:47 CET] <arcetera> hold up
[04:05:02 CET] <arcetera> --enable-debug?
[04:05:37 CET] <c_14> Also --disable-stripping probably
[04:06:05 CET] <arcetera> so --enable-debug --disable-stripping with ./configure
[04:06:06 CET] <arcetera> on it
[04:06:15 CET] <arcetera> and building
[04:08:47 CET] <arcetera> don't run source-based kiddies
[04:12:48 CET] <arcetera> don't ask IRC questions late at night or you have to stay up later
[04:13:23 CET] <c_14> But where's the fun in that.
[04:14:08 CET] <arcetera> okay, how what
[04:14:14 CET] <arcetera> s/h/n/
[04:14:38 CET] <c_14> Either run it in a debugger, or run it and then process the crash dump in a debugger
[04:15:04 CET] <arcetera> OH BOY
[04:15:08 CET] <arcetera> NOW I GET TO BUILD GDB
[04:15:51 CET] <c_14> Nothing quite as interesting as watching code compile.
[04:16:18 CET] <arcetera> I'm gonna sleep
[04:16:55 CET] <chungy> your distro doesn't have a binary of gdb? o.O
[04:17:43 CET] <arcetera> chungy: my distro doesn't have binaries period
[04:18:08 CET] <arcetera> source distros are fun
[04:20:08 CET] <arcetera> oh dear me
[04:20:14 CET] <arcetera> well i give up
[04:20:20 CET] <arcetera> on libressl that is
[04:20:48 CET] <arcetera> aight
[04:20:53 CET] <arcetera> no more segfaults, but missing .so
[04:21:07 CET] <arcetera> and looks like i'm rebuilding
[04:21:29 CET] <arcetera> night
[04:21:37 CET] <arcetera> I'll be waiting for it to compile while I'm asleep
[07:36:36 CET] <rektimus> :(
[07:36:42 CET] <rektimus> efnet has been netsplit for like 5 hours
[07:36:54 CET] <rektimus> i aint got no one to ramble with :'(
[07:43:20 CET] <digidog> rektimus: why? isn't freenode and OFTC not enough space to ramble around? :)
[07:43:45 CET] <rektimus> freenode is full of too many european oss people
[07:43:49 CET] <rektimus> they didnt grow up on real irc
[07:43:54 CET] <rektimus> everyones feelings get hurt so easily
[07:46:43 CET] <digidog> rektimus: and you think this depends on the main IRC server netwoorks they use? :)
[07:46:51 CET] <rektimus> it does
[07:46:54 CET] <digidog> LOL
[07:46:59 CET] <rektimus> freenode has rules against being an asshole
[07:48:24 CET] <digidog> rektimus: oss people -> https://en.wikipedia.org/wiki/Category:People_from_Oss  :-P
[07:48:30 CET] <rektimus> https://freenode.net/policy.shtml#offtopic
[07:49:21 CET] <rektimus> "arious forms of antisocial behavior, including (but not limited to) political, racial, ethnic, religious or gender-related invective. Off-topic activity may result in users being barred from the network"
[07:49:27 CET] <rektimus> ^ where most meaningful dialog occurs
[07:49:34 CET] <digidog> rektimus: yep, I saw it ,)
[07:50:09 CET] <rektimus> that doesnt happen on efnet
[07:50:13 CET] <rektimus> you might get banned from a channel
[07:50:15 CET] <rektimus> not the network
[07:50:57 CET] <rektimus> cause EU, etc is too PC
[07:51:02 CET] <rektimus> cant hurt anyones feelers
[07:51:39 CET] <rektimus> when in reality thats why the irc gods invented ignore
[07:51:44 CET] <digidog> rektimus: Well, I think there are bigger probs then IRC network rules and EU is too big for general statements on it and if the conversation is connected to a meaningful discussion I am pretty sure it wouldn't be interpreted as sth from above.
[07:52:27 CET] <rektimus> i could go on for hours on one of those subtopics
[07:52:29 CET] <rektimus> not in here
[07:52:31 CET] <rektimus> but in general
[07:52:41 CET] <rektimus> id easily get banned from freenode for half the shit i say on efnet
[07:52:54 CET] <digidog> LOL
[07:53:01 CET] <rektimus> freenode is not free!
[07:53:04 CET] <rektimus> its gratis!
[07:53:12 CET] <rektimus> gratisnode
[07:53:14 CET] <rektimus> /rms
[07:53:23 CET] <digidog> never mind. dont worry. your network will come back :)
[07:53:46 CET] <rektimus> no lie man
[07:53:56 CET] <rektimus> ive been banned for a few days here for hurting someones feelings
[07:54:49 CET] <rektimus> and its always the same communit tactic!
[07:54:58 CET] <rektimus> start a provacitive discussion
[07:54:59 CET] <digidog> well, evrythings for sth good. you maybe can make a wlk thru the naibourhood ...
[07:55:04 CET] <rektimus> and when someone says something you disagree with
[07:55:07 CET] <rektimus> call it hatespeech and cry
[07:55:22 CET] <rektimus> communist*
[07:55:50 CET] Action: rektimus puts on his 'MURICA cap
[08:12:57 CET] <rektimus> star trek movies are so lulz
[08:13:02 CET] <rektimus> y u make sound in space!?
[09:33:28 CET] <k_sze[work]> I would like to use the ffmpeg command to check if a .nut file is somehow malformed, in a script.
[09:33:59 CET] <k_sze[work]> I'm guess I should set the loglevel so that ffmpeg writes to stderr only if there is a problem with the .nut file
[09:34:15 CET] <k_sze[work]> but what loglevel should I realisticly set? error or warning?
[09:35:35 CET] <rektimus> prob warning
[12:04:47 CET] <rektimus> ughhhhh
[12:04:54 CET] <rektimus> debating on converting dts/ac3 to flac!
[12:12:58 CET] <c_14> ...
[12:13:09 CET] <c_14> Unless it's DTS-HD MA, what are you even?
[12:15:49 CET] <chungy> converting ac3 to flac is dumb, it's always lossy
[12:15:52 CET] <rektimus> compatability
[12:16:05 CET] <chungy> few things are incapable of playing back ac3
[12:16:10 CET] <rektimus> what doesnt support pcm
[12:17:24 CET] <chungy> DTS-HD MA... you could have a purpose for it, since it is a lossless codec, but you would lose some of its features (like good downmixing if it's a 5.1 or 7.1 source)
[12:19:52 CET] <rektimus> i dont use dts
[12:19:57 CET] <rektimus> so i already convert dts to ac3
[12:20:42 CET] <rektimus> this seems wtf though
[12:20:44 CET] <rektimus> dts to flac
[12:20:46 CET] <rektimus> added 1gb
[12:21:01 CET] <rektimus> 1.1gb
[12:21:10 CET] <c_14> sure
[12:21:13 CET] <c_14> dts isn't lossless
[12:21:15 CET] <c_14> flac is
[12:21:30 CET] <rektimus> oh
[12:21:35 CET] <rektimus> i thought the compression would help a bit
[12:21:56 CET] <c_14> no
[12:21:57 CET] <rektimus> looks like im sticking with ac3
[12:21:59 CET] <c_14> well
[12:22:01 CET] <rektimus> saves me 12 hours of reencoding
[12:22:03 CET] <c_14> the flac is smaller than pcm
[12:22:16 CET] <rektimus> so
[12:22:26 CET] <rektimus> flac<pcm>>>dts
[12:25:52 CET] <chungy> It's not usually a good idea to convert from lossy (such as DTS Core or DTS-HD) to a lossless codec, particularly for long-term storage (sometimes you might do it for temporary compatibility, especially something like pcm_s16le...)
[12:26:12 CET] <chungy> You get all the disadvantages of both lossy and lossless that way. It doesn't gain quality, and increases the stream size significantly
[12:26:33 CET] <rektimus> how do you chime in about dts to ac3
[12:26:36 CET] <rektimus> since i dont have dts
[12:26:52 CET] <c_14> Well, you'll lose quality.
[12:26:57 CET] <c_14> May or may not be noticeable.
[12:27:01 CET] <c_14> Also depends on the bitrates.
[12:27:20 CET] <chungy> *nods* usually not a good idea to convert from lossy to lossy either. The first time is usually acceptable, but quality drops off rapidly with more lossy encodes
[12:27:37 CET] <chungy> Normally best to keep it as the original codec except when you need to make a file for compatibility
[12:27:44 CET] <rektimus> ^
[12:27:50 CET] <rektimus> i got the original dts stored
[12:27:58 CET] <rektimus> for when i upgrade all 3 tvs to dts/hd
[12:28:06 CET] <rektimus> whether its dts/hd
[12:28:08 CET] <rektimus> i got them
[12:28:22 CET] <rektimus> i mean i could add an ac3 from dts stream to the file
[12:28:24 CET] <rektimus> but meh
[12:28:37 CET] <rektimus> maybe you guys can help me solve this
[12:28:49 CET] <rektimus> i got a 1920x800 video
[12:29:13 CET] <rektimus> when i watch it through dlna or through local usb playback on bluray
[12:29:21 CET] <rektimus> it adds like 1px line to top/bottom
[12:29:30 CET] <rektimus> thats whiteish with blended colors from scene above/below it
[12:29:52 CET] <rektimus> but when i watch with software on windows
[12:29:54 CET] <rektimus> like vlc etc
[12:29:55 CET] <rektimus> no line
[12:30:21 CET] <chungy> sounds like a player bug
[12:30:58 CET] <rektimus> im thinking so
[12:31:05 CET] <rektimus> cause the mod is divisible by blocks right
[12:31:10 CET] <rektimus> 1920x800
[12:31:17 CET] <rektimus> should perfectly fit in a 1920x1080 window
[12:31:58 CET] <chungy> yeah it should
[12:38:08 CET] <Neon> Hey, I have an avi file and I tried encoding it to an mp4 with h264 using the following command: ffmpeg -i input.avi -c:v libx264 -c:a copy output.mp4; However, ffmpeg fails with the message: Could not write header for output file #0 (incorrect codec parameters ?): Invalid data found when processing input; The avi encoding appears to be lagarith (native). Can you tell me how I can fix my input file or get ffmpeg to
[12:38:08 CET] <Neon> convert my video anyway?
[12:42:43 CET] <Neon> Here you go: http://pastebin.com/jeFJNhns
[12:43:38 CET] <J_Darnley> mp4 does not support PCM audio.
[12:43:49 CET] <c_14> Yeah, that.
[12:43:52 CET] <c_14> You'll have to reencode.
[12:44:16 CET] <Neon> Oh, ok. Why can't it just tell me "cannot copy audio" then?
[12:44:32 CET] <c_14> It did
[12:44:34 CET] <c_14> >[mp4 @ 0000000000457040] Tag [1][0][0][0]/0x00000001 incompatible with output codec id '65536' ([0][0][0][0])
[12:44:42 CET] <c_14> It's just not very legible
[12:46:20 CET] <Neon> :( Thanks for the quick help, though. I'll be happy if this is the only issue.
[12:47:08 CET] <rektimus> need some nub friendly errors man
[12:47:15 CET] <Neon> +1
[12:47:31 CET] <rektimus> thats some straight up code debug error output
[12:47:56 CET] <bencoh> :]
[12:48:16 CET] <c_14> Well, it would be legible if it reversed the tag and the codec id
[12:48:23 CET] <c_14> I'm not sure there exists such a mapping though.
[12:48:35 CET] <c_14> Reversed as in replaced with a textual name
[12:48:57 CET] <bencoh> codec_name?
[12:49:30 CET] <Neon> But really, I can cope with that. I'm happy to have such a clean and vanilla encoder for Windows. These fancy free encoders out there are filled with ads and bloatware.
[12:51:03 CET] <J_Darnley> They all probably use ffmpeg anyway and just violate the license
[12:51:13 CET] <rektimus> lol
[12:51:22 CET] <rektimus> notffmpeg.exe --version
[12:51:23 CET] <rektimus> ffmpeg
[12:51:41 CET] <Betablocker> lol
[12:51:45 CET] <Neon> But maybe you can explain something to me: I reencode videos taken with my smartphone sometimes, which are already in an mp4 container, but get much smaller after reencoding with h264 and yuv. However, when playing them with VLC, sometimes the colors went all gray and need some seconds of video to recover. Is this a player issue, encoding issue or my fail?
[12:51:55 CET] <c_14> bencoh: that attribute is deprecated
[12:52:17 CET] <J_Darnley> Odd
[12:52:36 CET] <bencoh> ah
[12:52:38 CET] <J_Darnley> What about the original videos, do they go grey at the same point in VLC or other players
[12:53:24 CET] <Neon> Good question. Maybe I'll do a quick test if I find one of the videos.
[13:11:07 CET] <chungy> MP4 should support ALAC, if you want to keep things lossless
[13:11:29 CET] <chungy> also MP3 and AAC, if you don't care
[15:33:46 CET] <gener1c> hello, i am trying to pipe several files into ffmpeg one after the other , somewhat imitating concat programatically , is there a certain chunk size i have to use to make it work?
[15:34:12 CET] <gener1c> i am piping to its stdin
[15:34:28 CET] <gener1c> using popen
[16:14:45 CET] <digidog> Any suggestion how to deinterlace the best possible way with ffmpeg regarding footage quality. I need to transcode old SD DV material into something uptodate and need to implement a deinterlacing step before.
[16:18:52 CET] <BtbN> yadif with one frame per field propably yields the best quality.
[16:21:33 CET] <Fjorgynn> no
[16:21:55 CET] <ChocolateArmpits> BtbN: yadif suffers quite a few artifacts, 2x somewhat helps to mitigate this due to higher temporal resolution
[16:22:34 CET] <digidog> BtbN: yeah, remeber yadif and that I used it with avisynth and ffmpeg. BtbN, thank you for taking the time to answer, what do you mean with one frame per field. You mean not to merge the two fields into one frame ??
[16:22:49 CET] <ChocolateArmpits> digidog: if you're looking for best quality then use qtgmc through vapoursynth or avisynth
[16:23:16 CET] <ChocolateArmpits> even fastest modes there result in better quality than yadif or other filters available with ffmpeg
[16:23:32 CET] <digidog> ChocolateArmpits: from what I remember, yeah, that was how I did it back in the days after reading 2 weeks doom9 forum :) ... but now I am on linux
[16:23:53 CET] <ChocolateArmpits> digidog: vapoursynth should be compatible with Linux, no ?
[16:24:06 CET] <digidog> ChocolateArmpits: oh O.O .. didnt knwo that
[16:24:08 CET] <durandal_170> That av/vs filters are slow
[16:24:09 CET] <digidog> *know*
[16:24:18 CET] <ChocolateArmpits> digidog: yeah it's using python
[16:24:45 CET] <ChocolateArmpits> digidog: just keep in mind vapoursynth has no audio processing, so you will have to combine the video and audio streams after processing
[16:25:11 CET] <digidog> ChocolateArmpits: this is ifine for us, since we need to seperate audio anyway
[16:25:14 CET] <ChocolateArmpits> durandal_170: I got around 200fps using draft with NEEDI and it looked better than whatever yadif gave out
[16:26:18 CET] <durandal_170> with what CPU and video size
[16:26:40 CET] <ChocolateArmpits> 4 core i7 4771k, SD video
[16:27:17 CET] <ChocolateArmpits> I think yadif gave around 500fps
[16:27:24 CET] <ChocolateArmpits> through ffmpeg
[16:27:31 CET] <digidog> ChocolateArmpits: ok, some things come back slowly now after you all have touched some things in my mind :) I remeber that I used to use yadif first and exactly in this time the new option came around and further testin glead to better results than with yadif ... But I also remember that we had some issue with the fields and that scaling before was no good idea
[16:28:10 CET] <ChocolateArmpits> digidog: Is there a question somewhere in this paragraph ? :s
[16:28:27 CET] <digidog> ChocolateArmpits: arrm, no not really ... *hides*
[16:28:37 CET] <digidog> ChocolateArmpits: sory, loud thinking ....
[16:28:58 CET] Action: digidog needs coffee ... again ....
[16:30:46 CET] <digidog> ChocolateArmpits: hm, ok maybe the question which comes out of this is: should I play around with scaling before or after deinterlacing. from what I knew, scaling after deinterlacing.
[16:31:03 CET] <ChocolateArmpits> digidog: definitely after
[16:31:09 CET] <digidog> ChocolateArmpits: yep
[16:31:31 CET] <ChocolateArmpits> digidog: the interlaced scaling would still have to employ some sort of a deinterlacer
[16:32:25 CET] <digidog> True that. Thanks a million to you all! ChocolateArmpits, durandal_170, Fjorgynn, BtbN, that was very very helpful. ffmpeg community is simply #awesome!!
[16:32:49 CET] Action: digidog had to much coffee ... sorry ...
[16:36:23 CET] Action: digidog will test vapoursynth with qtgmc now on linux and will report back ...
[16:49:29 CET] <ChocolateArmpits> What's the idea behind putting two b frames at the beginning of an mpeg2 stream prior to the first i-frame ?
[16:50:42 CET] <J_Darnley> cutting mistake?
[16:52:56 CET] <ChocolateArmpits> J_Darnley: hmm actually, when using ffprobe and show_frames it reports the two b frames before the i frame, however show_packets doesn't reveal them
[17:02:39 CET] <ChocolateArmpits> ok I think I have an open gop case in my hands here
[18:50:31 CET] <dystopia> can i set ffmpeg to download content via proxy?
[18:50:46 CET] <dystopia> with the static builds
[19:20:02 CET] <digidog> ChocolateArmpits: Am I too tired or I don't get it. Following the install instructions of vapursynth for ubuntu (since it is actually the same like with Debian) it seems that the installation failt without any given errors ...
[19:23:32 CET] <ChocolateArmpits> digidog: Are you using this guide ? http://www.vapoursynth.com/doc/installation.html I have no experience with the Linux version, only using it on Windows
[19:23:49 CET] <ChocolateArmpits> http://www.vapoursynth.com/doc/installation.html#linux-and-os-x-installation-instructions
[19:24:23 CET] <ChocolateArmpits> You also need to have the corresponding Python version installed
[19:25:48 CET] <ChocolateArmpits> digidog: Myrsloik, the developer of VS is in this channel too, so you can try asking him directly :)
[19:42:27 CET] <digidog> ChocolateArmpits: yeah, I followed the installation guide. thanks for taking the time to answer again :)
[19:43:37 CET] <digidog> ChocolateArmpits: the strange thing is in synaptic it say I have tons of python 3.5 libs installed but when I check in terminal python --version it says 2.7.x
[19:45:48 CET] <digidog> Myrsloik: Can I shortyl ask (make sure) that the install guide is uptodate and if so, if I may misundertand some things? The compiling was successul but there is no plugins folder in vapoursynth folder and the installation had some warnings. Are you interested in them ?
[19:46:05 CET] <digidog> ChocolateArmpits: thanks for pointing to the right directions
[19:46:06 CET] <jkqxz> Different versions of python can coexist peacefully.  Try "python3".
[19:46:34 CET] <digidog> jkqxz: true ... damn it. I forgot that ...
[19:46:50 CET] <digidog> jkqxz: thanks! -> python3 --version -> Python 3.5.1+
[20:01:25 CET] <Myrsloik> digidog: the warnings are known
[20:01:37 CET] <digidog> Myrsloik: here is pastebin of the compiling/installation output of zimg and vapoursynth under Debian stretch/sid with some warnings http://pastebin.com/cBzAtq3H
[20:01:49 CET] <digidog> Myrsloik: heh, ups. ah ok ...
[20:03:01 CET] <digidog> Myrsloik: thanks for answering.
[20:03:07 CET] <Myrsloik> The common problem is that ypu have to set PYTHONPATH in Debian and derivatives
[20:03:22 CET] <Myrsloik> Since python doesn't look in site-packages there by default
[20:04:07 CET] <Myrsloik> Or make it locate the module one of the many other ways
[20:05:23 CET] Action: digidog googles setting PYTHONPATH in Debian and makes a strong coffee
[20:06:03 CET] <digidog> Myrsloik: thank you very much for taking the time to hightlight some things I can check ...
[20:07:24 CET] <digidog> Myrsloik: Is there an exmaple script I can run to check if all works fine or a discussion forum fo rme to know how vapoursynth works. I will have no hard time to get it but atm.... ?
[20:08:40 CET] <digidog> Myrsloik: the installation says /bin/mkdir -p '/usr/local/lib/python3.5/site-packages' what seems right so far ...
[20:09:44 CET] <digidog> Myrsloik: ls /usr/local/lib/python3.5/site-packages shows me vapoursynth.la and .so being there
[20:09:47 CET] <JEEB> after an ldconfig run after getting all installed you should be able to run a python3 shell and import vs and start the core
[20:09:55 CET] <JEEB> if that works, you should be pretty good on
[20:10:12 CET] <Myrsloik> vspipe -v can also be used to test it
[20:11:17 CET] Action: Myrsloik hopes some nice person will come along and maintain debain/ubuntu packages
[20:11:24 CET] <digidog> JEEB, Myrsloik: thanks a million
[20:14:19 CET] <digidog> JEEB: ldconfig command unknown
[20:14:33 CET] <digidog> Myrsloik: vspipe -v vspipe: error while loading shared libraries: libvapoursynth-script.so.0: cannot open shared object file: No such file or directory
[20:14:59 CET] <JEEB> how can you not have ldconfig?
[20:15:18 CET] <relaxed_>  /sbin/ldconfig
[20:15:19 CET] <JEEB> it's the thing that indexes your shared libraries :P
[20:15:31 CET] <digidog> JEEB: thats what I thought ... but it maybe has been accidently removed yesterday ... mom
[20:16:19 CET] <digidog> *facepalm*
[20:16:35 CET] Action: digidog is too tired and is doing dump things ...
[20:16:59 CET] <digidog> relaxed_: thanks ... yeah I forgot it is not in the userpath *facepalm*
[20:19:08 CET] <digidog> Myrsloik: JEEB: relaxed_:  okay finally something meaningful happend. after sudo /sbin/ldconfig and vspipe -v I get an: Failed to initialize VapourSynth environment
[20:20:05 CET] Action: digidog should write this all down and if we finally get it to work I amybe can provide a documention addon page for the Debian users to help you with it until you find a Debian package manager 
[20:21:00 CET] <digidog> at least this error says that it reacts on vspipe
[20:22:23 CET] <Myrsloik> PYTHONPATH=/usr/local/lib/python3.4/site-packages vspiipe -v
[20:22:31 CET] <Myrsloik> if it's python 3.4 you happen to have that is
[20:23:04 CET] <Myrsloik> personally I blame debian for deciding that the normal path to put python modules just wasn't good enough for them
[20:23:08 CET] <digidog> Myrsloik: python3 --version -> Python 3.5.1+
[20:23:24 CET] <digidog> Myrsloik: yeah ...
[20:23:58 CET] <digidog> Myrsloik: If we get it working I will provide documentation and can try to build deb packages
[20:24:29 CET] <digidog> Myrsloik: ls og(+Zi)] [24:Freenode/#ffmpeg(+cnt)] [Act: 1,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,25,26,27,28]
[20:24:46 CET] <digidog> ups my irssi plays funny things, sry
[20:24:48 CET] <digidog> og(+Zi)] [24:Freenode/#ffmpeg(+cnt)] [Act: 1,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,25,26,27,28]
[20:25:24 CET] <digidog> Myrsloik:  /usr/local/lib | grep python -> pathon 2.7, python 3.5
[20:25:45 CET] <digidog> finally ... sry, clipboard confusion ...
[20:26:06 CET] <digidog> Myrsloik: /usr/local/lib | grep python -> python 2.7, python 3.5
[20:26:16 CET] <digidog> *facepalm*
[20:26:21 CET] <Myrsloik> not your day?
[20:26:34 CET] <digidog> Myrsloik: How do you know ... o.O
[20:26:39 CET] <digidog> :)
[20:28:07 CET] <digidog> Myrsloik: I have translate your recommended command to my env like this: PYTHONPATH=/usr/local/lib/python3.5/site-packages vspipe -v
[20:29:00 CET] <digidog> the output looks good: VapourSynth Video Processing Library \n Copyright (c) 2012-2016 Fredrik Mellbin \n Core R30 \n API R3.4 \n Options: -
[20:30:24 CET] <Myrsloik> should work then
[20:31:11 CET] <digidog> Myrsloik: JEEB: relaxed_: thank you all for being patient with me today.
[20:33:18 CET] <digidog> thanks a million!
[20:33:25 CET] <digidog> Myrsloik++
[20:33:27 CET] <digidog> JEEB++
[20:33:32 CET] <digidog> relaxed_++
[20:33:58 CET] <digidog> ChocolateArmpits++
[20:36:05 CET] <digidog> Myrsloik: JEEB: relaxed_: I'll create an installation experience report with the parts from IRC here and will show you before, for some correction. Maybe we can link this info somehow to gain Debian users in my situation running Debian. Hope this helps and I can give sth back.
[20:36:25 CET] <Myrsloik> ok
[21:48:53 CET] <dsl420> hi i triy this https://trac.ffmpeg.org/wiki/Create%20a%20video%20slideshow%20from%20images but i dont understand the "-i img%03d.png" part what does it mean?
[21:48:56 CET] <dsl420> try
[21:50:22 CET] <dsl420> i have shot001.png - shot004.png and tried "-i shot%004d.png" it seems it is not right, hm
[21:50:48 CET] <clb_> -i specifies input stream, and %03d is a format specifier, which means 'd'=all digits, '3' means three, and '0' means to prepend with zeroes, i.e. 000, 001, 002, etc. instead of 0, 1, 2, ...
[21:52:07 CET] <clb_> for shot001.png and forward you'd use -i shot%03d.png -start_number 1
[21:53:25 CET] <dsl420> thanks
[21:58:09 CET] <spidey> What is the best method to loop a video file as a constant live stream to a server without just using a while loop.
[22:03:11 CET] Action: genii ponders -loop 1
[22:03:38 CET] <IanWizar1> I'm having a weird issue where, seemingly for no reason, when I try to create a thumbnail of a jpg, it complains about an audio stream and fails.  That said, using the same exact command a different time doesn't have any issues.  Also, it only does this on a heroku dyno.  If I'm running locally, no problem anywhere.  Here's the command and output when it's failing: http://pastebin.com/cp9dzPch  I tried dropping -an in so it would ignore any aud
[22:08:41 CET] <jbendes> Hey all, I was wondering if anyone had any luck with the Logitech C930e and getting an H264 stream out of, what appears to be the output multiplexed MJPEG/H264 stream?
[22:42:20 CET] <spidey> genii: what version did loop show up?  not seeing it in my build from Sept.
[22:43:00 CET] <spidey> read about a -stream_loop -1, but that option didn't show up either
[22:49:56 CET] <genii> spidey: From my manpages :  "-loop_input  Loop over the input stream. Currently it works only for image streams. This option is used for automatic FFServer testing. This option is deprecated, use -loop 1"
[22:51:07 CET] <genii> spicypixel: Default version of whatever is in Ubuntu 15.04, apt-cache policy reports version as:   Installed: 7:2.5.9-0ubuntu0.15.04.1
[22:51:15 CET] <genii> meh tab fail
[22:51:39 CET] <spicypixel> ha
[23:04:11 CET] <spidey> genii: ok thanks.  since that is only for image streams that wouldn't work anyway
[00:00:00 CET] --- Thu Jan 21 2016

More information about the Ffmpeg-devel-irc mailing list