[Ffmpeg-devel-irc] ffmpeg.log.20160121

burek burek021 at gmail.com
Fri Jan 22 02:05:01 CET 2016

[02:52:21 CET] <k_sze[work]> Just me or `-f rawvideo -y /dev/null` as output is faster than `-f null -y /dev/null`?
[02:52:56 CET] <rektimus> -sn strips subs right?
[02:53:32 CET] <rektimus> does rawvideo create a buffer?
[03:01:08 CET] <rektimus> sweet didnt even need to strip subs
[03:26:52 CET] <DHE> k_sze[work]: -f null is fast if you add "-c copy"
[10:21:23 CET] <Maz0m> Hello, I'm trying to encode a file to webm VP9 / OGG. I'm using the ffmpeg--78077-g5989 binary from evermeet (El Capitan 10.11.3) but it only uses one core. Here is the command I used : http://pastebin.com/raw/eHzQXDzz Where am I suppose to enter the -threads option ? before -input ? or after ? I tried both, it doesn't change anything.
[10:22:04 CET] <c_14> before the output file
[10:22:11 CET] <c_14> the way you have it right now should fail outright
[10:22:45 CET] <c_14> And I think for vp9 threading you need to set at least -tile-columns
[10:24:18 CET] <Maz0m> Alright, I'll try that
[10:25:54 CET] <AreaScout> hi all, is the 'decoder_ctx->flags2 |= CODEC_FLAG2_FAST' flag still used or not ?
[10:26:27 CET] <AreaScout> or better say, does it change something or is it useless ?
[10:26:41 CET] <Maz0m> c_14 well, same thing, it still use one core only
[10:33:42 CET] <c_14> Hmm, no idea.
[10:35:06 CET] <Maz0m> No prob, could you tell me if the command is correct though ? http://pastebin.com/raw/dFa0YUfW thanks
[10:45:06 CET] <c_14> looks fine, except for maybe the qmin and qmax
[11:12:00 CET] <jkqxz> Tiles in VP9 are at least 256 pixels wide, so there is at most 2x gain to be had with that resolution (the number you give is log2(number of tile columns), anyway).  There is also -frame-parallel to try if you want.
[16:25:43 CET] <mrAZ> Hello, changing aspect in one file - does it exist? Is that normal that somebody is asking me to produce that?
[16:27:31 CET] <DHE> aspect ratio? it can be done, but it might require a transcode to do it depending on the file formats involved, etc
[16:29:58 CET] <mrAZ> DHE: are you sure? one file with switching aspect several times from 16:9 tp 4:3 and back?
[16:33:04 CET] <jkqxz> Is it the resolution of the stream changing, or just the shape of the pixels?
[16:34:48 CET] <jkqxz> WRT it being normal, it's a common thing on broadcast video channels as they switch between different content.
[16:40:56 CET] <DHE> I don't know that you can do that so easily. may need to concatenate several files together or just stretch/skew them to a common encoder resolution (ie: letterbox/pillar the videos)
[16:42:41 CET] <YamakasY> hi guys, when I do a  -vcodec copy -acodec copy are the copy ones temp file names or not ?
[16:43:19 CET] <J_Darnley> What?
[16:43:59 CET] <J_Darnley> "copy" is a special case for choosing what "encoder" is used.
[16:44:07 CET] <YamakasY> I need to convert from flv to mp4 so the params above are best it seems, but is copy temp filename between the codev conversion ?
[16:44:12 CET] <YamakasY> ahj ok
[16:44:19 CET] <mrAZ> DHE: i tried to make two files with different aspect and cat them together. If it is transport stream with mpeg2video. it works. thanks.
[16:44:37 CET] <YamakasY> J_Darnley: but that is best for quality it seems ?
[16:44:51 CET] <J_Darnley> It is a copy
[16:44:55 CET] <J_Darnley> copy
[16:46:48 CET] <YamakasY> J_Darnley: best for quality ? it's a repackage I think ?
[16:47:36 CET] <furq> it remuxes the existing streams into a new container
[16:47:46 CET] <furq> also you can use -c copy instead of specifying both
[16:50:27 CET] <YamakasY> okay both are default -c copy ?
[16:51:01 CET] <J_Darnley> No.  That is not what he said.
[16:51:23 CET] <YamakasY> J_Darnley: no but that is what I make out of it ?
[16:51:48 CET] <J_Darnley> Is that a question?
[16:51:56 CET] <YamakasY> yes
[16:52:07 CET] Action: J_Darnley doesn't think it looks like one.
[16:52:14 CET] <J_Darnley> No the default is not "copy"
[16:52:18 CET] <YamakasY> I mean... questionable statement :)
[16:52:54 CET] <J_Darnley> The default depends on what output format you use and what encoders are available.
[16:53:08 CET] <J_Darnley> If you want to copy then use "copy"
[16:53:11 CET] <YamakasY> I can install what I want I just want best quality left
[16:53:18 CET] <J_Darnley> If you want to copy then use "copy"
[16:53:34 CET] Last message repeated 1 time(s).
[16:53:34 CET] <YamakasY> ok
[16:53:38 CET] <YamakasY> merci
[16:54:34 CET] <merlink> Anybody worked with decklink output of FFMPEG?
[20:03:51 CET] <Logicgate> hey guys, is there a way to automatically calculate side to side padding?
[20:04:02 CET] <Logicgate> I'm having problems coming up with the formula
[20:05:27 CET] <Logicgate> example, I want to encode a 568x320 video into a 480x480 container
[20:05:35 CET] <Logicgate> and pad the sides
[20:05:53 CET] <Logicgate> Do I *have* to pass the side to side padding parameters? Or can ffmpeg do it automatically
[20:09:25 CET] <J_Darnley> Yes and yes.
[20:09:34 CET] <J_Darnley> Use an expression.
[20:09:51 CET] <J_Darnley> They are ugly as hell but they'll work.
[20:10:12 CET] <Logicgate> What I thought, :(
[20:22:02 CET] <t4nk470> Hey, I was just wondering if there is a way to flatten all audio tracks in the input file into just one in the output file?
[20:22:20 CET] <t4nk470> Without knowing how many audio tracks there are in the input file
[20:28:36 CET] <saranshsrivastav> ##limechat
[20:28:59 CET] <J_Darnley> yes?
[20:29:15 CET] <saranshsrivastav> Hello, I am developing a static library for android using ffmpeg
[20:29:26 CET] <saranshsrivastav> and i am facing an PIE error
[20:29:43 CET] <saranshsrivastav> I think it is due to Lollipop version of android
[20:29:50 CET] <saranshsrivastav> but i couldnt get any leads
[20:29:52 CET] <J_Darnley> What?  If you need more pies go and make or buy some.
[20:30:10 CET] <saranshsrivastav> Lol
[20:31:52 CET] <saranshsrivastav> PIE - Position independent executables
[20:31:57 CET] <J_Darnley> wikipedia suggests you might mean "position independant executable"
[20:32:06 CET] <J_Darnley> /snap
[20:32:18 CET] <J_Darnley> Is that on x86?
[20:32:27 CET] <saranshsrivastav> no it is on ARM
[20:33:23 CET] <saranshsrivastav> The following is the error: error: only position independent executables (PIE) are supported.
[20:34:13 CET] <J_Darnley> Wait for somone who knows or cares about arm to come along.
[20:34:27 CET] <saranshsrivastav> surely, thanks anyways :)
[20:39:46 CET] <Logicgate> saranshsrivastav, since ffmpeg is open source, you're lucky.
[20:39:59 CET] <Logicgate> You'll need to modify the source code to make it a PIE executable
[20:40:04 CET] <Logicgate> That's going to be a ton of work
[20:40:16 CET] <Logicgate> And then need to recompile
[20:40:29 CET] <saranshsrivastav> I was hoping that I will have to add some flags to make it PIE compatible
[20:40:36 CET] <Logicgate> http://stackoverflow.com/questions/13061086/building-ffmpeg-library-for-ios6-0-armv7-processor
[20:40:45 CET] <Logicgate> here something that might help
[20:41:20 CET] <saranshsrivastav> checking..
[20:41:37 CET] <Logicgate> That's for iOS, but it's still related to ARM architecture
[20:41:42 CET] <Logicgate> Which should work for your issue
[20:45:32 CET] <saranshsrivastav> I think the problem is not in the ARM architecture but because of android lollipop
[20:46:45 CET] <saranshsrivastav> I have already '--enable-pic'
[20:49:20 CET] <Logicgate> saranshsrivastav, you need to make it a PIE executable
[20:49:21 CET] <saranshsrivastav> This is the closest answer I have got till now for my problem : http://stackoverflow.com/questions/30498776/position-independent-executables-and-android-lollipop
[20:49:28 CET] <Logicgate> Which is what is described on the SO post
[20:49:31 CET] <jkqxz> Has it told you what files you build are not position-independent?  You could try adding '--disable-asm' and if that fixes it (though that probably isn't a good idea to use, it hopefully helps in fixing the problem).
[20:50:42 CET] <saranshsrivastav> The log cannot tell me the exact files because I am using a precompiled binary of ffmpeg for android
[20:50:52 CET] <Logicgate> saranshsrivastav, lol
[20:51:00 CET] <Logicgate> Like I said, you'll need to recompile yourself.
[20:51:12 CET] <Logicgate> So you know exactly what goes into your package
[20:51:19 CET] <Logicgate> Don't expect precompiled bins to work for you
[20:51:49 CET] <saranshsrivastav> I am not sure about all the flags
[20:52:04 CET] <Logicgate> Well, do your research
[20:52:05 CET] <Logicgate> Ask here
[20:52:09 CET] <Logicgate> ask on stack overflow
[20:55:42 CET] <jkqxz> If we assume that the precompiled library you have can work (definitely not a given, but assume), then the problem is likely that something on your side is not compiled with -fpic or not linked with -fpie.  Are you sure that /every single other file/ compiled has those flags set?
[20:58:31 CET] <saran> I'm not sure...i pass as an argument cflag = -fpic & -fpie along with ./configure when i build the executable
[21:01:32 CET] <saran> Which i suppose sets the executable as pie enabled
[21:02:04 CET] <saran> Right?
[00:00:00 CET] --- Fri Jan 22 2016

More information about the Ffmpeg-devel-irc mailing list