[Ffmpeg-devel-irc] ffmpeg.log.20160123

burek burek021 at gmail.com
Sun Jan 24 02:05:01 CET 2016

[00:57:07 CET] <SeanM_> is there an easy automated/newbie proof way to install ffmpeg on osx?
[00:58:43 CET] <genii> ...perhaps https://www.ffmpeg.org/download.html#build-mac  ?
[01:00:31 CET] <J_Darnley> or perhaps an osx link from http://trac.ffmpeg.org/wiki/CompilationGuide if you want to compile yourself
[01:01:04 CET] <SeanM_> Thanks guys
[07:46:36 CET] <probalaa> I run the command given on this page: https://trac.ffmpeg.org/wiki/StreamingGuide AND the terminal says: Unknown input format: 'dshow'
[07:46:53 CET] <probalaa> $ ffmpeg -y -loglevel warning -f dshow -i video="screen-capture-recorder" -vf crop=690:388:136:0 -r 30 -s 962x388 -threads 2 -vcodec libx264 -vpre baseline -vpre my_ffpreset -f flv rtmp:///live/myStream.sdp
[07:52:53 CET] <rektimus> https://trac.ffmpeg.org/wiki/DirectShow
[07:53:13 CET] <rektimus> does screen capture recorder show in ur device list output
[08:00:57 CET] <rektimus> or
[08:01:00 CET] <rektimus> are you on windows?
[09:01:28 CET] <digidog> rektimus: hi. ffmplay seesm not to have STDIN support. do you have any idea how to setup the part of a shell script playing audio thru ffmplay, which tries to bind keys for skipping or forward/rewind, etc ?
[09:03:03 CET] <digidog> rektimus: maybe a work around via trap?
[09:03:21 CET] <c_14> digidog: I don't think ffplay reads stdin
[09:03:32 CET] <digidog> c_14: thats what I think too
[09:04:06 CET] <digidog> c_14: any idea how to get around this. at least for some minimum control
[09:04:34 CET] <digidog> c_14: at least for break up a play or skip if multiple files are in queue
[09:05:11 CET] <digidog> trap 'trap - INT; kill -INT "$$"' INT ... hm ...
[09:14:57 CET] <c_14> You could try using an actual scriptable player such as mpv
[09:17:13 CET] <digidog> c_14: hm, yeah but I was hoping to be able to stay low level and tight to ffmpeg. BUt maybe you are right
[09:17:32 CET] <Degot> Hi, All. Is there a tutorial on how to start ffserver as service on Ubuntu 14.04.x?
[09:17:50 CET] <c_14> digidog: otherwise you'd have to patch ffplay to accept input on stdin
[09:18:33 CET] Action: digidog hides and facepalms
[09:18:40 CET] <digidog> :)
[09:22:35 CET] <digidog> c_14: sadly this options only work if ffplay has been started directly and with display  http://ffmpeg.org/ffplay-all.html#While-playing
[09:24:17 CET] <digidog> does anyone know if I can route ffplay thru alsa under linux ?
[09:25:24 CET] <c_14> -sinks alsa probably
[09:26:03 CET] <c_14> hmm, that just lists them
[09:28:16 CET] <digidog> c_14: yep
[09:32:44 CET] <c_14> Don't think there's an option.
[09:33:08 CET] <digidog> c_14: :$ yeah, tried to find sth, with no luck
[09:33:35 CET] <digidog> c_14: but hey, thanks a million for chiming in and trying to help
[09:33:38 CET] <digidog> c_14++
[09:33:57 CET] <digidog> LOL
[09:33:58 CET] <c_15> np
[09:38:46 CET] <digidog> c_14: maybe we better switch to mplayer (mpv is too much fo rthis appraoch) and use ffplay as a fall back.
[09:54:23 CET] <digidog> c_14: https://github.com/diqidoq/playa
[12:45:00 CET] <davnik> Hello, I am trying to remove the watermark from a video using the --delogo option
[12:45:25 CET] <davnik> http://snag.gy/B5BUv.jpg
[12:45:40 CET] <davnik> Could anyone please give me the proper coordinates to use here?
[13:24:47 CET] <jkqxz> davnik:  You mean the "made with ..." thing?  That's too big to plausibly remove.  You can blur it over but there won't be enough information to recreate anything sensible underneath.
[13:33:01 CET] <chungy> you could probably try to recreate the background and overlay it... but I'm assuming that banner appears in other scenes too that aren't identical
[13:42:42 CET] <rektimus> if photoshop can do it
[13:50:38 CET] <chungy> it's not really a matter of software, but artistic skill and how much effort will be involved
[14:19:52 CET] <micechal> is it possible to *completely* drop any metadata when encoding pcm s16le?
[14:20:36 CET] <micechal> so far I tried "-map_metadata -1" but that still leaves some stuff
[14:20:46 CET] <micechal> like encoder information
[14:21:03 CET] <c_14> try adding -fflags +bitexact
[14:21:11 CET] <c_14> You can get rid of the encoder info as well, but I can't remember how.
[14:22:54 CET] <micechal> I'll try some googling
[14:23:00 CET] <micechal> well, that seems to have dropped the "ISFT" thingy, but yeah, the encoder info is still here
[14:23:03 CET] <micechal> I'll try some googling
[15:46:58 CET] <Chagall> is there a way to tell programmatically whether there exists a pass log file corresponding to a certain input file?
[15:49:37 CET] <Chagall> or any other way to tell after the process exits whether it was encoding with pass 1 or not
[15:50:12 CET] <Chagall> in the log file situation i would know where the log file is located, but i don't know if it is parsable and how to do it
[15:52:44 CET] <dystopia_> look in media info
[15:53:04 CET] <dystopia_> undner encoding settings it will say rc=2pass
[16:02:00 CET] <Chagall> i mean between the first and second pass
[16:02:13 CET] <Chagall> need to check whether the process that ended was the one that did the first or the second pass
[16:03:05 CET] <Chagall> i guess i could check that the files exist but i'd rather be sure
[16:24:47 CET] <gattler> Hi all, can I convert only the audio part of a video? e.g I have a with a 5.1 dts audio but I want it to have 5.1 ac3 with a certain bitrate
[16:25:03 CET] <gattler> can I do that without touching the video?
[16:27:21 CET] <jkqxz> -c:v copy
[16:28:40 CET] <gattler> do I have to worry about the audio channels? or will ffmepg ensure that e.g. front-left stays front-left?
[16:29:25 CET] <c_14> yes
[16:29:32 CET] <c_14> you don't have to worry
[16:30:28 CET] <gattler> ffmpeg -i input.mkv -vcodec copy -acodec ac3 -ab 192k output.mkv
[16:30:30 CET] <gattler> like this?
[16:30:55 CET] <c_14> sure
[16:31:10 CET] <c_14> 192k is rather low for ac3 though
[16:31:25 CET] <gattler> ah ok, what do you suggest?
[16:32:03 CET] <Mavrik> well 192k is what you do for stereo mp3
[16:32:07 CET] <Mavrik> not 6 channel audio :)
[16:32:29 CET] <c_14> 5.1 AC3 afaik is usually between 400 and 500k
[16:32:32 CET] <Mavrik> It's usually 448 or so for 5.1
[16:32:56 CET] <gattler> good to know, thanks
[16:33:02 CET] <gattler> Decoder (codec id 94210) not found for input stream #0.3
[16:33:15 CET] <gattler> this is what i get, i guess I need some extra packages
[16:33:37 CET] <gattler> can I lookup what "codec id 94210" means?
[16:33:41 CET] <c_14> try adding -c copy before -c:a ac3
[16:33:49 CET] <c_14> and maybe -copy_unknown
[16:33:56 CET] <c_14> Though I'm not sure why it's trying to decode that.
[16:34:13 CET] <gattler> kk
[16:39:07 CET] <gattler> c_14: http://pastebin.com/J9gNNb3X
[16:39:16 CET] <jkqxz> 94210 = 0x17002 is a text subtitle stream <https://github.com/FFmpeg/FFmpeg/blob/master/libavcodec/avcodec.h#L507>.
[16:39:27 CET] <c_14> ah
[16:39:28 CET] <jkqxz> (So just copy it, as suggested.)
[16:39:56 CET] <c_14> gattler: that's an ancient binary from libav, not FFmpeg. try again with a static build
[16:39:58 CET] <c_14> http://johnvansickle.com/ffmpeg/
[16:40:02 CET] <gattler> c_14:
[16:40:15 CET] <gattler> yeah, I'm on ubuntu 12.04 :P
[16:43:54 CET] <gattler> ok, It seems wo work with the static ffmpeg build
[16:43:57 CET] <gattler> thanks alot guys
[16:44:54 CET] <gattler> Is it normal that it takes alot of time? I was hoping just converting the audio will only take a few minutes
[16:45:23 CET] <c_14> it shouldn't take that long. It does have to read and write the whole file so it might depend on your IO though
[16:53:13 CET] <gattler> It worked ;) thanks alow again guys
[16:53:24 CET] <gattler> *alot..
[17:29:28 CET] <redsPL^GxG> heya
[17:29:45 CET] <redsPL^GxG> i've got a compro videomate u900
[17:29:50 CET] <redsPL^GxG> i want to use it on linux
[17:30:10 CET] <redsPL^GxG> but i dont know where to start.. dmesg sees that high speed usb device is connected..
[17:30:17 CET] <redsPL^GxG> lsusb says "Compro"
[17:30:30 CET] <J_Darnley> What is it?  A webcam?
[17:31:08 CET] <redsPL^GxG> nope
[17:31:17 CET] <redsPL^GxG> that is a analog tv
[17:31:18 CET] <redsPL^GxG> tuner
[17:31:28 CET] <J_Darnley> Ah
[17:31:30 CET] <redsPL^GxG> +composite video input
[17:31:36 CET] <redsPL^GxG> and i wanna use that composite video
[17:31:55 CET] <J_Darnley> Then I think you need to read about video4linux
[17:32:29 CET] <J_Darnley> (I probably would have said that anyway)
[18:28:46 CET] <vincentdumont> Hello everyone! I am seeking to help the open source ffmpeg community. I would be glad to contribute to this wonderful project so feel free to visit my website (www.vincentdumont.com) in order to have more information about me. Thank you in advance!
[22:22:37 CET] <popara> hello it's possible in the -f segment output format, to specify the segments to be always incremental?
[22:22:54 CET] <popara> because i give also the wrap argument and the number is changing back to an old one again
[22:24:27 CET] <J_Darnley> How should that work then?
[22:24:30 CET] <J_Darnley> An error?
[22:25:18 CET] <popara> not an error, nothing. It works fine, just the segment number is not incremental
[22:26:57 CET] <furq> what else would you expect wrap to do
[22:41:59 CET] <popara> yes for example in the HLS container there is an option to delete old segments
[22:42:03 CET] <popara> and keep the number incremental
[22:43:00 CET] <J_Darnley> Doesn't sound like "wrap" to me but like "delete old"
[22:46:26 CET] <edman007> Hi, how do I set the pixel format with the scale filter?
[22:46:31 CET] <furq> weird
[22:46:41 CET] <furq> hls has delete_segments but segment doesn't appear to have any equivalent
[22:46:53 CET] <furq> i guess you should file a feature request
[22:46:56 CET] <edman007> when I use it I get [swscaler @ 0x1e2fe00] deprecated pixel format used, make sure you did set range correctly [Parsed_vidstabtransform_0 @ 0x1e2f500] pixel-format error: bpp 1<>2  chroma_subsampl: w: 1<>1  h: 0<>0 [Parsed_vidstabtransform_0 @ 0x1e2f500] Failed to configure input pad on Parsed_vidstabtransform_0
[22:46:59 CET] <J_Darnley> patches welcome!
[22:47:04 CET] <furq> or that
[22:47:16 CET] <edman007> and the docs just say you have to give it an integer...where do I get the meanings of the integers?
[22:50:43 CET] <J_Darnley> Isn't it the format option?
[22:51:00 CET] <furq> edman007: https://github.com/georgmartius/vid.stab/issues/13
[22:52:21 CET] <J_Darnley> oh no, you stick the format filter in afterwards
[22:55:07 CET] <edman007> furq, hrm, I can get it to work, but it breaks with the scale filter
[22:56:01 CET] <J_Darnley> edman007: can you put the full log on pastebin?
[23:02:55 CET] <edman007> http://pastebin.com/FjMg2MpG
[23:03:01 CET] <edman007> if I take the scale out of the filter it works
[23:04:55 CET] <furq> use pix_fmt yuv444p as an output option
[23:13:32 CET] <edman007> ffmpeg -y -pix_fmt yuv444p -framerate 30 -i F%04d-L0-normal.jpg -frames 5 -c:v libx264 -r 30 -vf vidstabtransform=input=transforms.trf:crop=keep:tripod=1:optzoom=0:smoothing=0:zoomspeed=5:debug=0:interpol=no,scale=w=0.75*iw:h=0.75*ih,crop=w=3840:h=2160:y=0 -pix_fmt yuv444p stacked.mp4
[23:13:38 CET] <edman007> like that? because it doesn't work...
[23:17:38 CET] <edman007> I think I can get away without video stabilization for now anyways...so I'm probably fine...but it should still work..
[23:21:05 CET] <J_Darnley> Oh shit!  I forogt it was an external lib
[23:21:43 CET] <J_Darnley> Screw it.  I'm not going to debug this anymore for now.
[23:25:33 CET] <furq> try removing pix_fmt as an input option
[23:26:07 CET] <furq> and/or use -vf format=yuv444p instead of pix_fmt
[23:26:43 CET] <furq> presumably before any of the other filters
[00:00:00 CET] --- Sun Jan 24 2016

More information about the Ffmpeg-devel-irc mailing list