[Ffmpeg-devel-irc] ffmpeg.log.20160124

burek burek021 at gmail.com
Mon Jan 25 02:05:01 CET 2016

[00:09:59 CET] <Exon> Could someone help me with the command to stream a certain audio output to an icecast server? Thanks!
[00:16:22 CET] <Fjorgynn> no
[00:16:32 CET] <Fjorgynn> but I am going to bed soon
[00:16:32 CET] <Exon> :X
[00:17:57 CET] <edman007> Exon, just ask away
[00:18:14 CET] <Exon> <Exon> Could someone help me with the command to stream a certain audio output to an icecast server? Thanks!
[00:18:32 CET] <Exon> i know the icecast:// parameters
[00:19:27 CET] <Exon> But I keep getting "Unable to find a suitable output format"
[00:19:40 CET] <Exon> I once had a .bat file where the correct command was but I can't find it anymore
[00:19:44 CET] <Exon> and I havent used FFMPEG in ages
[00:19:50 CET] <pzich> what format should it be?
[00:19:57 CET] <Exon> mp3 is fine
[00:27:14 CET] Action: J_Darnley wonders whether Exon has tried -f mp3
[00:28:06 CET] <Exon> Ah the actualy error is Output file #0 does not contain any stream
[00:28:18 CET] <Exon> The other arrow fixed itself after I appended .mp3 to the mountpoint
[01:26:08 CET] <J_Darnley> Exon: so you still have a problem?
[01:26:20 CET] <J_Darnley> if so put the full log on pastebin
[01:41:42 CET] <Exon> It's just Output file #0 does not contain any stream J_Darnley
[01:50:57 CET] <furq> pastebin the full command
[02:25:25 CET] <Logicgate> J_Darnley, I want to keep a video under a certain output size
[02:25:31 CET] <Logicgate> Do I absolutely need to do a 2 pass?
[02:26:28 CET] <Logicgate> For instance, I want a 720p video to be maximum 4mb in output
[02:26:33 CET] <Logicgate> h264
[02:26:41 CET] <J_Darnley> 2 pass would be much better than trying ABR
[02:26:44 CET] <Logicgate> The video is a maximum of 6.8 seconds
[02:29:07 CET] <Logicgate> this is my current command: ffmpeg -i <input> -c:a aac -ac 2 -t 6.8 -c:v libx264 -movflags +faststart -crf 20 -vf "scale=w=if(gte(dar\,1)\,720\,720*dar):h=if(lte(dar\,1)\,720\,720/dar):flags=lanczos,format=yuv420p,pad=720:720:(720-iw*min(720/iw\,720/ih))/2:(720-ih*min(720/iw\,720/ih))/2:black" <out.mp4>
[02:29:21 CET] <furq> i guess you could try with bufsize and maxrate
[02:29:32 CET] <furq> and b:v instead of crf obviously
[02:29:45 CET] <furq> i'd expect better results with 2-pass though
[02:30:03 CET] <J_Darnley> If you only expect to cap a few files out of many you could consider using "slow first pass" and then only doing the second for files which need to be smaller.
[02:30:03 CET] <J_Darnley> But that means the first pass takes as long as the second.
[02:30:04 CET] <Logicgate> how does one keep the best quality possible doing two pass
[02:30:20 CET] <Logicgate> J_Darnley, I'm fine with that
[02:30:21 CET] <furq> https://trac.ffmpeg.org/wiki/Encode/H.264#twopass
[02:31:01 CET] <J_Darnley> Keeping "best quality" means using all the available bits when doing 2 pass
[02:32:39 CET] <Logicgate> okay so what would my command look like for 2 pass with a set size?
[02:32:50 CET] <Logicgate> I have to calculate bitrate right
[02:32:54 CET] <J_Darnley> Yes
[02:33:12 CET] <Logicgate> so does b:v set a max bitrate or its a fixed bitrate
[02:33:19 CET] <furq> it's the average bitrate
[02:33:43 CET] <J_Darnley> In this case for x264 the average
[02:33:44 CET] <Logicgate> So how does one calculate theoretical bitrate
[02:34:07 CET] <J_Darnley> simply put: video bitrate = size / length - audio bitrate
[02:34:49 CET] <J_Darnley> or: (size - audio size) / length
[02:34:55 CET] <Logicgate> 128k for audio per second = 870.4k
[02:35:03 CET] <Logicgate> Or those are kilobits
[02:35:09 CET] <furq> those are indeed kilobits
[02:35:16 CET] <J_Darnley> ffmpeg uses bits for bitrate
[02:35:25 CET] <furq> it's 108KB
[02:35:43 CET] <furq> actually why did i even work that out
[02:36:13 CET] <furq> https://www.google.co.uk/search?q=4%20megabytes%20%2F%206.8%20seconds%20in%20kilobits%20per%20second
[02:36:30 CET] <furq> so you have 4577kbps for video
[02:36:40 CET] <furq> also i love google. it's great
[02:37:40 CET] <Logicgate> no kidding
[02:37:44 CET] <Logicgate> Okay, so that's my max
[02:38:01 CET] <Logicgate> So i need to substract 128kilobits per second for audio
[02:38:06 CET] <furq> one of these days i'll have to do a basic unit conversion without internet access and i'll die
[02:38:09 CET] <furq> but today is not that day
[02:38:21 CET] <furq> Logicgate: i just did that for you
[02:38:24 CET] <Logicgate> 3834.6 kilobits
[02:38:28 CET] <furq> ...what
[02:38:38 CET] <Logicgate> furq, you gave me total kilobits
[02:38:44 CET] <furq> 4705 - 128 is not 3834
[02:38:52 CET] <Logicgate> 128kilobits per second no?
[02:38:57 CET] <furq> yes
[02:39:00 CET] <Logicgate> exactly
[02:39:03 CET] <furq> ...no
[02:39:12 CET] <Logicgate> so 6.8 * 128 = 870.4kilobits ?
[02:39:48 CET] <furq> you do not have to multiply kilobits by anything to get kilobits
[02:40:01 CET] <Logicgate> I thought it was kbps (kilobits per second)
[02:40:02 CET] <Logicgate> NO?!
[02:40:41 CET] <furq> i don't know how to explain this more clearly
[02:40:43 CET] <Logicgate> You guys said to substract audio bitrate to get video bitrate, I'm doing it as a total
[02:40:45 CET] <Logicgate> both ways works
[02:40:53 CET] <J_Darnley> When you said "maximum 4mb" is that four megabytes?
[02:40:55 CET] <furq> oh.
[02:41:06 CET] <Logicgate> J_Darnley, yes
[02:41:09 CET] <furq> 4705 is not the total number of kilobits
[02:41:13 CET] <furq> that's the bitrate
[02:41:17 CET] <Logicgate> furq, my point exactly
[02:41:20 CET] <furq> dfndsds
[02:41:29 CET] <Logicgate> SO in order to calculate the video bitrate, I need to substract total audio bitrate
[02:41:47 CET] <Logicgate> total bitrate - total audio bitrate = total allowed video bitrate
[02:42:12 CET] <Logicgate> total allowed video bitrate / 6.8 = 564.04kbpd
[02:42:18 CET] <Logicgate> kbps*
[02:42:44 CET] <Logicgate> so my b:v should be 564k, or to be on the safe side 555k
[02:43:55 CET] <J_Darnley> no
[02:44:07 CET] <Logicgate> Okay, then I'm completely lost.
[02:44:18 CET] <furq> 01:36:13 ( furq) https://www.google.co.uk/search?q=4%20megabytes%20%2F%206.8%20seconds%20in%20kilobits%20per%20second
[02:44:21 CET] <furq> 01:36:30 ( furq) so you have 4577kbps for video
[02:44:24 CET] <furq> that is the answer
[02:44:57 CET] <furq> notice that the google answer is in kilobits per second, not kilobits
[02:45:08 CET] <Logicgate> okay, I get it
[02:45:18 CET] <Logicgate> so 4mb * 8192 / 6.8
[02:45:41 CET] <J_Darnley> close enough
[02:46:00 CET] <Logicgate> 4818.82 - 128k = 4690 max bitrate
[02:46:08 CET] <furq> 8000, not 8192
[02:46:11 CET] <furq> although it pains me to say it
[02:46:18 CET] <Logicgate> On the ffmpeg docs it says 8192
[02:46:25 CET] <Logicgate> http://puu.sh/mHfkE/92f114f9c9.png
[02:46:30 CET] <furq> i'm pretty sure ffmpeg uses kilobits, not kibibits
[02:46:31 CET] <Logicgate> Docs are wrong then
[02:46:43 CET] <furq> probably
[02:46:55 CET] <J_Darnley> (4*1048576*8)/6.8
[02:47:01 CET] <Logicgate> which preset should I use?
[02:47:14 CET] <furq> whichever preset you want
[02:47:16 CET] <Logicgate> and can I do the scaling in the second pass?
[02:47:21 CET] <J_Darnley> As slow as you can tolerate except for placebo
[02:47:38 CET] <J_Darnley> Logicgate: you must provice the encoder with the same video
[02:47:50 CET] <Logicgate> I see
[02:47:54 CET] <Logicgate> So then I need to do 3 passes
[02:48:04 CET] <furq> huh
[02:48:07 CET] <J_Darnley> what?
[02:48:17 CET] <Logicgate> It just makes for one long command
[02:48:20 CET] <Logicgate> is what I'm saying
[02:48:31 CET] <Logicgate> if I do 3 passes with the scaling algorithm
[02:48:49 CET] <J_Darnley> Why would you do the scale seprately?
[02:49:06 CET] <Logicgate> Because I'm stupid, clearly.
[02:49:47 CET] <Logicgate> How does it do the two passes, does it store the data of the first pass that goes to /dev/null?
[02:49:56 CET] <furq> yeah it writes out a log file which is used by the second pass
[02:50:08 CET] <J_Darnley> ffmpeg -i INPUT -vf FILTERS [OUTPUT OPTIONS] -pass 1 OUTPUT ; ffmpeg -i INPUT -vf FILTERS [OUTPUT OPTIONS] -pass 2 OUTPUT
[02:50:25 CET] <furq> Logicgate: you might also want to check the additional information section of that wiki page
[02:50:40 CET] <furq> specifically the cbr and crf with maximum bitrate sections
[02:51:31 CET] <Logicgate> you can do crf with maxrate
[02:51:39 CET] <Logicgate> Then what's the point of two pass then
[02:51:47 CET] <Logicgate> bufsize is total size?
[02:51:49 CET] <furq> 2-pass ought to be higher quality
[02:52:01 CET] <furq> "-bufsize is the "rate control buffer" so it will enforce your requested "average" (4000k in this case) across each 1835k worth of video."
[02:52:12 CET] <J_Darnley> VBV max rate is not for maximum file size!
[02:52:32 CET] <furq> i was just typing that i've never used anything but -crf on its own so idk how effective this is
[02:52:54 CET] <J_Darnley> VBV is for streaming or hardware limits like bluray
[02:53:11 CET] <Logicgate> These videos are for mobile streaming
[02:53:29 CET] <Logicgate> So I need to figured out how much is being buffered basically or does that matter.
[02:53:50 CET] <J_Darnley> Then I would expect you to be using them if you are *streaming*
[02:54:29 CET] <Logicgate> Jesus, I don't know what to do now
[02:54:35 CET] <Logicgate> I think I'm going overkill
[02:54:50 CET] <Logicgate> Should I do CRF + Maxrate or 2 pass
[02:54:55 CET] <furq> wouldn't -maxrate 4700k -bufsize 4000k give acceptable results
[02:55:00 CET] <furq> considering the video is only 4mb
[02:56:04 CET] <furq> or am i just being a distraction here
[02:56:17 CET] <J_Darnley> I don't know
[02:56:35 CET] <J_Darnley> I haven't kept up with the nonsense of streaming
[02:56:39 CET] <furq> i guess try crf + maxrate, if it gives crap results then do 2-pass
[02:56:51 CET] <Logicgate> Lol J_Darnley
[02:56:54 CET] <furq> crf + maxrate will be faster and less complicated but it might not give the desired results
[02:57:03 CET] <Logicgate> furq, I like your style
[02:57:11 CET] <Logicgate> going to give it a shot
[02:57:17 CET] <Logicgate> it's just 720p, not blu-ray 4k
[02:59:59 CET] <J_Darnley> I would have expected that last ~8 years to have settled all this but I guess streaming people keep thieir knowledge to themselves.
[03:00:42 CET] <furq> actually bufsize is in kbps isn't it
[03:00:50 CET] <furq> i think i got it confused with rtbufsize
[03:00:54 CET] <J_Darnley> ?
[03:00:59 CET] <Logicgate> lol
[03:01:00 CET] <J_Darnley> its s aize not a rate
[03:01:07 CET] <furq> kbit, rather
[03:01:10 CET] <J_Darnley> its a size not a rate
[03:01:11 CET] <furq> i thought it was in KB for some reason
[03:01:43 CET] <J_Darnley> No I don't think it was bytes
[03:01:50 CET] <furq> yeah i checked and it is kbit
[03:01:59 CET] <furq> rtbufsize is in bytes i think
[03:02:17 CET] <furq> also s/kbit/bits since you need to specify a suffix
[03:02:33 CET] <Logicgate> furq, that's what I thought to actually
[03:03:22 CET] <furq> i was thinking of -bufsize 32000k in that case
[03:03:36 CET] <furq> but that doesn't seem like a thing which is right
[03:03:50 CET] <furq> check out that expert technical analysis there
[03:07:09 CET] <Logicgate> furq, it worked
[03:07:22 CET] <Logicgate> furq, you can't do that though
[03:07:30 CET] <Logicgate> Because video buffers are never that big
[03:07:38 CET] <Logicgate> They're much smaller chunks (I think)
[03:58:13 CET] <Guest49336> greetings - seeking assistance debugging ffmpeg build - ldd indicates libavdevice.o.57 but only *.o.56 in /usr/local/lib
[04:03:51 CET] <Guest49336> ./ffmpeg: error while loading shared libraries: libavdevice.so.57: cannot open shared object file: No such file or directory
[07:32:35 CET] <Guest49336> too bad nobody was able to help. maybe next time.
[07:32:46 CET] <Guest49336> <crickets>
[09:54:00 CET] <SeanM_> Hi, can someone here please hellp point me in the right direction why this command doesnt work -->   ffmpeg -i INPUTFILE.mpg -i logo.png -filter_complex "[0:v][1:v] overlay=10:10:enable='between(t,4,12)'" -scale=1728:970,crop=1280:720:224:6 -sws_flags lanczos -codec:v libx264 -crf 18 -preset ultrafast -movflags faststart -pix_fmt yuv420p -c:a copy OUTPUTFILE.mp4     (it is supposed to crop and overlay a png file watermark that
[09:54:00 CET] <SeanM_>  only displays from 4s-12s of the video, yet it doesn't work. i am new to ffmpeg and spent 10+ hours on this. puzzled)
[09:56:11 CET] <waressearcher2> SeanM_: hallo und herzlich willkommen
[09:59:07 CET] <c_14> SeanM_: that's broken
[09:59:12 CET] <c_14> there is no -scale option
[09:59:24 CET] <c_14> I'm assuming you wanted that and the crop as part of the filterchain
[09:59:36 CET] <c_14> the filterchain is comma separated
[09:59:51 CET] <SeanM_> Yes I want to first crop it like that and then apply the watermark over it, but it doesnt seems to work together
[09:59:56 CET] <c_14> move the double quote behind the :6, drop the space and replace the '-' with a comma
[10:00:14 CET] <c_14> Move the sws_flags as an option to the scale filter (it should work as is, but just in case)
[10:00:25 CET] <c_14> Do you want to crop first or overlay first?
[10:00:31 CET] <SeanM_> crop first
[10:00:36 CET] <c_14> And do you want to crop then scale or scale then crop
[10:01:14 CET] <SeanM_> scale and then crop, and then apply the watermark overlay
[10:02:14 CET] <c_14> -filter_complex "[0:v]scale=1728:970,crop=1280:720:224:6[iv];[iv][1:v]overlay=10:10:enable='between(t,4,12)'[v]" -map '[v]'
[10:02:59 CET] <c_14> Might need to escape the commas in the between(), not sure
[10:06:02 CET] <SeanM_> Wow thats very helpful c_14, it nearly worked, it's just that it doesnt seem to have audio now =/ i probably did the command wrong
[10:06:46 CET] <SeanM_> ffmpeg -i INPUTFILE.mpg -i logo.png -filter_complex "[0:v]scale=1728:970,crop=1280:720:224:6[iv];[iv][1:v]overlay=10:10:enable='between(t,4,12)'[v]" -map '[v]' -sws_flags lanczos -codec:v libx264 -crf 18 -preset ultrafast -movflags faststart -pix_fmt yuv420p -c:a copy OUTPUTFILE.mp4
[10:06:46 CET] <SeanM_> it plays and has the overlay but no audio, not sure if i did your fix wrong
[10:06:57 CET] <c_14> add -map 0:a
[10:08:33 CET] <SeanM_> Awesome, that did exactly what i wanted perfectly, thank you so much c_14
[11:26:52 CET] <Farika> Hi
[11:31:06 CET] <Farika> Someone has it succeded to use xvba on catalyst for video acceleration?
[12:56:10 CET] <Tzimmo> I have a bluray .m2ts file with multiple audio tracks and subtitles. I'd like to get only one video, one audio and one subtitle track and just copy them over, keeping the original container etc is fine. When I try to do
[12:56:29 CET] <Tzimmo> ffmpeg -i source.m2ts -vcodec copy -acodec copy -scodec copy output.m2ts
[12:56:33 CET] <c_14> Do you care which you want to keep?
[12:56:48 CET] <Tzimmo> it breaks the output file so that it can no longer to be played:
[12:56:58 CET] <Tzimmo> ffmpeg -i output.m2ts
[12:57:07 CET] <Tzimmo> Stream #0:0[0x100]: Data: bin_data ([6][0][0][0] / 0x0006)
[12:57:14 CET] <Tzimmo> #0:1[0x101]: Audio: ac3 ([129][0][0][0] / 0x0081)
[12:57:22 CET] <Tzimmo> Stream #0:2[0x102]: Data: bin_data ([6][0][0][0] / 0x0006)
[12:57:31 CET] <J_Darnley> I would suggest you put the full log on pastebin
[12:57:37 CET] <c_14> Can you upload the complete command and full console output for your command -- ^yes
[12:57:41 CET] <Tzimmo> I can use -map to select which tracks I want, but the problem is to get any playable output at all in m2ts format.
[12:57:55 CET] <Tzimmo> ok, a second
[12:58:45 CET] <J_Darnley> c_14makes a good point, the whole command too please
[13:04:01 CET] <Tzimmo> http://pastebin.com/694vvSQ3
[13:04:52 CET] <J_Darnley> FYI you could shorten those sizes to 1G
[13:05:55 CET] <Tzimmo> My TV has a poor selection of subtitle tracks, it generates just 20 "unnamed" subtitles and it is very laborous to figure out which one of them is the right one for me (finnish) so I try to rip away all the other subtitles so that there is only 1 subtitle available any more to make it usable
[13:06:26 CET] <Tzimmo> (sony tv, pick subtitle #15, scroll at the end of the list, right arrow to highlight "OK" and then you're done.)
[13:06:37 CET] <c_14> You might need to add the analyzeduration and the probesize to the second command
[13:06:47 CET] <Tzimmo> Repeat that 20-30 times as you don't know which is the correct subtitle for this specific file and you're lost.
[13:07:00 CET] <Tzimmo> c_14: ah...
[13:07:39 CET] <Tzimmo> c_14: still at least about the same output
[13:07:54 CET] <Tzimmo> bin_data ... and it cannot be played unlike the original that still plays
[13:08:56 CET] <c_14> try putting the analyzeduration and probesize before the -i in the first command
[13:09:17 CET] Action: J_Darnley missed that
[13:09:17 CET] <Tzimmo> And if I convert it to mkv, the TV no longer is able to show any subtitles at all as pgs is not supported in mkv but only ass :(
[13:10:08 CET] <Tzimmo> c_14: ah, ok, even though I think I saw at least some difference in adding them after -i, because otherwise it didn't find any subtitle tracks (of course)
[13:11:42 CET] <Tzimmo> Still just bin_data, now I had those analyzeduration and probesize options as the first options with 1G argument in both commands
[13:12:50 CET] <J_Darnley> Does ffmpeg stop printing those warnings if you increase those sizes more in first command
[13:12:52 CET] <Tzimmo> Another option could be to be able to convert those pgs subtitles to ass (or dvb subtitles) that might work in mkv but I guess at least conversion to ass requires OCR?
[13:12:59 CET] <J_Darnley> Yes
[13:13:01 CET] <Tzimmo> even more than 1G? like 100G?
[13:13:07 CET] <J_Darnley> No
[13:13:12 CET] <J_Darnley> like 2 or 4 maybe
[13:13:18 CET] <Tzimmo> I'll try.
[13:13:50 CET] <J_Darnley> Converting bitmap subs to text subs will require OCR, something ffmpeg cannot do.
[13:13:59 CET] <c_14> it can actually
[13:14:01 CET] <c_14> just not very well
[13:14:21 CET] <J_Darnley> When did that happen?
[13:14:27 CET] <c_14> (you have to build with tesseract support, and it afaik it doesn't generate subtitle output)
[13:14:34 CET] <Tzimmo> Hmm, true, with 4G I get only some DTS discontinuity warnings...
[13:14:36 CET] <c_14> A few months ago iirc
[13:14:40 CET] <J_Darnley> ah
[13:14:59 CET] <J_Darnley> Anyway, your TV may not support text subtitles
[13:15:06 CET] <J_Darnley> You would have to consult the manual.
[13:15:09 CET] <Tzimmo> Also I couldn't convert pgs to dvb_subtitle for some reason... or maybe it was a limitation in matroska format that dvb_subtitle is not allowed?
[13:15:19 CET] <Tzimmo> dvb_subtitle is also bitmap-based
[13:15:31 CET] <c_14> the ocr filter was added in september
[13:15:33 CET] <Tzimmo> TV supports srt and ass in mkv
[13:15:46 CET] <Tzimmo> and dvb/dvd in SD video (mpeg2ts)
[13:16:23 CET] <Tzimmo> and pgs but only in mpeg2ts, not in mkv (yes, I guess you can code like that) :)
[13:17:04 CET] <Tzimmo> And also a separate srt/sub/whatever next to the file if it is avi/mkv/mpegps at least.
[13:17:21 CET] <Tzimmo> But I'll see what 4G sizes do... a sec
[13:18:26 CET] <Tzimmo> ...still bin_data :(
[13:18:35 CET] <J_Darnley> :(
[13:19:11 CET] <Tzimmo> If I was encoding my own bluray m2ts file, what would be the appropriate format (-f) for it?
[13:19:17 CET] <J_Darnley> I wonder whether ffmpeg supports muxing the vc1 and pgs streams correctly
[13:19:19 CET] <c_14> If you can cut a small sample of the video using dd, you might want to open a bugreport on trac with that as a sample
[13:19:42 CET] <Tzimmo> I can... what is a proper size for "small"?
[13:19:55 CET] <c_14> as small as you can make it and still reproduce the problem with it
[13:19:57 CET] <Tzimmo> (I of course check that it still reproduces the issue)
[13:20:02 CET] <c_14> I think attaching to trac limits to 2mib or so
[13:20:02 CET] <Tzimmo> ok
[13:20:22 CET] <J_Darnley> There's an ftp server you can put bigger things on
[13:20:28 CET] <Tzimmo> The subtitle won't be there in the beginning of the file but this is not just about subtitles, also the video gets broken-
[13:20:41 CET] <Tzimmo> Unless I cut in the middle of the file
[13:20:49 CET] <c_14> This is m2ts you can just cut anywhere
[13:21:14 CET] <J_Darnley> There's a bit of a limit with video though.
[13:21:24 CET] <Tzimmo> Yes, but 2 megs of bluray movies doesn't last long enough to catch a video, audio and subtitle, maybe... or maybe if I can find the right spot.
[13:21:46 CET] <JEEB> if you are aiming at creating a fully compliant MPEG-TS mux for blu-ray, I don't think the mpegts muxer is applicable for that
[13:21:50 CET] <Tzimmo> Yes, I should find a keyframe and a start of the subtitle close to each other.
[13:22:02 CET] <c_14> It can be larger than 2mib, you'll just have to upload to the ftp server then
[13:22:15 CET] <c_14> JEEB: he's just trying to get the output recognized (ie not bin_data)
[13:22:17 CET] <Tzimmo> Ok, I'll check what I can do. Btw, I noticed Im
[13:22:25 CET] <J_Darnley> JEEB: at the moment we are just trying to get ffmpeg to see vc1 and pgs in its own output
[13:22:30 CET] <Tzimmo> using 2.84 version and there is 2.85 available. Any worth trying 2.85 first?
[13:22:30 CET] <JEEB> ah
[13:22:46 CET] <J_Darnley> Tzimmo: use the git head
[13:22:50 CET] <JEEB> you should in general be using not releases but master unless FATE is red everywhere
[13:23:19 CET] <Tzimmo> J_Darnley: ok
[13:39:23 CET] <micechal> I'm trying to encode a ogg vorbis file without any metadata at all, but ffmpeg keeps adding the "encoder" field no matter what I try. yesterday, when encoding some PCM WAVs, "-fflags +bitexact -map_metadata -1" was enough
[13:39:52 CET] <micechal> but with the OGGs it doesn't seem to work that well
[13:41:12 CET] <c_14> try adding -flags +bitexact
[13:42:10 CET] <micechal> no difference :(
[13:47:03 CET] <c_14> Hmm, that's what my logs tell me should work. Maybe something changed.
[13:48:59 CET] <micechal> "-map_metadata -1 -c:a libvorbis -flags +bitexact -fflags +bitexact" this is what I tried
[13:49:11 CET] <Chagall> I think encoding is failing because of the subtitle filter - I'm escaping single quote marks to mark the input file (with whitespace in the path), but if I have single quote marks in the input file name (from which I get the subtitles) then it fails. can I wrap the input path around double quotes instead or somehow mark the single quotes inside the input as being part of the filename?
[13:49:38 CET] <c_14> you can use double quotes or escape the single quotes with a '\'
[13:50:09 CET] <Chagall> "-i D:/Encodes/my file 'name'.mkv -ss 00:00:00.000 -t 00:07:17.400 -c:v:0.0 libvpx -pass 1 -b:v 3917K -quality good -cpu-used 0 -vf subtitles=\\'D\\:/Encodes/my file \\'name\\'.mkv\\':si=0 -an -sn -sws_flags lanczos -f webm D:\\Encodes\\temp\\null"
[13:50:38 CET] <Chagall> i'll try double quotes then
[13:54:05 CET] <Chagall> doesn't seem to work either
[14:03:34 CET] <Tzimmo> J_Darnley: with git head I actually get video stream looking a lot better
[14:03:44 CET] <Tzimmo> Stream #0:0[0x100]: Video: vc1 (Advanced) (VC-1 / 0x312D4356), yuv420p(bt709), 1920x1080 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 90k tbn, 47.95 tbc
[14:03:52 CET] <Tzimmo> the subtitle is still bin_data
[14:04:05 CET] <Tzimmo> but let's see if this now at least is playable
[14:05:21 CET] <Tzimmo> yes, video and audio plays fine, subtitle isn't recognized
[14:09:42 CET] <Tzimmo> If I try with -scodec dvb_subtitle to try to convery the subtitles I get
[14:09:52 CET] <Tzimmo> Stream #0:13 -> #0:2 (hdmv_pgs_subtitle (pgssub) -> dvb_subtitle (dvbsub))
[14:09:54 CET] <Tzimmo> ...
[14:09:59 CET] <Tzimmo> frame= 1855 fps=600 q=-1.0 size=  160661kB time=00:01:17.28 bitrate=17029.5kbitsSubtitle encoding failed
[14:10:02 CET] <Tzimmo> Conversion failed!
[14:10:26 CET] <Tzimmo> I can provide a full output if you think this should work...?
[14:16:13 CET] <c_14> I don't think ffmpeg can convert between video subtitle formats well/at all.
[14:16:47 CET] <durandal_1707> it can
[14:17:00 CET] <c_14> never seemed to work when I tried
[14:17:29 CET] <c_14> Are there restrictions on which codecs it can convert to certain other codecs?
[14:17:46 CET] <durandal_1707> probably
[14:18:20 CET] <durandal_1707> but its bug and should be reported
[14:28:40 CET] <iive> i'm sure it cannot convert from bitmap to text based subtitles
[14:29:07 CET] <iive> howeve both pgs and dvb are bitmap subtitles.
[14:31:40 CET] <Chagall> i tried a bunch of different things but still not working
[14:31:56 CET] <Chagall> just need to support any file name in the sub filter input
[14:32:17 CET] <Chagall> single quotes alone don't work because i surround the input file name in single quotes, but can't figure out how to make the alternatives work
[14:32:30 CET] <Chagall> or escape the inner single quote properly
[14:34:03 CET] <c_14> you probably need either more or less '\'
[14:35:17 CET] <Chagall> i tried adding an extra layer but it didn't work either
[14:35:56 CET] <Chagall> and i tried removing some and then all of them and that still didn't work
[14:36:15 CET] <Tzimmo> Yes I've converted from dvb subtitles to dvd subtitles etc, bitmap-to-bitmap and it has mostly been working at least somewhat.
[14:36:21 CET] <Chagall> just need a clear pattern for this
[14:36:26 CET] <c_14> have you tried using -filter_script
[14:37:14 CET] <hassonofer> How do I retransmit RTSP stream using ffmpeg ?
[14:37:41 CET] <Tzimmo> Chagall: At least in the example you gave above, you have the whole command line inside double quotes. You should only put filenames (with spaces and ':s) in double quotes, not the whole command line...?
[14:38:13 CET] <Chagall> they're not actually there
[14:38:29 CET] <Chagall> the same settings work when i have no subtitles enabled
[14:38:41 CET] <Tzimmo> Ok
[14:38:50 CET] <Chagall> that's debug output i copy-pasted
[15:09:31 CET] <hassonofer> How do I retransmit RTSP stream using ffmpeg ? I'm keep getting "Could not write header for output file #0 (incorrect codec parameters ?): Connection refused" error
[15:10:16 CET] <hassonofer> The command I use is: "ffmpeg -i "rtsp://USER:PASS@DOMAIN.dvrlists.com:8554/streaming/channels/601" -f rtsp rtsp://"
[16:14:09 CET] <t0by> Hi. Stupid question - I would like to *add* (render) some grain. Is there a way to do so with ffmpeg or do I need to use a GUI editor?
[16:15:20 CET] <c_14> The noise filter?
[16:21:06 CET] <t0by> c_14, the thing is that I would like to specify an average size for the "grains", if you get what I mean, to make it look actually grainy and not noisy
[16:21:20 CET] <t0by> which obviously would be >1px
[16:23:39 CET] <Chagall> in filter_complex [0:s:0], first 0 is first input and second is first sub stream in the input?
[16:23:56 CET] <Chagall> so if i did 0:s:1 i would get the 2nd subtitle stream?
[16:24:02 CET] <c_14> t0by: don't think there's a filter for that
[16:24:13 CET] <c_14> Chagall: yes
[16:24:26 CET] <t0by> c_14, any sort of magic that can be done to approximate that?
[16:24:27 CET] <Chagall> thanks
[16:25:11 CET] <c_14> t0by: if you can get a video with alpha of the grain you want you might be able to overlay it
[16:26:08 CET] <t0by> c_14, I thought of that approach, but... that would require me to render 2 hours of pure noise at 1080p on my disk
[16:26:14 CET] <t0by> which I'm not exactly looking forward to
[16:26:27 CET] <c_14> overlay or blend
[16:26:43 CET] <c_14> If you don't mind the noise repeating after n minutes, it doesn't have to be full-length
[16:27:13 CET] <c_14> And if whatever's rendering the noise can output to stdout (or even just to a named fifo) you can use that as input for ffmpeg so you don't have to save it to disk
[16:29:09 CET] <t0by> c_14, is there a simple way of chaining the noise filter with scale and blur to get that instead of an external tool?
[16:29:13 CET] <t0by> sorry for the newbie question
[16:29:20 CET] <t0by> but I've never had to do complex filter chains like this
[16:30:35 CET] <c_14> probably
[16:31:40 CET] <t0by> c_14, sorry, so how do I combine the two chains?
[16:31:49 CET] <t0by> (this chain I'll make up somehow and my source)?
[16:32:17 CET] <Kak> good morning, how can I record my desktop and my voice at the same time with ffmpeg?
[16:34:44 CET] <c_14> Kak: https://trac.ffmpeg.org/wiki/Capture/Desktop https://trac.ffmpeg.org/wiki/Capture/ALSA
[16:36:36 CET] <c_14> t0by: just testing it out here first
[16:36:46 CET] <t0by> c_14, thank you *so* much
[16:40:12 CET] <Kak> thank you very much
[16:44:53 CET] <Chagall> -filter_complex "[0:v:0][0:s:0]overlay[vid]" fails for me
[16:46:52 CET] <Chagall> "Filter overlay has a unconnected output"
[16:47:02 CET] <c_14> did you map [vid] ?
[16:48:35 CET] <Chagall> oh my bad
[16:48:38 CET] <Chagall> was missing
[16:49:30 CET] <c_14> t0by: ffmpeg -f lavfi -i color=black at 0.8:s=640x360 -i movie -filter_complex '[0:v]noise=alls=40:allf=t,scale=1920x1080,smartblur[iv];[iv][1:v]blend=all_mode=hardlight[v]' -map '[v]' -t 2 out.mkv <- something like this maybe
[16:49:35 CET] <c_14> the blend mode isn't great currently
[16:49:46 CET] <c_14> And you might want to adjust how much you scale by and the noise settings etc
[16:50:17 CET] <c_14> I tired getting overlay to work, but it's either not reading the opacity or one of the other filters is throwing it away
[16:50:36 CET] <t0by> c_14, i might be in love with you
[16:50:38 CET] <t0by> just one thing
[16:50:44 CET] <t0by> where do I put my input file in all that?
[16:50:49 CET] <gener1c> he's a guy
[16:50:55 CET] <t0by> so what
[16:50:57 CET] <c_14> where I wrote movie
[16:51:04 CET] <t0by> d'oh
[16:51:05 CET] <gener1c> ffmpeg -i input_file
[16:51:17 CET] <c_14> t0by: using white instead of black seems to work better
[16:51:50 CET] <t0by> thank you so so so so much
[16:53:10 CET] <gener1c> i cant find the fifo bug anywhere
[16:53:16 CET] <gener1c> is there fifo support already?
[16:53:28 CET] <c_14> hmm? fifo for what?
[16:53:34 CET] <gener1c> fifo files
[16:53:45 CET] <gener1c> for multiple pipes to the same encoding process
[16:53:53 CET] <gener1c> in different time periouds
[16:54:09 CET] <c_14> should work
[16:54:18 CET] <t0by> hum
[16:54:22 CET] <t0by> not working?
[16:54:34 CET] <gener1c> well i didnt try yet
[16:54:36 CET] <c_14> t0by: error or you don't see anything?
[16:54:49 CET] <t0by> i get circa 1 second of pure noise
[16:54:55 CET] <t0by> let me try again
[16:55:08 CET] <c_14> The -t 2 limits the output to 2 seconds (for testing purposes)
[16:55:26 CET] <t0by> d'oh
[16:55:27 CET] <c_14> you might have to change the blend mode to something better (I just picked one at random)
[16:55:36 CET] <t0by> but i mean, I get *pure* white
[16:55:41 CET] <t0by> er, noise
[16:55:43 CET] <t0by> er, noise-on-white
[16:56:03 CET] <c_14> you can also control the strength of the noise in each of the chroma values as well as the seed, and control blending per chroma value as well
[16:56:52 CET] <c_14> Aha
[16:56:57 CET] <c_14> found what I was looking for
[16:57:03 CET] <gener1c> after the first pipe ffmpeg stops
[16:57:05 CET] <c_14> The blend filter has an all_opacity option
[16:57:11 CET] <c_14> Set that to 0.2 or something
[16:57:12 CET] <gener1c> it makes sense because it sees and eof
[16:57:16 CET] <gener1c> how to i make it stay up?
[16:57:27 CET] <gener1c> an*
[16:57:34 CET] <c_14> gener1c: it won't. As soon as it sees EOF it stops
[16:57:45 CET] <c_14> t0by: like so blend=all_opacity=0.2
[16:57:46 CET] <gener1c> but its a fifo pipe
[16:57:54 CET] <gener1c> i need to >> several files into it
[16:57:56 CET] <gener1c> :|
[16:58:05 CET] <c_14> Are you trying to concatenate?
[16:58:12 CET] <gener1c> i know -concat
[16:58:24 CET] <gener1c> i am trying to live encode random blobs
[16:58:27 CET] <gener1c> that come as files
[16:58:35 CET] <c_14> What format?
[16:58:41 CET] <gener1c> humz
[16:58:53 CET] <c_14> Because that won't work with most formats (it'll work for mpegts)
[16:59:02 CET] <gener1c> mpeg2 i think
[16:59:10 CET] <gener1c> file outputs mpeg transport stream
[16:59:28 CET] <gener1c> then yeah
[17:01:07 CET] <gener1c> so i get transport stream blobs ... how can i make this work without closing on me because of the eof?
[17:01:08 CET] <c_14> You might have better luck writing a small program and then just piping from that program via stdout to ffmpeg
[17:02:16 CET] <gener1c> how will i go about it? use libav?
[17:03:23 CET] <gener1c> or just open ffmpeg with popen?
[17:03:29 CET] <c_14> gener1c: just write a small script in your favorite scripting language that reads from the fifo (or whatever) and then pipes that out via stdout to ffmpeg -i foo bar
[17:03:43 CET] <c_14> something like that, ye
[17:03:57 CET] <t0by> c_14, thank you so much
[17:10:45 CET] <gener1c> well that was easy enough
[17:11:06 CET] <gener1c> i was scared ffmpeg wont like the chunk sizes or something but it ate it like a pro, it just works
[17:11:54 CET] <gener1c> now i need to make this thing stable and pretty
[17:27:42 CET] <Chagall> well... overlaying subs kinda worked, only it makes the image look like complete garbage
[17:28:21 CET] <Chagall> http://i.imgur.com/SaARwNq.png at 3k kbps
[17:29:28 CET] <Chagall> no issue when i disable subs, all i did was -filter_complex [0:v:0][0:s:0]overlay[vid] -map [vid]
[17:29:34 CET] <Chagall> not sure if it'S because i did it on the first pass
[17:29:39 CET] <Chagall> or some other issue
[17:33:36 CET] <c_14> are you encoding 2-pass?
[17:33:40 CET] <Chagall> yes
[17:33:48 CET] <c_14> only apply filters on the second pass
[17:33:52 CET] <Chagall> ok
[17:33:54 CET] <c_14> although
[17:33:56 CET] <c_14> or was it both
[17:34:09 CET] <Chagall> yeah both
[17:34:12 CET] <c_14> both should be fine
[17:34:18 CET] <Chagall> yeah it works when i use regular filters
[17:34:21 CET] <c_14> Is your bitrate 3000k or 3k?
[17:34:38 CET] <c_14> because 3k is really low
[17:37:10 CET] <Chagall> same thing on 2nd pass only
[17:41:02 CET] <Chagall> it works on actual dvd subtitle but not on vobsub it seems
[17:43:46 CET] <Chagall> chaining filters like crop=something,scale=something doesn't work in filter_complex?
[17:44:07 CET] <c_14> it does
[17:46:03 CET] <Chagall> oh, cannot use normal filter and complex filter for the same stream
[18:02:22 CET] <Chagall> so yeah now i can handle raw dvd subs, but what can i do about vobsub
[18:02:30 CET] <Chagall> it turns it into garbage
[18:58:13 CET] <debianuser> Hello. How can I disable ODML when writing .avi file with ffmpeg? I'm encoding a 1.5GB video for a hardware player, and it stops playing after ~1GB. But if I remux the file with `mencoder -noodml ...` the player plays it all fine.
[18:59:08 CET] <debianuser> (I currently have that player here, so I can test any options you know)
[19:03:34 CET] <c_14> debianuser: I don't think there's an option for that. (I just checked the code and all the calls to the odml writing functions aren't conditional)
[19:06:07 CET] <debianuser> c_14: Maybe there's a way to increase the boundary to create ODML index if the file is >1.9GB instead of 1GB?
[19:10:42 CET] <c_14> You'd have to recompile, but sure.
[19:10:57 CET] <c_14> change AVI_MAX_RIFF_SIZE in libavformat/avi.h
[19:18:36 CET] <debianuser> Hm, I think I can do that... but not now. Maybe later, if I get this issue happens again. This time I'll just remux those two files with mencoder -noodml.
[19:18:57 CET] <debianuser> c_14: Thanks a lot for your help!
[19:19:22 CET] Action: debianuser saves a note to increase AVI_MAX_RIFF_SIZE when building ffmpeg next time...
[20:43:26 CET] <dorp> If one uses ffmpeg for screen capturing a playing video, should the exported video match (precisely) the framerate of the playing video, or it might as well exceed it?
[20:45:02 CET] <DHE> ffmpeg captures at the framerate you specify, but scheduling may cause it to drift a little bit. you may get duplicate and dropped frames
[20:45:13 CET] <DHE> and then there's stuff like videos running at 29.97fps when you record at 30
[20:47:50 CET] <dorp> DHE: So as I take it that there's no special significance to the precise framerate?
[20:48:47 CET] <DHE> I haven't tried recording video playback with ffmpeg. usually I just download the video itself and save it. much easier, faster and reliable
[20:49:02 CET] <DHE> mostly I've recorded things like games, instructional demonstrations, etc
[20:49:15 CET] <DHE> where a little bit of framerate jitter is more tolerable
[20:49:45 CET] <dorp> I see, thanks
[20:50:51 CET] <DHE> all I can suggest is trying it and see if you're happy with the results
[21:01:24 CET] <Chagall> to use fast seeking (-ss before -i) with text subtitles is the only way to extract the subtitle and change the timestamps externally before feeding it back to the filter or is there a better solution?
[21:27:58 CET] <Farika> hi
[21:28:19 CET] <Farika> xvba works with ffmpeg ?
[21:42:48 CET] <Warblefly> Not that I can find on http://www.ffmpeg.org/ffmpeg-all.html. It was talked about three years ago. https://trac.ffmpeg.org/search?q=xvba
[21:44:01 CET] <BtbN> xvba still exists?
[22:28:55 CET] <Farika> BtbN : yes when you use catalyst :)
[22:29:16 CET] <BtbN> The only player which supported that was kodi, and i think they dropped it.
[22:29:25 CET] <BtbN> Or does something else still support it?
[22:29:42 CET] <Farika> ah :( and i have a bug with opensource driver and i can use only catalyst
[22:29:44 CET] <Farika> suckz :(
[22:30:47 CET] <Farika> so , no video acceleration with proprietary drivers
[22:31:03 CET] <Farika> vainfo: Driver version: AMD MMD 1.0
[22:32:08 CET] <Farika> don't work with vlc
[22:32:29 CET] <JEEB> xvba was the worst of all the lunix hw decoding APIs
[22:32:46 CET] <JEEB> pretty sure it wasn't even full hw decoding, but rather you had to do parts of the job yourself
[22:32:55 CET] <JEEB> which is why pretty much nothing supports it
[22:32:56 CET] <Farika> yeah... and catalyst is bad too but no choice
[22:32:58 CET] <Farika> https://bugs.freedesktop.org/show_bug.cgi?id=93826
[22:33:10 CET] <Farika> my 290X and my screen don't work with opensource driver
[22:33:21 CET] <JEEB> my condolences then
[22:33:34 CET] <Farika> tks :p
[22:33:35 CET] <JEEB> also I thought AMD did VA-API :P
[22:33:41 CET] <JEEB> at least with those newer pieces
[22:34:00 CET] <JEEB> xvba was a thing for like early middle 2000s or so
[22:34:14 CET] <Farika> hum
[22:34:29 CET] <Farika> my vainfo output is ok
[22:34:39 CET] <Farika> but vlc wont work with
[22:35:08 CET] <JEEB> try building mpv withe va-api from the mpv-build repository
[22:35:19 CET] <JEEB> (or installing from packages if you have new enough)
[22:35:29 CET] <Farika> i've post a topic on vlc forum... but a dev say the error is between libavcodec and vdpau
[22:35:30 CET] <Farika> https://forum.videolan.org/viewtopic.php?f=13&t=130325&p=436402#p436402
[22:35:46 CET] <JEEB> vdpau is not va-api
[22:36:48 CET] <JEEB> anyways, my recommendation would be with trying out the latest mpv with va-api and the opengl renderer, I guess
[22:38:54 CET] <Farika> heuu
[22:39:01 CET] <Farika> i don't know what i've but i think its ok
[22:39:06 CET] <Farika> [00007f75a4c0bf58] avcodec decoder: Using AMD MMD 1.0 for hardware decoding.
[22:39:11 CET] <Farika> *what i've done
[22:40:38 CET] <Farika> :) thanks
[22:40:49 CET] <Farika> wish u good night
[00:00:00 CET] --- Mon Jan 25 2016

More information about the Ffmpeg-devel-irc mailing list