[Ffmpeg-devel-irc] ffmpeg.log.20160603

burek burek021 at gmail.com
Sat Jun 4 02:05:01 CEST 2016

[00:09:37 CEST] <speedcube> balls! Dont think the libv4l2 is enabled in the Debian repos...
[00:10:27 CEST] <jnorthrup> hi i have to stitch two clips together and run an overlay on the first, longest one.
[00:10:27 CEST] <speedcube> IIRC there was a way to get around that? -use-v4l2 or something along the lines
[00:10:42 CEST] <jnorthrup> >ffmpeg.exe -i Y:\jiraftp\BugPacks\RG-5640\Sources\Yellen.mp4 -i Y:\jiraftp\BugPacks\RG-5640\Sources\logo.png  -i Y:\jiraftp\BugPacks\RG-5640\Sources\ending_english.mp4 -filter_complex "[0:v][1:v] overlay=25:25" -pix_fmt yuv420p -map 2:v -c:a copy -y out.mp4
[00:11:29 CEST] <jnorthrup> this was my guess to transcode the two homogenous video sources under a common set of switches/sample headers
[00:11:46 CEST] <jnorthrup> except it only focussed on the overlay vid stream
[00:12:31 CEST] <jnorthrup> in the ancient days like 2006 or so i would have better success mapping concurrent vids into a single container before stitiching with mp4box
[00:12:54 CEST] <jnorthrup> because mp4box makes excuses for bitwise different sample headers to not splice
[00:13:58 CEST] <llogan> by "stitch" do you want to concatenate or mux multiple video streams into the output container
[00:14:37 CEST] <jnorthrup> the first pass i want two cncurrent video tracks/streams,  then i expect mp4box can be told to concatenate second track to first in a brand new container
[00:15:49 CEST] <jnorthrup> that was what or possibly, i might write two containers at once, for the benefit of mp4box, but i don't recall the specifics of what i did 10 years ago
[00:16:40 CEST] <llogan> if you want to concatenate see the concat demuxer or concat filter
[00:17:04 CEST] <jnorthrup> i guess no such thing existed in 06
[00:25:25 CEST] <speedcube> Doing a capture from a webcam. ffmpeg -f v4l2 -framerate 25 -video_size 640x480 -i /dev/video0 output.mkv Getting weird warnings from ffmpeg
[00:25:30 CEST] <speedcube> Past duration 0.803886 too large    6006kB time=00:00:11.34 bitrate=4336.8kbits/s
[00:25:30 CEST] <speedcube> [video4linux2,v4l2 @ 0xf73880] Dequeued v4l2 buffer contains corrupted data (691200 bytes).
[00:25:51 CEST] <speedcube> video is kinda choppy. Is this a bug?
[00:28:01 CEST] <speedcube> Think it is a bug https://trac.ffmpeg.org/ticket/4401
[00:38:30 CEST] <nucular> Hey, what's the best way to shift a video stream by one frame, i.e. moving the last frame of it to the front or vice-versa?
[00:49:04 CEST] <llogan> nucular: probably with setpts filter
[00:49:41 CEST] <llogan> or trim+concat
[00:50:01 CEST] <llogan> s/setpts/select
[00:57:55 CEST] <speedcube> So there seems to be a bug when capture video with framerates but you can get around it with -filter:v fps=(your framerate) How would I add that to this cmd
[00:57:59 CEST] <speedcube> ffmpeg -f v4l2 -video_size 720x480 -i /dev/video0 output.mkv
[00:58:49 CEST] <speedcube> oh wait. Was just a formatting issue on my part.
[00:59:57 CEST] <Alives> i have some music that is clipping, but avconv -af volumedetect shows max_volume at 0.0 dB... How can I get a more detailed analysis that indicates clipping?  followup, if I run these tracks through -af "volume=-0.9dB" they usually don't change and still report max_volume at 0.0 dB.  Sometimes they change though... very random.  Am I doing something wrong?
[01:04:17 CEST] <llogan> Alives: avconv isn't from FFmpeg
[01:05:24 CEST] <Alives> oh
[01:05:30 CEST] <Alives> i thought avconv was some fork of it
[01:06:09 CEST] <c_14> that doesn't mean it's supported here. either use ffmpeg from FFmpeg (a static build, build from source, etc) or ask in #libav
[01:06:11 CEST] <Alives> ah it looks like it is a fork from 2011
[01:06:18 CEST] <Alives> i see
[01:06:19 CEST] <Alives> thanks
[01:20:40 CEST] <Alives> c_14: if i were to use ffmpeg/FFmpeg, what would I do?  Are the flags I mentioned for ffmpeg?
[01:22:22 CEST] <llogan> Alives: perhaps the astats filter: ffmpeg -i input.wav -af astats -f null -
[01:24:16 CEST] <Alives> thanks ill try that!
[01:25:13 CEST] <Alives> woah NICE!
[01:27:22 CEST] <nick0> I'm trying to resample some audio I decoded and filtered, I managed to setup the resampler, get the same amount of frames as the input, then I flush it. Flushing gives me the extra frames I needed, but it also gives *extra* frames, which sounds like a few seconds of the clip, played backwards and sped up. What could it be?
[01:29:40 CEST] <Alives> is min level -1 the same as max level 1?  thus a clip?
[01:32:19 CEST] <Alives> im just trying to prevent some tracks from clipping that i have.  my hardware DSP mutes when it detects clipping.  If i set my preamp to -1dB output everything is fine... I'd rahter programatically lower each track to the max volume without clipping if possible
[03:01:16 CEST] <hispeed67> hi, im using  ffmpeg to put text on a video clip. how do i put the text on more than three lines? (i.e. date, date, author) but not on one line.
[03:01:59 CEST] <c_14> Add more newlines?
[03:02:41 CEST] <hispeed67> hmmm... seems so simple...did i just assume that wouldn't work.. wait one.
[03:04:32 CEST] Action: hispeed67 smacks head into wall
[03:05:06 CEST] <ATField> heheh
[03:26:25 CEST] <llogan> alternatively, use textfile option. or use subtitles filter.
[03:45:58 CEST] <hispeed67> ok, what i want to do should be easy. i created a 3 second blue screen mp4 and i want to put text on it. im having issues with the fontfile option.. do i need to specify full path?
[03:46:36 CEST] <hispeed67> vi make.file
[03:47:52 CEST] <c_14> probably, though relative to cwd should also work
[03:48:55 CEST] <hispeed67> so i have to find out where they are all the way to the .ttf file?
[03:51:48 CEST] <c_14> if you built with fontconfig support you can just use the font option
[03:52:08 CEST] <c_14> like font='Bitstream Vera' or something
[04:06:39 CEST] <hispeed67> doesn't look like i built it with fontconfig support
[04:07:15 CEST] <hispeed67> all the examples im finding are very complex..
[04:55:34 CEST] <ATField> hispeed67: Try putting the location in the following format: fontfile=I\\:\Misc\\\\~Software\\\\~OS\\\\I386\\\\arial.ttf
[05:00:20 CEST] <furq> or just move the font into the working directory
[05:00:49 CEST] <furq> at the very least quote the path so you don't need to double escape
[05:04:09 CEST] <ATField> furq, do you know any good and large sample collections of various ffmpeg commands, perchance?
[05:04:37 CEST] <furq> that seems like an odd thing to waht
[05:04:40 CEST] <furq> or want
[05:05:58 CEST] <hispeed67> fontfile=/usr/share/fonts/truetype/dejavu/DejaVuSans-Bold.ttf
[05:06:16 CEST] <ATField> Its just that I am usually having better time learning the proper usage from analysing examples than reading manuals.
[05:06:34 CEST] <ATField> reading manuals alone*
[05:13:07 CEST] <ATField> What would be a good way to preserve quality and optimize process in general if the operations include 1. burning subtitles into the file, 2. trimming several different segments together from that (http://superuser.com/questions/681885/how-can-i-remove-multiple-segments-from-a-video-using-ffmpeg) , 3. then finally converting it to vp8?
[05:13:43 CEST] <ATField> All I have now is either burning the subtitles in step one with high bitrate or making a temporary lossless video output.
[05:14:35 CEST] <furq> steps 2 and 3 can be done in one go
[05:14:50 CEST] <furq> they can all be done in one go if you're cutting at keyframes, but that's not likely
[05:14:54 CEST] <ATField> true
[05:15:25 CEST] <furq> so yeah your options are a lossless working file or editing the subtitles to match the trimmed output
[05:15:37 CEST] <furq> the former sounds like less hassle
[05:17:40 CEST] <ATField> (that was re: comment 1) ,, re: comment 2: I tried including it all in a filter_complex, but burning didnt work well with the trims paragraph. And piping step one into step 2 didnt magically preserve quality (which was obvious in retrospect).
[05:18:10 CEST] <ATField> Does it matter which lossless format to use? Or theyre more or less the same in terms of space and encoding time?
[05:18:19 CEST] <furq> ffv1 is generally a good bet
[05:18:29 CEST] <ATField> Ah, thanks.
[05:19:02 CEST] <furq> it's pretty fast and it compressed pretty well
[05:19:06 CEST] <furq> compresses
[05:19:13 CEST] <furq> all the alternatives i know of that are better at one are much worse at the other
[05:19:23 CEST] <furq> or are non-free
[05:22:02 CEST] <ATField> Also, do I get it right that trimming (https://ffmpeg.org/ffmpeg-all.html#trim) from startpoint to endpoint only works with seconds as its format (e.g. trim=start=180.115), and there isnt a way to make it work with sexagesimals (e.g. trim=start=01:30:45.115)?
[05:23:07 CEST] <ATField> The docs page says start, end, and duration are expressed as time duration specifications, but whenever I tried the sexagesimal option, it failed.
[05:27:51 CEST] <hispeed67> what does trimming do?
[05:30:34 CEST] <furq> ATField: select might be a better idea than trim if you want to merge several different parts together
[05:30:54 CEST] <furq> https://ffmpeg.org/ffmpeg-all.html#select_002c-aselect
[05:32:08 CEST] <ATField> furq: Ill look into that, thanks. I used trim because thats what was suggested here: http://superuser.com/questions/681885/how-can-i-remove-multiple-segments-from-a-video-using-ffmpeg.
[05:33:41 CEST] <ATField> hispeed67: For me, at least, it was taking several different segments from the file and putting them together in the output (e.g. [ABCDEFG[ ’ [BDF]), like if you edited the video in something like Vegas.
[05:35:38 CEST] <hispeed67> aahh. i haven't gotten there yet. i'm still just cutting clips out of the file
[05:36:12 CEST] <hispeed67> after i have the clip, i want to put 3 lines of text in first 5 seconds or so...
[05:39:54 CEST] <ATField> hispeed67: If a more precise cut would be preferable for your purposes, I would suggest using MPC-HC. Its one of the only players that can show the current time in HH:MM:SS.MS format.
[05:47:48 CEST] <hispeed67> nah, i want to learn to use ffmpeg it seems to do all kinds of cool things.
[05:48:32 CEST] <hispeed67> hey, you guys can prolly answer my ?. i want to get a new computer. if im going to edit videos using ffmpeg, is it better for 2 processors, or 1 proc and good video card?
[05:54:06 CEST] <furq> hispeed67: he meant to get the timecodes before putting them into ffmpeg
[05:54:17 CEST] <furq> and also you almost certainly want as much cpu power as possible
[05:55:35 CEST] <furq> hardware accelerated video encoding still sort of sucks unless you need it in realtime without touching the cpu
[05:55:40 CEST] <hispeed67> i was thinking about getting a dual cpu, quad core (total 8 core) with 32 gigs ram for 150..
[05:55:53 CEST] <furq> 150 what, bars of gold?
[05:56:03 CEST] <furq> that should cost more than 150 of any currency
[05:56:05 CEST] <hispeed67> xeon 5xxx series cpu.
[05:56:09 CEST] <hispeed67> used. ebay.
[05:56:12 CEST] <hispeed67> 143.00
[05:56:18 CEST] <hispeed67> oh, rack mount.
[05:56:56 CEST] <furq> xeon 5000 series doesn't really mean anything, they reuse the product numbers
[05:57:05 CEST] <furq> if it's that cheap then it's probably one of the ones from 2007
[05:57:11 CEST] <furq> which i think is basically a core 2 quad
[05:57:41 CEST] <furq> any recent 6-core i7 will smash that to pieces
[05:57:48 CEST] <furq> although obviously it'll cost you
[05:58:07 CEST] <hispeed67> DELL POWEREDGE 2950 GEN III SERVER 2*INTEL XEON X5450 3.00GHz QUAD CORE 32GB RAM
[05:58:21 CEST] <furq> http://ark.intel.com/products/34446/Intel-Xeon-Processor-X5450-12M-Cache-3_00-GHz-1333-MHz-FSB
[05:58:24 CEST] <furq> i was right
[05:59:40 CEST] <hispeed67> http://www.ebay.com/itm/DELL-POWEREDGE-2950-GEN-III-SERVER-2-INTEL-XEON-X5450-3-00GHz-QUAD-CORE-32GB-RAM/361554643470?_trksid=p2047675.c100005.m1851&_trkparms=aid%3D222007%26algo%3DSIC.MBE%26ao%3D1%26asc%3D36860%26meid%3De87596519c064c66b8bc83f62fea182a%26pid%3D100005%26rk%3D4%26rkt%3D6%26sd%3D381622430178
[05:59:50 CEST] <hispeed67> uck.. sorry.
[06:00:09 CEST] <furq> and yeah 32GB doesn't really matter for video encoding
[06:00:15 CEST] <furq> maybe it will for editing, i don't really bother with that
[06:00:56 CEST] <furq> i wouldn't bother with server-grade stuff either, for that use case it's not really worth the premium for ECC memory
[06:01:37 CEST] <furq> plus it'll be in an awkward and ugly case unless you have a cabinet for it to go into
[06:06:21 CEST] <hispeed67> are you busy? would you mind giving your opinion on a couple?
[06:06:55 CEST] <ATField> >	150 what, bars of gold? || Hahaha. Is this #minecraft yet? : p
[06:07:39 CEST] <ATField> hispeed67: Not dissuading you or anything, but you can also try https://www.reddit.com/r/buildapc/. Havent used it myself yet, but they seem to be pretty willing to help in such matters and also explain things.
[06:08:28 CEST] <hispeed67> well, there are others available, im getting something old and used, but cheap.. and upgrades will be cheap. ;)
[06:09:58 CEST] <hispeed67> http://www.ebay.com/itm/Dell-PowerEdge-2900-III-Tower-2x-2-66GHz-Quad-Core-E5430-No-RAM-No-3-5-HDD/381622430178
[06:10:49 CEST] <furq> any dual socket quad core which costs that much is a nine-year-old core 2 quad
[06:12:28 CEST] <furq> the only cheap xeon system that it might be worth buying is a westmere-ep
[06:12:39 CEST] <furq> but i'd probably just get a recent desktop cpu
[06:12:50 CEST] <hispeed67> because it doesn't have hyperthreading?
[06:12:56 CEST] <furq> no, because it's old and it sucks
[06:13:24 CEST] <furq> HT doesn't really contribute much for video encoding
[06:13:26 CEST] <hispeed67> now, what about upgrading the bios and CPU to one that supports hyperthreading?
[06:13:30 CEST] <hispeed67> oh.
[06:13:34 CEST] <hispeed67> ignore my comment.
[06:13:41 CEST] <furq> and HT isn't a bios feature
[06:13:55 CEST] <furq> oh nvm you said cpu
[06:13:58 CEST] <hispeed67> it's a CPU feature, but the CPU has to be supported
[06:14:04 CEST] <furq> but yeah HT isn't supported on any chip which would go in that board
[06:14:11 CEST] <furq> they moved to a new socket for nehalem
[06:14:13 CEST] <hispeed67> ok
[06:14:37 CEST] <hispeed67> man.. they go to 500 bucks for the ones you're talking bout
[06:14:51 CEST] <furq> westmere-ep is from 2011
[06:15:01 CEST] <furq> if you're spending money then buy something newer
[06:15:14 CEST] <furq> i'm only aware of it because it'd be a cheap upgrade for my nehalem system
[06:15:51 CEST] <hispeed67> http://www.ebay.com/itm/Dell-Poweredge-2900-II-Tower-Server-2-X-QC-2-66GHZ-8GB-3-X-146GB-PERC-5I-RPS/351747850091
[06:16:11 CEST] <furq> Memory Type: DDR2
[06:16:13 CEST] <furq> that's a core 2
[06:17:02 CEST] <hispeed67> http://www.ebay.com/itm/HP-ML150-G6-2-0GHZ-Quad-Xeon-24GB-DDR3-NO-HD-ML150G6/231959387672
[06:20:25 CEST] <furq> it really breeds confidence when the cpu model number is only visible in the bios screenshot
[06:20:52 CEST] <furq> i guess that's quite cheap but it's a bottom-end cpu
[06:21:31 CEST] <hispeed67> meh. not even dual socket.
[06:22:06 CEST] <furq> AMD need to hurry up and make viable products again
[06:22:19 CEST] <furq> haswell i7s still cost $300 just for the cpu
[06:22:55 CEST] <hispeed67> Processors:  2 x  QC 2.4/8MB E5530 <== hows that cpu?
[06:23:17 CEST] <furq> http://ark.intel.com/products/family/28144/Intel-Xeon-Processor-5000-Sequence#@All
[06:26:45 CEST] <hispeed67> http://www.ebay.com/itm/HP-Proliant-ML350-G6-2x-X5675-3-06ghz-Hex-Core-32gb-4x-300gb-10k-2x-PSU/231948393673
[06:31:55 CEST] <furq> that's not bad for the price
[06:45:20 CEST] <hispeed67> know anywhere else i can look for a good deal? craigslist is hard to search to dual processor
[07:01:41 CEST] <darns`> is there any command line player that can give you the byte position of the file being played ?
[07:08:28 CEST] <ATField> darns`: Maybe you can tweak ffplay to display the information you need in its terminal window (not sure)?
[07:36:33 CEST] <prelude2004c> hey.. guys i am trying to get closed caption data
[07:36:36 CEST] <prelude2004c> how do i enale it.. --enable-a53 ?
[07:36:41 CEST] <prelude2004c> and how do i set it in ffmpeg
[08:51:48 CEST] <k_sze[work]> What's the correct way to make tell the ffmpeg command to display the effective options at the beginning of encoding, and then remain quiet and display the encoding stats only once at the end?
[08:53:01 CEST] <k_sze[work]> "effective options" as in slices, threads, keyint, etc of libx264
[08:58:28 CEST] <yagiza> Hello!
[08:59:02 CEST] <yagiza> Still looking for someone, who knows anything about streaming with ffmpeg.
[11:14:28 CEST] <Copy> Hi, i tried to compile ffmpeg for android but when i make the project, i got an error telling me to report my config.log here : https://www.filepicker.io/api/file/kQUvnkvBTU2lT2vOoAt8?signature=5331b1d3b581b897f2eb48b889784bb30f20968ac2f4c7407ed915f725382a10&policy=eyJleHBpcnkiOjE0NjQ5NDgzODB9
[11:26:25 CEST] <jussili> I have a problem that when I encode as HEVC, the -g setting is ignored. I get only one intra frame. However, the same parameters with AVC works as intended. What could be the reason?
[11:43:24 CEST] <chama> I have a problem with overlaying text on a video. I need to something like this...
[11:43:43 CEST] <chama> ---------------------------
[11:43:52 CEST] <chama> ---Hello-----------------
[11:44:09 CEST] <chama> ---------------------------
[11:44:18 CEST] Last message repeated 1 time(s).
[11:44:18 CEST] <chama> ----------------World!----
[11:45:06 CEST] <chama> skip
[11:45:33 CEST] <chama> ignore the ------ in it. I know i can do this with drawtext. but i need to add some timing effects to it
[11:46:01 CEST] <chama> display "H"
[11:46:19 CEST] <chama> after 1 second display "He"
[11:46:28 CEST] <chama> after 1 second display "Hel"
[11:46:30 CEST] <chama> after 1 second display "Hell"
[11:46:34 CEST] <chama> after 1 second display "Hello"
[11:47:06 CEST] <chama> and continue to the end of the text
[11:47:24 CEST] <chama> also some color formatting should be applied...
[11:47:32 CEST] <chama> what is the best way to do this?
[12:07:06 CEST] <iive> chama: Advanced SubStation alpha (also known as .ass) subtitles seem to implement stuff like that (as karaoke mode)
[12:07:45 CEST] <iive> you might try aegisub program, for visual editing of the subtitles.
[12:26:04 CEST] <chama> @live i tried that. but how can i create two text for the same time stamp appearing in two places in the video
[12:26:05 CEST] <chama> ?
[13:35:40 CEST] <tuptup> Hello there, i'm trying to get libffmpeg to decode 10bpp (yuv444) AVC/h264 using the dxva2 hwaccel interface. I assume the output format cannot be the expected NV12 as it is an yuv420 related format. What would be the best approach to that? Is it supported by ffmpeg in the first place? (i already have a working decoder for classic 8bpp streams)
[13:37:18 CEST] <JEEB> first of all, there is no official libffmpeg
[13:37:42 CEST] <tuptup> hello JEEB, yes let's say libAV then
[13:42:14 CEST] <JEEB> av* or libav*
[13:42:41 CEST] <JEEB> or you could have spoken of just libavcodec/lavc
[13:42:42 CEST] <tuptup> right, libav(codec) it is then
[13:42:45 CEST] <JEEB> which is the decoding library
[13:43:22 CEST] <JEEB> uhh, no libav without the * doesn't really mean too much. if you mean lavc then note that either with the long or short way :) but aaanyways
[13:43:33 CEST] <JEEB> I don't think 10bit is supported by DXVA2 outside of HEVC
[13:43:50 CEST] <JEEB> and 4:4:4 support I think is pretty much unavailable as far as I can tell
[13:44:05 CEST] <tuptup> i mean the wonderful piece of code you get when downloading the sources from ffmpeg.org
[13:44:05 CEST] <JEEB> HW decoders primarily care about 8bit 4:2:0
[13:44:29 CEST] <JEEB> with HEVC they decided to finally make use of 10bit 4:2:0 and that was added
[13:44:49 CEST] <JEEB> nvidia has some 4:4:4 support but I wouldn't be surprised if it wasn't available through DXVA2
[13:46:20 CEST] <tuptup> nice, this was exactly what i was wondering. I'm actually encoding/capturing in real time through an Nvidia GPU and it has an option to output in 4:4:4 which seems working. But on the decoding side i wasn't sure about the state of things
[13:47:31 CEST] <tuptup> probably i'd have to drop dxva2 and rely on each brand's specific api, which would suck :p
[13:47:45 CEST] <tuptup> thank you for your help JEEB!
[13:48:56 CEST] <tuptup> (for what it's worth playing some 10bit AVC file right now with the latest VLC for windows shows 0% utilization for the video decoder on an Nvidia GPU, if VLC can't do that for sure i cannot either)
[13:53:04 CEST] <JEEB> it uses avcodec for the DXVA2 interaction as well :)
[13:54:03 CEST] <tuptup> yes sources seemed to suggest that at first look
[13:58:34 CEST] <tuptup> actually i was interested in yuv444 only because i have "banding" artefacts in my streams and hoped more bits would fix it. If you have some suggestion regarding banding i'd be happy to hear about it. I'm not limited by bandwidth in my application, 1080p at 60fps and 50Mbps bandwidth look good but large areas of the same colors still show rough gradients and it spoils all the fun
[14:24:06 CEST] <Sokolio> Good afternoon. Has anyone used the functions from ffmpeg_vaapi.c to decode AVC?
[14:57:00 CEST] Last message repeated 1 time(s).
[15:02:56 CEST] <jkqxz> Sokolio:  What do you mean?  The functions in that file are not exported.
[15:05:12 CEST] <Sokolio> jkqxz one actually is exported, it's not static and it is mentioned in ffmpeg.h
[15:05:48 CEST] <Sokolio> int vaapi_decode_init(AVCodecContext *avctx);
[15:07:02 CEST] <jkqxz> I mean exported to library users.  It is there to add vaapi support to the ffmpeg utility.
[15:56:09 CEST] <Franciman> Hello, what does it mean if in an AVCodecContext I have sample_fmt set to AV_SAMPLE_FMT_NONE?
[15:56:36 CEST] <Franciman> (I am trying to decode & demux audio from an mp4 video)
[15:57:06 CEST] <yagiza> Franciman, it will determine sample format automatically?
[15:57:57 CEST] <yagiza> Franciman, or maybe it is not an audio stream?
[15:58:13 CEST] <Franciman> uhm, it is the audio stream
[15:58:26 CEST] <yagiza> Franciman, or maybe it failed to detect stream properties?
[15:59:15 CEST] <Franciman> but I used avcodec_open2 and it did not fail
[16:02:03 CEST] <Franciman> yagiza, how can I determine the error precisely?
[16:05:51 CEST] <yagiza> Franciman, hmm... To tell the truth, I don't know. Which codec do you use?
[16:07:23 CEST] <Franciman> I don't know, I let libavcodec figure out
[16:07:28 CEST] <Franciman> figure it out*
[16:09:21 CEST] <Sokolio> It's actually avformat which tries to figure out the codec
[16:09:53 CEST] <Sokolio> avformat_find_stream_info
[16:11:31 CEST] <Mavrik> Step through code, figure out what sets that to none? :)
[16:12:03 CEST] <Franciman> yes, sorry, I was wrong, it's avformat_find_stream_info
[16:12:07 CEST] <Franciman> I will do, thanks!
[16:12:13 CEST] <kepstin> it might also be interesting to check the output of the 'ffmpeg' or 'ffprobe' command line tools to see what they think of your file
[16:12:31 CEST] <Franciman> right! What options should I use with ffmpeg?
[16:12:55 CEST] <kepstin> just try "ffmpeg -i testfile.mp4". It'll print some file info then exit with an error (complain that you have no outputs)
[16:15:02 CEST] <Franciman> kepstin, http://pastebin.com/B9WNuTgF here's what I get
[16:15:48 CEST] <kepstin> right, so  aac audio, decodes to planar floating point (32bit/sample) :/
[16:16:26 CEST] <Franciman> in my code, in the switch i have every case contemplated
[16:16:38 CEST] <Franciman> but it sets it to NON
[16:16:50 CEST] <Franciman> AV_SAMPLE_FMT_NONE
[16:19:00 CEST] <kepstin> it looks like you might have to decode a frame before the sample_fmt is set in the context.
[16:19:58 CEST] <kepstin> or at the very least, the decoding example code in the ffmpeg docs doesn't check sample_fmt until after decoding a frame.
[16:20:22 CEST] <Franciman> I based my code on that example, yes
[18:00:26 CEST] <Maisre> I inherited a program that tries to take a snapshot image from a video stream using ffmpeg, it tries for 5 seconds then assumes it failed and kills the ffmpeg process. About 1 out of 10 times it successfully creates the image the rest of the time it fails. I can see the video stream just fine in VLC the whole time. Is there something wrong with my command line arguments? Does the camera stream just not contain a key frame? i would have
[18:00:26 CEST] <Maisre> imagined that I would have gotten at least one key frame in 5 seconds
[18:00:27 CEST] <Maisre> http://pastebin.com/yyFqMFvy
[18:01:26 CEST] <Maisre> any insight or suggestions on how to improve this would be appreciated
[18:05:35 CEST] <Maisre> most examples online just have the -vfrmaes 1 flags but the other ones I have on there don't seem like they should cause any problems
[21:05:50 CEST] <CoJaBo> Has anyone ever heard of the audio codec (FourCC) "ASNL"? :/
[21:37:36 CEST] <Fyr> guys, I need to compress a TIFF into JPEG keeping quality as much as possible.
[21:37:47 CEST] <Fyr> what tool would you recommend?
[21:40:48 CEST] <Sokolio> image magick?
[21:42:15 CEST] <Fyr> thanks
[21:43:01 CEST] <Sokolio> has a 'convert' tool, nicely documented, quite powerful
[21:48:37 CEST] <Fyr> is there a JPEG replacement that is implemented in FF, Chrome besides WebP?
[21:49:41 CEST] <kyleogrg> Yo
[21:49:54 CEST] <Fyr> hoi
[21:50:49 CEST] <furq> webp isn't implemented in firefox
[21:50:56 CEST] <Fyr> ooops
[21:51:00 CEST] <furq> or ie/edge/safari if anyone cares about those
[21:51:37 CEST] <kyleogrg> I'm using a build script to build ffmpeg.  I'm troubleshooting a bug where libfdk_aac is unknown, and the author wants me to give him the "full output" of "ffmpeg -codecs"
[21:51:39 CEST] <Fyr> so, there's no way to avoid JPEG?
[21:51:49 CEST] <furq> you could not do web development
[21:52:07 CEST] <furq> or you could use a javascript image decoder because that's the sort of bullshit which is acceptable on the web now
[21:52:11 CEST] <kyleogrg> So I gave him the output of "ffmpeg -codecs > output.txt" but he says no, he wants the configure parameters.  what does that mean?
[21:52:26 CEST] <furq> it means he's not very good at asking questions
[21:52:36 CEST] <Sokolio> send him the config.log file
[21:52:43 CEST] <furq> no
[21:52:52 CEST] <furq> ffmpeg -codecs 2>&1 > output.txt
[21:53:59 CEST] <furq> although it doesn't take a genius to figure out that you're missing --enable-libfdk-aac
[21:54:42 CEST] <kyleogrg> ahh, but this is the windows build helper script in linux, and his script uses --disable-nonfree=n
[21:55:26 CEST] <kyleogrg> anyway, i'm not a genius
[21:56:06 CEST] <furq> i was trying to insult him, not you
[21:56:43 CEST] <kyleogrg> if i was a genius i would have realized that
[21:56:50 CEST] <furq> --enable-nonfree doesn't do anything by itself
[21:57:47 CEST] <kyleogrg> anyway, i think it worked.  it didn't make the text file correctly, but i copied the console text manually.
[22:00:29 CEST] <kyleogrg> bye
[22:00:34 CEST] <kyleogrg> thanks
[22:01:44 CEST] <TD-Linux> Fyr, you can use mozjpeg if you want maximum jpeg quality
[22:23:03 CEST] <nyuszika7h> ffmpeg seems to incorrectly copy image attachments (cover art) as a video track which causes them to stop being recognized by Explorer
[22:23:14 CEST] <Fyr> ='(
[22:23:28 CEST] <Fyr> sometimes words can hurt.
[22:23:36 CEST] <ziro_axis> hello All
[22:23:39 CEST] <Fyr> I posted a bug long time ago about cover art.
[22:23:56 CEST] <ziro_axis> a question
[22:24:00 CEST] <nyuszika7h> an answer
[22:24:19 CEST] <Fyr> the pain
[22:24:47 CEST] <ziro_axis> what is the difference between xtream-codes and ffmpeg
[22:25:11 CEST] <ziro_axis> OK actually i'm new to IPTV sector
[22:25:43 CEST] <ziro_axis> and i'm required to build on IPTV project in my company
[22:26:21 CEST] <ziro_axis> we need to build it based on open source softwares
[22:26:30 CEST] <ziro_axis> any advices
[22:26:33 CEST] <ziro_axis> please
[23:08:10 CEST] <llogan> never heard of xtream-codes. but that name makes me think of mid to late 1990's
[23:12:32 CEST] <kyleogrg> That "Unknown encoder libfdk_aac" problem I mentioned earlier?  Turns out nothing was wrong with the build, but it was a problem with the Windows path variable.  When I accessed the .exe directly, it worked.
[23:13:08 CEST] <Sokolio> problem solved? :)
[23:13:12 CEST] <kyleogrg> I'm trying to track down the other ffmpeg which is conflicting
[23:13:24 CEST] <kyleogrg> yes, as far as the build itself is concerned.
[23:14:55 CEST] <kyleogrg> I probably have to go through all the Path folders and find a conflict
[23:15:44 CEST] <drv> 'where ffmpeg.exe'
[23:16:35 CEST] <kyleogrg> drv: what do you mean?
[23:16:51 CEST] <drv> 'where' is a windows command line utility that searches %PATH%
[23:16:55 CEST] <kyleogrg> whoa
[23:16:57 CEST] <kyleogrg> yeah
[23:17:36 CEST] <kyleogrg> awesome, thx
[23:17:54 CEST] <furq> also https://www.voidtools.com/
[23:19:10 CEST] <kyleogrg> okay, I do "where ffmpeg.exe" and I get the correct folder.  I do "where ffmpeg" (no .exe) and I get three folders (two imagemagick folders and the correct folder).  the imagemagick folders are NOT in the path variable.  what am i missing?
[23:19:52 CEST] <furq> which ffmpeg do you get if you run it from that command prompt
[23:20:51 CEST] <furq> if you change PATH then you need to restart anything which needs the new one
[23:20:51 CEST] <kyleogrg> ffmpeg 2.8.4, probably imagemagick
[23:20:58 CEST] <kyleogrg> ok
[23:23:02 CEST] <kyleogrg> yahoo, it works now
[23:23:12 CEST] <kyleogrg> thanks furq and drv
[23:25:19 CEST] <kyleogrg> adios
[23:46:02 CEST] <ATField> Come to think of it, if ImageMagick has its own copy of ffmpeg, which path gets used for ffmpeg when you call on it?
[23:47:04 CEST] <ATField> (Ill try to version check)
[23:48:52 CEST] <ziro_axis> what is the difference between xtream-codes and ffmpeg
[23:50:21 CEST] <ATField> Is there a way to specify which ffmpeg should be called when you just use >ffmpeg? Currently it seems to call upon the imagemagicks ffmpeg.
[23:51:50 CEST] <c_14> either fix your path or use the full path
[23:54:08 CEST] <ATField> How can I fix it? Removing the imagemagick location would remove the problem, but I need imagemagick in path too, so I guess thats not an option. Will changing their order of listing in path work (i.e. ffmpegs loc first, then imagemagick)?
[23:54:19 CEST] <c_14> yes
[23:54:26 CEST] <ATField> Oh, thanks!
[00:00:00 CEST] --- Sat Jun  4 2016

More information about the Ffmpeg-devel-irc mailing list