[Ffmpeg-devel-irc] ffmpeg.log.20160610

burek burek021 at gmail.com
Sat Jun 11 02:05:01 CEST 2016

[00:43:52 CEST] <mosb3rg> evening gents, im a bit confused on an error im getting and was hoping someone could explain how to patch the error i been reading a bit and i felt like i found a solution but i have no idea how to implement it, as i dont see a physical patch file or replacement files to download and fix the current array i have here prior to recompiling it.
[01:42:16 CEST] <sliter> Hello
[01:42:36 CEST] <sliter> Will ffmpeg -i foo.mp4 -vn -i bar.mp3 work?
[01:44:04 CEST] <sliter> -i foo.mp4 -vn -i bar.gif
[01:44:05 CEST] <sliter> fix
[01:44:20 CEST] <sliter> So. Get only audio from video file and then add looped gif file
[01:44:51 CEST] <furq> -vn won't work before -i and it won't do what you think it does anyway
[01:45:02 CEST] <furq> you want -map 0:a -map 1
[01:45:23 CEST] <furq> you probably also want some combination of -loop and -shortest but i forget the exact invocation
[01:46:20 CEST] <sliter> I'm starting to understand
[01:47:02 CEST] <furq> iirc it'd be -loop 1 -i foo.gif -i bar.mp4 -map 0 -map 1:a -shortest
[01:47:45 CEST] <sliter> option loop not found
[01:48:17 CEST] <furq> oh yeah i think the name has been changed since i wrote the script i just copied that from
[01:48:20 CEST] <sliter> there is loop_stream, loop_input and loop_output
[01:48:22 CEST] <sliter> Which one?
[01:49:08 CEST] <sliter> Ahem
[01:49:10 CEST] <sliter> -loop_input
[01:49:10 CEST] <sliter> Loop over the input stream. Currently it works only for image streams. This option is used for automatic FFserver testing. This option is deprecated, use -loop 1.
[01:50:00 CEST] <c_14> you want -loop
[01:50:00 CEST] <furq> actually i don't think you need -loop for gifs
[01:50:16 CEST] <furq> or any option, that is
[01:50:27 CEST] <furq> if it's an animated gif then the docs suggest it'll loop forever by default
[01:50:44 CEST] <c_14> depends on whether the gif has the info to loop infinitely
[01:51:04 CEST] <furq> https://www.ffmpeg.org/ffmpeg-formats.html#gif-1
[01:51:12 CEST] <furq> i don't see an option to force it to loop forever
[01:51:16 CEST] <sliter> For some reason gif applies to preview
[01:51:23 CEST] <furq> unless you can use image2 to handle animated gif
[01:51:26 CEST] <sliter> But neither mpc nor wmp can't play it
[01:52:09 CEST] <furq> oh right you do need -ignore_loop 0
[01:52:13 CEST] <furq> that's a pretty awkwardly named option
[01:52:30 CEST] <sliter> But gif don't even appears on video
[01:52:39 CEST] <sliter> So it's full black and it's long is 0 seconds
[01:54:17 CEST] <sliter> Maybe im doing something wrong?
[01:54:23 CEST] <sliter> >ffmpeg -y -i "f oo.mp4" -i "b ar.gif" -map 0:a -map 1 -threads 4 -b:v 5K -b:a 5K barr.webm
[01:55:32 CEST] <furq> -ignore_loop 0 -i foo.gif -i bar.mp4 -map 0 -map 1:a -shortest
[01:56:00 CEST] <furq> also that video bitrate is almost certainly too low
[01:56:39 CEST] <sliter> furq: for video, limited with 40mb and that lenghts 10 hours it's ok
[01:57:11 CEST] <sliter> option ignore_loop not found
[01:58:02 CEST] <sliter> I've got it working
[01:58:11 CEST] <sliter> But now i get past duration problems
[01:58:54 CEST] <sliter> btw how do i specify default color space for webm?
[01:58:58 CEST] <sliter> yuv_420?
[01:59:03 CEST] <furq> -pix_fmt yuv420p
[01:59:06 CEST] <sliter> Thansk
[01:59:08 CEST] <sliter> ks*
[02:00:01 CEST] <sliter> works pretty well, but i worried about pastduration 0.6**** too large
[02:03:39 CEST] <sliter> Why i can't specify bitrate in bits?
[02:04:31 CEST] <furq> you can
[02:04:35 CEST] <furq> just get rid of the K
[02:04:44 CEST] <sliter> That gives me error.
[02:05:11 CEST] <furq> you're probably setting it too low
[02:05:14 CEST] <sliter> maybe incorrect parameters such as bit_rate, rate, width
[02:05:15 CEST] <sliter> Yeah
[02:05:27 CEST] <sliter> at 1kbit it's just disabling audio
[02:05:43 CEST] <furq> that works for me with libvpx-vp9 though
[02:05:47 CEST] <furq> [libvpx-vp9 @ 0x80a843420] Bitrate 1 is extremely low, maybe you mean 1k
[02:05:52 CEST] <furq> it throws a warning but it still runs
[02:06:34 CEST] <furq> if you're encoding 10 hours of this at 5kbps i would encode a segment first because i doubt you'll end up with something usable
[02:06:49 CEST] <furq> 5kbps is not enough for pretty much any video
[02:09:09 CEST] <sliter> for 200x150 it's ok
[02:09:44 CEST] <furq> have you checked
[02:10:08 CEST] <sliter> but for 10h video i'm need bitrate around 8kbits
[02:11:05 CEST] <sliter> 8.8(8) is max bitrate i accept.
[02:11:18 CEST] <sliter> now i'm getting around 15.
[02:12:10 CEST] <furq> i mean i guess you could do a 2-pass encode if the ratecontrol isn't good enough
[02:12:37 CEST] <furq> but i'm not confident that libvpx has any idea what to do at such low bitrates
[02:12:57 CEST] <sliter> You mean to encode 10 hour video 2 times?
[02:13:12 CEST] <sliter> I was interested in 2-pass encoding, but not enought to learn it.
[02:13:29 CEST] <furq> out of interest, what fps are you getting
[02:13:56 CEST] <sliter> 81/4.6
[02:14:19 CEST] <furq> 81fps speed on a 4.6fps video?
[02:14:32 CEST] <sliter> 81 fps on 4.6 speed
[02:14:39 CEST] <sliter> So for 1 speed it would be 18 fps
[02:15:12 CEST] <furq> oh 4.6x
[02:15:40 CEST] <sliter> Oh wait
[02:15:48 CEST] <sliter> Is bitrate too multiplied by speed?
[02:16:03 CEST] <furq> no?
[02:17:19 CEST] <sliter> it is.
[02:17:35 CEST] <kepstin> the 'fps' value on the stats line just says how fast the encoder is running (number of frames encoded per second). It has nothing to do with the framerate of the input video.
[02:18:03 CEST] <kepstin> and "speed" is just the fps from the stats line divided by the the actual playback fps of the video stream.
[02:18:11 CEST] <kepstin> bitrate doesn't go in there anywhere
[02:18:17 CEST] <furq> bitrate is kbps of the encoded video, not kilobits encoded in the last second of clock time
[02:18:45 CEST] <kepstin> the bitrate shows on the stats line is a long term average bitrate (I think over the entire file length)
[02:18:53 CEST] <furq> yeah
[02:18:59 CEST] <sliter> Ok.
[02:19:17 CEST] <sliter> 4 kbits/s less and i won.
[02:19:25 CEST] <furq> is this video actually watchable
[02:19:30 CEST] <sliter> Sort of.
[02:19:41 CEST] <furq> could you not maybe do five hours
[02:19:48 CEST] <kepstin> if there's basically no motion, and you're using a large gop size, maybe?
[02:20:00 CEST] <sliter> it's a good idea
[02:20:07 CEST] <sliter> How do i cut file when size is more than X
[02:20:16 CEST] <furq> i don't think you can
[02:20:46 CEST] <furq> -t will cut at a certain length, but not filesize
[02:22:15 CEST] <sliter> So how do i cut video on 7th hour?
[02:22:25 CEST] <furq> -t 07:00:00
[02:22:29 CEST] <sliter> and where is hould place t
[02:22:33 CEST] <sliter> Before or after -i?
[02:22:35 CEST] <furq> after
[02:22:57 CEST] <sliter> Looks like it will work
[02:23:00 CEST] <sliter> ok.
[02:23:04 CEST] <sliter> 7 hours / 13.7
[02:23:09 CEST] <kepstin> (it would probably work before as well, but the behaviour's a bit different, particularly if there's multiple inputs)
[02:23:13 CEST] <furq> you probably also should make sure the output framerate is as low as possible
[02:23:19 CEST] <sliter> 30 mins
[02:23:24 CEST] <furq> i assume the gif demuxer does the right thing but i don't know for sure
[02:23:27 CEST] <furq> it might be duplicating frames
[02:23:31 CEST] <sliter> -r 5
[02:23:39 CEST] <furq> is that the framerate of the gif
[02:23:46 CEST] <sliter> of entire video
[02:23:56 CEST] <furq> i meant explicitly matching the output framerate to the gif's framerate
[02:24:11 CEST] <sliter> no it's ok
[02:24:15 CEST] <furq> fair enough
[02:24:21 CEST] <furq> 5 is pretty low anyway
[02:24:47 CEST] <furq> as long as you're passing that as an output option
[02:24:58 CEST] <sliter> Btw mp4 video weighted 1.5 gigs
[02:26:00 CEST] <sliter> what does mean dup=0 and drop=30000?
[02:26:08 CEST] <sliter> It is dropping gif frames cause of -r option?
[02:26:08 CEST] <furq> duplicated and dropped frames
[02:26:12 CEST] <sliter> Yup.
[02:26:12 CEST] <furq> probably
[02:27:15 CEST] <sliter> first hour encoded.
[02:27:17 CEST] <sliter> 6 left.
[02:29:41 CEST] <sliter> Also i've added ffmpeg option in context menu.
[02:29:48 CEST] <sliter> So i can run it in any directory.
[02:46:45 CEST] <Nobgul> I have a offtopic question, what is it called when you pause a video but it keeps downloading and you see the download progress in the bar?
[02:48:03 CEST] <c_14> buffering?
[03:22:37 CEST] <Nobgul> c_14: I got it it is Psuedo streaming.
[03:25:56 CEST] <mosb3rg> hey folks, im running into an error i tried patching and i could really use a point in the right direction:
[03:25:58 CEST] <mosb3rg> [mpegts @ 0x2f79d40] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.
[03:26:42 CEST] <DHE> it's a new coding style of ffmpeg. even the standard ffmpeg tool has a few errors lingering. it's still safe for now
[03:27:31 CEST] <mosb3rg> could i provide you a link in private to prove my error
[03:27:41 CEST] <mosb3rg> a feed url
[03:27:56 CEST] <DHE> is there a reason it has to be private? I discourage this
[03:28:01 CEST] <mosb3rg> thats the only reason im not interested in posting in public if thats ok with you, we can continue here
[03:28:07 CEST] <mosb3rg> just the link.
[03:28:14 CEST] <mosb3rg> i agree the help should be here
[03:28:16 CEST] <Nobgul> hey mos
[03:28:22 CEST] <DHE> feel free to censor anything private (passwords, link details, etc)
[03:28:22 CEST] <Nobgul> hehe
[03:28:24 CEST] <mosb3rg> oh shit whats up man long time :>
[03:28:30 CEST] <Nobgul> yea last night
[03:28:31 CEST] <Nobgul> lol
[03:28:54 CEST] <mosb3rg> DHE nah man its the actual link to the feed.
[03:29:00 CEST] <mosb3rg> its private source live stream.
[03:29:11 CEST] <mosb3rg> legit we can talk about everything else in here its no problem.
[03:30:35 CEST] <mosb3rg> nevermind it wont let me msg you since im not a chanserv up and everything ok
[03:30:41 CEST] <mosb3rg>
[03:30:46 CEST] <mosb3rg> its fine whatever. its token based anyway
[03:31:19 CEST] <mosb3rg> whether i attempt to relay or dump. i get a PES packet size error
[03:31:39 CEST] <mosb3rg> then it defaults to that error above. and i tried finding a version of ffmpeg which could parse this link correctly. but im coming up short.
[03:34:15 CEST] <DHE> I got a 403... so I'm out.
[03:40:14 CEST] <mosb3rg> i can get you a fresh one
[03:40:20 CEST] <mosb3rg> if so will you please investigate?
[03:42:26 CEST] <mosb3rg> obviously the token timing matters, its not that i dont want to just post it, but to pull a fresh one from the mobile device takes effort if your not going to do it :P
[03:42:43 CEST] <c_14> mosb3rg: what's the problem?
[03:42:55 CEST] <mosb3rg> hey bud, sec ill paste
[03:43:33 CEST] <mosb3rg> [mpegts @ 0x2f79d40] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.
[03:43:46 CEST] <c_14> that's not an error, it's a warning
[03:43:53 CEST] <c_14> just ignore it
[03:43:54 CEST] <mosb3rg> yet it still fails
[03:44:00 CEST] <mosb3rg> PES packet size mismatch first
[03:44:04 CEST] <c_14> it shouldn't fail because of that
[03:44:09 CEST] <mosb3rg> hang on
[03:44:10 CEST] <c_14> there's probably another error somewhere else
[03:44:31 CEST] <mosb3rg> one sec ill paste the output log to a note
[03:45:23 CEST] <mosb3rg> http://pastebin.ca/3621942
[03:45:29 CEST] <mosb3rg> there we go, thats what i see
[03:47:29 CEST] <c_14> i think the problem isn't ffmpeg per se, but rather that each .ts fragment is only 7 seconds long
[03:47:41 CEST] <c_14> what you need to find is the playlist that lists each of the segments and use that as your input
[03:48:10 CEST] <mosb3rg> thats honestly my mistake shesh, i should have realized that
[03:48:37 CEST] <mosb3rg> my company has my over worked ill work the entire day, then i come and sit here and put this shit together for them for another 6 hours, just lack of rest
[03:50:34 CEST] <mosb3rg> ill give it a crack again dump the correct url this time.
[04:04:10 CEST] <ycon_> Hi all, Im trying to add some text to a video with ffmpeg. I'm using -vf drawtext, but it is not working (creates empty files) . Any ideas? http://dpaste.com/3SVYS2F
[04:11:59 CEST] <c_14> are you sure you aren't seeking past the end of the video?
[06:17:29 CEST] <carlosirssi> hi im getting this after trying to conver from mp4 to mp3: Encoder (codec mp3) not found for output stream #0:0
[06:17:48 CEST] <carlosirssi> please help me with this
[06:36:00 CEST] <carlosirssi> never mind
[10:40:35 CEST] <meldron> Hey guys, i am using ffmpeg to capture an rtsp stream from some ip cameras and the first few seconds of the video sometimes have a green overlay/ video error, anybody has a similar problem or knows how to fix that?
[11:00:56 CEST] <Sokolio> <meldron> This usually means that the first captured frames are P,B frames
[11:09:17 CEST] <Sokolio> The rtsp server, when unicasting, can simply start rtp stream with an iframe, but that is not a rule
[11:10:42 CEST] <Jxm> Hello, what's the best way to convert a FLAC to MP3 without loss of quality
[11:11:06 CEST] <Jxm> Well, I don't care about time required, size, but I need a MP3 with equivalent quality of FLAC
[11:11:40 CEST] <Jxm> I've been finding a lot, but couldn't find it
[11:12:00 CEST] <speak> ffmpeg -i inputfile.flac -q:a 0 outfile.mp3
[11:12:04 CEST] <speak> For an V0 MP#
[11:12:06 CEST] <speak> * MP3
[11:12:17 CEST] <speak> Which is the best you can get quality-wise
[11:12:21 CEST] <Jxm> OK
[11:13:04 CEST] <speak> "Thanks" "Np".
[11:13:28 CEST] <flux> what kind of bit rate it might end up using in that case? 320?
[11:14:06 CEST] <speak> V0 is highest quality variable bitrate
[11:14:15 CEST] <speak> So it'll use around 320 when needed, otherwise less
[11:14:35 CEST] <Sokolio> That's actually an interesting question, can ffmpeg drop leading b/p frames?
[11:18:10 CEST] <furq> flux: the nominal bitrate of v0 is 245kbps
[11:18:25 CEST] <furq> but it could be anything from 32 to 320
[11:20:17 CEST] <furq> http://wiki.hydrogenaud.io/index.php?title=LAME#Recommended_settings_details
[11:32:55 CEST] <meldron> Sokolio: thanks alot, you are right they were P frames
[12:29:21 CEST] <shayla> Hi guys, i'm having a problem cropping an audio file
[12:29:31 CEST] <shayla> I want to take the first 7 seconds from mp3
[12:29:35 CEST] <shayla> I do
[12:29:51 CEST] <shayla> ffmpeg -t 7 -i audio.mp3 -acodec copy audio.mp3
[12:30:03 CEST] <shayla> But then if I open audio.mp3 i get only the first 3 seconds...
[12:30:07 CEST] <shayla> Where i'm wrong?
[12:30:14 CEST] <__jack__> shayla: reencode it
[12:31:01 CEST] <__jack__> shayla: -t & stream copy are limited by the input stream format, it will be as close as possible to the selected duration, nothing more
[12:31:33 CEST] <__jack__> shayla: if you reencode the stream, however, it will be able to cut to the correct frame, to better match the required duration
[12:34:23 CEST] <BtbN> stream-copy cutting an mp3 with second-accuracy should be possible though.
[12:36:50 CEST] <shayla> Well, thank you !
[15:26:35 CEST] <Alphos> hiya people ! bouncing ideas for a personal project : when cutting up video, does ffmpeg load the entire source file in memory at once, or does it load frame(s) by frame(s) ?
[15:27:46 CEST] <flux> no, ffmpeg doesn't load complete source file to memory
[15:28:26 CEST] <flux> I suppose it oftentimes (ie. with mp4) reads complete metadata (frame times, sizes, locations) about the source file into memory, though
[15:28:28 CEST] <Alphos> yay :) so there's one thorn off my side, maybe this thing is doable after all :)
[16:05:25 CEST] <ATField> also, it reads even less if you dont re-encode the streams
[16:07:21 CEST] <Regda> hi there, i get a warning about avstream. i've wrote a post here: https://ffmpeg.zeranoe.com/forum/viewtopic.php?f=7&t=3678
[16:08:01 CEST] <Regda> does someone know any about that message ? and how to fix it ?
[16:08:16 CEST] <Regda> (dont want to break an actual conversation if there is any...)
[16:08:38 CEST] <furq> Regda: just ignore it
[16:09:15 CEST] <furq> there is no workaround for it, ffmpeg.c hasn't been updated to use the new api
[16:18:30 CEST] <Regda> uhm ok, then i have another question
[16:18:46 CEST] <Regda> i've get an message "not enough frames to estimate rate; consider increasing probesize" too
[16:19:21 CEST] <Regda> has it something to do with that i force the framerate to 30 ? :/
[16:19:34 CEST] <c_14> Regda: if it works, ignore it. If it doesn't set -probesize to 1G or something
[16:19:54 CEST] <Regda> ok thanks :)
[16:40:10 CEST] <Nobgul> Does anyone have a refrence that shows the proper dimensions of the different video qualties ie: 360 480 576 720? I see different numbers all over the place for both 16:9 and 4:3
[16:40:55 CEST] <Mavrik> There's no "proper dimensions" in general.
[16:41:01 CEST] <Mavrik> Depends on the environment you get the video.
[16:41:48 CEST] <Mavrik> What are you trying to do?
[16:41:50 CEST] <Nobgul> the original is 1080p 16:9 I need to reencode it for adaptive bitrate.
[16:42:09 CEST] <Nobgul> so i need to make it 720 576 480 360 240
[16:42:13 CEST] <Nobgul> each video.
[16:42:33 CEST] <Mavrik> Calculate from input video.
[16:42:38 CEST] <Mavrik> If you want to avoid problems.
[16:42:58 CEST] <Mavrik> Hardcoding sizes will give you headaches with anamorphic video.,
[16:43:05 CEST] <Mavrik> Just use "scale=-2:720" or whatever.
[16:43:24 CEST] <Nobgul> I tried as suggested here last night doing 1:360
[16:43:29 CEST] <Nobgul> and it errors ffmpeg
[16:44:13 CEST] <Mavrik> So instead of figuring out why it errors...
[16:44:33 CEST] <Mavrik> you went for a harder path of trying to handle anamorphic and all other videos in standard resoltions? :P
[16:45:09 CEST] <Nobgul> Well i can try to run one now and show you the error =)
[16:45:58 CEST] <Nobgul> sws: filterSize 1920 is too large, try less extreme scaling or increase MAX_FILTER_SIZE and recompile
[16:46:42 CEST] <Nobgul> ffmpeg -i video.mp4 -c:v libx264 -c:a aac -ab 128k -strict experimental -preset veryslow -vf scale=1:360  video-360.mp4
[16:46:48 CEST] <Nobgul> thats my line i am using
[16:46:54 CEST] <Mavrik> Dude.
[16:47:12 CEST] <Mavrik> You're resizing your video to 1px x 360px.
[16:47:13 CEST] <Mavrik> Why?
[16:47:22 CEST] <Mavrik> Of course ffmpeg won't let you that stupidity :P
[16:47:36 CEST] <Nobgul> oh im missing a -
[16:48:07 CEST] <Nobgul> omg thank you!
[16:49:39 CEST] <Mavrik> :)
[16:49:45 CEST] <Mavrik> Nobgul, use -2 if your ffmpeg supports that
[16:49:50 CEST] <Mavrik> instead of -1 :)
[16:50:01 CEST] <Mavrik> Also actually pass a quality parameter.
[16:50:13 CEST] <Mavrik> (It's all in the H.264 wiki.)
[16:50:46 CEST] <Nobgul> Yes someone pointed that out yesterday, i started reading then got thrown on another project.
[16:51:04 CEST] <Nobgul> Would you happen to have the link, i closed the window
[16:51:18 CEST] <Nobgul> nvm ill google
[16:53:25 CEST] <Nobgul> I lied ill take the link if you have it, what i found is not right
[16:53:55 CEST] <c_14> https://trac.ffmpeg.org/wiki/Encode/H.264 iirc
[16:58:29 CEST] <Regda> uhm c_14
[16:59:05 CEST] <Regda> if i ad this probesize flag then i have trouble with the forced framerate (r)
[16:59:23 CEST] <furq> Nobgul: if you're doing this for adaptive bitrate then you probably want to do a 2-pass abr encode
[17:00:17 CEST] <Nobgul> Mavrik: Thank You Very Much The Video Looks SOOOOOO much better
[17:00:23 CEST] <Nobgul> furq: Why is that?
[17:01:03 CEST] <furq> i assume you have some target bitrate in mind for each of those
[17:01:37 CEST] <Nobgul> Not so much bitrate but more Size,
[17:01:55 CEST] <furq> do you mean filesize or resolution
[17:02:08 CEST] <Nobgul> the system will detect the users bandwidth and choose the proper video, and if the bandwidth drops it will lower the video
[17:02:31 CEST] <furq> well yeah i know what adaptive bitrate is
[17:02:47 CEST] <furq> but it's not much use if your videos are whatever bitrate the crf gives you
[17:03:43 CEST] <Nobgul> Is there a list of bitrates for video size?
[17:03:59 CEST] <Nobgul> Or a standard or formula?
[17:04:02 CEST] <furq> not really
[17:04:13 CEST] <Nobgul> ouch lol
[17:04:36 CEST] <furq> i guess you could look at what youtube uses for each of those resolutions
[17:05:12 CEST] <furq> but i'm pretty sure they do some heavy denoising and then a lot of videos are still poor quality
[17:05:20 CEST] <Nobgul> yea
[17:05:23 CEST] <Nobgul> thats what we cant have
[17:05:47 CEST] <Nobgul> even in 360p these videos need to be very detailed
[17:06:10 CEST] <furq> i would normally recommend using crf (which is the default) but then you have no way of knowing what bitrate you're going to get
[17:07:19 CEST] <Nobgul> looking at the h264 wiki they are using -crf 22
[17:07:24 CEST] <Nobgul> what does the 22 denote?
[17:07:32 CEST] <furq> lower values are higher quality
[17:07:49 CEST] <Nobgul> ah ok
[17:07:57 CEST] <furq> i think it goes from 0 (lossless) to 53
[17:08:05 CEST] <furq> 16-24 is the useful range
[17:08:36 CEST] <furq> 23 is the default
[17:08:40 CEST] <Nobgul> and not specifying it, then it is just using whatever is already there?
[17:08:58 CEST] <furq> no, it uses -crf 23
[17:09:09 CEST] <Nobgul> i mean without using -crf
[17:09:29 CEST] <furq> that's the default if you don't specify any quality setting
[17:09:40 CEST] <Nobgul> Ah ok
[17:10:04 CEST] <Nobgul> Now i dont know what to do
[17:12:42 CEST] <Nobgul> I forgot to ask what is the difference in scale when using -1 or -2
[17:13:01 CEST] <furq> -2 rounds to the nearest even number
[17:13:20 CEST] <Nobgul> ok that makes sense
[17:13:24 CEST] <Nobgul> gonna try now
[17:15:16 CEST] <Nobgul> It is running
[17:20:48 CEST] <mao> hi, does anyone know if the internal rtmp implementation of libavformat exposes any interface to modify the input/output chunk sizes?
[17:43:59 CEST] <saml> -framerate 25 -f image2 -i %d.jpg -c:v h264  -acodec copy out.mp4
[17:44:46 CEST] <saml> https://gist.github.com/saml/fd3b464642e1aaf327063e267e775ddd
[17:49:21 CEST] <Nobgul> is scale=-2:576 valid?
[17:49:47 CEST] <Nobgul> or is that pal only?
[17:49:48 CEST] <thebombzen> yes
[17:49:50 CEST] <thebombzen> wait
[17:50:00 CEST] <thebombzen> I don't know -2. I'd have to look that up.
[17:50:16 CEST] <Nobgul> the 2 farq said just makes it round to the closest 2
[17:50:18 CEST] <Nobgul> instead of 1
[17:50:34 CEST] <Nobgul> i more ment the 576 is that a ntsc standard or just pal?
[17:50:48 CEST] <Nobgul> huh
[17:50:51 CEST] <Nobgul> Video: h264 (libx264) ([33][0][0][0] / 0x0021), yuv420p, 1024x576
[17:50:59 CEST] <Nobgul> i guess is lol
[17:51:08 CEST] <thebombzen> -2:576 will cause it to scale to the same aspect ratio as the beginning
[17:51:16 CEST] <thebombzen> however it makes sure that it's divisible by 2
[17:51:29 CEST] <Nobgul> i dont seems to remember 576i being 1024 though
[17:51:41 CEST] <thebombzen> 1024x576 is 16x9
[17:51:52 CEST] <thebombzen> it ensures that if the input was 16:9 then so is the output
[17:52:10 CEST] <Nobgul> yes the input is 16:9 1080p
[17:52:53 CEST] <Nobgul> i think the 1024 is wrong though =/
[17:53:15 CEST] <Nobgul> 768 × 576
[17:53:30 CEST] <Nobgul> is the right resolution, of so for this one should i use scale=-1:576
[17:56:57 CEST] <Nobgul> ill check the output and if it looks funky ill re do it.
[17:57:18 CEST] <saml> [libx264 @ 0x335f640] width not divisible by 2 (1669x2500)
[17:57:21 CEST] <saml> what is this?
[17:57:48 CEST] <Nobgul> 1669 isnt evenly divided by 2
[17:58:22 CEST] <Nobgul> i think your having the same issue i am right now with funly resolutions
[17:59:18 CEST] <Nobgul> if your using scale=-2 try using scale=-1
[18:01:01 CEST] <furq> Nobgul: 1024*576 is 16:9 576p
[18:01:14 CEST] <furq> it's not a standard resolution but neither are any of the other sub-720p resolutions you're planning on using
[18:01:35 CEST] <furq> or any of the sub-720p resolutions that youtube, iplayer et al use
[18:04:42 CEST] <arehman> Hi, if a HLS livestream exists, can it be viewed as MP4 live? So far I can only seem to record and playback an mp4 from an m3u8 input
[18:05:02 CEST] <Nobgul> furq: Thank You I found a refrence site. https://gist.github.com/jonlabelle/7834592
[18:05:29 CEST] <furq> yeah that is worthless for your use case
[18:05:34 CEST] <furq> use whatever resolution you want
[18:05:57 CEST] <Nobgul> furq: I think the client would like the video to be full in the phone rather then have black bars so i will run with the 16:9 but what i wanted to ask you was, is the bitrate going to affect bandwidth?
[18:06:07 CEST] <saml> ffmpeg -loop 1 -framerate 3 -i '%d.jpg' -c:v libx264 -t 5 -pix_fmt yuv420p -r 25 -vf scale=800:1200 out.mp4
[18:06:09 CEST] <saml> this worked
[18:06:32 CEST] <furq> bitrate is bandwidth
[18:06:49 CEST] <Nobgul> and with the line i am using its not liimiting bitrate is that right?
[18:06:54 CEST] <furq> nope
[18:07:08 CEST] <furq> no it isn't limiting bitrate, yes that is right
[18:07:14 CEST] <Nobgul> Ok so can you instruct me on how to modify the bitrate.
[18:07:38 CEST] <furq> https://trac.ffmpeg.org/wiki/Encode/H.264#twopass
[18:08:03 CEST] <furq> https://trac.ffmpeg.org/wiki/Encode/H.264#AdditionalInformationTips
[18:08:08 CEST] <furq> read that bit as well
[18:09:18 CEST] <furq> you should probably read the whole page really, it explains all the different ratecontrol methods
[18:09:25 CEST] <furq> except qp but nobody uses that for lossy encoding
[18:09:40 CEST] <Nobgul> Yea but i am not sure what bitrate to make them thats the issue as well
[18:09:53 CEST] <furq> that's not really something that we can help you with
[18:10:09 CEST] <furq> it depends on the video contents and your clients' bandwidth constraints
[18:10:12 CEST] <Nobgul> Do you know of any channels that can?
[18:10:20 CEST] <thebombzen> Nobgul: a better idea with libx264 is to do CRF based encoding
[18:10:32 CEST] <thebombzen> you pick the quality and it does the bitrate for you
[18:10:38 CEST] <thebombzen> it' also the most efficient
[18:10:39 CEST] <furq> thebombzen: he's doing adaptive bitrate encodes
[18:10:45 CEST] <Nobgul> We dont have bandwidth constraints our cdn is over 400 servers, its the end users im worried about. the person watching on the phone
[18:10:45 CEST] <thebombzen> euh
[18:10:54 CEST] <furq> Nobgul: by clients i meant end users
[18:10:59 CEST] <Nobgul> ah ok =)
[18:11:09 CEST] <Nobgul> do you know of a channel here that may be able to help
[18:11:12 CEST] <thebombzen> you can do CRF and still set maxrate though
[18:11:21 CEST] <furq> by "we" i meant anyone who isn't you
[18:11:47 CEST] <furq> the correct answer is totally specific to your use case
[18:12:15 CEST] <thebombzen> Nobgul: I'd recommend using CRF (constant rate factor) which allows you constant quality with variable bitrate. Then, you can cap off the bitrate because some users might not be able to stream the video fast enough.
[18:12:26 CEST] <thebombzen> you'd do that by using CRF and the maxrate option.
[18:12:40 CEST] <Nobgul> -b:v
[18:13:03 CEST] <furq> like i said, read that wiki page
[18:13:10 CEST] <furq> it explains all the ratecontrol options you might want to use
[18:13:31 CEST] <Nobgul> thebombzen: Yea but the issue still is for a 360p what -b:v -maxrate    do i set
[18:13:44 CEST] <thebombzen> Nobgul: the wiki describes it better than I can
[18:13:45 CEST] <thebombzen> https://trac.ffmpeg.org/wiki/Encode/H.264#CRFwithmaximumbitrate
[18:13:46 CEST] <thebombzen> read that
[18:14:46 CEST] <Nobgul> i got it I understant the controls, i just need to find a refrence that tells me what i should make a 360p etc
[18:17:03 CEST] <furq> Nobgul: seriously, there is no correct bitrate for all 360p videos, there's not even anything close
[18:17:13 CEST] <furq> you'll just need to experiment and find a value that looks reasonably good
[18:20:39 CEST] <Nobgul> furq: Thanks for the help, I really don't have the time to experment the project is launching in 30 hours and i have 20 videos to split into 5 resolutions each =/
[18:25:35 CEST] <thebombzen> Nobgul: encode one of them at CRF 23
[18:25:37 CEST] <c_14> Regda: like I said, if it works don't touch it.
[18:25:40 CEST] <thebombzen> and look at the average bitrate
[18:25:44 CEST] <thebombzen> and there's a starting point.
[18:26:02 CEST] <Regda> hm yeah right. :/
[18:27:01 CEST] <Nobgul> i found a ustream page with "recomended" bitrates so im redoing the 360p at 1200k
[18:27:05 CEST] <Nobgul> lets see hwo it looks
[18:27:29 CEST] <Nobgul> i guess as farq said im going to just have to experment
[18:27:50 CEST] <Nobgul> furq* sorry
[18:50:55 CEST] <Regda> youtube says a mp4 container does not have edit lists, is there a way to let ffmpeg display if there are any ?
[19:38:00 CEST] <Mista-D> A quick question, concat filter doesn't allow absolute path, only relative as a security precaution. Deosn't this path qualifies as relative: "    [concat @ 0x1ca08c60] Unsafe file name '../free/test2500.ts'     "?
[19:38:54 CEST] <Nobgul> 48000 Hz, stereo, fltp, 128 kb/s <-- 128kb/s written out in long form is 128000?
[19:52:37 CEST] <c_14> Nobgul: ye
[19:52:38 CEST] <Nobgul> furq: You still around?
[20:20:53 CEST] <DHE> if I had more CPU than I knew what to do with, is there a good way to 'improve' the image quality of an H264 video being decoded?
[20:24:43 CEST] <kepstin> depends. You could run something like 'gradfun' to reduce banding maybe?
[20:25:38 CEST] <kepstin> there's not really any way to make the video decode itself look better; you have whatever data the encoder decided to give you. But some post-processing effects can make the video look "nicer"
[20:27:39 CEST] <c_14> You can sharpen it, blur it, add grain, remove grain, remove grain and add dithering
[20:27:47 CEST] <c_14> Depends a lot on the input video and your preferences
[20:33:16 CEST] <c_14> you can also mess around with the hue/contrast/saturation but that's (more) evil
[21:25:59 CEST] <haasn> I'm encoding a sequence of images, and ffmpeg constantly spams Input stream #0:0 frame changed from size:1920x1080 fmt:rgb24 to size:1920x1080 fmt:pal8 (and vice versa)
[21:26:04 CEST] <haasn> as well as Past duration 1.999992 too large
[21:26:23 CEST] <haasn> I'm doing ffmpeg -r 60 -i frame%d.png -c:v libx264 test.mkv
[21:26:35 CEST] <haasn> the exact same invocation worked fine on a different sequence of .png, and the result of this command also seems fine
[21:26:40 CEST] <haasn> but I don't understand the error and why it's getting spammed
[21:27:44 CEST] <haasn> Oh, seems like pal8 means it's an 8-bit palette (e.g. as produced by imagemagick for low-color PNGs)
[21:27:55 CEST] <haasn> so that error is probably worth ignoring
[21:39:43 CEST] <haasn> but I cannot understand the past duration 1.999992 error
[21:41:57 CEST] <c_14> try using -framerate 60 instead of -r 60
[21:42:33 CEST] <flux> standard answer from c_14.. :-)
[21:42:49 CEST] <flux> sorry, I just recalled you answered almost the same words just yesterday ;)
[21:43:39 CEST] <c_14> I probably say those words a lot :p
[21:43:58 CEST] <haasn> thanks, that silences the warning :p
[21:44:06 CEST] <c_14> It is annoying that those do different things
[21:44:26 CEST] <haasn> it's annoying that the ffmpeg man page shows examples using -r
[21:44:29 CEST] <haasn> because that's where I got it from
[22:00:52 CEST] <llogan> haasn: where at in the man page, exactly?
[22:01:24 CEST] <haasn> llogan: here, this is the first result I found when searching for rate: https://0x0.st/cYo.txt
[22:03:10 CEST] <llogan> that's utilizing a different demuxer. the image file demuxer uses -framerate.
[22:03:22 CEST] <llogan> as does other things such as input devices
[22:03:48 CEST] <haasn> I understand that now but I did not understand that before getting this warning spammed at me and asking #ffmpeg for help
[22:04:07 CEST] <llogan> yes, it's not very intuitive
[22:04:30 CEST] <haasn> ffmpeg's man page is so long that the only way to parse it is to use the search functionality and try the thing that seems vaguely related
[22:04:41 CEST] <haasn> maybe -framerate should be mentioned somewhere earlier than -r
[22:04:54 CEST] <haasn> or the two should be unified
[22:04:57 CEST] <haasn> both seems reasonable
[22:04:59 CEST] <c_14> tbh, that bullet could probably go. People who need to force input framerates usually either know what they're doing or are already asking for help in here. Or we could just add an example with the image2 demuxer there (or v4l2)
[22:08:53 CEST] <llogan> haasn: the man pages are available as sections as well, such as "man ffmpeg-filters"
[22:09:33 CEST] <llogan> refer to ALSO section at end of "man ffmpeg" for list of available sections
[22:12:20 CEST] <furkan> hi, does anybody have any tips on how i can troubleshoot this error: [mp3 @ 0xb26fe08] RTP: dropping old packet received too late
[22:12:51 CEST] <furkan> we have a sound system putting out two RTP streams, one on UDP port 30000, and one on 30001
[22:12:59 CEST] <furkan> the second stream works, and the first gives that error
[22:13:05 CEST] <DHE> you have something preventing real-time processing. latency, high CPU, something like that.
[22:13:33 CEST] <furkan> is there any way i can figure out why it's happening with the 1st stream, but not the 2nd?
[22:14:25 CEST] <furkan> they're both 128kbps mp3 streams
[22:18:09 CEST] <c_14> check wireshark?
[22:18:36 CEST] <furkan> yeah that's what i'm doing actually
[22:18:41 CEST] <furkan> seem to be receiving both streams
[22:19:48 CEST] <c_14> not sure if wireshark has an rtp "filter" but if it does you can check the timestamps/timestamp ordering of the packets
[22:44:05 CEST] <furkan> blah... i changed the port from 30000 to 30002, and now it works
[22:44:08 CEST] <furkan> go figure
[22:44:17 CEST] <Nobgul> lol
[22:44:24 CEST] <Nobgul> there must have been something else on that port
[22:44:41 CEST] <furkan> that sounds plausible
[22:44:45 CEST] Action: furkan runs wireshark again
[22:44:48 CEST] <Nobgul> hehe
[22:45:05 CEST] <Nobgul> or system reserved or something else crazy
[22:45:38 CEST] <furkan> yeah i dunno, wireshark doesn't seem to be capturing anything on that port anymore
[22:46:11 CEST] <Nobgul> i have herd of weirder things
[22:46:12 CEST] <Nobgul> lol
[22:49:02 CEST] <furkan> ah, but after changing the port, the other stream stopped working
[22:49:16 CEST] <furkan> so there must be some weird interaction going on
[22:49:24 CEST] <Nobgul> lol
[22:49:28 CEST] <c_14> eeh
[22:49:29 CEST] <Nobgul> are you using an encoder
[22:49:31 CEST] <c_14> rtcp traffic?
[22:49:37 CEST] <c_14> that's usually on rtp port + 1
[22:49:42 CEST] <c_14> try spacing the ports out further
[22:50:38 CEST] <furkan> c_14: you nailed it :D
[22:50:45 CEST] <furkan> now they're both working
[22:51:00 CEST] <furkan> thanks a lot :)
[22:53:52 CEST] <LMGN> "Could not find video device with name [screen-capture-recorder] among source devices of type video. video=screen-capture-recorder:audio=virtual-audio-capturer: I/O error"
[22:53:53 CEST] <LMGN> wat do
[22:54:19 CEST] <LMGN>  -f dshow -framerate 20 -i video="screen-capture-recorder":audio="virtual-audio-capturer"
[22:55:12 CEST] <c_14> ffmpeg -f dshow -list_devices ?
[22:56:47 CEST] <LMGN> Unrecognized option 'list_device'. Error splitting the argument list: Option not found
[22:57:00 CEST] <LMGN> Unrecognized option 'list_devices'. Error splitting the argument list: Option not found
[22:58:16 CEST] <LMGN> http://sx.thelmgn.com/2016/06/2016-06-10_21-57-23.txt
[22:58:34 CEST] <LMGN> that good enough?
[23:00:16 CEST] <c_14> ye, try this:
[23:00:19 CEST] <c_14> ffmpeg -list_devices true -f dshow -i dummy
[23:00:53 CEST] <LMGN> http://sx.thelmgn.com/2016/06/2016-06-10_21-59-58.txt
[23:02:10 CEST] <c_14> yeah, it looks like you just don't have the screen-capture-recorder, try using gdigrab I guess?
[23:03:36 CEST] <LMGN> works in my screenshot software.
[23:03:36 CEST] <LMGN> http://sx.thelmgn.com/2016/06/vivaldi_2016-06-10_22-02-32.png
[23:03:49 CEST] <llogan> i assume this is the "screen-capture-recorder" https://github.com/rdp/screen-capture-recorder-to-video-windows-free
[23:06:44 CEST] <LMGN> ty
[23:06:56 CEST] <LMGN> (insert inception bwwwaaaaap here) http://sx.thelmgn.com/2016/06/ffplay_2016-06-10_22-05-43.png
[23:07:19 CEST] <Nobgul> lol
[23:07:27 CEST] <Nobgul> trippy
[23:08:16 CEST] <LMGN> http://inception.davepedu.com/inception.mp3
[23:10:15 CEST] <LMGN> http://sx.thelmgn.com/2016/06/2016-06-10_22-08-39.mp4
[00:00:00 CEST] --- Sat Jun 11 2016

More information about the Ffmpeg-devel-irc mailing list