[Ffmpeg-devel-irc] ffmpeg.log.20160614

burek burek021 at gmail.com
Wed Jun 15 02:05:01 CEST 2016

[00:35:34 CEST] <DHE> my tearing issue in h264 encoding has been narrowed down to the encoder itself. I switched the output codec to ffv1 (and the format to mkv) and it looks fine
[01:07:23 CEST] <DHE> anyone know what could cause libx264 to not properly encode an input frame and result in tearing? but only situationally, some videos do it and some are fine.
[02:38:00 CEST] <ivi> What does the sample/frame number mismatch mean? https://i.imgur.com/ceVzpwQ.png
[02:38:05 CEST] <ivi> I take the resulting file is faulty? How do I fix this? Just rerip from the CD? Thanks.
[02:43:45 CEST] <DHE> looks like a FLAC-specific error
[03:16:56 CEST] <vladashram> ivi: I would listen to the song, that error is usually minimal and likely won't affect the music.
[04:07:32 CEST] <heeen> why does ffmpeg ignore the percentage sign: ffmpeg -f rawvideo -vcodec rawvideo -s 1088x1600 -pix_fmt yuv420p -i out%04d.yuv420  out.mp4
[04:07:57 CEST] <heeen> it tries to open that literal filename instead of file numbering
[04:08:09 CEST] <heeen> open("out%04d.yuv420", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
[05:53:03 CEST] <nifwji2> I reencoded a movie since it was 1080p and I needed it to be much smaller for my laptop to play it.
[05:53:16 CEST] <nifwji2> I think I messed up though
[05:53:27 CEST] <nifwji2> because the frame height was higher thean the width
[05:53:40 CEST] <nifwji2> but I just told my video playr to stretch it
[05:53:43 CEST] <nifwji2> and it looks fine.
[06:24:35 CEST] <ivi> It seems that the sample/frame number mismatch error (https://i.imgur.com/ceVzpwQ.png) when converting FLAC to V0 VBR MP3 appears only if I beforehand edit the FLAC tags in Rhythmbox. What does this mean?
[11:37:30 CEST] <certaindestiny> Hi all, We are getting a lot of errors and the screen is displaying 1 frame every 10 seconds or so. Anybody know why we are getting the errors?
[11:37:31 CEST] <certaindestiny> http://pastebin.com/CyiiJx8h
[11:39:28 CEST] <certaindestiny> The command we use http://pastebin.com/xLwRyjzm
[12:02:45 CEST] <certaindestiny> Hi all, We are getting a lot of errors and the screen is displaying 1 frame every 10 seconds or so. Anybody know why we are getting the errors? output http://pastebin.com/CyiiJx8h command http://pastebin.com/xLwRyjzm
[12:04:00 CEST] <ababhya> I am trying to stream my desktop to a live feed using "ffmpeg -f gdigrab -framerate 30 -i desktop -c:v libx264 -preset ultrafast http://localhost/feed1.ffm"
[12:04:34 CEST] <ababhya> But the codec it uses is still mpeg4.
[12:05:19 CEST] <ababhya> When I change the output to output.mp4, it uses the libx264. Why doesnt it work with the live stream link ?
[12:05:52 CEST] <certaindestiny> ababhya can you paste the output of the command?
[12:08:08 CEST] <ababhya> just a second
[12:13:06 CEST] <ababhya_> certaindestiny: ffmpeg version 3.0.2 Copyright (c) 2000-2016 the FFmpeg developers
[12:14:27 CEST] <certaindestiny> wababhya_ i mean the complete command output. no just the version.
[12:15:06 CEST] <jkqxz> certaindestiny:  The input is coming from RTSP?  Is it actually faster than 25fps?  That seems likely to be the source of all your dropped packets, because the -re option locks the decode speed to the fixed 25fps matching the output so it can't keep up with the stream (probably you only see intra frames).
[12:15:07 CEST] <certaindestiny> something like this http://pastebin.com/CyiiJx8h
[12:15:40 CEST] <certaindestiny> jkqxz, If you give me one second i wil take a look at the camera settings
[12:16:52 CEST] <ababhya_> certaindestiny: the problem  is that even though I set the codec to libx264, it still uses mpeg4. But when I the output is some file like  "output.mp4" instead of "http://....", it uses the desired codec.
[12:17:52 CEST] <certaindestiny> jkqxz, The camera output is 25 fps libx264, max bitrate 8192
[12:18:31 CEST] <certaindestiny> ababhya, I understand your problem. but i would like the command output to be able to see what is actually happening
[12:18:49 CEST] <ababhya_> certaindestiny: just a second
[12:21:04 CEST] <jkqxz> Well, you are getting behind the stream somehow.  Maybe the machine isn't fast enough to do this?  (Does it work if you output the stream to a local file instead of sending it to your decklink thing?)
[12:21:25 CEST] <ababhya_> certaindestiny: https://ideone.com/fDsizg
[12:22:00 CEST] <ababhya_> certaindestiny: yeah it works if I change the output to output.mp4 or .mkv
[12:22:40 CEST] <certaindestiny> Let me have a look,
[12:22:52 CEST] <certaindestiny> jkqxz: any other ideas?
[12:27:03 CEST] <certaindestiny> ababhya, I think the problem is that you call the output .ffm. afaik you are trying to write a file on the server at this point. I have not used http streaming before so i might be wrong
[12:27:45 CEST] <ababhya_> certaindestiny: I need to use .ffm file because, I am using ffserver to restream it.
[12:28:04 CEST] <ababhya_> certaindestiny: any workaround with  a different kind of file ?
[12:29:02 CEST] <certaindestiny> then why not use something like this? "ffmpeg -re -i <input> -c:v libx264 -f mpegts <destination server>
[12:29:21 CEST] <certaindestiny> that way you are directly streaming it to the server
[12:30:09 CEST] <jkqxz> certaindestiny:  Not really.  You need to work out why the decoder is getting behind.  The log output does actually suggest it is decoding frames at 25fps (though not successfully), so maybe the camera is lying around what it's sending?
[12:30:42 CEST] <ababhya_> certaindestiny: it worked. Thank you.
[12:31:40 CEST] <certaindestiny> jkqxz: i have googled some and some people are saying stuf about kernel buffer size
[12:31:52 CEST] <certaindestiny> but personally i do not get why it is failing
[12:33:25 CEST] <ababhya_> certaindestiny: well it failed actually with a Conversion error
[12:33:43 CEST] <jkqxz> The RTP layer probably has all the packets, but the log shows it having to discard them because the decoder isn't keeping up.
[12:33:55 CEST] <certaindestiny> So the decklink is to slow?
[12:34:03 CEST] <certaindestiny> Or the CPU is the bottleneck
[12:34:35 CEST] <jkqxz> Something like that.  What happens without -re?
[12:34:38 CEST] <certaindestiny> ababhya: Please show the output again, i have not tested your command. it was on the top of my head so i may have forgotten something
[12:35:06 CEST] <certaindestiny> -re is just read at line speed. It something i always put in because i stream from files. but you can leave it out if you want to
[12:35:59 CEST] <certaindestiny> jkqxz: trying now
[12:36:42 CEST] <certaindestiny> Same errors as before
[12:37:18 CEST] <certaindestiny> I wil brb,
[12:37:28 CEST] <certaindestiny> Please share the output ababhya_
[12:37:34 CEST] <ababhya_> just a second
[12:37:34 CEST] <jkqxz> Or some other way of pushing it into dropping after the decoder rather than before.  "-vf fps=25" maybe.
[12:42:40 CEST] <ababhya_> certaindestiny: https://ideone.com/osjyQX
[13:08:36 CEST] <certaindestiny> I haver returned. Ill take a look
[13:08:43 CEST] <certaindestiny> jkqxz, Ill try that
[13:11:48 CEST] <certaindestiny> ababhya_: You are not using the syntax right.  ffmpeg -re -f gdigrab -framerate 30 -i desktop -c:v libx264 -f mpegts
[13:12:02 CEST] <certaindestiny> replace the with the ip address of the server
[13:13:07 CEST] <certaindestiny> and pick a protocol such as udp/tcp
[13:13:39 CEST] <certaindestiny> say for example the server ip is the command would be udp://
[13:15:02 CEST] <certaindestiny> jkqxz: it is still not working
[14:33:56 CEST] <nifwji2> in most irc channels I am active.
[14:34:08 CEST] <nifwji2> while I am awake I make up over 50% of all posts
[14:34:23 CEST] <nifwji2> on this one channel in the last 8 hours I posted 181 lines
[14:34:29 CEST] <nifwji2> whereas everyone else only posted 10
[15:08:32 CEST] <certaindestiny> Anybody able to help me? I am trying to recompile ffmpeg however libavformat gives an error
[15:14:21 CEST] <furq> would it be rude to ask what the error is
[15:19:57 CEST] <certaindestiny> furq/l I did some troubleshooting and realised i made a very very very dumd mistake
[15:20:19 CEST] <certaindestiny> --enable-avcodec not --enable-libavcodec
[15:20:23 CEST] <certaindestiny> you may punch me now
[15:21:16 CEST] <furq> it's probably not worth the airfare
[15:30:31 CEST] <certaindestiny> now lets hope this fixes the other problems i am having :P
[15:50:08 CEST] <certaindestiny> forq: Can you help me with another problem? when using RTSP i get the message " Past duration 0.769997 too large" allot
[15:52:21 CEST] <certaindestiny> furq: Srr typo, still can you help me?
[15:59:29 CEST] <furq> certaindestiny: you can usually ignore that message
[15:59:43 CEST] <certaindestiny> Even when it is spammed like 20 time a sec?
[16:00:02 CEST] <furq> usually
[16:00:10 CEST] <furq> you can use -v error if you want to shut it up
[16:00:13 CEST] <certaindestiny> Alright thanks
[16:00:24 CEST] <furq> if the output is ok then it's probably not meaningful
[16:19:31 CEST] <pgorley> what kind of data is stored in AVBuffer?
[16:39:26 CEST] <k_sze> I'm confused about the situation of high10.
[16:39:54 CEST] <k_sze> If I build with high10 enabled, do I *lose* the ability to process 8-bit? Or it just defaults to 10-bit?
[16:40:09 CEST] <furq> if you mean x264 then the former
[16:40:27 CEST] <k_sze> Then who on earth would want that?
[16:40:35 CEST] <k_sze> And why is it one or the other?
[16:41:02 CEST] <furq> i would want that because i encode a lot of hi10p
[16:41:13 CEST] <furq> as to why it's one or the other i have no idea, that's just how libx264 does it
[16:41:40 CEST] <furq> if you build ffmpeg with shared libs you can have an 8-bit and a 10-bit libx264.so and switch with LD_LIBRARY_PATH
[16:43:39 CEST] <k_sze> And what do video players do about that (e.g. VLC)?
[16:43:55 CEST] <furq> libx264 is an encoder
[16:44:22 CEST] <furq> so unless your player does a lot of encoding it makes no difference
[16:44:33 CEST] <furq> libavcodec's decoder can handle both just fine
[16:46:16 CEST] <Mavrik> Is there a point encoding to high10 if you don't have an HDR display?
[16:46:34 CEST] <furq> it compresses better
[16:53:57 CEST] <pgorley> is the AVCodecContext->get_buffer2 call necessary to implementing hardware acceleration in my application?
[16:55:16 CEST] <BtbN> Depends entirely on the decoder.
[17:33:02 CEST] <Fyr> how to copy hdmv_pgs_subtitle from ts to mkv?
[17:39:15 CEST] <thebombzen> Fyr: did you try -c:s copy?
[17:39:31 CEST] <Fyr> I tried -c copy.
[17:39:49 CEST] <thebombzen> why didn't -c:s copy work? i.e. what was the error message?
[17:40:46 CEST] <Fyr> I tried:
[17:40:47 CEST] <Fyr> ffmpeg -i 00004.m2ts -c copy 1.mkv
[17:40:51 CEST] <Fyr> it just doesn't copy.
[17:41:14 CEST] <Fyr> it copies the streams before hdmv_pgs_subtitle.
[17:41:34 CEST] <thebombzen> try -map 0
[17:42:03 CEST] <thebombzen> i.e. ffmpeg -i input.m2ts -map 0 -c copy output.mkv
[17:43:05 CEST] <Fyr> thanks, it seems to be working now.
[17:44:03 CEST] <thebombzen> what the -map commands does is it tells FFmpeg which streams to map over from input to output. it has a "default option"
[17:44:17 CEST] <thebombzen> which usually includes one video stream and has a bit of other conditions
[17:44:24 CEST] <thebombzen> -map 0 says "map everything from input zero"
[17:44:41 CEST] <DHE> I asked this yesterday but got no response. I'm encoding H264 video with libav* but get this tearing effect. frame-stepping it looks like only the top ~1/3 of the frame was updated with the wrong frame data, but no decoder errors. switching to ffv1 makes flawless output so I must be doing something wrong with libx264. anyone seen this
[17:45:11 CEST] <thebombzen> DHE: pastebin full command line?
[17:45:19 CEST] <Fyr> thebombzen, do you know how to also embed SRT subtitles?
[17:45:30 CEST] <DHE> thebombzen: error, I said it's an libav* application written in C
[17:45:51 CEST] <thebombzen> DHE: well in that case, sorry :(
[17:45:58 CEST] <thebombzen> dunno libavcodec
[17:46:04 CEST] <thebombzen> Fyr: you can have multiple inputs
[17:46:26 CEST] <thebombzen> try ffmpeg -i input -i subtitles.srt -c copy output
[17:46:46 CEST] <thebombzen> you might need to do ffmpeg -i input -i subtitles.srt -map 0 -map 1 -c copy output
[17:46:57 CEST] <thebombzen> to force ffmpeg to copy streams from both input files.
[17:47:34 CEST] <Fyr> thebombzen, so the option c:s0 mov_text is not necessary?
[17:47:46 CEST] <Fyr> *-c:s:0 mov_text
[17:48:04 CEST] <thebombzen> well that would convert the srt subtitles to mov_text subtitles
[17:48:19 CEST] <Fyr> is there a difference?
[17:48:20 CEST] <Zaneo> If the frame dimensions i'm getting after decoding a video, are not what I'm encoding it at, chances are the pixel format is incorrect?
[17:48:35 CEST] <thebombzen> Fyr: It depends on what subtitles format the output supports. I think matroska supports embedded SRT subs
[17:48:42 CEST] <thebombzen> MP4 definitely doesn't though.
[17:49:26 CEST] <Fyr> ok, does FFMPEG supports multithreaded stream copying?
[17:49:37 CEST] <thebombzen> it doesn't matter
[17:49:44 CEST] <Fyr> why?
[17:49:46 CEST] <thebombzen> because the hard drive is the limiting factor there
[17:49:53 CEST] <Fyr> I have SSD. =)
[17:49:54 CEST] <thebombzen> and memory speed
[17:50:07 CEST] <thebombzen> stream copying isn't a drain on the CPU, even with an SSD
[17:50:12 CEST] <Fyr> DDR4 is always fast.
[17:50:19 CEST] <thebombzen> not as fast as a CPU
[17:50:34 CEST] <thebombzen> it's also irrelevant because stream copying is EXTREMELY fast
[17:50:49 CEST] <thebombzen> as for the actual answer to your question, I don't know. but I claim it doesn't really matter.
[17:52:33 CEST] <thebombzen> as in, I ran a quick experiment. to streamcopy a 23 minute 1080p video for me took 0.8 seconds and I don't have an SSD.
[17:54:38 CEST] <DHE> ffmpeg can multi-thread the IO a little bit, but it's not going to save much.
[17:54:57 CEST] <heeen> why does ffmpeg ignore the percentage sign: ffmpeg -f rawvideo -vcodec rawvideo -s 1088x1600 -pix_fmt yuv420p -i out%04d.yuv420  out.mp4
[17:56:06 CEST] <thebombzen> heeen: what do you mean "it's ignoring the percentage sign"
[17:56:15 CEST] <thebombzen> pastebin the output and post a link here?
[17:56:33 CEST] <heeen> it does not open out0001.yuv420
[17:56:43 CEST] <thebombzen> that's because rawvideo is a sequence of frames in 1 file
[17:56:49 CEST] <thebombzen> you're looking for the image2 format
[17:56:53 CEST] <heeen> what is the correct way
[17:56:57 CEST] <heeen> ah I see
[17:57:08 CEST] <heeen> thanks
[17:57:33 CEST] <thebombzen> image2 could also be a sequence of png, etc. depending on the codec.
[17:58:26 CEST] <heeen> ofc
[18:36:14 CEST] <DHE> nobody ever seen libx264 produce "tearing" video when using libavcodec?
[18:48:25 CEST] <Fyr> guys, when playing MKV created with FFMPEG, players don't show the picture when starting. if I scroll or go to a place, it plays normal.
[18:48:48 CEST] <Fyr> when I play other files, the picture is shown from the start.
[18:49:07 CEST] <Fyr> what's wrong with FFMPEG MKVs?
[18:49:21 CEST] <DHE> stream copy?
[18:49:25 CEST] <Fyr> yeah
[18:52:44 CEST] <Fyr> is there an option for MKV, something like Web-optimized for MP4?
[18:54:30 CEST] <furq> how did you make this mkv
[18:54:52 CEST] <Fyr> ffmpeg -i 1.m2ts -c copy 1.mkv
[21:08:51 CEST] <chovy> does anyone know the answer to this? https://www.mail-archive.com/ffmpeg-user%40ffmpeg.org/msg09688.html
[21:10:08 CEST] <Wader8> hello
[21:11:50 CEST] <Wader8> ah nvm solved it
[22:08:15 CEST] <neuro_sys> do you know an easy way to extract all the colors used in this image? http://i.imgur.com/cQusvft.jpg
[23:16:08 CEST] <Regda> has someone an idea whats wrong ? :/
[23:16:10 CEST] <Regda> ffmpeg -y -thread_queue_size 1024 -r:0 30 -f image2 -framerate 30 -pixel_format rgb24 -video_size 1280x1024 -i %06d.png\
[23:16:10 CEST] <Regda> -f image2 -framerate 30 -pixel_format rgb24 -video_size 1280x1024 -i src\Background.png\
[23:16:10 CEST] <Regda> -filter_complex "[1:0] format=rgba,fade=t=out:s=90:n=90:alpha=1 [tmp]; [0:v][tmp] overlay=0:0:format='rgb'"\
[23:16:10 CEST] <Regda> -r:0 30 -s 1280x1024 -aspect 5:4 -vcodec libx264rgb -dn -preset slow -pix_fmt bgr24 -bf 2 -g 15 -an -sn -movflags faststart Z:\bg_test.mp4
[23:16:41 CEST] <Regda>  
[23:16:52 CEST] <Regda> i have trouble with the fading
[23:17:31 CEST] <Regda> i want to fade out the background (an image over the video)
[23:18:35 CEST] <Regda> but the image does not hide or hides from one frame to another... via versa
[23:18:50 CEST] <Regda> i think i done something wrong with the input outputs...
[23:37:42 CEST] <computer> hello people, i am facing an error with using ffmpeg. error pasted here: https://da.gd/OvBq1 anyone could help me?
[23:43:37 CEST] <llogan> computer: looks like you're using convert. try imagemagick help.
[23:45:58 CEST] <computer> llogan: is imagemagick another program or a command within ffmpeg?
[23:46:21 CEST] <llogan> another project that provides cli tools such as convert & mogrify
[23:46:37 CEST] <Regda> computer: fill the filename with zeros then you can do: ffmpeg -i %06d.png FILENAME.m4v
[23:47:21 CEST] <computer> Regda: what do you mean fill with 0s?
[23:47:22 CEST] <Regda> in your case %03d.png
[23:47:34 CEST] <Regda> 15.png -> 015.png
[23:47:43 CEST] <computer> Regda: oh ok
[23:47:58 CEST] <computer> what does %03d and %06d mean?
[23:48:25 CEST] <Regda> d means digit
[23:48:33 CEST] <Regda> 03 means 3 digits
[23:48:40 CEST] <Regda> 06 means 6 digits
[23:48:43 CEST] <Regda> e.g.
[23:48:49 CEST] <pzich> 3 means 3 digits, 03 means 3 digits with zero padding
[23:48:53 CEST] <Regda> %06d -> 000015
[23:49:06 CEST] <Regda> sure... sry
[23:49:58 CEST] <Regda> pzich: if you know that why not helping ? :/
[23:50:07 CEST] <computer> pzich: Regda hmmmm ok
[23:51:24 CEST] <computer> do you have any short cut to naming 100 files with 0s behind them? instead of doing it manually?
[23:52:02 CEST] <pzich> Regda: I help when I can, just happened to pop in then
[23:52:41 CEST] <pzich> computer: maybe something like this? http://stackoverflow.com/q/55754
[23:53:43 CEST] <Regda> i use windows not linux sry :/
[23:54:41 CEST] <pzich> hmm, not seeing a lot of results for windows
[23:54:55 CEST] <Regda> http://stackoverflow.com/questions/9430642/win-bat-file-how-to-add-leading-zeros-to-a-variable-in-a-for-loop
[23:54:57 CEST] <Regda> ^^'
[23:55:32 CEST] <pzich> I think that's just outputting numbers, not renaming files, but it could probably be adapted to do that
[23:55:45 CEST] <Regda> not relevant
[23:59:18 CEST] <Regda> maybe you can try simply ffmpeg -i %3d.png FILENAME.m4v
[00:00:00 CEST] --- Wed Jun 15 2016

More information about the Ffmpeg-devel-irc mailing list