[Ffmpeg-devel-irc] ffmpeg.log.20160618

burek burek021 at gmail.com
Sun Jun 19 02:05:02 CEST 2016

[00:00:10 CEST] <echo1877> the libs all link properly, i get this when trying to link my code against libavcodec.a
[00:00:24 CEST] <echo1877> i don't get this if i use 3.0.2, only if i use the current snapshot
[00:01:38 CEST] <kepstin> zamba: keep in mind that you got the raw video input over USB in the first place, so obviously USB is fast enough to save it :)
[00:01:58 CEST] <zamba> kepstin: yeah :)
[00:03:57 CEST] <echo1877> just realized this may be some issue when building with --disable-optimizations and --disable-asm, so will try again without those
[00:04:27 CEST] <echo1877> although presumably that's how most ffmpeg devs build on the code on a daily basis (one would think)
[00:07:23 CEST] <zamba> kepstin: Past duration 0.669914 too large
[00:07:29 CEST] <salviadud> remember me?
[00:07:34 CEST] <salviadud> guess what, the apocalypse is coming
[00:07:51 CEST] <salviadud> sorta
[00:08:35 CEST] <salviadud> There's this pr0n site that has been releasing videos with the wrong aspect ratio, and pixel dimension
[00:08:45 CEST] <salviadud> I am being called upon my friends
[00:09:10 CEST] <salviadud> the sacred command of -s 1280x720 -aspect 16:9 will be invoked
[00:09:46 CEST] <furq> did you ever find the secret message in the paint can
[00:09:50 CEST] <zamba> kepstin: wow.. ok.. 1 minute of video with ffvhuff was around 700 mb :)
[00:10:27 CEST] <zamba> kepstin: for 90 minutes of video, that will be a huge file
[00:11:05 CEST] <salviadud> furq, I've tried so many different things, the last thing I tried was handbrake the original file with the latest h264, then I used an old computer with the oldest possible version of ffmpeg with the same version of the h264 codec to decompress it, and still no go.
[00:11:13 CEST] <zamba> kepstin: can i do something to keep the disk usage a bit down? and still keep the speed?
[00:11:26 CEST] <salviadud> Maybe it's only badly proportioned, and I should be thankful I can fix the aspect ratio.
[00:11:35 CEST] <kepstin> zamba: get a faster processor, and pick a slower codec :/
[00:12:06 CEST] <kepstin> if you can do ffv1 in realtime, go for it (it might be slightly tweakable, i dunno if e.g. -g 1 might speed it up)
[00:12:10 CEST] <salviadud> But I tell ya, go into pornhub right now and you'll find 1280x720 vids that are wrongly encoded to 960x720 in 4:3 format
[00:12:26 CEST] <salviadud> That is a sign, I'm not kidding.
[00:12:57 CEST] <salviadud> It is officially ffmpeg-pr0n my friends.
[00:13:01 CEST] <salviadud> And it's free
[00:13:29 CEST] <kepstin> Like, I wouldn't have been surprised at porn videos in anamorphic 1440x1080, since that's a common resolution for cheaper HDish cameras. But that's just an encoding error :/
[00:14:08 CEST] <furq> "i'm not kidding" because we all know the high standards of the amateur porn industry
[00:14:11 CEST] <spirou> so they are 720P 16:9 videos that they squeezed into 4:3 ?
[00:14:32 CEST] <salviadud> exactly
[00:14:34 CEST] <kepstin> maybe they just downscaled the 1440x1080 to 720 height and lost the anamorphic sample ratio info :/
[00:14:43 CEST] <salviadud> No
[00:14:50 CEST] <furq> that seems pretty likely tbh
[00:14:56 CEST] <salviadud> See, there's like a "catch"
[00:14:58 CEST] <furq> i've done that by accident when downscaling 1440*1080
[00:15:10 CEST] <salviadud> As I said previously, I have been involved with the pr0n industry in some way.
[00:15:18 CEST] <furq> don't tell me these videos also have secret messages hidden in them
[00:15:27 CEST] <salviadud> So, there are videos that have the correct aspect ratio of 16:9 and are 1280x720
[00:15:46 CEST] <spirou> the other day I experimented with converting a file to mono sound with    ffmpeg -i in.mp4 -vcodec copy -ac 1 -profile:a aac_he -b:a 32k out.mp4
[00:15:49 CEST] <spirou> what did I do wrong?
[00:15:57 CEST] <salviadud> The actresses in the wrongly proportioned videos are getting my attention.
[00:16:09 CEST] <salviadud> The want me to contact them.
[00:16:39 CEST] <furq> have you run out of tinfoil again
[00:16:53 CEST] <salviadud> I can't send you links right now because I'm at work
[00:17:01 CEST] <salviadud> but I can sure give you a search term.
[00:17:08 CEST] <salviadud> take a look yourself
[00:17:10 CEST] <kepstin> spirou: it's hard to say what you did wrong without knowing what problem you're having with the result.
[00:17:15 CEST] <salviadud> mommy me and a gangster 3
[00:17:18 CEST] <spirou> because nothing would play the sound then, and ffmpeg say "[aac @ 0xad70d00] Audio object type SBR+21 is not implemented" and "Failed to open codec in av_find_stream_info"
[00:17:37 CEST] <furq> spirou: the built-in aac encoder doesn't do he-aac
[00:17:45 CEST] <furq> you'd need to use -c:a fdk-aac
[00:17:55 CEST] <zamba> kepstin: i have quite a few glitches in the audio.. this is the raw dv output.. like some kind of electostatic noise
[00:17:57 CEST] <salviadud> I have already done the job of fixing the video and re-upload it, so you might find 2 copies of said video
[00:17:57 CEST] <kepstin> or just use aac-lc instead (the default)
[00:17:58 CEST] <furq> which requires a build with fdk-aac which isn't distributable
[00:18:09 CEST] <spirou> ah
[00:18:24 CEST] <salviadud> The fixed version has the site logo all stretched out, but the video looks as it should.
[00:19:22 CEST] <salviadud> I also did a two pass encoding so the audio doesn't glitch
[00:19:30 CEST] <salviadud> I love ffmpeg
[00:19:42 CEST] <salviadud> It works so nice
[00:19:49 CEST] <furq> those two things aren't related at all
[00:20:00 CEST] <salviadud> Two pass encoding?
[00:20:23 CEST] <furq> two-pass makes no difference to the audio
[00:20:33 CEST] <salviadud> How would you fix the aspect ratio of a video and have the output file have the same audio but without any hiccups?
[00:20:48 CEST] <furq> -c copy -aspect 16:9 out.mkv
[00:21:19 CEST] <furq> although it wouldn't make any difference even if you reencoded the video
[00:21:23 CEST] <salviadud> Yeah, but fixing the aspect ratio doesn't do all the work for you, you have to stretch it too
[00:21:25 CEST] <furq> the duration doesn't change
[00:21:47 CEST] <salviadud> Tell me if I'm doing this right.
[00:22:21 CEST] <spirou> hmm... when I try it says "Unknown encoder 'fdk-aac'" I suppose it is something I have to install separately?
[00:22:22 CEST] <kepstin> changing the aspect ratio will cause the player to stretch it during playback
[00:22:31 CEST] <furq> you don't need to reencode to change the aspect ratio, the player will set the correct dar if it's different from the par
[00:22:36 CEST] <salviadud> I go ffmpeg -i input.mp4 -vcodec libx264 -b:v (samebitrate) -an -s 1280x720 -aspect 16:9 output.mp4
[00:22:43 CEST] <kepstin> spirou: you need to do your own build of ffmpeg to get one with fdk-aac
[00:22:48 CEST] <salviadud> Then I strip the audio to another file
[00:23:01 CEST] <furq> why are you doing that in two steps
[00:23:04 CEST] <kepstin> spirou: just use aac-lc instead unless you have a really good reason to do otherwise, it's better supported in genera...
[00:23:05 CEST] <salviadud> and finally join them by doign ffmpeg -i video.mp4 -i audio.aac output.mp4
[00:23:20 CEST] <salviadud> I've had problems before
[00:23:23 CEST] <furq> that's not two-pass, and also that's totally redundant
[00:23:31 CEST] <salviadud> With the audio
[00:23:36 CEST] <salviadud> Well, how would you recommend it?
[00:23:42 CEST] <furq> -c copy -aspect 16:9
[00:23:50 CEST] <spirou> kepstin: aha ok
[00:23:56 CEST] <salviadud> I don't even need to fix the pixel ratio
[00:24:07 CEST] <salviadud> or specify a bit rate?
[00:24:18 CEST] <furq> it's copying the streams, there's no bitrate to specify
[00:24:28 CEST] <kepstin> salviadud: that doesn't re-encode the video or audio, it only changes some flags to make the player stretch it out during playback.
[00:24:35 CEST] <furq> that sets the container aspect ratio, it stretches it during playback
[00:24:57 CEST] <furq> if your player ignores the container aspect ratio, then -c:a copy -c:v libx264 -s 1280x720 -crf 20 out.mp4
[00:25:00 CEST] <furq> or something
[00:25:33 CEST] <salviadud> -crf is the same as handbrake's?
[00:25:39 CEST] <furq> they're both x264's crf
[00:26:15 CEST] <furq> i'd be surprised if you needed to do that though
[00:26:23 CEST] <furq> i've never encountered a player which ignored the container aspect ratio
[00:26:45 CEST] <salviadud> well then, I got more tests to do.
[00:26:58 CEST] <salviadud> I might of been doing this all wrong
[00:27:08 CEST] <salviadud> thanx furq
[00:31:48 CEST] <viric> is there any way ffmpeg can provide an ETA for the transcoding?
[00:34:12 CEST] <echo1877> optimizations and enable-asm don't seem to matter to do. is the current master supposed to be usable? is this a known issue with it?
[00:39:17 CEST] <salviadud> But wait, just changing the aspect ratio so a video player on my computer plays it right doesn't mean that if I upload it to a flash site it'll work properly
[00:39:31 CEST] <salviadud> I'll have to test it out...
[01:17:08 CEST] <azor> Hello
[01:17:55 CEST] <Guest83228> If there any flag or trick I can do to properly record full screen on a retina/super hd screen on PC? It looks like it internally records at full resolution but the crops it at the scaled resolution
[01:18:03 CEST] <Guest83228> Is*
[01:18:27 CEST] <Guest83228> So I can only see a small portion of the screen (upper-left area)
[01:19:07 CEST] <Guest83228> I'm using dshow with the default "fullscreen"
[01:20:12 CEST] <Guest83228> Specifically, ffmpeg -f dshow -i video="screen-capture-recorder":audio="virtual-audio-capturer"
[01:42:00 CEST] <kepstin> Guest19234: that's a bug with your external directshow screen capture software/driver, not with ffmpeg
[01:42:42 CEST] <kepstin> you can try using ffmpeg's internal 'gdigrab' stuff, but I wouldn't expect it to be particularly fast
[01:42:48 CEST] <c_14> kepstin: wrong Guest
[01:42:56 CEST] <c_14> The other one's gone
[01:43:00 CEST] <kepstin> oh.
[01:43:01 CEST] <kepstin> lol
[03:01:56 CEST] <gmh> What happens to "Delay relative to video" when I convert mkv (vp9/opus) to mp4 (avc/aac)? It is set to 7ms according to mediainfo, but is gone after convert.
[03:02:08 CEST] <gmh> Are my audio of by 7ms or does ffmpeg solve this automagically :P
[03:03:09 CEST] <dystopia> is that from media info?
[03:03:48 CEST] <dystopia> because if so there probably never was a delay
[03:04:53 CEST] <gmh> Yeah. Its pulled from youtube with youtube-dl. Every other episode is mkv with aac/opus, and the other one is webm (vp9/opus). My thought was to convert all to same format.
[03:05:22 CEST] <gmh> I noticed it is only the .mkv files that have this (when video is avc and sound is opus).
[03:05:40 CEST] <dystopia> media info messes up the decoding order of frames when there is an open gop
[03:06:10 CEST] <dystopia> so instead of checking from the first frame it checks from the first i-frame and assumes a delay when there isn't one
[03:06:31 CEST] <dystopia> so your encodes should be fine and in sync
[03:06:36 CEST] <gmh> I see. Well that is good news :)
[03:07:33 CEST] <gmh> As mentioned this only happens when video is avc and sound is opus. Not on avc/aac or vp9/opus. So it wasn't totally random.
[03:07:52 CEST] <dystopia> best thing to do
[03:08:15 CEST] <dystopia> is add "-t 60" before your -i in the ffmpeg encoding line
[03:08:24 CEST] <dystopia> then it will only encode the first 60 seconds
[03:08:35 CEST] <dystopia> so you can test it to see if it's good before encoding the whole thing
[03:08:52 CEST] <gmh> I don't think I would see 7ms tbh.
[03:09:03 CEST] <dystopia> :p
[03:09:08 CEST] <dystopia> true
[03:09:40 CEST] <gmh> Well I would, but I would also have my brain play tricks on me when there wasn't none, so not a very effective solution.
[03:09:48 CEST] <gmh> Tip is good though for other situations.
[03:09:56 CEST] <gmh> Thanks for your insights :)
[05:22:55 CEST] <CoJaBo> Is there a tool I can use to thoroghly verify a .webm file?
[05:23:08 CEST] <CoJaBo> Need to figure out why ffmpeg keeps hanging on it :/
[07:09:44 CEST] <xxx_> hi. I want copy part of mp3 file from beginning. start time is 0, but after cutting part have start time, why and how to avoid it?
[07:09:45 CEST] <xxx_> Why part have 0.011995 start time?
[07:09:45 CEST] <xxx_> Input #0, mp3, from '/home/xxx/demo/shared0/src/test/resources/000.orig.5352357791787324393.mp3':
[07:09:45 CEST] <xxx_>   Duration: 00:05:17.20, start: 0.000000, bitrate: 320 kb/s
[07:09:45 CEST] <xxx_> ffmpeg -hide_banner -analyzeduration 50000000 -probesize 50000000 -ss 0.000000 -i /home/xxx/demo/shared0/src/test/resources/000.orig.5352357791787324393.mp3 -t 1.018776 -async 1 -codec copy -f mp3 -y /tmp/p0.mp3
[07:09:47 CEST] <xxx_> [mp3 @ 0x21a8440] Skipping 0 bytes of junk at 0.
[07:09:49 CEST] <xxx_> [mp3 @ 0x21a8440] Estimating duration from bitrate, this may be inaccurate
[07:09:51 CEST] <xxx_> video:0kB audio:40kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 2.672327%
[07:09:53 CEST] <xxx_> ffmpeg -hide_banner -i /tmp/p0.mp3 2>&1 |grep Duration
[07:09:55 CEST] <xxx_>   Duration: 00:00:01.02, start: 0.011995, bitrate: 328 kb/s
[07:14:13 CEST] <kepstin> probably just some quirk of the ffmpeg muxer, why do you think that number should be zero? is this actually affecting anything (e.g. you you have a/v desync or something?)
[07:17:19 CEST] <xxx_> I need split audio, encode them and join again. So after then final audio has artifacts, I need to fix that.
[07:18:36 CEST] <xxx_> For demo I splitted mp3 by 1 second parts with -codec copy and then join, result mp3 have trouble on every second.
[07:19:12 CEST] <kepstin> how are you joining them again?
[07:19:49 CEST] <kepstin> ffmpeg will add some headers, etc. to the file, so simply concatenating them won't work nicely; you might get glitches as players hit the headers in the middle of the file
[07:20:48 CEST] <xxx_> ffmpeg -hide_banner -i concat:/tmp/p0.mp3|/tmp/p1.mp3|/tmp/p2.mp3|/tmp/p3.mp3|/tmp/p4.mp3|/tmp/p5.mp3|/tmp/p6.mp3|/tmp/p7.mp3|/tmp/p8.mp3|/tmp/p9.mp3|/tmp/p10.mp3|/tmp/p11.mp3|/tmp/p12.mp3|/tmp/p13.mp3|/tmp/p14.mp3|/tmp/p15.mp3|/tmp/p16.mp3|/tmp/p17.mp3|/tmp/p18.mp3|/tmp/p19.mp3 -strict experimental -fflags +genpts -flags +global_header -c copy -y /tmp/res.mp3
[07:21:21 CEST] <kepstin> yeah, the file protocol just concatenates them. you could try the concat demuxer instead :/
[07:21:40 CEST] <kepstin> the concat protocol just concatenates the file bytes*
[07:29:15 CEST] <xxx_> Kepstin you are great! Thak you. It works.
[08:07:22 CEST] <xxx_> I split mp3, encode parts to aac and concatenate them via demuxer. But on concatenation ffmpeg show me warnings and when playing, result mp3 freezes in some places and still have artifacts. What is wrong? Should i regenerate timestams?
[08:07:23 CEST] <xxx_> #encode parts
[08:07:23 CEST] <xxx_> ffmpeg -hide_banner -analyzeduration 50000000 -probesize 50000000 -ss 1.018776 -i /home/xxx/demo/shared0/src/test/resources/000.orig.5352357791787324393.mp3 -t 0.966530 -c:a aac -strict -2 -b:a 256k -ac 2 -vn -f mpegts -y /tmp/p1.ts
[08:07:23 CEST] <xxx_> #join
[08:07:25 CEST] <xxx_> ffmpeg -hide_banner -f concat -i /tmp/concat.txt -strict experimental -fflags +genpts -flags +global_header -c copy -bsf:a aac_adtstoasc -y /tmp/res.m4a
[08:07:28 CEST] <xxx_> [ipod @ 0x12fe160] Non-monotonous DTS in output stream 0:0; previous: 88063, current: 87039; changing to 88064. This may result in incorrect timestamps in the output file.
[08:07:31 CEST] <xxx_> [ipod @ 0x12fe160] Non-monotonous DTS in output stream 0:0; previous: 218111, current: 217087; changing to 218112. This may result in incorrect timestamps in the output file.
[10:17:53 CEST] <zamba> kepstin: nope.. didn't work.. A/V desync again
[10:20:15 CEST] <zamba> kepstin: the source DVs are in perfect sync.. then ffmpeg enters and screws everything up
[11:37:39 CEST] <f00bar80> http://vpaste.net/pb2x9 < this script should restart the ffmpeg process if it dies , every time i run it , it doesn't do that, I've even tried to echo the command , which seems to be correct , but always the process doesnt' start any idea what's wrong ?
[12:17:42 CEST] <f00bar80> ppl any comment?
[12:25:08 CEST] <DHE> f00bar80: well, you only save one PID at a time. so at very best it will auto-restart one service
[12:26:53 CEST] <DHE> if you don't know advanced scripting, you might just want to run 3 supervisor instances rather than 1 that monitors 3 instances of ffmpeg
[12:31:55 CEST] <f00bar80> DHE: it doesn't even start the dead process
[12:36:57 CEST] <f00bar80> DHE: Even this way http://vpaste.net/ABa8B , it's not starting the ffmpeg process
[12:38:38 CEST] <dystopia> im not a bash expert
[12:38:45 CEST] <dystopia> but wouldn't that script just run once
[12:38:57 CEST] <dystopia> and if ffmpeg was running, it would do nothing
[12:39:29 CEST] <dystopia> wouldnt you need to set the script looping, so it's always checking if the process id exists?
[12:40:33 CEST] <f00bar80> dystopia: that's what 'while !' should be doing
[12:41:04 CEST] <dystopia> ahh i see
[12:43:19 CEST] <DHE> f00bar80: well if you're monitoring ffmpeg synchronously, you're better off doing "while true; do ffmpeg $args ; sleep 1 ; done"
[12:43:26 CEST] <furq> http://vpaste.net/YNVzP
[12:43:28 CEST] <furq> what's wrong with this
[12:43:34 CEST] <furq> damn. beaten
[12:43:38 CEST] <DHE> yes that
[12:43:52 CEST] <DHE> furq: yes but yours looks nicer
[12:44:06 CEST] <furq> it could probably use `sleep 1` as well
[12:44:23 CEST] <DHE> and as a style thing, would putting `wait` at the bottom make sense so the script appears to take over the terminal?
[12:52:46 CEST] <f00bar80> furq: I'm getting error  1: not found
[12:53:08 CEST] <furq> change 1 to true
[12:55:37 CEST] <xxx_> I build ffmpeg from sources to use fdkaac for constant bitrate like described on https://trac.ffmpeg.org/wiki/Encode/AAC  but it still have vbr.
[12:55:37 CEST] <xxx_> How to force CBR? And what does it mean
[12:55:37 CEST] <xxx_> [adts @ 0x2e1f0e0] Using AVStream.codec to pass codec parameters to muxers is deprecated, use AVStream.codecpar instead.
[12:55:37 CEST] <xxx_> I can't google anything about ffmpeg codecpar?
[12:55:39 CEST] <xxx_> ~/bin/ffmpeg -hide_banner -analyzeduration 50000000 -probesize 50000000 -ss 0.025057 -i /home/xxx/demo_files/audio._kuznechik.mp3 -s 0 -t 0.967596 -ac 2 -c:a libfdk_aac -b:a 128k  -y /tmp/p0.aac && ~/bin/ffmpeg -i /tmp/p0.aac
[12:56:20 CEST] <xxx_> Input #0, aac, from '/tmp/p0.aac':
[12:56:20 CEST] <xxx_>   Duration: 00:00:01.34, bitrate: 99 kb/s
[12:56:20 CEST] <xxx_>     Stream #0:0: Audio: aac (LC), 44100 Hz, stereo, fltp, 99 kb/s
[13:01:12 CEST] <f00bar80> furq: should i use sleep 1 or not n why
[13:07:10 CEST] <f00bar80> furq: this is the script after i modified http://vpaste.net/WADJC it creates a file for every input , checking the audio and video streams, cause sometime one of them is dropped, so while sleep 5 could be using this much of memory , also this seems to be a nice way to accomplish what i mentioned ?
[13:08:36 CEST] <f00bar80> DHE: also what do you think .. ?
[13:29:55 CEST] <f00bar80> ppl any comment?
[14:31:32 CEST] <mr_lou> Is there any expert ffmpeg user online who's interested in putting one or more ffmpeg commands together for me? I need to create a CRT simulation of a retro-game recording. 9 steps in total, from scaling and applying multiply overlay glow blur, moving the picture and such. I can pay you 50 euro for the trouble. Thanks.
[15:19:14 CEST] <kepstin> mr_lou: i'm not interested in doing anything for you, but the code from the xscreensaver 'xanalogtv' hack might be a good start.
[15:35:46 CEST] <die_hoernse> Hi, BtbN.
[15:36:18 CEST] <die_hoernse> I promised yesterday that I would prepare and upload a sample.
[15:36:49 CEST] <pentanol> hi there
[15:37:34 CEST] <die_hoernse> unfortunately, qt-faststart detects a non-moov unknown toplevel atom at the end of my files.
[15:39:34 CEST] <die_hoernse> So I patched qt-faststart to actually use the "second to last) actual moov atom. This results in an invalid file. I have to stop doing this now for the weekend, but will definitely try further. The original file weighs over 14 GB, so sending it is a bit unhandy.
[15:40:40 CEST] <kepstin> die_hoernse: you might have better luck using ffmpeg in stream copy mode with the '-movflags faststart' option?
[15:41:18 CEST] <BtbN> die_hoernse, hm, weird.
[15:41:23 CEST] <BtbN> kepstin, that's not an option.
[15:41:35 CEST] <BtbN> The original mp4 file is damaged, ffmpeg can't propperly process it.
[15:43:20 CEST] <BtbN> die_hoernse, can't you just create a new sample? Record something for a few minutes with it?
[15:43:29 CEST] <BtbN> It should do the same weird stuff with its timestamps.
[15:44:28 CEST] <pentanol> how this make in one line? http://pastebin.com/0Xqzqiv7
[15:44:58 CEST] <mr_lou> kepstin, Thanks. But not quite what I'm after. :-)
[15:45:17 CEST] <pentanol> i.e. just frame=   89 fps=0.0 q=1.6 size=     938kB time=00:00:04.08 bitrate=1882.8kbits/
[15:46:22 CEST] <mr_lou> pentanol, You mean when it's running in the command prompt?
[15:46:25 CEST] <mr_lou> Oh...
[15:46:30 CEST] <mr_lou> Short patience.
[15:49:51 CEST] <pentanol> sorry, I been bisy, done it;)
[15:50:03 CEST] <die_hoernse> BtbN, in the meantime all capturing hardware is gone: VCR broke, camcorder was not able to record, Capture HArdware was sold.
[15:50:24 CEST] <die_hoernse> i am currently trying one last thing
[15:51:53 CEST] <furq> is there a command-line tool which can dump the chapter marker times from an ifo into some usable format
[15:57:05 CEST] <die_hoernse> BtbN: Ah, the file seemed to had 188 bytes garbage padding at the end that qt-faststart treated as additional atom.
[16:16:56 CEST] <die_hoernse> Ok, got the file down to 300 MB.
[16:19:09 CEST] <die_hoernse> Uploading... will take 2hrs if it is not canceled.
[17:17:27 CEST] <Mooniac> I'm using ffmepg on Linux (Fedora 23) to screenrecord. How can I pause the recording for a few seconds, and resume later? In many applications that's the space key, but that didn't work. I googled, and it said Ctrl Z, but that didn't work either. Thanks.
[17:19:56 CEST] <thebombzen> Mooniac: Ctrl+Z stops the process. that should work. and run "fg" to resume it
[17:20:10 CEST] <thebombzen> you could also just crop out the few seconds you don't like with ffmpeg right afterward.
[17:20:11 CEST] <Mooniac> I'll try ti again
[17:20:37 CEST] <thebombzen> fg stands for "foreground"
[17:20:45 CEST] <Mooniac> yes, I'm aware
[17:20:48 CEST] <thebombzen> ah okay
[17:21:04 CEST] <thebombzen> that makes it easier :D
[17:21:17 CEST] <Mooniac> it doesn't seem to pause
[17:21:30 CEST] <Mooniac>  it just continues, and I see the frame counter going up
[17:24:52 CEST] <thebombzen> huh
[17:24:57 CEST] <thebombzen> try stopping another process
[17:25:07 CEST] <thebombzen> like. "yes"
[17:25:23 CEST] <thebombzen> see if it's a problem with stopping the process
[17:26:02 CEST] <Mooniac> ah, I found it. I have to bring the mouse cursor back to the cmd window in which I launched the process. I had moved it to the screen in which I'm recording. But it needs to be back in the cmd window
[17:26:06 CEST] <Mooniac> all works, thanks
[17:26:35 CEST] <yagiza> Hello!
[17:27:17 CEST] <yagiza> I wrote some code for audio encode/decode, include RTP streaming/playing.
[17:27:41 CEST] <yagiza> It works with most of codecs, supported by FFMpeg.
[17:29:24 CEST] <yagiza> But when I try to use it with iLBC, it crashes in av_interleaved_write_frame().
[17:30:36 CEST] <yagiza> According to debugger it crashes not in one of FFMpeg libraries, but somewhere in libilbc.
[17:31:48 CEST] <yagiza> Who knows, what is so special in iLBC, which makes my universal code for encoding crash?
[17:32:31 CEST] <Mooniac> thebombzen: there is still a problem. That only stops the screenrecording, but it keeps recording my audio into the file. It does NOT stop the audio recording. Is there a way to do that? When I want some pause feature, I really mean to pause dumping ANYTHING into the file. There is no point in stopping the screenrecording when the audio recording continues.
[17:32:53 CEST] <thebombzen> Mooniac: how are you recording the audio?
[17:33:14 CEST] <Mooniac> fmpeg -video_size 1920x1080 -framerate 8 -f x11grab -i :0.0 -f pulse  -ac 2 -i default -c:v libx264 -qp 0 -preset ultrafast capture1.mkv
[17:33:31 CEST] <thebombzen> ah so you are using a pulse monitor.
[17:33:36 CEST] <Mooniac> I did these params by experiment. I'm not a pro
[17:33:45 CEST] <Mooniac> I think I could also use Alsa
[17:33:47 CEST] <thebombzen> that's weird. it should stop the process.
[17:33:51 CEST] <Mooniac> I want lossless and high res
[17:34:12 CEST] <thebombzen> Pulse is based on alsa so maybe try that? but I'm stumped why it would continue dumping to capture.mkv
[17:34:18 CEST] <Mooniac> some of these params may be wrong, I'm not proficient with ffmpeg
[17:34:33 CEST] <Mooniac> also tried capture.avi, some thing
[17:34:35 CEST] <Mooniac> same thing
[17:34:36 CEST] <thebombzen> you don't need -ac for the input
[17:34:47 CEST] <thebombzen> mkv is best for capturing. mkv is best for everything basically
[17:34:51 CEST] <thebombzen> btw, I'd recommend utvideo for screenrecording. fast losseless codec, not great compression ratio. designed for screen record.
[17:34:56 CEST] <thebombzen> supported by matroska.
[17:35:18 CEST] <Mooniac> OK, I'll try that.
[17:38:22 CEST] <Mooniac> how do I get/install that on Fedora?
[17:38:38 CEST] <Mooniac> utvideo is not a rpm package
[17:40:29 CEST] <Zeranoe> Does anyone have a 5th generation Intel CPU running Windows that they'd be willing to try a few FFmpeg commands for me? (fifth generation means the CPUs name is i#-5###)
[17:43:29 CEST] <JEEB> thebombzen: there's no mapping for ut video in matroska :P you can only write it in the AVI (VFW)-in-matroska mode, which is a generic compatibility hack made for VFW formats
[17:43:45 CEST] <thebombzen> ah
[17:43:53 CEST] <Mooniac> OK , anything I can do to stop the audio recording during pause?
[17:43:54 CEST] <thebombzen> why isn't there a warning when I try to do that, then?
[17:43:58 CEST] <thebombzen> JEEB:
[17:44:07 CEST] <JEEB> good question
[17:44:30 CEST] <JEEB> not sure how lavf would even write it there, but I guess it's in the VFW mode. if not, it's even more f'd up :D
[17:44:59 CEST] <thebombzen> what container is supposed to hold UT Video if not Matroska? I was under the impression that Matroska could basically hold anything
[17:45:38 CEST] <JEEB> well in that sense it can contain anything just as  mp4/ISOBMFF as long as someone defines the mapping for it
[17:45:52 CEST] <JEEB> there's the VFW mode which does enable a lot of stuff being hacked into it of course
[17:46:10 CEST] <JEEB> AVI and on OS X MOV is generally used for Ut Video, although I'm not sure if FFmpeg supports the latter mapping
[17:46:34 CEST] <JEEB> it's not like Ut Video requires b-pictures so AVI in general shouldn't be an issue
[17:54:26 CEST] <thebombzen> I use utvideo because afaik it's the best screenrecording codec. should there be problems with putting in in Matroska?
[17:55:13 CEST] <thebombzen> I mean, lavf/lavc can read the matroska file and decode it without problems, so I don't see why not, but that might be due to lack of strictness, which I don't want to rely on.
[17:55:54 CEST] <JEEB> I would expect only lavf to be able to demux those files but you can always remux to avi for editing apps on windows or whatever
[17:56:31 CEST] <JEEB> so while it's a (defined) hack, it should still work if it's the VFW mode. it's just that it's not a proper mapping for ut video @ matroska
[17:58:38 CEST] <thebombzen> that's fair. Honestly I only need lavf/lavc to be able to decode. because I primarily use Linux and most major websites like YouTube use lavf anyway
[17:59:07 CEST] <JEEB> yeah, as long as the lavf/lavc is new enough
[18:00:20 CEST] <BtbN> Zeranoe, my work Laptop is an i5-5200U running Windows 10, but I won't be at work until monday.
[18:06:38 CEST] <xxx_> i splited mp3 encode and then join and ffmpeg added some spaces, I drawed waveform http://i67.tinypic.com/2yl7evb.png  . I concat demuxed and other, problem still exists. I try to use filter_complex to cut empty, but it different for every part. /home/xxx/bin/ffmpeg -i /tmp/p0.ts -i /tmp/p1.ts -i /tmp/p2.ts -i /tmp/p3.ts -i /tmp/p4.ts -i /tmp/p5.ts -filter_complex [0:a]atrim=0,asetpts=PTS-STARTPTS[a0];[1:a]atrim=0,asetpts=PTS-STARTPTS[a1];[2:a]atrim=0,asetpts=PT
[18:06:39 CEST] <xxx_> S-STARTPTS[a2];[3:a]atrim=0,asetpts=PTS-STARTPTS[a3];[4:a]atrim=0,asetpts=PTS-STARTPTS[a4];[5:a]atrim=0,asetpts=PTS-STARTPTS[a5];[a0][a1][a2][a3][a4][a5] concat=n=6:v=0:a=1 [a] -map [a] -strict experimental -fflags +genpts -flags +global_header -c libfdk_aac -bsf:a aac_adtstoasc -y /tmp/res.m4a  Whyyyyyyy?)
[18:07:03 CEST] <Zeranoe> BtbN: I'll look for you here on Monday
[18:07:17 CEST] <BtbN> What do you want to test?
[18:08:10 CEST] <xxx_> to encode any part i use /home/xxx/bin/ffmpeg -analyzeduration 50000000 -probesize 50000000 -ss 1.018776 -i /home/xxx/demo_files/000.orig.5352357791787324393.short.mp3 -s 0 -t 0.900153 -async 1 -flags +global_header -af aresample=async=1:min_hard_comp=0.100000:first_pts=0 -c:a libfdk_aac -strict -2 -b:a 64k -ac 2 -ar 44100 -vn -f mpegts -y /tmp/p1.ts
[18:08:48 CEST] <xxx_> I got -ss and -t from ffprobe
[18:27:58 CEST] <Zeranoe> BtbN: MFX/QSV
[18:29:53 CEST] <Guest35> hi all, i have a question about the videotoolbox decoder: I've been trying for a couple of days now to properly initialize it, with no luck. It's crashing in ff_videotoolbox_avcc_extradata_create, because I don't have the priv_data member initialized
[18:30:40 CEST] <Guest35> who is supposed to initialize the priv_data stuff? it seems like I'm somehow supposed to parse the H264 stream before initializing videotoolbox, but how?
[18:32:34 CEST] <rkern> You can set the AVCodecContext.get_format function and init the hwaccel there. It will be called when the first frame is decoded.
[18:34:03 CEST] <Guest35> rkern: ahhh. so it's ok to call avcodec_open2 before i've initialized videotoolbox?
[18:34:15 CEST] <Guest35> i somehow thought it would get the process going with the wrong decoder
[18:34:20 CEST] <rkern> There's an example using another hwaccel in doc/examples/qsvdec.c
[18:34:38 CEST] <rkern> Yeah, you can open the codec first
[18:34:47 CEST] <Guest35> rkern: i will check it out, thank you!
[18:35:22 CEST] <Guest35> the API is really confusing for a newcomer. maybe once i get more comfortable with it i'll write a little tutorial
[18:35:26 CEST] <traveller_> Hi! May i ask what happened to ffvp9 from  Ronald Bultje?
[18:36:32 CEST] <c_14> traveller_: nothing?
[18:37:16 CEST] <traveller_> Is the codec usable? because ffmpeg -codec doenst list it. Just libvpx
[18:37:34 CEST] <BtbN> hm, die_hoernse left already. I think I might have a hack-fix for his problem.
[18:37:35 CEST] <c_14> ffvp9 is a decoder, not an encoder
[18:38:05 CEST] <c_14> He also wrote a vp9 encoder (called eve) but that's separate from FFmpeg
[18:38:32 CEST] <traveller_> Aww! Sucks!
[18:38:56 CEST] <traveller_> I read about eve .. seems proprietary though - and not ffmpeg associated as you mentioned.
[18:40:11 CEST] <bonzairob> Hi, I'm having a weird problem - i'm streaming from hdmi capture to twitch, but the framerate keeps going nuts and then buffering http://twitch.tv/bonzairob i'm not on a great computer, how can i mitigate it?
[18:41:28 CEST] <traveller_> which version of ffmpeg supports ffvp9? Seems like 2.8.6 doesn't yet. Do i need the dev version or is the actual version sufficient?
[18:42:29 CEST] <c_14> traveller_: 3.0 should be sufficient
[18:42:37 CEST] <c_14> The initial version of the decoder was added in 2013
[18:42:45 CEST] <c_14> anything branched after that point should have it
[18:45:01 CEST] <Guest35> rkern: and get_format should return AV_PIX_FMT_VIDEOTOOLBOX?
[18:45:43 CEST] <traveller_> i assume the codec string for ffvp9 is "vp9"? Because ffmpeg -codecs lists a "vp9" and a "libvpx-vp9" decoder.
[18:48:27 CEST] <traveller_> c_14: thx for helping out!
[18:48:55 CEST] <rkern> Guest35: yes. Do you need to filter/resize the video frames? If not, you can pass frames with the AV_PIX_FMT_VIDEOTOOLBOX format to the videotoolbox encoder.
[18:49:49 CEST] <Guest35> rkern: well i'm decoding not enoding, but for now i'm not doing any filtering or resizing
[18:50:19 CEST] <Guest35> rkern: now I'm getting a crash in av_buffer_get_ref_count because AVBufferRef is NULL
[18:52:32 CEST] <rkern> Can you post your get_format() code?
[18:53:20 CEST] <c_14> traveller_: yes
[18:54:19 CEST] <Guest35> rkern: http://pastebin.com/evs1utCM
[19:00:53 CEST] <rkern> Guest35: get the `h264_videotoolbox` hwaccel with av_hwaccel_next() and set it to AVCodecContext.hwaccel.
[19:05:35 CEST] <Guest35> thank you! still crashing but I'm suspecting it may have something to do with the pic I'm feeding it. I will keep at it.
[19:28:58 CEST] <yagiza> So, noone knows about my problem with iLBC codec?
[20:17:01 CEST] <poua> hello is there any other encoding channel beside this one on freenode?
[20:17:31 CEST] <poua> im looking for windows encoder that supports hardware amd VCE h264 encoding
[20:21:57 CEST] <Regda> poua: https://ffmpeg.org/ffmpeg-codecs.html#libx264_002c-libx264rgb
[20:22:23 CEST] <Regda> poua: x264 H.264/MPEG-4 AVC encoder wrapper.does not helping ?
[20:22:51 CEST] <poua> dont know havent tried
[20:24:22 CEST] <Regda> poua: https://ffmpeg.org/ffmpeg-codecs.html#libopenh264
[20:25:12 CEST] <Regda> poua: seems to be this both encoder wrapper are the only which are based on h.264
[20:38:45 CEST] <poua> alright thanks
[20:44:04 CEST] <yagiza> \
[22:18:06 CEST] <nick0> so I'm trying to decode some audio files and resample them for later reencoding to opus. However, I can't seem to get all the data (I think I should be getting..) when decoding. This is the smallest example I could come up with that represents how my code looks like: https://gist.github.com/anonymous/7c37991634ca3138d8e89a6417d838ee What am I doing
[22:18:06 CEST] <nick0>  wrong? Thanks
[00:00:00 CEST] --- Sun Jun 19 2016

More information about the Ffmpeg-devel-irc mailing list