[Ffmpeg-devel-irc] ffmpeg.log.20160624

burek burek021 at gmail.com
Sat Jun 25 02:05:01 CEST 2016

[00:00:51 CEST] <c_14> works fine here
[00:03:42 CEST] <MoSal> c_14: It works fine here too. But the output is noisy and using loglevel explicitly is not making it quiet.
[00:04:20 CEST] <c_14> What I meant, was that setting the loglevel to quiet was working correctly
[00:04:27 CEST] <c_14> as in, no output
[00:04:36 CEST] <c_14> No console output
[00:05:23 CEST] <MoSal> c_14: Is that on latest master?
[00:06:14 CEST] <c_14> master as of 2 days ago
[00:06:32 CEST] <c_14> I can build from current HEAD if you think it's more recent
[00:07:11 CEST] <MoSal> c_14: no need I think. my build is from 6 days ago ;)
[02:28:08 CEST] <CFS-MP3> This theoretically simple command
[02:28:09 CEST] <CFS-MP3> ffmpeg -i udp://  http://localhost:8090/feed1.ffm
[02:28:26 CEST] <CFS-MP3> (just following ffserver's example but with a UDP feed)
[02:28:28 CEST] <CFS-MP3> causes this error:
[02:28:46 CEST] <CFS-MP3> Stream mapping:
[02:28:47 CEST] <CFS-MP3>   Stream #0:1 -> #0:0 (mp2 (native) -> mp2 (native))
[02:28:47 CEST] <CFS-MP3>   Stream #0:0 -> #0:1 (mpeg2video (native) -> mpeg1video (native))
[02:28:47 CEST] <CFS-MP3>   Stream #0:1 -> #0:2 (mp2 (native) -> wmav2 (native))
[02:28:47 CEST] <CFS-MP3>   Stream #0:0 -> #0:3 (mpeg2video (native) -> msmpeg4v3 (msmpeg4))
[02:28:47 CEST] <CFS-MP3> Error while opening encoder for output stream #0:1 - maybe incorrect parameters such as bit_rate, rate, width or height
[02:29:14 CEST] <CFS-MP3> And I'm at a loss here since I don't know what's causing it... the input stream is just a regular TS, nothing fancy
[02:33:17 CEST] <c_14> That's not the real error, the actual error is usually somewhere above that.
[02:33:24 CEST] <c_14> Also, problems with ffserver are meh
[02:33:59 CEST] <c_14> (nobody here really knows how to fix them and it's not very well supported)
[02:35:32 CEST] <CFS-MP3> c_14 I also have this: [mpeg1video @ 0x4292b80] MPEG-1/2 does not support 3/1 fps
[02:35:46 CEST] <CFS-MP3> no idea where it's getting that fps from
[02:35:51 CEST] <CFS-MP3> not the stream for sure
[02:42:01 CEST] <CFS-MP3> OK it comes from the sample config file for ffserver
[02:42:26 CEST] <CFS-MP3> c_14 so what do you suggest if I need to have a server from which wowza can fetch a stream?
[02:42:44 CEST] <c_14> what protocol?
[02:46:35 CEST] <CFS-MP3> rstp would probably be best, but whatever wowza supports... apparently wowza has to come fetch the stream, I cannot push it from ffmpeg which would be a lot more convenient
[02:47:18 CEST] <c_14> there's stuff like nginx-rtmp, or maybe hls or something
[02:47:36 CEST] <furq> nginx-rtmp is good but you'd need to reencode to h.264/aac
[02:47:39 CEST] <furq> which i assume you don't want
[02:49:30 CEST] <CFS-MP3> If at all possible I'd rather not reencode of course
[02:49:37 CEST] <CFS-MP3> but for now I need to demo that works
[02:50:23 CEST] <furq> if you're reencoding then you might as well just push to wowza over rtmp anyway
[03:04:18 CEST] <CFS-MP3> furq I'm being asked for a URL they can enter in wowza's config so wowza gets the stream instead of my ffmpeg connecting to wowza. Don't know if this is a limitation of wowza or just smoething that the admin has decided.
[03:06:28 CEST] <DHE> I'd consult the wowza documentation to see what it supports. can it accept the multicast feed straight up? (I was under the impression it could)
[05:20:54 CEST] <ramapunk> hi
[05:21:00 CEST] <ramapunk> someone speak spanish?
[05:21:38 CEST] <ramapunk> estoy a punto de suicidarme con el cable de un teclado
[05:23:17 CEST] <ramapunk> im getting a lot of random errors restreaming from ffserver to ffmpeg
[05:26:17 CEST] <ramapunk> [h264 @ 0x8d87a0] cabac decode of qscale diff failed at 29 7 [h264 @ 0x8d87a0] error while decoding MB 29 7, bytestream 1056 [h264 @ 0x8d87a0] concealing 320 DC, 320 AC, 320 MV errors in P frame
[05:29:58 CEST] <ramapunk> i am geting dvb-t signals from dvblast and trascoding with ffmpeg in ffserver in flv h264. Then, from other box, i connect to this streams and convert to hls. if i do all the process locally all is ok, but from the other box i get that kind of errors.  I think is a buffer thing but i tried everythig without success to get stability
[05:31:17 CEST] <ramapunk> other random error i get [h264 @ 0xc828e0] concealing 380 DC, 380 AC, 380 MV errors in P frame
[05:32:11 CEST] <ramapunk> and get an freeze ffmpeg too, process still working but no frame count.
[06:12:40 CEST] <snakeryslug> trying to find in 'man ffplay' how to 'ffplay silence for x time units'. I'm trying to have a sound play every X seconds.
[10:18:07 CEST] <xfceone> converted a video with avconv and the video is overturned ?
[11:59:43 CEST] <viric> Hello ffmpeg
[12:00:01 CEST] <viric> I can see the original date/time of a MTS stream with 'exiftool', but not with ffprobe -show_format
[12:02:16 CEST] <viric> so "-map_metadata 0" is not helping me keeping the original date/time
[12:17:46 CEST] <cowai> When I use -c copy -vtag dvsd on a DV type 1 file to convert it to a Microsoft DV type 2 file. I loose the scan type flag.
[12:17:54 CEST] <cowai> How can I fix that?
[12:20:38 CEST] <cowai> mediainfo reports "Scan Type: Interlaced" on the original file, and "Scan Type: Progressive" on the output file.
[12:21:22 CEST] <cowai> $ ffmpeg -i /host/media/v/Temp/file.dv -c copy -vtag dvsd -aspect 16:9  -y file.avi
[12:32:55 CEST] <pZombie> http://forum.videohelp.com/threads/356455-FFmpeg-and-mpeg2-interlaced-encoding this might help
[12:35:01 CEST] <cowai> -flags +ilme -top 0 does not help I afraid.
[12:35:07 CEST] <cowai> I think this is a metadata problem
[12:39:22 CEST] <pZombie> are you sure the input is actually interlaced?
[12:39:35 CEST] <pZombie> just because mediainfo says so, does not guarantee it
[12:41:04 CEST] <cowai> the original file is produced with -target -pal-dv
[12:41:13 CEST] <cowai> from a 720p50 prores file
[12:41:32 CEST] <cowai> mediainfo reports the scan type being interlaced on the type 1 dv file
[12:41:45 CEST] <cowai> but not when changed container to a type 2 dv file.
[12:46:54 CEST] <pZombie> does the output quality look bad ?
[12:49:25 CEST] <cowai> I can see it is interlaced, if that is what you are asking
[12:49:49 CEST] <cowai> i am trying to create a type 2 dv avi file which can be played in a weird playout
[12:50:20 CEST] <cowai> i have a sample file that works. so I am trying to have all fields match with mediainfo.
[12:50:33 CEST] <cowai> the dv files from ffmpeg does not work atm.
[12:53:50 CEST] <pZombie> cowai http://www.hardwareheaven.com/community/threads/encoding-an-interlaced-source-into-an-interlaced-x264-format.218040/   this part "I had to fix the input source conversion to state true for interlaced... and then set the output -tff to specify that the output format is top feild first interlaced. "
[12:54:09 CEST] <pZombie> does not look like x264 supports it fully
[12:55:07 CEST] <cowai> I am creating x264
[12:55:14 CEST] <cowai> *not
[12:57:07 CEST] <cowai> I am simply changing container for a type1 dv file into type2.
[12:57:16 CEST] <cowai> the codec is dv
[13:19:42 CEST] <pZombie> cowai which OS are you using?
[13:25:15 CEST] <pZombie> you might want to try one of those tools listed here http://www.videohelp.com/software/Canopus-DV-File-Converter and see if mediainfo labels the output as interlaced, then compared quality. those are for windows however. Should work in linux under wine as well
[13:34:17 CEST] <cowai> pZombie: ubuntu 16.04
[13:34:37 CEST] <cowai> I see that old versions of mediainfo reports it as being interlaced, but not newer ones
[13:34:39 CEST] <pZombie> i have a dv file i will tell enosoft dv processor on
[13:34:52 CEST] <pZombie> tell = use
[13:35:18 CEST] <pZombie> unfortunately mediainfo does not tell me much about it
[13:35:38 CEST] <cowai> pZombie: Do you know if ffmpeg can produce a opendml avi 2.0 file?
[13:35:57 CEST] <pZombie> no clue, sorry
[13:36:50 CEST] <cowai> http://ffmpeg.gusari.org/viewtopic.php?f=11&t=1723
[13:36:50 CEST] <cowai> Here is a guy wanting the opposite.
[13:38:45 CEST] <pZombie> this stupid program let me load the dv file, specify type 2 dv avi as output, but does nothing... so much for this
[13:39:46 CEST] <cowai> ...
[13:40:23 CEST] <pZombie> probably does not like win10
[13:42:36 CEST] <cowai> http://ffmpeg-users.933282.n4.nabble.com/ffmpeg-and-AVI-2-0-td938231.html
[15:59:55 CEST] <m3gab0y> ffmpeg and 512 kbps hard limit bad 3g network..... any suggestions on getting the best possible quality out of this?
[16:31:25 CEST] <ChocolateArmpits> m3gab0y: Is the input stream local ?
[17:01:30 CEST] <kepstin> m3gab0y: are you sending or receiving media over that connection?
[17:02:13 CEST] <kepstin> for sending, it's basically down to "use the most efficient codecs you can, with vbv settings as appropriate"
[17:09:50 CEST] <m3gab0y> kepstin it's about sending (source is interlaced content)
[17:11:53 CEST] <kepstin> right, so deinterlace it, downscale it, compress with a modern codec like h264 (x264), hevc (x265), maybe vp9, use vbv (bufsize, max bitrate) settings, use an efficient audio codec (probably opus is best).
[17:29:44 CEST] <delicado> hi guys, I'm updating my karaoke background video player that uses old ffmpeg version, Now i'm down to these last code that uses AVStream::codec to get the AVCodecContext.. But it's labeled as deprecated and says "use the codepar struct instead".. But when I looked at the codepar member (AVCodecParameters*) it doesn't have a AVCodecContext* in it, so I tried to allocate a context with
[17:29:45 CEST] <delicado> avcodec_alloc_context3() but I get a segfault. So what's the new way to get the AVCodecContext*?
[17:30:09 CEST] <delicado> *codecpar*
[17:39:58 CEST] <m3gab0y> kepstin i've done something on this with some filters but the quality is not OK for me as of yet, I want to do it better
[17:40:45 CEST] <compost> Does anyone have any experience with using force_style for subtitles?
[17:41:48 CEST] <kepstin> 512kbps is way to low to get anything "good", particularly if there's lots of motion, but you can probably pull off "acceptable" at lower-than-sd resolutions.
[17:45:29 CEST] <m3gab0y> i want to get near this: http://www.progettosinergia.com/flashvideo/super-250.mp4
[17:49:49 CEST] <kepstin> m3gab0y: well, that's a fairly low motion video, and it's pretty full of obvious h264 compression artifacts.
[17:51:04 CEST] <m3gab0y> i will be very happy if i can achieve similar quality- it's more than enough for low-end class TV on a very limited connection (512 kbps)
[17:51:10 CEST] <kepstin> i don't know how to check, but they might be using an unconstrained vbr mode there, which wouldn't work over a limited connection like 512kbit. And it's obviously a 2-pass encode, which you can't do live.
[17:51:41 CEST] <kepstin> so depending what exactly your source is, you can maybe do it, maybe not.
[17:52:20 CEST] <m3gab0y> source is fullHD 20-35 mbps interlaced directly from an SPI port
[17:52:49 CEST] <kepstin> live source? not pre-recorded?
[17:52:55 CEST] <m3gab0y> yes, live
[17:53:09 CEST] <kepstin> because you can do a *lot* better quality with 2-pass on non-live material
[17:53:49 CEST] <m3gab0y> AFAIK HLS should help me on this as it splits the video on chunks
[17:55:17 CEST] <furq> this is using 16 refs, so if it is x264 i assume it's -preset veryslow
[17:55:29 CEST] <furq> and it's almost certainly 2-pass
[17:55:51 CEST] <kepstin> but yeah, you're probably going to want to deinterlace it and downscale it, probably to around 360p, figure out your overheads, audio bitrate, expected buffering time and set '-b:v', '-maxrate', and 'bufsize' as appropriate, get a fast cpu (for 360p more cores isn't super helpful), encode with the slowest x264 settings you can tolerate
[17:55:58 CEST] <kepstin> and then it'll still kinda suck
[17:57:15 CEST] <m3gab0y> -codec:v libx264 -profile:v high -preset veryslow  -g 250  -vf "scale=400:320,hqdn3d=4:4:6:8,pp7=2:1,hue=h=0:s=0.6" is as best as I can get and not even near this quality
[17:57:25 CEST] <furq> yeah this video is almost all static shots and almost 10% of it is just a black screen
[17:57:31 CEST] <furq> and it still doesn't look great
[17:57:38 CEST] <furq> more than 10%, in fact
[17:58:34 CEST] <furq> m3gab0y: what audio bitrate are you using
[17:59:09 CEST] <m3gab0y> he-aac v2 at 32 kbps
[17:59:38 CEST] <m3gab0y> that's the sweetspot for ffmpeg, 24 is way too bad for TV
[17:59:52 CEST] <kepstin> using fdk_aac, I assume
[18:00:04 CEST] <kepstin> that's probably as low as you can go with pretty much any codec, yeah
[18:00:57 CEST] <m3gab0y> -c:a libfdk_aac -profile:a aac_he -b:a 32k -f mpegts ...
[18:00:59 CEST] <furq> there's not really any magical settings that you're missing out on
[18:01:24 CEST] <furq> some sources just aren't that compressible
[18:01:36 CEST] <m3gab0y> err -c:a libfdk_aac -profile:a aac_he -b:a 32k
[18:02:27 CEST] <furq> why 400x320 though, that's not a standard aspect ratio
[18:03:01 CEST] <m3gab0y> going any higher gets the picture screwed....
[18:03:09 CEST] <furq> i mean why not 400*304
[18:03:11 CEST] <m3gab0y> and lower makes things blurry
[18:03:30 CEST] <furq> or 400*224 for widescreen
[18:03:44 CEST] <m3gab0y> 400*224 is completely unwatchable
[18:04:17 CEST] <m3gab0y> 400*300 (302,304, and so on until 320) is also very bad
[18:04:21 CEST] <m3gab0y> and muddy
[18:52:07 CEST] <blue_misfit> hello! I want to extract the first 6 channels of this audio track: Stream #0:1[0x3ea]: Audio: s302m (BSSD / 0x44535342), 48000 Hz, 8 channels (FL+FR+FC+LFE+BL+BR+DL+DR), s16, 7680 kb/s
[18:52:27 CEST] <blue_misfit> what's the proper syntax to do this?
[18:59:34 CEST] <EvanR> hey everybody rkern fixed a nasty bug which stopped avfoundation capture from working on OSX macbooks!
[19:01:02 CEST] <rkern> haha, one number is off and the output is all scrambled
[19:01:35 CEST] <EvanR> i was expecting the patch to be like "n" -> "n-1"
[00:00:00 CEST] --- Sat Jun 25 2016

More information about the Ffmpeg-devel-irc mailing list