[Ffmpeg-devel-irc] ffmpeg.log.20160628

burek burek021 at gmail.com
Wed Jun 29 02:05:01 CEST 2016

[00:56:18 CEST] <blue_misfit> hey guys - I'm dealing with handling input files with a single video track and 7-8 audio tracks
[00:56:52 CEST] <blue_misfit> sometimes the video is on track 0 and audio is on 1-7 or 1-8. Sometimes the video is on track 7 or 8 and the audio is on 1-6 or 1-7
[00:57:23 CEST] <blue_misfit> I need to grab one specific track. can I tell ffmpeg "Grab audio track 7"
[00:57:30 CEST] <blue_misfit> regardless of the position of the video track?
[00:57:54 CEST] <furq> -map 0:a:6
[00:58:36 CEST] <blue_misfit> got it
[00:58:37 CEST] <blue_misfit> thank you so much
[00:59:55 CEST] <blue_misfit> works perfectly :D
[01:12:50 CEST] <hyponic> I am willing to pay to whoever can make FFMPEG change teletext subtitles to dvbsubtitles while transcoding a live stream.
[03:29:23 CEST] <Bray90820> Can someone tell me what these errors mean?
[03:29:23 CEST] <Bray90820> http://pastebin.com/raw/mjBFuX7A
[03:29:56 CEST] <c_14> ffmpeg doesn't like your input
[03:30:15 CEST] <c_14> Do you have some sort of video player that plays the file?
[03:30:21 CEST] <Bray90820> Yes but why?
[03:30:24 CEST] <c_14> If yes, it's a bug in FFmpeg. If no, the file is broken.
[03:30:32 CEST] <c_14> What player?
[03:30:42 CEST] <Bray90820> VLC plays it just fine
[03:30:54 CEST] <c_14> then it might be a regression or fixed in a newer version
[03:31:05 CEST] <Bray90820> And all the other MKV files from that disc work just fine with ffmpeg
[03:31:20 CEST] <c_14> oh
[03:31:23 CEST] <c_14> wait
[03:31:27 CEST] <c_14> I see what happened
[03:31:47 CEST] <c_14> Did you run that command before?
[03:31:59 CEST] <Bray90820> On other files yes
[03:32:06 CEST] <c_14> on that file?
[03:32:06 CEST] <Bray90820> I have converted many other files
[03:32:14 CEST] <Bray90820> I have not ran it on that file
[03:32:20 CEST] <c_14> Because that will overwrite that file breaking it
[03:32:29 CEST] <kepstin> Bray90820: your input and output filenames are the same in that command, you overwrote the file as it was being read.
[03:33:11 CEST] <c_14> kepstin: it should have prompted whether to overwrite or not
[03:33:15 CEST] <Bray90820> Well there we go that was dumb
[03:33:27 CEST] <Bray90820> Why didn't it prompt me tho?
[03:33:45 CEST] <c_14> If he ran it before and said y it would be broken. Otherwise it should still be fine. he didn't use -y
[03:34:00 CEST] <c_14> Bray90820: can you still play that file with vlc?
[03:34:02 CEST] <kepstin> well, it didn't prompt this time because it failed to open the input, and didn't even get around to starting output
[03:34:21 CEST] <c_14> which is why I asked if he'd run it before. But he said he hadn't
[03:34:29 CEST] <Bray90820> I can play the MKV version from pre conversion but the MP4 file was not playable
[03:34:45 CEST] <c_14> then you probably overwrote the mp4
[03:34:48 CEST] <Bray90820> I am currently reconverting the MKV file to see if it was a typo that I made
[03:34:50 CEST] <c_14> If you still have the mkv restart from that
[03:35:46 CEST] <Bray90820> Yep currently doing so
[03:37:47 CEST] <Bray90820> I am also getting another error with a few other files
[03:37:48 CEST] <Bray90820> http://pastebin.com/raw/t0PakWhz
[03:38:11 CEST] <c_14> The Past duration thing?
[03:38:18 CEST] <c_14> that's not an error
[03:38:19 CEST] <c_14> just ignore it
[03:38:33 CEST] <c_14> ah, no
[03:38:37 CEST] <c_14> codec frame size not set
[03:38:50 CEST] <Bray90820> What should I do?
[03:39:09 CEST] <c_14> No clue, it doesn't look fatal so you can probably ignore it.
[03:39:27 CEST] <Bray90820> I'll try to ignore it and see what happens
[03:40:23 CEST] <Bray90820> Even tho it is happening every few seconds on that file
[03:58:03 CEST] <Bray90820> Yea I reconverted the file and now it's playable
[04:40:02 CEST] <sseann> Does anyone know if I can use the prebuilt binary 'arm64/testing(stretch)' on a raspbian jessie system?
[04:40:32 CEST] <furq> is it an rpi 3
[04:40:39 CEST] <sseann> 1 modelb+
[04:40:44 CEST] <furq> no, then
[04:40:58 CEST] <sseann> do I have to compile it myself in this case?
[04:41:08 CEST] <furq> the pi 1 is armv6, which isn't covered by any debian packages
[04:41:30 CEST] <sseann> thank you furq
[04:42:28 CEST] <furq> i imagine there's a raspbian-compatible repo with ffmpeg somewhere
[04:42:46 CEST] <furq> i only have an rpi2 though so i just run debian armhf on it
[04:44:24 CEST] <sseann> furq: is armhf (ARMv7) similar to arm64?
[04:44:37 CEST] <furq> arm64/aarch64 is armv8
[04:44:40 CEST] <furq> armv7 is 32-bit
[05:58:52 CEST] <Bray90820> Uh explain this one to me frame=87880 fps= 75 q=29.0 size=  381382kB time=00:48:52.28 bitrate=1065.5kbits/
[05:58:59 CEST] <Bray90820> the video is less than 42 minutes long
[06:05:54 CEST] <c_14> same command as earlier?
[06:32:49 CEST] <Bray90820> c_14: Different video file but yes "ffmpeg -i "The Long Long Trailer.VOB" -c:a copy "The Long Long Trailer.mp4"
[06:33:57 CEST] <c_14> maybe the timestamps are funky?
[06:34:11 CEST] <Bray90820> Is there a way to check the time stamp
[06:34:46 CEST] <Bray90820> *timestamp
[06:35:06 CEST] <c_14> ffprobe -show_entries packet=pts_time should do it I think
[06:36:30 CEST] <Bray90820> Put the video file after that command?
[06:36:39 CEST] <c_14> ye
[06:36:46 CEST] <Bray90820> Lets find out
[06:39:54 CEST] <Bray90820> c_14: http://pastebin.com/raw/HeF6QXAv
[06:43:52 CEST] <c_14> eh, you'll probably have to add -count_frames
[06:45:33 CEST] <Bray90820> Will that give the time or the amount of frames
[06:45:57 CEST] <c_14> that's mainly just to make ffprobe read the whole file
[06:46:00 CEST] <c_14> It usually only reads part of it
[06:46:38 CEST] <Bray90820> ffprobe -show_entries packet=pts_time -count_frames "video.VOB"
[06:46:42 CEST] <Bray90820> Like that?
[06:48:28 CEST] <c_14> yeah, though it looks like it should do it correctly without that as well (on the video I'm testing on though)
[06:48:36 CEST] <c_14> ah, I think your paste might have gotten cut off
[06:48:46 CEST] <c_14> The last packet in your paste doesn't have the closing element
[06:48:53 CEST] <c_14> Which is why it only goes to 33 minutes
[06:49:00 CEST] <Bray90820> Yes the paste was cut off I didn't wanna take the time to copy it all
[06:49:39 CEST] <c_14> you just need the last part
[06:50:10 CEST] <Bray90820> Is the command suppose to stop on it's own or do I need to manually stop it?
[06:50:19 CEST] <c_14> That'll give you the last pts which should be (pretty close) to the duration
[06:50:23 CEST] <c_14> It stops on its own
[06:50:26 CEST] <Bray90820> Ok
[06:50:35 CEST] <Bray90820> So what command should I run?
[06:51:29 CEST] <c_14> ffprobe -show_entries packet=pts_time,duration_time -select_streams v file
[06:51:46 CEST] <c_14> that will also give you the duration of the last frame and make it so it only outputs for the video frames
[06:57:32 CEST] <Bray90820> c_14: Uh the paste is to big for pastbin
[06:57:41 CEST] <c_14> just look at the last few lines
[06:59:36 CEST] <Bray90820> c_14: http://pastebin.com/raw/mjTCiwCN
[07:01:57 CEST] <c_14> So the last frame with a timestamp is at 41 minutes, but there's a bunch of frames without timestamps, though those might be the dvd_nav_packets (not sure if those count as a video stream)
[07:02:22 CEST] <c_14> It might be because of those that the time= is off?
[07:02:36 CEST] <Bray90820> maybe e idk but the video file is 41:43
[07:03:54 CEST] <Bray90820> Is it not possible to copy it correctly?
[07:07:12 CEST] <c_14> Is the output video actually longer than it should be or is ffmpeg just reporting the wrong time?
[07:09:04 CEST] <Bray90820> It is longer
[07:10:02 CEST] <c_14> hmm
[07:10:06 CEST] <c_14> sounds like it's probably a bug
[07:12:53 CEST] <Bray90820> It might me a really screwed up VOB file actually because I put in the DVD and the DVD is longer than 41:43
[07:16:52 CEST] <Bray90820> I am gonna just say the VOB is f***ed because the MP4 is the length of the DVD
[09:21:07 CEST] <vandemar> does 10 bit instead of 8 bit encoding (8-bit source) compress noticeably in x265 like it does with x264?  A test suggests it doesn't (10bit x265 got larger), but is it supposed to?
[09:23:43 CEST] <u0083> ffmpeg -i 264.mp4 -c:a copy -c:s copy -c:v libx265 -preset veryslow -x265-params lossless=1 265.mp4
[09:24:35 CEST] <u0083> i used these params to convert h.264 file to h.265 and supposed output file will smaller than input file
[09:25:14 CEST] <u0083> but output file is bigger. of: 1.2G if:600M
[09:25:40 CEST] <u0083> anything wrong with my params?
[09:25:46 CEST] <vandemar> because you're telling it to encode losslessly. you almost never want to do that.
[09:26:29 CEST] <u0083> @vandemar you mean if my input file is not lossless file i shouldn't use `lossless=1`?
[09:26:53 CEST] <vandemar> doesn't matter what your input is, if you encode losslessly expect very high bitrate
[09:28:20 CEST] <u0083> @vandemar if i try to keep same quality with input file, is there a common params i can use or i have to adjust params due to different input file?
[09:29:09 CEST] <vandemar> what do you mean "same quality"?  same *visual* quality, approxmimately?  I don't know what the standard is for x265.  For x264 it's roughly crf=18, so for x265, somewhere between 18 and 23?
[09:31:52 CEST] <u0083> @vandemar approximate visual quality. so I think I should use crf to control output.
[09:32:18 CEST] <u0083> ffmpeg -i 264.mp4 -c:a copy -c:s copy -c:v libx265 -preset veryslow -x265-params crf=22 265.mp4
[09:32:56 CEST] <u0083> maybe like this, I will have a test. If I am wrong, please let me know
[09:35:21 CEST] <vandemar> is the 264.mp4 the original?  Encode from the original if possible, not from the x264 encoding
[09:37:50 CEST] <u0083> @vandemar i don't have original file. why i do this is try to keep approximate visual quality and save the storage.
[11:36:56 CEST] <yagiza> Hello!
[11:37:57 CEST] <yagiza> I have some strange problem with g.722 encoding.
[11:38:28 CEST] <yagiza> Using FFMpeg libraries for RTP streaming.
[11:41:00 CEST] <yagiza> When g.726 encoding is used, no matter which bitrate I specify, it always writes G722-0 in SDP.
[11:41:55 CEST] <yagiza> Instead of writing G726-32 for 32000bps or G726-40 for 40000bps.
[11:42:21 CEST] <yagiza> When using ffmpeg.exe it's all right.
[11:43:23 CEST] <yagiza> I experience problem only when encoding and streaming, using my code.
[11:44:21 CEST] <yagiza> I specify bitrate by setting AVCodecContext::bit_rate field.
[11:44:32 CEST] <yagiza> What am I doing wrong.
[11:44:39 CEST] <yagiza> ?
[11:45:24 CEST] <yagiza> Everywhere, where I wrote "g.722" or "G722" read "g.726/G726"
[12:00:56 CEST] <c_14> Can you check what bits_per_coded_sample is set to on the AVCodecContext?
[12:04:44 CEST] <c_14> It should always clip to at least 2 though
[12:04:47 CEST] <c_14> hmm
[12:06:17 CEST] <c_14> btw, what version of ffmpeg is this with?
[12:09:50 CEST] <c_14> If it's post codecpar (which I believe landed in 3.1) it could be because sdp.c uses codecpar but you're not setting the bitrate there
[12:10:23 CEST] <yagiza> c_14, which call should set bits_per_coded_sample field?
[12:10:45 CEST] <c_14> The g726 init function handles that
[12:11:13 CEST] <yagiza> c_14, yes, I found that already. But when init function of a codec is called?
[12:13:38 CEST] <yagiza> c_14, I need it initialized before actual encoding started. 'Cause I use av_sdp_create() to pre-calculate RTP payload types.
[12:17:16 CEST] <c_14> It should be initialized after open2
[12:17:21 CEST] <c_14> avcodec_open2
[12:19:02 CEST] <yagiza> c_14, but I don't use that call.
[12:19:38 CEST] <c_14> You're using something that calls avctx->codec->init
[12:20:08 CEST] <yagiza> c_14, is it avformat_new_stream()?
[12:24:20 CEST] <c_14> nah, should be after that
[12:40:40 CEST] <yagiza> c_14, hmmm... don't see.
[13:11:58 CEST] <Joshua__> Hello. Someone what to exaplain how to convert only the audio track of a video? I want the audio to be ac3
[13:14:28 CEST] <Joshua1> This is the audio:
[13:14:29 CEST] <Joshua1> Stream #0:1(ger): Audio: dts (DTS-HD MA), 96000 Hz, 7.1, s32p (24 bit)
[13:32:17 CEST] <c_14> Joshua1: ffmpeg -i video -c:v copy -c:a ac3 out.mkv
[14:14:44 CEST] <cowai_> anyone know why the scan order attribute is changed on a AVI DV file by simply doing ffmpeg -i dvfile.avi -c copy dvfile2.avi ?
[14:15:10 CEST] <cowai_> mediainfo reports the scan type to be interlaced on dvfile.avi, but progressive on dvfile2.avi
[14:15:51 CEST] <cowai_> if I take dvfile2.avi into avidemux and simply save it again (without reencoding) it is reported to be interlaced in mediainfo again.
[14:15:59 CEST] <cowai_> so there is something ffmpeg does that removes it.
[14:17:31 CEST] <cowai_> I have tried both ffmbc and ffmpeg 2.8/3.0
[16:17:49 CEST] <Conder_> hello, parameters -vcodec and -c:v are the same?
[16:27:08 CEST] <cowai_> Conder_: yes
[17:15:22 CEST] <matwey> Hello. I have to inputs: x11grab video and audio receiving from rtp. I would like the audio and the video be put into the single output stream (say theora or x264). I would like to implement the following rule for syncronisation. Video always goes at the constant framerate, if there is no audio (rtp connection is broken, for instance) then the silence should be encoded instead. Could you please point me which audio/video filter shoul
[18:44:17 CEST] <ChocolateArmpits> I have a UDP input and sometimes it stops and then continues after a few seconds. Is there a way to output black frames instead of outputting nothing during those moments ?
[18:58:28 CEST] <Conder> hello, with what x265 CRF i should reencode MPEG-4 visual (xvid) video for no visual quality lossless?
[19:01:03 CEST] <Conder> *no loss of visual quality :D
[19:01:22 CEST] <__jack__> Conder: try 20-23 or something
[19:03:47 CEST] <Conder> ty
[19:10:50 CEST] <soulshock> is it possible to tell ffmpeg to read all necessary input data from the source file into memory, before starting transcoding? I want to run multiple instances of ffmpeg on the same file and I want to prevent a lot of seeking in the source file
[19:12:01 CEST] <DHE> that's what your OS cache is for
[19:12:26 CEST] <DHE> it's better served anyway since they can share it rather than all munching up your RAM in several copies of ffmpeg
[19:12:42 CEST] <furq> why not run one ffmpeg instance with multiple outputs
[19:12:46 CEST] <DHE> also there is a third option. it may be possbile to make ffmpeg
[19:12:48 CEST] <DHE> do exactly that
[19:12:51 CEST] <furq> hi
[19:13:59 CEST] <soulshock> because I'm trying to make ffmpeg run in parallel to use 20-50 instances at the same time and thus speed up overall transcoding time
[19:14:16 CEST] <soulshock> each encoding part of the video and then stitching it together after
[19:14:48 CEST] <furq> are you using a codec that can't use multiple threads or something
[19:15:11 CEST] <soulshock> no it's for x264. but the idea is that 50 machines can transcode 1 hour a lot faster than 1 machine can transcode 1 hour
[19:16:13 CEST] <soulshock> this would be for a system for a broadcast company, so we have a lot of transcoding every day. between 100 and 200 hours of source material a day
[19:16:29 CEST] <furq> if you're splitting it across machines then what's the point of caching the input file
[19:17:14 CEST] <soulshock> each machine would cache it so the source disk doesn't have to perform excessive seeking
[19:17:28 CEST] <soulshock> or rather, would cache the part they need. say they would cache 1 minute of the source
[19:19:03 CEST] <DHE> 100 and 200 files a day? why not just run each file on a distinct system?
[19:20:26 CEST] <soulshock> because this would provide us with the option to scale: add more ffmpeg instances = faster throughput
[19:20:58 CEST] <soulshock> faster throughput for the same amount of material
[19:22:32 CEST] <furq> well i don't really have a better solution than copying the source onto a tmpfs
[19:22:49 CEST] <furq> i hope your storage box has plenty of ram
[19:23:39 CEST] <soulshock> heh yeah we discussed storing in memory. though sometimes the source material is 50gb
[19:23:47 CEST] <soulshock> it's XDCAM HD 422 at 60 mbit/s
[19:24:03 CEST] <furq> copying chunks to a tmpfs on the encoding system is probably a better idea
[19:26:33 CEST] <soulshock> I though about that. you mean "ffmpeg -i source.mxf -c copy -t 60 chunk.mxf" e.g.?
[19:27:20 CEST] <furq> -i foo -c copy -t 60 -ss 60 -t 120
[19:27:21 CEST] <furq> etc
[19:27:34 CEST] <furq> i'm not sure if that would be frame accurate though
[19:28:34 CEST] <furq> er
[19:28:39 CEST] <furq> -i foo -c copy -t 60 -c copy -ss 60 -t 120
[19:29:14 CEST] <soulshock> yeah
[19:30:28 CEST] <soulshock> that's worth a shot. should allow the storage to be able to perform adequately
[19:32:07 CEST] <soulshock> cheers
[19:44:53 CEST] <TenLeftFingers> I'm trying to set up a live stream to DailyMotion with the command (testing with an mp4 for now, but need a webcam eventually): ffmpeg -i ~/ana-pasg.mp4 -vf -re -acodec copy -ar 22050 -vcodec h264 -f flv rtmp://publish.dailymotion.com/publish-dm
[19:45:15 CEST] <TenLeftFingers> but get the error "RTMP_ReadPacket, failed to read RTMP packet header"
[19:46:54 CEST] <Chocola4> TenLeftFingers: first your -vf command is empty, second -re is an input option, not an output
[19:47:29 CEST] <Chocola4> Also there is no "h264" encoder, you probably meant x264
[19:51:31 CEST] <ChocolateArmpits> the error probably happens because the way you formatted your output ffmpeg thinks it's input
[20:04:21 CEST] <TenLeftFingers> ChocolateArmpits: thanks, I'll go back through the man page.
[20:05:11 CEST] <ChocolateArmpits> TenLeftFingers: I think you can fix your command like this fmpeg -re -i ~/ana-pasg.mp4 -acodec aac -ar 22050 -vcodec x264 -f flv rtmp://publish.dailymotion.com/publish-dm
[20:05:31 CEST] <ChocolateArmpits> also you can't resample audio without transcoding it
[20:06:00 CEST] <ChocolateArmpits> hmmm x264 supposed to be libx264
[20:06:08 CEST] <ChocolateArmpits> excuse me
[20:06:46 CEST] <TenLeftFingers> Yeah, it seems this command isn't a good base to start from.
[20:06:58 CEST] <TenLeftFingers> Even changing those still gives errors
[20:08:09 CEST] <ChocolateArmpits> any in particular?
[20:13:26 CEST] <TenLeftFingers> Unable to find a suitable output format for '22050'
[20:13:26 CEST] <TenLeftFingers> 22050: Invalid argument
[20:13:38 CEST] <TenLeftFingers> Unable to find a suitable output format for '22050'
[20:13:54 CEST] <ChocolateArmpits> Can you paste your command line ?
[20:13:59 CEST] <TenLeftFingers> sure
[20:14:15 CEST] <TenLeftFingers> ffmpeg -i ~/ana-pasg.mp4 -vf -ar 22050 -vcodec libx264 -f flv rtmp://publish.dailymotion.com/publish-dm
[20:14:26 CEST] <ChocolateArmpits> you need to remove -vf
[20:14:38 CEST] <ChocolateArmpits> -vf is meant for video filters, but you don't specify any
[20:14:47 CEST] <ChocolateArmpits> after it
[20:15:08 CEST] <ChocolateArmpits> so ffmpeg ends up thinking that -ar is the argument to -vf and 22050 is the output
[20:15:12 CEST] <TenLeftFingers> Okay, so removing -vf I see: RTMP_ReadPacket, failed to read RTMP packet header
[20:15:13 CEST] <TenLeftFingers> rtmp://publish.dailymotion.com/publish-dm: Unknown error occurred
[20:15:45 CEST] <ChocolateArmpits> I'm pretty sure it needs a key of sorts
[20:16:14 CEST] <ChocolateArmpits> did you use it in your command?
[20:16:28 CEST] <TenLeftFingers> There is a "Stream Name" ascii string provided by DailyMotion - that could be it. I was wondering what it's role was.
[20:16:58 CEST] <kepstin> in most cases, you just add it as a filename on the end of the rtmp url
[20:17:03 CEST] <ChocolateArmpits> that looks like one https://dailymotionpartners.zendesk.com/hc/fr/article_attachments/200456612/Image2.jpg
[20:17:12 CEST] <ChocolateArmpits> just don't share it as it's your personal key lol
[20:17:19 CEST] <TenLeftFingers> :) thanks
[20:17:24 CEST] <TenLeftFingers> Ill try taht
[20:17:25 CEST] <TenLeftFingers> *that
[20:17:36 CEST] <ChocolateArmpits> just add a slash after the link
[20:17:41 CEST] <ChocolateArmpits> and before the key
[20:18:00 CEST] <TenLeftFingers> yep
[20:18:35 CEST] <TenLeftFingers> Great, I'm getting 'proper' output on the terminal :)
[20:19:01 CEST] <ChocolateArmpits> cheers, you can continue configuring it then to tune the quality
[20:19:42 CEST] <TenLeftFingers> And I see the output on DailyMotion! Amazing, thank you so much :) Can I just swap the mp4 for /dev/video0 to get the webcam?
[20:21:34 CEST] <ChocolateArmpits> Don't have much idea about that, sorry
[20:22:03 CEST] <TenLeftFingers> Yes, it is that simple!
[20:22:48 CEST] <shincodex> someone write a better article of compiling this garbage poopsicle for windows
[20:22:52 CEST] <shincodex> than on the wiki
[20:22:58 CEST] <shincodex> im bleeding my eyeballs out making it work
[20:23:11 CEST] <shincodex> ffmpegw32exit
[20:52:26 CEST] <_MyStartx_> guys exist a version of ffmpeg for android?
[20:57:55 CEST] <kepstin> _MyStartx_: ffmpeg should compile just fine for android, I'd expect there's many android apps using the libraries.
[21:00:04 CEST] <_MyStartx_> portable version of ffmoeg should wotk on routed sndroid?
[21:00:33 CEST] <furq> if you mean http://johnvansickle.com/ffmpeg/ then no
[21:00:35 CEST] <furq> it depends on glibc
[21:04:19 CEST] <_MyStartx_> yes ....I understand. .that's it
[21:29:20 CEST] <Spring> each binary of ffmpeg has to be manually compiled doesn't it?
[21:29:40 CEST] <Spring> in order to update it that is
[21:34:42 CEST] <DHE> well, there's no official binary builds. but linux distros and 3rd parties offer them
[21:38:50 CEST] <shincodex> I think i did it
[21:38:55 CEST] <shincodex> i gained 8 billion xp points
[21:39:00 CEST] <shincodex> using mingw
[21:39:11 CEST] <shincodex> now to sell guides
[21:39:19 CEST] <shincodex> hue hue hue hue
[21:57:56 CEST] <shincodex> i compile all of them at once with ffmpeg make file as statics
[21:58:11 CEST] <shincodex> then compile them as one dll to rule them all with a class to control the nonsense
[21:58:52 CEST] <shincodex> Windows - Make operating systems great again.
[21:59:14 CEST] <furq> he seems nice
[22:10:02 CEST] <jancoow> Hay there; I'm just asking a general question. I also talked to someone here a while ago, but have some other questions. I'm working on a surveilance system in my house. Because of my home automatic system there is already 1 raspberry pi in each room. What i want to achieve is to connect a (cheap) usb webcam to each raspberry. Each raspberry has to do live transcoding to a file mp4 or avi file format or something. Then i want to stream / save this v
[22:10:26 CEST] <furq> jancoow: that cut off after "save this v"
[22:10:43 CEST] <jancoow> the reason i wanna use the raspberry pi gpu is to pull of some load from the fileserver because it gonna be 10 - 20 video streams. If it has to be streamed raw over ethernet and live decoded on the server on the same time it asks some bandwith and gpu power
[22:10:54 CEST] <jancoow> oh damn..
[22:11:28 CEST] <jancoow> I'm sorry but i gonna repeat the question (please don't mark this as spam) :)
[22:11:34 CEST] <jancoow> Hay there; I'm just asking a general question. I also talked to someone here a while ago, but have some other questions. I'm working on a surveilance system in my house. Because of my home automatic system there is already 1 raspberry pi in each room. What i want to achieve is to connect a (cheap) usb webcam to each raspberry. Each raspberry has to do live transcoding to a file mp4 or avi file format or something.
[22:11:38 CEST] <jancoow> Then i want to stream / save this video on my local fileserver (so a general file stream over samba for example). Eventually i want to stream to my browser, but that will be handled on the server. What do you guys think? Is this possible? Is it possible to use the raspberry pi gpu to do the live encoding?
[22:11:59 CEST] <furq> the rpi has an onboard h.264 encoder, but it's not particularly great, and ffmpeg can't use it
[22:12:22 CEST] <furq> although iirc there's some popular webcam capture tool for the rpi which will just output h.264
[22:13:05 CEST] <jancoow> okay mm i though ffmpeg could use it. Do you know which tool can use it?
[22:13:25 CEST] <jancoow> does this mean that the cpu of the raspberry pi stays quite low on usage?
[22:13:34 CEST] <furq> raspivid
[22:13:36 CEST] <jancoow> And do you maybe know if the webcam matters? ;p
[22:13:38 CEST] <furq> and yeah it's a hardware encoder
[22:14:18 CEST] <furq> last time someone asked this i think my suggestion was raspivid piped to ffmpeg streaming to nginx-rtmp on the main server
[22:15:26 CEST] <jancoow> then it was probably me you was talking with :)
[22:15:34 CEST] <jancoow> because someone here suggested me to use nginx-rtmp
[22:16:00 CEST] <jancoow> a little bit my bad that i didn't save the chat log proparly; did a reinstall of my system so log files where lost :/
[22:17:03 CEST] <jancoow> furq: so you suggest to use ffmpeg to stream towards nginx-rtmp? Why do you prefer this instead of a samba share or something (so a normal file stream)
[22:17:43 CEST] <furq> you mentioned streaming it to a browser
[22:18:29 CEST] <jancoow> that's true!. But i also want to save video logs for a week or so
[22:18:42 CEST] <furq> you can do that with nginx-rtmp
[22:18:56 CEST] <jancoow> that's cool!
[22:19:11 CEST] <furq> https://github.com/arut/nginx-rtmp-module/wiki/Directives#record
[22:19:20 CEST] <jancoow> i was just looking at that :)
[22:19:34 CEST] <jancoow> well i will first start with raspivid, check if that works
[23:04:43 CEST] <jancoow> furq: uhwm,,, i've been trying but after asking in #raspberrypi they say raspivid is only for raspicamera
[23:04:47 CEST] <jancoow> not for usb camera's
[23:49:43 CEST] <Sashmo_> does anyone have experiance with selecting programs from a multi program source via UDP?  If I make the signal a single program, there is no errors, but if I take the multiple program feed, I get constant errors in the output, can anyone point out what I might be doing wrong? http://pastebin.com/BwvAGBfq
[23:50:14 CEST] <Sashmo_> lots of h264 decoder errors, but the same signal as a spts has no problem, its only when its a mpts I get issues
[23:51:19 CEST] <sangy> Hi, does anyone know if ffmpeg has rtmp(e) support already?
[23:51:33 CEST] <jancoow> i'm currently working on rtmp
[23:51:35 CEST] <furq> yes it does
[23:51:37 CEST] <jancoow> and it does
[23:51:39 CEST] <jancoow> ^
[23:51:40 CEST] <jancoow> :)
[23:51:48 CEST] <furq> it's had it through librtmp for ages but it has native support now
[23:52:12 CEST] <sangy> nice!
[23:52:46 CEST] <sangy> so, does it take any special flags upon ./configure to enable rtmp? or will it figure things out by itself?
[23:52:58 CEST] <furq> it's enabled automatically
[23:53:06 CEST] <furq> you need one of gcrypt, gmp or gnutls for rtmpe support
[23:53:51 CEST] <furq> er, gcrypt or gmp
[23:54:13 CEST] <sangy> nice! Thanks!
[23:54:24 CEST] <sangy> (and thanks for the awesome work in ffmpeg :) )
[00:00:00 CEST] --- Wed Jun 29 2016

More information about the Ffmpeg-devel-irc mailing list