[Ffmpeg-devel-irc] ffmpeg.log.20160629

burek burek021 at gmail.com
Thu Jun 30 02:05:01 CEST 2016

[00:31:27 CEST] <jancoow> furq: do you know how to eventually stream a rtmp over http?
[00:34:10 CEST] <furq> https://github.com/arut/nginx-rtmp-module/wiki/Directives#hls
[00:35:06 CEST] <furq> hls isn't much good for security camera footage though because it has high latency
[00:37:06 CEST] <jancoow> on what latency are we talking about
[00:37:56 CEST] <furq> it depends on the video gop size
[00:38:03 CEST] <furq> at least several seconds though
[00:38:54 CEST] <furq> you could probably get it below five seconds if this is on a lan
[00:39:03 CEST] <jancoow> that's fine!
[00:39:13 CEST] <jancoow> 5-10 secons is fine
[00:39:53 CEST] <jancoow> what does hls_fragment mean?
[00:40:09 CEST] <jancoow> sample time or something?
[00:41:07 CEST] <furq> right
[00:41:27 CEST] <furq> that has to be a multiple of the video gop size, though (or else it'll just be ignored)
[00:41:32 CEST] <furq> segments have to start on an idr frame
[00:42:02 CEST] <jancoow> 5 seconds should be fine then i think; then would the latency be around 5-10 seconds i guess?
[00:42:21 CEST] <furq> probably more like 10-20
[00:42:43 CEST] <furq> you should be able to use very short gops (1-2 seconds) on a lan
[00:43:13 CEST] <furq> hls latency is at least one full segment, but in practice more like 2-3 segments
[00:45:12 CEST] <jancoow> i will try some different values! :)
[00:45:22 CEST] <jancoow> do you suggest writing to ram?
[00:46:22 CEST] <furq> i can't say i've tried it
[00:46:25 CEST] <furq> it couldn't hurt though
[00:46:45 CEST] <jancoow> writing to /tmp is on ram so
[00:46:51 CEST] <furq> yeah i just realised that i do in fact do that
[00:46:56 CEST] <furq> and that this vps does have a tmpfs on /tmp
[00:47:14 CEST] <jancoow> cool!
[00:47:28 CEST] <furq> i probably shouldn't do that considering this vps only has 256mb
[00:48:13 CEST] <jancoow> lololo
[00:48:16 CEST] <jancoow> that isn't much
[00:48:38 CEST] <furq> it's enough for an irc client and a quakeworld server
[00:52:12 CEST] <jancoow> if it sufficiente the needs its fine
[00:52:38 CEST] <tmm1> is there a way to copy side data (like A53_CC) when transcoding mpeg2 -> h264
[00:53:37 CEST] <jancoow> only getting forbidden 403 everytime when going to host/hsl
[00:53:42 CEST] <jancoow> :/
[01:00:19 CEST] <jancoow> any idea why furq ?
[01:00:24 CEST] <jancoow> has to be something with permissions
[01:02:00 CEST] <c_14> tmm1: libx264 has an a53cc option. -a53cc 1
[01:19:02 CEST] <jancoow> furq: any idea if it's possible to do a http live stream?
[01:19:14 CEST] <jancoow> within the browser
[01:19:20 CEST] <jancoow> because that would be awesome :D
[01:23:45 CEST] <furq> not with nginx-rtmp
[01:23:54 CEST] <furq> http streaming is flaky and unreliable anyway
[01:24:03 CEST] <furq> your best bet is probably to just use flash
[01:24:34 CEST] <jancoow> would be funny to just display slow 1fps vids on my home automatic website
[01:45:55 CEST] <DelphiWorld> sup everyone
[01:46:05 CEST] <DelphiWorld> anyone using FFMpeg with quickSync?
[01:46:59 CEST] <jancoow> well many many thanks furq for helping me
[01:47:08 CEST] <jancoow> i think i can make this perfect for me :)
[01:47:15 CEST] <jancoow> gn everyone
[01:51:57 CEST] Action: DelphiWorld need FFMpeg with quicksync but zeroSucsess...
[01:53:12 CEST] <kepstin> with intel's hardware encoder? I've gotten that working on linux with ffmpeg 3.1 and the vaapi driver
[01:53:42 CEST] <DelphiWorld> kepstin: should you help me please ?
[01:53:58 CEST] Action: DelphiWorld started to fetch ffmpeg's DEPS in ubuntu 16.04
[01:56:15 CEST] <DelphiWorld> kepstin: could you give me the FFMpeg source git repo?
[01:56:27 CEST] <kepstin> DelphiWorld: ...
[01:56:48 CEST] <kepstin> it's linked right on the downloads page.
[01:59:50 CEST] <DelphiWorld> Kei_N: do i need intel dev studio or media studio or something?
[02:00:00 CEST] <kepstin> when you're installing the deps on ubuntu, make sure you get the 'intel-vaapi-driver' and 'libva-dev' packages, then it's just a matter of building ffmpeg; I think i'll autodetect, but you can use --enable-vaapi
[02:03:24 CEST] <DelphiWorld> kepstin, intel-vaapi-driver not found
[02:04:12 CEST] <DelphiWorld> i could see i965-va-driver
[02:05:57 CEST] <kepstin> oh, yeah, that's the right one
[02:06:03 CEST] <DelphiWorld> :-P
[02:06:38 CEST] Action: DelphiWorld would give kepstin a iceCream if he get the qsv codec to work... ;)
[02:08:02 CEST] <DelphiWorld> restarting my pc...
[02:15:48 CEST] <thebombzen> does anyone here know how to probe the duration of a GIF image correctly?
[02:16:13 CEST] <thebombzen> setting -probesize and -analyzeduration each to 2147483647 didn't work
[02:17:48 CEST] <DelphiWorld> kepstin, surprisingly i965-va-driver was allready there ;)
[02:18:19 CEST] <thebombzen> I was unable to probe with either ffmepg -i or with ffprobe -show_streams
[02:18:32 CEST] <thebombzen> it just says duration N/A no matter what
[02:18:36 CEST] <kepstin> DelphiWorld: as far as actually using the thing, the libav docs are the best reference atm: https://wiki.libav.org/Hardware/vaapi
[02:18:56 CEST] <DelphiWorld> kepstin, should i need libmfx?
[02:19:01 CEST] <kepstin> DelphiWorld: nope
[02:19:08 CEST] <DelphiWorld> strange.
[02:19:20 CEST] <DelphiWorld> official ffmpeg hw encoding saying libmfx is required
[02:28:59 CEST] <kepstin> the current version of ffmpeg has two different ways to encode using the intel qsv. One is via libmfx, and it's a pain to set up, the other is with vaapi, which is a fair bit easier imo
[02:29:26 CEST] <kepstin> all the stuff for the vaapi encoder is readily available in linux distros
[02:29:38 CEST] <DelphiWorld> kepstin: but it's a bit complex to use
[02:29:44 CEST] <DelphiWorld> upload & download ... complicated
[02:29:57 CEST] <DelphiWorld> why i dont just use the "h264_qsv" encoder?
[02:30:33 CEST] <kepstin> well, i can't help you with that :) it needs you to install that intel media sdk thing manually, and I've never gotten it to work.
[02:30:58 CEST] Action: DelphiWorld hope the FFMpeg dev make it easyer ...
[02:31:02 CEST] <DelphiWorld> i realy hope to get it to work
[02:31:32 CEST] <c_14> Well, you have to patch the kernel
[02:31:35 CEST] <c_14> so...
[02:31:40 CEST] <c_14> (last time I checked)
[02:31:45 CEST] <kepstin> for vaapi? you don't
[02:31:46 CEST] <DelphiWorld> c_14: so kernel patch required ?
[02:31:52 CEST] <kepstin> dunno about the intel media sdk stuff.
[02:31:53 CEST] <c_14> for qsv
[02:32:06 CEST] <DelphiWorld> c_14: give any instruction ?
[02:32:15 CEST] <c_14> Never gotten it to work either.
[02:32:24 CEST] <DelphiWorld> sadly
[02:32:54 CEST] <DelphiWorld> c_14: https://github.com/lu-zero/mfx_dispatch
[02:33:18 CEST] <c_14> That'll let you build it
[02:33:21 CEST] <c_14> Never got it working though
[02:33:26 CEST] <kepstin> Of course, even though I've gotten vaapi to work, I haven't really had any use for it; the encoder is fast, but so is libx264...
[02:33:28 CEST] <c_14> Well, I got it to build.
[02:33:50 CEST] <kepstin> if you're encoding videos and your cpu is busy doing something else it might be worthwhile
[02:33:58 CEST] <DelphiWorld> but qsv should be faster, and LESS CPU usage no?
[02:34:10 CEST] <kepstin> qsv and vaapi use the same hardware encoder chip
[02:34:15 CEST] <kepstin> they should be pretty comparable
[02:34:22 CEST] <vandemar> isn't qsv dependent on proprietary intel libs?
[02:34:28 CEST] <DelphiWorld> kepstin: the vaapi usage is a bit complex
[02:34:34 CEST] <kepstin> DelphiWorld: not really...
[02:34:52 CEST] <kepstin> and if you're doing it regularly you're probably using a script anyways :/
[02:35:06 CEST] <DelphiWorld> :P
[02:37:14 CEST] Action: DelphiWorld is building
[02:40:43 CEST] <DelphiWorld> autoreconfing libmfx
[03:51:20 CEST] <DelphiWorld> yo
[03:51:26 CEST] <DelphiWorld> c_14, see this issue: https://trac.ffmpeg.org/ticket/4831
[03:51:31 CEST] <DelphiWorld> not fixed i think
[04:23:02 CEST] <thebombzen> I think my question got drowned out by another conversation so I'll ask again just to be safe:
[04:23:15 CEST] <thebombzen> I cannot find the duration of GIF file with ffprobe or ffmpeg -i. the duration is "N/A"
[04:23:34 CEST] <thebombzen> setting -analyzeduration and -probesize to 2^31-1 didn't help. Any suggestions?
[04:24:19 CEST] <thebombzen> (that is, for some reason the duration is still N/A when I use ffmpeg -probesize 2147483647 -analyzeduration 2147483647 -i input.gif
[04:25:43 CEST] <pzich> do you need to do it with ffmpeg? it looks like `identify` from imagemagick or `exiftool` can do it: http://www.imagemagick.org/discourse-server/viewtopic.php?t=23276#p97676
[05:45:47 CEST] <thebombzen> pzich: well I'm writing a program that's supposed to analyze a generic video file with ffprobe -show_streams
[05:46:03 CEST] <thebombzen> I want it to work if I give it an animate GIF in addition to say, an mkv
[05:46:42 CEST] <c_14> thebombzen: you can check packet=pts_time,duration_time then grab the last packet outputted
[05:46:55 CEST] <c_14> add duration_time to pts_time and you'll have the duration of the video
[05:48:56 CEST] <thebombzen> c_14: you're going to have to elaborate on that one. I don't see duration_time or pts_time in either -show_streams or -show_format
[05:49:43 CEST] <c_14> I think it's show_packets? Just use -show_entries packet=pts_time,duration_time
[05:49:50 CEST] <c_14> that way you don't also dump all the other info
[05:52:24 CEST] <thebombzen> c_14: thanks, that seems to do the trick
[05:53:07 CEST] <thebombzen> however c_14 it appears to be somewhat inefficient for a long video
[05:53:28 CEST] <thebombzen> as in a regular video file. as in it spits out a LOT of packets. is there a way to make it faster?
[05:53:41 CEST] <c_14> sure, it'll have to decode the whole video
[05:54:38 CEST] <c_14> If you know about how long the video is at least, you can use read_intervals to skip decoding part of it
[05:54:40 CEST] <c_14> but that's about it
[05:58:11 CEST] <thebombzen> I think I'm going to use a two-step thing
[05:58:14 CEST] <thebombzen> first it'll check format.duration
[05:58:25 CEST] <thebombzen> with -show_format. and then it'll check -show_packets only if that fails.
[05:58:30 CEST] <kepstin> thebombzen: keep in mind that gif files often (usually) loop, and thus have infinite duration :)
[05:58:39 CEST] <thebombzen> no they don't
[05:58:47 CEST] <kepstin> I suppose you could use '-ignore_loop 1'
[05:58:56 CEST] <kepstin> (demuxer option on the gif demuxer)
[05:59:07 CEST] <kepstin> oh, actually, that's on by default
[05:59:08 CEST] <kepstin> nvm
[05:59:19 CEST] <thebombzen> you can loop a gif with -loop -1 in ffplay
[05:59:32 CEST] <thebombzen> or with --loop-file=inf
[05:59:34 CEST] <thebombzen> in mpv
[08:31:49 CEST] <cowai_> Is there a way I can make this into only one command? I am trying to make type 2 DV in AVI. "ffmpeg -i input-target pal-dv -filter:v "setfield=1, fieldorder=bff" -aspect 16:9 -y /host/media/v/dvtest.dv && ffmpeg -i /host/media/v/dvtest.dv -c copy -tag:v dvsd -y /host/media/v/dvtest.avi"
[08:40:40 CEST] <relaxed> you're transcoding dv to dv?
[08:43:51 CEST] <relaxed> why is this needed?
[08:58:57 CEST] <cowai_> because there is something called type 1 DV and type 2
[08:59:09 CEST] <cowai_> there is no transcoding though, only -c copy
[08:59:30 CEST] <cowai_> simply adding -tag:v dvsd to the first command doesnt help.
[09:00:16 CEST] <cowai_> ffmpeg does not make a compliant DV AVI file if I simply have an avi extension and add the "dvsd" tag.
[09:00:50 CEST] <cowai_> notes on the problem here: http://en.flossmanuals.net/open-video-workbook/hands-on-transcoding-files-with-ffmpeg/
[09:01:06 CEST] <relaxed> hmm, I think the use of -filter:v means there's transcoding going on.
[09:05:02 CEST] <relaxed> try this for a 10 second sample output, ffmpeg -i input -t 10 -c copy -flags +ildct+ilme -top 0 output.avi
[09:05:20 CEST] <relaxed> (add your -tag:v)
[09:09:41 CEST] <cowai_> ah, the first commands input is not dv
[09:09:50 CEST] <cowai_> that is a decklink card.
[09:12:50 CEST] <relaxed> ffmpeg -i input -target pal-dv -filter:v "setfield=1, fieldorder=bff" -aspect 16:9 -tag:v dvsd output.avi
[09:15:46 CEST] <hero100> how to probe max_bit_rate of video stream in mov container with ffprobe?
[09:16:19 CEST] <relaxed> -target might try to force the output format to dv, if that's the case add "-f avi" before the output
[09:32:48 CEST] <cowai_> relaxed: if I force avi with "-f avi" the settings from -target is destroyed
[09:33:02 CEST] <cowai_> it then tried to have default codec for avi
[09:33:11 CEST] <cowai_> mp3 lame and mpeg4
[09:33:55 CEST] <relaxed> can I see a pastebin.com of the command and console output?
[09:34:35 CEST] <cowai_> hold on, I trying without -f avi
[09:35:06 CEST] <cowai_> I am producing dv for a weird playout, so even when everything looks ok in mediainfo/gspot, it doesnt work.
[09:37:11 CEST] <cowai_> relaxed: the files that is produced with "ffmpeg -i input -target pal-dv -filter:v "setfield=1, fieldorder=bff" -aspect 16:9 -tag:v dvsd output.avi"
[09:37:11 CEST] <cowai_> cannot be opened in avidemux.
[09:38:34 CEST] <cowai_> But if I use "ffmpeg -i output.avi -c copy output_fixed.avi", avidemux opens them immediatly
[09:39:33 CEST] <cowai_> there is lots of notes on the web on how to make ffmpeg produce dv avi files, and all of consists of using -c copy a second time.
[09:39:36 CEST] <cowai_> No idea why.
[09:46:36 CEST] <relaxed> try this,  ffmpeg -i decklink-input -t 10 -filter:v "scale=720:576, setdar=dar=16/9, setfield=1, fieldorder=bff" -r 25 -c:v dvvideo -c:a pcm_s16le -tag:v dvsd output.avi
[09:49:26 CEST] <cowai_> This command doesnt give the commercial name of "dvcpro"
[09:49:39 CEST] <cowai_> which the sample file I have here, has.
[09:50:08 CEST] <cowai_> But I will send it that as well to the mcr.
[09:50:12 CEST] <cowai_> Thanks
[09:51:00 CEST] <cowai_> hold on, it gives me a file with 4 tracks.
[09:51:12 CEST] <cowai_>  Stream #0:1 -> #0:0 (rawvideo (native) -> dvvideo (native))
[09:51:12 CEST] <cowai_>   Stream #0:0 -> #0:1 (pcm_s16le (native) -> pcm_s16le (native))
[09:51:12 CEST] <cowai_>   Stream #0:1 -> #1:0 (rawvideo (native) -> mpeg4 (native))
[09:51:12 CEST] <cowai_>   Stream #0:0 -> #1:1 (pcm_s16le (native) -> mp3 (libmp3lame))
[09:52:47 CEST] <BtbN> that looks like you have two outputs.
[09:53:17 CEST] <cowai_> I dont
[09:53:42 CEST] <cowai_> "-t 30 -pix_fmt yuv420p -s 720x576 -c:v dvvideo -c:a pcm_s16le -filter:v "tinterlace=5:1, fieldorder=bff" -aspect 16:9 -tag:v dvsd" this gives me only two tracks
[09:54:35 CEST] <BtbN> Well, you have #0 and #1 there. That usually means you have two outputs.
[09:54:37 CEST] <cowai_> but doesnt entirely match the attributes in mediainfo like target pal-dv and a second command to copy it to avi.
[09:55:16 CEST] <cowai_> nput #0, decklink, from 'DeckLink Mini Recorder at 13':
[09:55:16 CEST] <cowai_>   Duration: N/A, start: 0.000000, bitrate: 1536 kb/s
[09:55:16 CEST] <cowai_>     Stream #0:0: Audio: pcm_s16le, 48000 Hz, 2 channels, s16, 1536 kb/s
[09:55:16 CEST] <cowai_>     Stream #0:1: Video: rawvideo (UYVY / 0x59565955), uyvy422, 1280x720, -8 kb/s, 50 tbr, 1000k tbn, 50 tbc
[09:56:02 CEST] <BtbN> That's the Input stream. Also, don't flood the channel with pastes, use a pastebin.
[09:57:54 CEST] <cowai_> ah,
[09:58:08 CEST] <cowai_> I actually had two outputs, silly me.
[09:58:23 CEST] <cowai_> yes I will use pastebin next time, sorry
[09:59:09 CEST] <relaxed> the fourcc for dvcpro is "dvpp"
[09:59:32 CEST] <relaxed> so use -tag:v dvpp
[10:00:52 CEST] <cowai_> dvpp is only for hd as I recall
[10:01:48 CEST] <cowai_> it says its incompatible with the codec
[10:02:40 CEST] <relaxed> ok
[10:04:22 CEST] <relaxed> you're right, it's dvsd
[10:05:21 CEST] <cowai_> I sent 10 dv files produced by ffmpeg with different options to the playout guys and only the one where I used -c copy a second time worked.
[10:38:21 CEST] <relaxed> cowai_: can you pastebin the output from "ffmpeg -i input.avi" on a file that works?
[10:47:47 CEST] <cowai_> relaxed: http://pastebin.com/wLdvbZ6z , there is nothing special here. Lots of files have exactly the same info but does not work in the playout in question.
[10:51:20 CEST] <relaxed> well, the 4/3 DAR is different
[10:55:28 CEST] <MadWasp> How can i check if the video index is at the start or the end of my mp4 file? Id like to see if the videos i encoded are streamable
[10:58:43 CEST] <cowai_> yes
[10:59:40 CEST] <cowai_> I have two files that works. one 16/9 DAR and one wrongly tagged as 4/3 which actually is 16/9.
[10:59:50 CEST] <cowai_> So it shouldnt matter.
[12:39:44 CEST] <Schwarzbaer> Hi. Is there a way to change the filter graph without restarting ffmpeg / ffserver?
[12:42:49 CEST] <Schwarzbaer> An application that'd come to mind would be a mosaic mixer that changes the mosaic pattern each time an input connects.
[13:00:54 CEST] <BtbN> no
[13:01:13 CEST] <BtbN> you can send commands to filters, but changing the entire graph is not supported
[13:40:20 CEST] <jancoow> furq: mm.. i just think nginx-rtmp is not the best solution
[13:48:29 CEST] <BtbN> There aren't a lot of alternatives available to it.
[13:48:34 CEST] <BtbN> And it works quite well.
[13:49:50 CEST] <jancoow> i was looking at zoneminder now
[13:50:42 CEST] <BtbN> That looks like something entirely diffrent.
[13:50:55 CEST] <jancoow> is it?
[13:51:12 CEST] <BtbN> That's some surverilance software from the looks of their website.
[13:51:27 CEST] <jancoow> and where was i looking for? :)
[13:51:49 CEST] <BtbN> No idea, you only talked about nginx-rtmp without any context.
[13:52:13 CEST] <jancoow> was talking to furq expeccialy becuase i talked to him yesterday about it, but i repeat my question:
[13:52:32 CEST] <jancoow> Hay there; I'm just asking a general question. I also talked to someone here a while ago, but have some other questions. I'm working on a surveilance system in my house. Because of my home automatic system there is already 1 raspberry pi in each room. What i want to achieve is to connect a (cheap) usb webcam to each raspberry. Each raspberry has to do live transcoding to a file mp4 or avi file format or something.
[13:52:34 CEST] <jancoow> Then i want to stream / save this video on my local fileserver (so a general file stream over samba for example). Eventually i want to stream to my browser, but that will be handled on the server. What do you guys think? Is this possible? Is it possible to use the raspberry pi gpu to do the live encoding?
[14:25:10 CEST] <jancoow> silence <.<
[14:25:24 CEST] <ChocolateArmpits> Wel lthat depends if the gpu has a hardware encoder
[14:25:35 CEST] <ChocolateArmpits> and not just decoder
[14:26:14 CEST] <jancoow> well in the mean time i figured out that it has one, but only works with the raspicam
[14:27:49 CEST] <jancoow> just looking for a good server side solution
[14:27:53 CEST] <jancoow> with http stream
[14:31:16 CEST] <Fyr> can FFMPEG mux H265 into MP4 container?
[14:33:16 CEST] <ChocolateArmpits> Fyr: yes
[14:50:42 CEST] <Fyr> ChocolateArmpits, can FFMPEG mux SRT subtitles into MP4 container?
[14:52:45 CEST] <JEEB> it can convert them to the format of timed text that ISOBMFF can handle, yes
[14:52:54 CEST] <JEEB> I think it's called mov_timed_text or whatever
[14:53:20 CEST] <Fyr> mp4 supports 3GPP timed text and MPEG4 timed text.
[15:02:22 CEST] <JEEB> I think they're the same thing
[15:02:56 CEST] <JEEB> unless my memory derps at me. and since the format originated from MOV it's called like that for hysterical raisins
[15:03:11 CEST] <JEEB> so if you -i lulz.srt and output .mp4 it should get converted to mov_text or whatever
[15:34:00 CEST] <Eduard_Munteanu> Hi. Is there some codec which can be decoded fast enough without hw acceleration for HD (720p) videos, without a lot of CPU usage?
[15:34:34 CEST] <Eduard_Munteanu> I mean, a reasonably good one. Raw files don't really count because I/O is the bottleneck then.
[15:41:46 CEST] <Fyr> divX?
[15:55:37 CEST] <Spring> hey, does anyone know what the deal is with the missing 'sharpness' option?
[15:55:39 CEST] <Spring> http://wiki.webmproject.org/ffmpeg
[15:56:01 CEST] <Spring> This lists it as being available for VPx yet when I go to encode it says the option doesn't exist
[16:12:26 CEST] <Danimal> I'm trying to figure out the difference between -framerate and -r. if I use -framerate on the gdigrab input, and -r on the output, the rates don't line up, and I get duped frames. if I use -r on both input and output, after 7.5 hours or so my rtbuffer fills up and my audio becomes unintelligible.
[16:38:24 CEST] <kepstin> Danimal: ok, so -r is a funny option
[16:38:47 CEST] <kepstin> if used as an input option, it causes the timestamps on the source to be *ignored*, and it rewrites them as constant fps
[16:39:08 CEST] <kepstin> this will obviously cause desync if the rate isn't exactly right (and with gdigrab, it never will be)
[16:39:42 CEST] <kepstin> as an output option, it's identical to adding '-vf fps=[...]', which means it duplicates, drops, and retimes frames to be constant fps
[16:40:03 CEST] <kepstin> the '-framerate' input option on gdigrab is what actually sets the rate at which frames are captured live
[16:40:23 CEST] <kepstin> the way it works, is gdigrab grabs a frame, sleeps until it is supposed to get the next frame, repeat.
[16:40:59 CEST] <kepstin> this is obviously a bit inexact, so the result is variable framerate video (and gdigrab is kinda slow, too, so it might not be able to keep up with the requested framerate)
[16:41:34 CEST] <kepstin> so: If you are OK with variable framerate video, use "-framerate" on input and no "-r" anywhere.
[16:42:06 CEST] <kepstin> if you need constant framerate video, use "-framerate" on input and "-r" (or "-vf fps") on output, and accept that there'll be some duplicated/droppped/retimed frames.
[16:43:10 CEST] <kepstin> Danimal: hope that helps explain things :)
[17:11:49 CEST] <Spring> errm, anyone know of builds that support both VPx and the new dynaudnorm filter?
[17:12:23 CEST] <Spring> been using these http://ffmpeg.zeranoe.com/builds/ but apparently they lack the dynamic normalizer filter
[17:14:58 CEST] <Spring> https://ffmpeg.org/ffmpeg-filters.html#dynaudnorm
[19:03:04 CEST] <gem606> does ffmpeg support the compression of a 64-bit h264 format  into a 32-bit h264?
[19:03:45 CEST] <BtbN> What's 64 and 32 bit h264?
[19:04:05 CEST] <DHE> h264 isn't CPU architecture-specific if that's what you mean
[19:04:14 CEST] <BtbN> do you mean 10/12bit vs. 8bit?
[19:08:38 CEST] <hyponic> I am willing to pay to whoever can make FFMPEG change teletext subtitles to dvbsubtitles while transcoding a live stream.
[19:22:20 CEST] <jancoow> teletext subtitles
[19:22:25 CEST] <jancoow> do people still use these?
[19:24:20 CEST] <DHE> is that the same as the ATSC subtitles?
[19:24:26 CEST] <hyponic> jancoow yeah.. there are some streams that still use that.
[19:26:15 CEST] <gem606> I'm referring to cpu which is probably unrelated to the conversion
[19:34:01 CEST] <strongcoffee> is there an ffmpeg frontend that supports 2 pass encoding (via a checkbox) and doesn't suck?
[19:34:14 CEST] <strongcoffee> I must have tried half a dozen and they all lack something
[19:34:50 CEST] <strongcoffee> just need something that supports direct command line options, input/output, and a 2 pass checkbox
[19:35:09 CEST] <strongcoffee> it's frustrating how hard this is to find
[19:43:47 CEST] <ChocolateArmpits> Why not just use the CLI?
[19:44:04 CEST] <ChocolateArmpits> I mean you need exactly what's there already
[19:44:08 CEST] <strongcoffee> ChocolateArmpits, I need 2 pass to be automated for users
[19:44:16 CEST] <ChocolateArmpits> You can write a script for that
[19:44:29 CEST] <ChocolateArmpits> Is an application mandatory?
[19:44:59 CEST] <strongcoffee> needs to be something that is simple for the user, essentially
[19:45:29 CEST] <ChocolateArmpits> Scripts seem easy, drag and drop
[19:45:45 CEST] <strongcoffee> ChocolateArmpits, you mean a batch script?
[19:45:58 CEST] <ChocolateArmpits> Yeah, if you're on Windows
[19:46:04 CEST] <ChocolateArmpits> Can be Powershell too
[19:46:35 CEST] <strongcoffee> didn't realize batch scripts support D&D
[19:46:56 CEST] <ChocolateArmpits> Oh you can try this http://winff.org/html_new/
[19:47:08 CEST] <ChocolateArmpits> The documentation says it has a 2pass checkbox
[19:47:20 CEST] <ChocolateArmpits> >2Pass check box will run Ffmpeg twice on the
[19:47:21 CEST] <ChocolateArmpits> same video
[19:47:41 CEST] <strongcoffee> from a quick search seems like there's one caveat with batch scripts in they don't support special characters in the path, from a stackoverflow
[19:47:48 CEST] <strongcoffee> but that's not too bad
[19:48:27 CEST] <strongcoffee> this one is nice but the dev refuses a 2 pass option because 'it makes no difference' https://sourceforge.net/projects/ffmpegyag/
[19:48:30 CEST] <strongcoffee> UGHH
[19:48:51 CEST] <strongcoffee> they even previously had a checkbox but it was removed. Just why.
[19:49:06 CEST] <strongcoffee> I've done comparisons and 2 pass is vastly better quality
[19:49:09 CEST] <ChocolateArmpits> strongcoffee: ceck my link
[19:49:12 CEST] <ChocolateArmpits> check
[19:50:17 CEST] <strongcoffee> ChocolateArmpits, yeah saw that. Might give it a whirl. Nice thing about the one I just linked is the live timecode A-B cropping.
[19:50:26 CEST] <strongcoffee> which almost none have
[19:53:36 CEST] <jancoow> Hay there; need to stream a webcam with ffserver
[19:53:59 CEST] <jancoow> Ffserver part is all setup, but ffmpeg giving me errors with v4l2 https://jancokock.me/f/72597
[19:55:29 CEST] <jancoow> it says [video4linux2,v4l2 @ 0x55944f66da60] Cannot find a proper format for codec 'none' (id 0), pixel format 'none' (id -1)
[19:55:52 CEST] <jancoow> when running ffmpeg -f video4linux2 -r 2 -s 352x288 -i /dev/video0 http://localhost:8090/feed1.ffm
[20:09:21 CEST] <UnDeRsOuL> hello, I have ffmpeg in OS X (10.5.5) compiled by brew. I wanted to know how can I list all colorspace/pixel format soported by avfoundation
[20:09:49 CEST] <UnDeRsOuL> get an output like this https://bugs.chromium.org/p/chromium/issues/detail?id=346634
[20:13:39 CEST] <strongcoffee> hold on, why am I reading that people saying 'dont use CRF 2 pass'? I've used it and the difference is obvious
[20:14:08 CEST] <furq> obvious compared to what
[20:14:15 CEST] <strongcoffee> CRF vs CRF 2 pass
[20:16:32 CEST] <furq> are you saying 2-pass crf gives a better result at the same filesize
[20:16:56 CEST] <furq> with x264
[20:17:09 CEST] <strongcoffee> furq, at a smaller filesize actually, yes. No, using VP9 encoding.
[20:17:13 CEST] <furq> oh
[20:17:22 CEST] <furq> christ knows what libvpx does then
[20:17:31 CEST] <furq> it's definitely not true for x264
[20:17:53 CEST] <strongcoffee> well, the difference is night and day using -crf 8 with 2 passes in ffmpeg
[20:18:02 CEST] <strongcoffee> vs not
[20:18:15 CEST] <furq> are people saying to not use 2-pass crf specifically with vp9
[20:18:40 CEST] <furq> it might just be received wisdom because that traditionally has no effect other than wasting time
[20:18:45 CEST] <strongcoffee> no, but all the online results are filled with 'CRF vs 2-pass' and '2 pass is unncessary with CRF'
[20:19:36 CEST] <strongcoffee> so CRF must behave differently with vpx
[20:19:39 CEST] <strongcoffee> or something
[20:19:59 CEST] <furq> it should be true of anything, but i guess libvpx just has shitty ratecontrol
[20:20:19 CEST] <furq> i've not really used it enough to say for sure
[20:26:54 CEST] <strongcoffee> I will say though, vpx encoding takes FOR...EV...ER. Always has. Wish it was faster.
[20:26:59 CEST] <strongcoffee> h.264 just flies by like it ain't no thing
[20:35:00 CEST] <Mac101> hi, was wondering if someone could help me with the stereo3d filter, im using "mpv -vf stereo3d=sbsr:sbsl" on a media pc plugged into a 3dtv. The glasses/tv combo i have doesnt let me switch left/right. The mpv line work for some 3d sbs mkv files but not others?
[20:35:19 CEST] <Mac101> instead it reverts to mono output?
[21:08:23 CEST] <Mac101> hi, anyone? right now im stuck with wearing upside down glasses :/
[21:27:07 CEST] <Mac101> o.o
[21:32:02 CEST] <basisbit> Mac101, this is IRC. wait a few hours for an nswer..
[21:35:22 CEST] <ozette> i have a .mp4 of 500mb, can i chop the video up in parts of for example 50kb with ffmpeg?
[21:35:45 CEST] <ozette> or for example 30 seconds each
[21:46:19 CEST] <ChocolateArmpits> ozette: use segmenter
[21:47:45 CEST] <ozette> ChocolateArmpits: sounds promising, i will have a look, thanks
[21:48:31 CEST] <ozette> i heard ffmpeg also has a segment option
[21:49:33 CEST] <furq> ozette: https://www.ffmpeg.org/ffmpeg-formats.html#segment_002c-stream_005fsegment_002c-ssegment
[21:51:27 CEST] <blue_misfit> hey guys, what is ffmpeg doing when I supply it with a single track of audio containing 8 channels (5.1+2.0) and -map 0:a:0 -ac 2
[21:51:42 CEST] <blue_misfit> is it intelligently grabbing the 2.0 or is it somehow downmixing everything to 2ch?
[21:52:00 CEST] <ozette> furq: i happened to stumble on this page just as you linked it to me, thanks :)
[21:53:25 CEST] <furq> blue_misfit: i assume it's downmixing
[21:53:33 CEST] <furq> if you want to be sure then use the pan filter
[21:54:09 CEST] <blue_misfit> thanks
[21:54:38 CEST] <furq> -af "pan=stereo|c0=c7|c1=c8"
[21:54:50 CEST] <furq> er
[21:54:54 CEST] <furq> -af "pan=stereo|c0=c6|c1=c7"
[21:55:12 CEST] <blue_misfit> what about -map_channel 0.1.6 -map_channel 0.1.7 -c:a pcm_s16le
[21:56:18 CEST] <furq> that should work too
[21:56:35 CEST] <blue_misfit> cool, many thanks @furq
[22:11:34 CEST] <Mac101> hmm
[22:26:16 CEST] <c_14> Mac101: are you sure the input is sbsr?
[22:26:52 CEST] <Mac101> hi
[22:27:22 CEST] <Mac101> i have tried sbsr:sbsl & sbsl:sbsr
[22:27:39 CEST] <Mac101> it falls back to mono on some files
[22:27:52 CEST] <Mac101> its odd some work fine
[22:28:00 CEST] <c_14> Does it log anything?
[22:29:16 CEST] <Mac101> [ffmpeg/video] mjpeg: ignoring invalid SAR: 0/0
[22:29:32 CEST] <Mac101> comes up in yellow on files that dont play right
[22:29:53 CEST] <c_14> That only pops up on files that don't play right?
[22:30:02 CEST] <c_14> What does the video look like without the filter?
[22:30:11 CEST] <Mac101> that dont play correctly*
[22:30:31 CEST] <Mac101> on all my 3d mkvs half half side by side
[22:30:48 CEST] <Mac101> when the swap doesnt work it merges the images
[22:32:01 CEST] <Mac101> i can paste full outputs online or provide samples
[22:32:15 CEST] <c_14> Yeah, maybe a short sample would help
[22:32:15 CEST] <Mac101> if anyone is willing to take a look
[23:07:46 CEST] <strongcoffee> is there a way of applying no scaling using  -vf scale= ?
[23:07:55 CEST] <strongcoffee> apart from not using it
[23:08:06 CEST] <strongcoffee> can the value be left blank?
[23:08:37 CEST] <c_14> strongcoffee: -vf scale=iw:ih
[23:09:00 CEST] <c_14> It should probably no-op in that case, don't know if it actually does though
[23:09:22 CEST] <Bray90820_> Is there a way to convert MKV files to MP4 without loosing video quality
[23:09:32 CEST] <c_14> bray90820: -c copy
[23:09:46 CEST] <Mac101> thank you c_14!
[23:10:42 CEST] <Bray90820> ffmpeg "video.mkv" -c copy -c:a copy "video.mp4"?
[23:10:49 CEST] <Bray90820> I am also passing through the audio
[23:10:57 CEST] <Bray90820> c_14:
[23:11:08 CEST] <c_14> -c copy will apply to all streams, no need to explicitly mention -c:a copy
[23:11:39 CEST] <Bray90820> -c:a copy is for the audio is it nor?
[23:11:46 CEST] <Bray90820> *Not
[23:12:15 CEST] <c_14> yes, but -c copy already applies to all streams (video, audio, subtitle) so there's no explicit need to also copy the audio streams since it's done implicitly
[23:19:24 CEST] <Bray90820> c_14: I might be missing something here what about ffmpeg -i "video.mkv" -c:a copy "video.mp4" if the -c copy applies to everything or is the A doing only the audio?
[23:20:19 CEST] <c_14> the :a specifies all the audio streams, :v would be all the video streams, :s all the subtitle streams etc
[23:20:39 CEST] <c_14> https://ffmpeg.org/ffmpeg.html#Stream-specifiers-1
[23:22:03 CEST] <Bray90820> c_14: last question would the syntax be"ffmpeg -c "video.mkv" "video.mp4"?
[23:22:16 CEST] <c_14> no
[23:22:21 CEST] <c_14> ffmpeg -i video.mkv -c copy video.mp4
[23:23:23 CEST] <Bray90820> Aaahhh thanks
[23:23:40 CEST] <Bray90820> Just to check that will keep 100% video quality?
[23:23:47 CEST] <c_14> yes
[23:24:35 CEST] <Bray90820> Thanks
[23:25:06 CEST] <Bray90820> what about? ffmpeg -i "video.mkv" -c:a copy "video.mp4"
[23:25:25 CEST] <c_14> that will copy the audio and reencode the video
[23:25:36 CEST] <Bray90820> I see
[23:25:41 CEST] <Bray90820> Thanks that helps alot
[23:25:47 CEST] <Bray90820> Now to go test it out
[23:26:56 CEST] <ChocolateArmpits> Is there any place I can find interlaced sd ntsc video samples ?
[23:27:09 CEST] <ChocolateArmpits> xiph media has everything in progressive only
[23:27:15 CEST] <c_14> ChocolateArmpits: try samples.ffmpeg.org
[23:27:50 CEST] <anticw> when using mpegts, derives by using ffmpeg to convert rtsp into mpegts ... i'm pulling the pkts apart and looking at the pids, i see 0, 17, 256, 257 and 4096
[23:28:12 CEST] <ChocolateArmpits> c_14: oh cool didn't know of that
[23:28:20 CEST] <anticw> googling tells me 256 and 257 are video and audio respectively (untested), curious what 17 and 4096 are
[23:29:39 CEST] <Bray90820> c_14: [mp4 @ 0x7fc8ab00d000] pts has no value
[23:29:48 CEST] <Bray90820> I get that error when I don't reencode
[23:30:19 CEST] <c_14> error or warning?
[23:30:45 CEST] <Bray90820> Uh not syre
[23:30:49 CEST] <c_14> error means the encoding aborts
[23:30:57 CEST] <Bray90820> Warning then
[23:31:11 CEST] <c_14> ignore it, the input video is slightly messed up but it should be fine
[23:31:48 CEST] <Bray90820> The input is a really weird VOB file so yes it is messed up
[00:00:00 CEST] --- Thu Jun 30 2016

More information about the Ffmpeg-devel-irc mailing list