[Ffmpeg-devel-irc] ffmpeg.log.20170513

burek burek021 at gmail.com
Sun May 14 03:05:01 EEST 2017

[02:07:21 CEST] <thebombzen> what's the trendy new denoising filter
[02:07:29 CEST] <thebombzen> i.e. which one should I pick
[02:35:06 CEST] <james9999> TrumpSharpMaskv2
[04:08:23 CEST] <mccc> Hi - I'm having trouble recording on ffmpeg.  When I play back - the audio is playing back about 5% - 10% slower than it should.
[04:08:58 CEST] <mccc> I've put my commands and output at  https://pastebin.com/4s2FmWzp  - I'm recording from a sound card to AAC (in MPEG2 TS).
[04:11:51 CEST] <mccc> Does anything look immediately wrong with my commands, or is there anything in the recorded file I can look at for a clue to what's happening?  Could one part of the encoding be getting the sample rate wrong?
[06:48:08 CEST] <Colin_> i keep getting Error: libx264 not found when doing this pi at ColinsPi:/usr/src/FFmpeg $ sudo ./configure --arch=armel --target-os=linux --enable-gpl --enable-libx264 --enable-nonfree when installing it for discord music bot
[06:57:59 CEST] <Colin_> umm hi can you guys help?
[07:01:01 CEST] <Colin_> welp
[07:15:51 CEST] <james9999> lol
[07:16:00 CEST] <james9999> knowing linux you probably have to have libx264-devel installed
[07:16:05 CEST] <james9999> or something
[07:49:25 CEST] <AndrewMock> Most webcams are 150ms+ latency. Anything quicker than Kinect 2.0 (60ms)?
[10:46:31 CEST] <crow> i am trying revert this commit 744801989099df26e90b00062c645969c5347533 because of https://trac.ffmpeg.org/ticket/6364#comment:6 errors are: error: patch failed: libavcodec/h264_slice.c:1699 .... doing it with 'git apply -R "${srcdir}/744801989099df26e90b00062c645969c5347533.patch" '
[18:02:42 CEST] <sadas> hi, anyone could help me to download an m3u8 video at ffmpeg?
[18:18:16 CEST] <Marco_> Hello all!
[18:18:43 CEST] <Marco_> oops, shift+enter not working..
[18:19:54 CEST] <Marco_> Anyways, I have a question I have been searching about all day long now with hevc_qsv (Intel Quick Sync encoder), I cannot find any documentations or explanation about setting keyframes interval
[18:20:54 CEST] <Marco_> Which means that when I encode a video, there is only ONE keyframe at the beginning so seeking somewhere on the video results in a black screen until the video decodes all the way there from the beginning
[18:21:26 CEST] <Marco_> So if I seek to a place 2 minutes from the beginning of the video, it's quite quick, while if I seek one hour in, it takes a very long time
[18:21:54 CEST] <Marco_> If anyone knows a bit how to set keyframe interval in hevc_qsv, please tell me :)
[18:56:55 CEST] <ChocolateArmpits> Marco_, did you try running ffmpeg -help encoder=hevc_qsv ?
[19:06:37 CEST] <oleitner> hi guys
[19:07:04 CEST] <Marco_> ChocolateArmpits, yes I tried, there are a bunch of options there, I tried them all, plus some combinations.. I could post them here, they are not so long
[19:07:22 CEST] <ChocolateArmpits> no -keyint ?
[19:08:06 CEST] <oleitner> having a problem with ffmpeg after pulling the latest version from your git repo..., cannot encode with h264_nvenc cause of 8.0 api he wants, but he just finds 7.1 on my machine, i already "installed" the latest video sdk vom nvdevnet (8.x) into /usr/local and ldconfig'd, still after recompiling getting that same error
[19:08:07 CEST] <Marco_> nope, thereis something that sounds like I-frames, I tried playing with it but it doesn't change anything:
[19:08:09 CEST] <Marco_> -b_strategy        <int>        E..V.... Strategy to choose between I/P/B-frames (from -1 to 1) (default -1)
[19:08:15 CEST] <oleitner> which hoops is it this time?
[19:08:17 CEST] <oleitner> =)
[19:09:06 CEST] <ChocolateArmpits> Marco_, -b_strategy is totally not that
[19:09:34 CEST] <Marco_> Then there is also this:
[19:09:35 CEST] <Marco_>   -adaptive_i        <int>        E..V.... Adaptive I-frame placement (from -1 to 1) (default -1)
[19:10:20 CEST] <ChocolateArmpits> Marco_, did you try -g:v ?
[19:10:32 CEST] <oleitner> according to the changelog 5.x shouldve been deprecated, but not 7.1, so it should still work, allthough id prefer that it grabs what i have
[19:10:58 CEST] <oleitner> i hope im in the right channel for that q, should i go to dev rather?
[19:11:31 CEST] <Marco_> ChocolateArmpits, yep it's totally ignored.. maybe because there is no "no-scenecut" param like in x264
[19:15:28 CEST] <oleitner> ive already made a more complete post on the forum, just no answer the past 16 hours or so...
[19:20:31 CEST] <Marco_> ChocolateArmpits: Actually, I have just noticed that when encoding, it says this:
[19:20:35 CEST] <Marco_> ChocolateArmpits: [hevc_qsv @ 000000000236b420] GopPicSize: 120; GopRefDist: 9; GopOptFlag: closed ; IdrInterval: 0
[19:22:20 CEST] <Marco_> ChocolateArmpits: So I guess it means it is indeed adding keyframes and I guess the problem with the video that has trouble seeking to a specified time (that's why I wanted to add keyframes) might be a ffmpeg bug
[19:22:35 CEST] <ChocolateArmpits> I have no further idea really
[19:23:23 CEST] <ChocolateArmpits> You could try analyzing the frames using ffprobe, it should give out frame types
[19:29:14 CEST] <Marco_> ChocolateArmpits: ok, that seems like the only option now, I'll try that thanks :)
[19:29:35 CEST] <ChocolateArmpits> It would fix anything but maybe give a clearer picture what gets coded
[19:29:39 CEST] <ChocolateArmpits> won't*
[19:30:36 CEST] <Marco_> yep, agreed, I'll see if there's any info there
[19:50:42 CEST] <nho> Hello
[19:51:00 CEST] <nho> I'm trying to convert flac to mp3. Getting an error:   Stream #0:1 -> #0:0 (mjpeg (native) -> png (native)) Error while decoding stream #0:1: Invalid data found when processing input
[19:51:00 CEST] <nho> Too many packets buffered for output stream 0:1.
[19:51:07 CEST] <nho> How to discard video?
[19:51:42 CEST] <oleitner> resulting codec is an image?
[19:51:45 CEST] <oleitner> hi btw
[19:52:17 CEST] <nho> png(native) apparently
[19:52:46 CEST] <sfan5> nho: add -vn
[19:52:54 CEST] <oleitner> png is an image, have you tried setting -c:v to libmp3lame (youll have to have mp3lame installed...)
[19:53:00 CEST] <sfan5> now my own question: how do i ocr with ffmpeg?
[19:53:23 CEST] <nho> Thank you, sfan5
[19:53:50 CEST] <nho> And problem is not with converting to image, it's from converting from mjpeg image...
[19:53:52 CEST] <nho> Was
[19:53:57 CEST] <oleitner> i c
[19:54:05 CEST] <sfan5> you could also try -c:v copy
[19:54:31 CEST] <nho> No, dropping better - more to cram into shitty mp3 player.
[19:56:43 CEST] <mccc> Hello,
[19:56:52 CEST] <mccc> I'm having trouble recording AAC audio in ffmpeg.
[19:57:28 CEST] <mccc> When I do, the file that I get plays back a little bit slower than it should (tested so far on VLC, and and Android)
[19:58:08 CEST] <mccc> This didn't happen when I was recording AAC in to an MPEG4 container, but is happening now that I'm recording AAC in to an MPEG2 container.
[19:58:10 CEST] <oleitner> mccc, how does the output look?
[19:58:20 CEST] <oleitner> mccc, i mean the output while encoding
[19:58:50 CEST] <mccc> Hi oleitner, I put the commands I used and the output up at:
[19:58:50 CEST] <mccc> https://pastebin.com/4s2FmWzp
[20:00:29 CEST] <oleitner> thanks, ill check as soon as my browser loads it..., seems my scriptblocker is kinda going berserk on me today
[20:01:13 CEST] <mccc> No problem thank you for having a look - I'm going to try and keep running variations of the commands and simplifying the repro.
[20:01:48 CEST] <oleitner> ok, im not the ffmpeg ace, but have you tried to reduce the audio rate?
[20:03:01 CEST] <mccc> The bitrate or the sample rate?  I've tried varying both.  I ended up at the ones I have based on a compatability chart I saw online, I'm looking for that tab now..
[20:04:25 CEST] <oleitner> im checking on the wikipedia page on mpeg-1_audio_layer_ii
[20:04:29 CEST] <oleitner> i guess you already did that
[20:05:14 CEST] <mccc> https://android.googlesource.com/platform/external/aac/+/master/libAACenc/include/aacenc_lib.h @Line 503
[20:06:35 CEST] <mccc> Well I'm under the impression that's unrelated - I'm not an expert on this, but I understand that to be an unfortunate overlapping of terms between a codec (MPEG-1 container, Layer II codec) and a container (MPEG-2 container, AAC codec).
[20:07:06 CEST] <oleitner> oki, as i said, im not the wiz
[20:08:19 CEST] <mccc> Me neither but I appreciate your help!  I'm trying to figure out the next way I can narrow this down to understand it.
[20:09:56 CEST] <oleitner> i usually do the other way around, mpegts to h264 mp4
[20:11:30 CEST] <mccc> Yep - I'm actually going from a sound card to MPEG2-TS, I'd previously gone to MP4 but the Android exoplayer doesn't seem to support it.
[20:11:52 CEST] <oleitner> mp4 is yet another container, right?
[20:11:56 CEST] <oleitner> if i had that right
[20:12:01 CEST] <mccc> Yes I believe so.
[20:12:14 CEST] <oleitner> so its rather the content of that container than the container itself
[20:12:29 CEST] <oleitner> id try switching out audio codec i.e. "on the way"
[20:14:35 CEST] <mccc> Well what's interesting is it was seeming to work with the same codec, AAC via libfdk_aac, in the MP4 container but not the MPEG-2 TS.  But that's a good thing to narrow down, I'll see if I can get two simple repros with one and the other.  I'll also just record raw AAC and see what that sounds like.
[20:15:32 CEST] <oleitner> im not into the whole mobile stuff, does that exoplayer thing has a list of supported media somewhere on their website maybe?
[20:16:49 CEST] <mccc> https://google.github.io/ExoPlayer/supported-formats.html under HLS.
[20:17:49 CEST] <mccc> But wait does anyone know what FMP4 is under DASH?  Is that "fragmented MP4"?
[20:17:59 CEST] <oleitner> it supports m4a, that might be a solution...
[20:18:23 CEST] <oleitner> i have no idea, gonna google it though
[20:18:47 CEST] <mccc> Yes it's looking like it - looks like I missed this first read through.
[20:19:24 CEST] <oleitner> fragmented probably has to do with optimized streaming, thats fmp4...
[20:20:01 CEST] <mccc> Okay - I'm going to experiment with this for a bit.  Thank you for the help.
[20:21:41 CEST] <yasar> when down sampling a flac file, will ffmpeg automatically apply some sort of low pass filter?
[20:22:06 CEST] <oleitner> i doubt that
[20:22:12 CEST] <oleitner> though id have to check the headerfiles
[20:23:21 CEST] <yasar> So, lets say I am down sampling from 192k to 96k, will it just select every other sample and be done with it?
[20:24:01 CEST] <oleitner> what do you mean by "every other sample"?
[20:25:10 CEST] <yasar> in 192k file, there are twice the number of samples, compared to 96k file, I was wondering if it would just eliminate half of those samples without any other kind of filtering
[20:25:29 CEST] <oleitner> well, if you loop your script over each file, itll call each file with the flags you define
[20:26:24 CEST] <oleitner> also if youd set an output directory different to the input directory for the resampled files, youd see the difference
[20:28:52 CEST] <oleitner> id guess theres some well thought through logic implemented, so that it knows what to "trim off"
[21:08:20 CEST] <GNU\colossus> Hi everyone
[21:08:48 CEST] <grublet> GNU\colossus: sup
[21:09:30 CEST] <GNU\colossus> I'm archiving a documentary with multiple seasons and episodes from DVD, and would like to use the MP4 container format, creating these files with ffmpeg. is there a guide/docunmentation available that details how I'd properly feed ffmpeg with Unicode metadata for that purpose?
[21:11:45 CEST] <grublet> GNU\colossus: I don't have any firsthand experience with that but you might find something useful here http://ffmpeg.org/ffmpeg-all.html#Metadata-1
[21:11:52 CEST] <grublet> otherwise i'd just wait til someone else can help
[21:12:12 CEST] <GNU\colossus> grublet, thanks, I will take a look at that :)
[22:01:02 CEST] <kinkinkijkin> reflowing from 720p23 to 720p60 at half-pixel accuracy and reencoding to h265 with -preset slower
[22:01:06 CEST] <kinkinkijkin> 0.02x speed
[22:01:14 CEST] <kinkinkijkin> I'm glad this video is only 4 minutes long
[22:02:24 CEST] <ChocolateArmpits> why do you need higher framerate
[22:02:49 CEST] <kinkinkijkin> recording of a game which my computer can't record at 60fps
[22:03:21 CEST] <ChocolateArmpits> but why do you need interpolated motion ?
[22:03:34 CEST] <kinkinkijkin> for looks
[22:03:39 CEST] <ChocolateArmpits> but it won't look good
[22:03:41 CEST] <kinkinkijkin> I don't "need" it
[22:03:59 CEST] <kinkinkijkin> also I've got it done up extremely carefully so that it will look good
[22:04:03 CEST] <kinkinkijkin> extremely rare artifacts
[22:04:22 CEST] <kinkinkijkin> worst that happens is that occasionally a part of the scene updates at the original framerate
[22:05:55 CEST] <GNU\colossus> does x264 encoder performance scale linearly with # of threads/when does it plateau?
[22:06:15 CEST] <kinkinkijkin> depends on cores to threads
[22:06:38 CEST] <kinkinkijkin> it doesn't plateau until a little bit after the processor is full
[22:07:25 CEST] <GNU\colossus> so on a 32 core machine, I can expect 32x speedup over a 1 core machine?
[22:07:37 CEST] <kinkinkijkin> oh, not linear as in exact
[22:07:42 CEST] <kinkinkijkin> also it's not linear
[22:07:57 CEST] <kinkinkijkin> you should expect around a 30x speedup probably
[22:08:15 CEST] <GNU\colossus> that's still very much good enough for my taste :)
[22:08:29 CEST] <kinkinkijkin> that is, assuming that you're not blocked by i/o
[22:08:41 CEST] <kinkinkijkin> which, at that thread number, you might be
[22:16:39 CEST] <GNU\colossus> I'm contemplating temporarily taking over one of the spare boxes at work for this batch of files to convert
[22:17:49 CEST] <GNU\colossus> the machines are big enough that I could do it all on tmpfs 8)
[00:00:00 CEST] --- Sun May 14 2017

More information about the Ffmpeg-devel-irc mailing list