[Ffmpeg-devel-irc] ffmpeg.log.20170519

burek burek021 at gmail.com
Sat May 20 03:05:01 EEST 2017

[00:38:21 CEST] <JordiGH> How can I stitch together a bunch of jpgs losslessly? I'm trying to animate a fractal.
[00:38:44 CEST] <JordiGH> I don't want any smudging or artifacts. Every pixel counts. Every pixel is sacred.
[00:43:55 CEST] <JordiGH> Aha! https://video.stackexchange.com/questions/7903/how-to-losslessly-encode-a-jpg-image-sequence-to-a-video-in-ffmpeg?rq=1
[01:08:56 CEST] <ThugAim> Hey guys, is there an activation issues with Gmail users?
[01:40:11 CEST] <ThugAim> mm got d/c so don't know if it was answered
[03:15:57 CEST] <maicod> Hi I demuxed a TS file and one of the streams is AC3 but doesn't play. Now windows MediaInfo says its PCM/Little Endian/AES3/2 Channel/48khz/20 bits depth. Is this file playable or convertable ? I've never seen it. Its not regular AC3
[03:19:44 CEST] <Trevor_> Hi, I have a tiff image file sequence I am trying to turn into an mp4, but I am getting "no such file or directory".  Could it be because I installed ffmpeg on my C: drive and the tiff files are on a D: drive?
[03:21:46 CEST] <Trevor_> https://pastebin.com/XNauuzvY
[03:23:10 CEST] <maicod> Trevor: windows uses backslash in file paths
[03:23:48 CEST] <maicod> D:/BeginningIntro%%4d.tif should be D:\BeginningIntro%%4d.tif
[03:24:17 CEST] <Trevor_> thank you, I thought I already tried that.  One sec :)
[03:24:30 CEST] <maicod> just something I immediately noticed
[03:26:41 CEST] <Trevor_> Using backslashes and %04d instead of %%4d I get this: https://pastebin.com/qd04KNPt
[03:27:12 CEST] <Trevor_> my file names have no spaces and start numbered "name0000.tif"
[03:27:59 CEST] <maicod> sorry that I don't know else what is wrong
[03:28:21 CEST] <Trevor_> would it be a problem because the files are on a different hard drive?
[03:29:08 CEST] <maicod> sorry got booted
[03:29:36 CEST] <Trevor_>  would it be a problem because the files are on a different hard drive?
[03:29:47 CEST] <maicod> don't think so
[03:30:24 CEST] <maicod> could you changedir to that D:\ and then run the ffmpeg commandline with its full path ?
[03:31:06 CEST] <maicod> maybe that works
[03:31:08 CEST] <slalom> maicod: sounds like the stream in the TS is AES3-PCM and not AC3.. why do you think it's AC3?
[03:31:40 CEST] <maicod> slalom: tsDemuxer used that extention for the extracted file
[03:31:54 CEST] <Trevor_> I am a novice, let me say
[03:32:06 CEST] <maicod> trevor: we all are 'in a way' :)
[03:32:38 CEST] <maicod> trevor I lost the pastebin cause the freenode server d/c-ed on me
[03:32:52 CEST] <Trevor_> should I use %04d or %%4d? I saw both in my google searching
[03:33:00 CEST] <Trevor_> https://pastebin.com/qd04KNPt
[03:33:18 CEST] <maicod> Trevor: sorry I don't know either
[03:33:26 CEST] <maicod> I'll look at your pastebin
[03:33:58 CEST] <Trevor_> omg it's going
[03:34:04 CEST] <maicod> cool
[03:34:34 CEST] <maicod> did you change to D:\ and run ffmpeg from C:\Program Files\ffmpeg.exe (like that) ?
[03:35:01 CEST] <maicod> slalom: do you know how I can play or convert AES3-PCM ?
[03:35:12 CEST] <Trevor_> I typed ffmpeg -r 30 -i D:\BeginningIntro\BeginningIntro%04d.tif streamintro.mp4
[03:35:24 CEST] <maicod> cool !
[03:35:26 CEST] <Trevor_> it might have just been the forward slash lol
[03:35:34 CEST] <maicod> maybe
[03:35:38 CEST] <Trevor_> I wasn't using them before, I must have forgot to change it back
[03:35:53 CEST] <Trevor_> anyways, thank you very much person on the internet!! gl
[03:35:54 CEST] <maicod> good thing it works
[03:36:07 CEST] <maicod> no thanks :)
[03:41:15 CEST] <maicod> my TS stream contains a AES3-PCM track. Can that be played/converted ? So far all I get is white noise
[08:12:45 CEST] <stdint> I want to analysis encoded stream, showing the size of echo encoded frame
[08:13:16 CEST] <stdint> just showing the size of echo frame in a avc stream, and marked all its frame type, like I, P, B
[08:13:33 CEST] <stdint> could ffmpeg utils do that?
[11:48:09 CEST] <termos> i'm having issues transcoding aac audio and it seems to be related to this https://github.com/FFmpeg/FFmpeg/blob/master/ffmpeg.c#L840 based on this http://stackoverflow.com/questions/37239113/how-to-encode-audio-to-aac-with-profile-ff-profile-aac-low is it something I need to take into account?
[13:02:48 CEST] <dannysmc95> Hi everyone, I have a question, I am currently trying to run this command: ffmpeg -f avfoundation -framerate 30 -i "0" -target pal-vcd ws://localhost:8082 to stream my mac's webcam to a socket, but I keep getting the following error: ws://localhost:8082: Protocol not found, I looked online and re-compiled with --enable-openssl flag, but still no use? Anyone know the problem?
[13:04:54 CEST] <dannysmc95> Also this command: ffmpeg -f avfoundation -framerate 30 -i "0" -b 0 ws://localhost:8081 doesn't work either, says: Unable to find a suitable output format for 'ws://localhost:8081' ws://localhost:8081: Invalid argument
[13:05:17 CEST] <BtbN> I'm not aware of ffmpeg being able to act as a websocket server.
[13:06:40 CEST] <dannysmc95> No it doesn't act as one it's able to stream to one
[13:06:44 CEST] <dannysmc95> BtbN: ^
[13:07:19 CEST] <dannysmc95> This thing here gives me a websocket relay: https://github.com/phoboslab/jsmpeg
[13:07:24 CEST] <BtbN> So you already have a ws server running on localhost:8081, waiting for a connection?
[13:07:36 CEST] <dannysmc95> BtbN: yes
[13:07:47 CEST] <BtbN> Then just use an propipate format via -f and hope for the best
[13:08:44 CEST] <dannysmc95> What do you mean by that? I thought what I was giving was usable? in the link above, that's what it says, but I have had to amend it to work with mac instead
[13:10:53 CEST] <zerodefect> At the moment, I'm transcoding a DV clip.  I notice that DV field order is Bottom field. If I wan't to move that to Top field, what is the correct way to do that?  I'm thinking that I may want to combine a DV clip and say MPEG2 clip together (different field orders). I've read a few snippets that some people will cater for this by  transitioning each line of their decoded DV lower by 1 line
[13:10:53 CEST] <zerodefect> and leave black as the first line.  Any suggestions on how this should be handled (or even if it needs to be handled specially)?
[13:15:42 CEST] <furq> !filter fieldorder @zerodefect
[13:15:42 CEST] <nfobot> zerodefect: http://ffmpeg.org/ffmpeg-filters.html#fieldorder
[13:16:01 CEST] <furq> dannysmc95: normally the output format is autodetected from the filename, but you're outputting to a url, so you need to provide one manually with -f
[13:16:09 CEST] <furq> e.g. -f mpegts or whatever it expects
[13:18:06 CEST] <zerodefect> nfobot: Thanks!  I'll try this out.
[13:19:17 CEST] <dannysmc95> But I am doing -f avfoundation?
[13:19:20 CEST] <dannysmc95> for the mac webcam?
[13:19:43 CEST] <dannysmc95> furq: ^ Sorry maybe I am missing something but I see it like this:
[13:20:15 CEST] <dannysmc95> ffmpeg -f avfoundation -framerate 30 -i "0" is the configuration for the mac webcam?
[13:20:34 CEST] <furq> that's the input format
[13:20:37 CEST] <furq> you need an output format
[13:20:44 CEST] <dannysmc95> So I have to do another -f?
[13:20:47 CEST] <furq> yes
[13:20:52 CEST] <dannysmc95> Where abouts in the string?
[13:21:06 CEST] <furq> between -i "0" and ws://...
[13:21:31 CEST] <furq> assuming this even works at all which i have no idea about
[13:24:01 CEST] <dannysmc95> furq: IT WORKS!
[13:24:03 CEST] <dannysmc95> Thank you!
[13:24:12 CEST] <dannysmc95> This was the command in the end:
[13:45:48 CEST] <beaver545_> Hi, I'm having trouble encoding using h264_qsv, I setup using avcodec_find_encoder_by_name() and set up the CodecContext and open the encoder successfully with avcodec_open2(), however, when I send a frame to the encoder with avcodec_send_frame(), I get an exception thrown trying to execute the location 0x0
[13:46:27 CEST] <beaver545_> can anyone suggest what I'm missing as part of the setup for this to occur? When using x264 to encode, everything works fine.
[14:29:39 CEST] <dannysmc95> Hey, I was wondering when using this, I had issues with Safari (iOS) not playing audio? from a stream? Now I know this is a common issue, but is there any fixes for this?
[14:30:07 CEST] <dannysmc95> I've come to you for a collective answer from experienced people, if nothing from here I shall do some research
[14:32:38 CEST] <Guest25915> Hello, I'm trying to get ffmpeg libraries to work on android with Unity. Getting DllNotFoundException every time. After some research and testing, it seems like when a shared library has to import an other one (like libavcodec needs libavutil) the needed library fails to be imported successfuly. Any idea how to get it working ?
[14:48:10 CEST] <Guest25915> could it be libraries not loading in the correct order ? even if I doubt it's the problem
[15:15:54 CEST] <FishPencil> Does FFmpeg have an internal opus encoder now?
[15:16:22 CEST] <durandal_1707> yes
[15:16:38 CEST] <FishPencil> How is it used?
[15:17:23 CEST] <durandal_1707> like any other audio encoder
[15:18:27 CEST] <FishPencil> No additional configuration options are needed, and it can be used alongside a build with libopus included?
[15:20:01 CEST] <durandal_1707> yes, you just need to pick right encoder name
[15:20:30 CEST] <kerio> how does it compare?
[15:21:11 CEST] <durandal_1707> its better than native vorbis for sure
[15:22:23 CEST] <ackjewt__> Anyone knows if ffmpeg can add a timestamp (and possibly date) when outputting to stderr/stdout? e.g "[2017-05-19 10:10:10] Guessed Channel Layout for Input Stream #0.0 : hexadecagonal"
[16:11:00 CEST] <truexfan81> i need to know what was changed in the configure script recently, after doing a git pull today i can no longer compile ffmpeg in msys2 mingw64
[16:12:30 CEST] <truexfan81> i get this error even when i add --enable-cross-compile to my ./configure line as it suggests https://pastebin.com/tRWMqzCZ
[16:12:46 CEST] <DHE> I like to use: git log -p configure
[16:14:02 CEST] <truexfan81> all this was working perfectly until i did a git pull today, so i'd appreciate it if ffmpeg would fix whatever they broke
[16:15:18 CEST] <DHE> it helps if you could narrow it down
[16:16:22 CEST] <truexfan81> not sure how
[16:16:30 CEST] <truexfan81> i'm trying to compile git master
[16:16:54 CEST] <DHE> do you have the git versions that you originally ran? your 'git pull' command should begin with "Updating 1234567..abcdef" where those are the old and new versions
[16:18:12 CEST] <truexfan81> Updating f73ef3748e..162414cefe
[16:19:08 CEST] <furq> f73ef37 is from february
[16:19:17 CEST] <DHE> yep... bisecting will take longer than I thought
[16:19:30 CEST] <furq> so probably quite a lot of things have changed since then
[16:19:31 CEST] <truexfan81> which was the last time i had time to compile it
[16:19:38 CEST] <DHE> around 12 or 13 attempts required
[16:20:07 CEST] <DHE> truexfan81: so here's how it works. run: git bisect start ; git bisect good f73ef3748e ; git bisect bad 162414cefe
[16:20:36 CEST] <DHE> git checks out a version half way between the two and you build it. if it succeeds, you run `git bisect good` and if it won't build you run `git bisect bad`
[16:20:51 CEST] <DHE> it takes about 12 or 13 build attempts while it searches for the breaking point
[16:21:04 CEST] <furq> in the meantime, pastebin config.log
[16:21:10 CEST] <furq> and also don't use enable-cross-compile
[16:21:14 CEST] <truexfan81> Bisecting: 1261 revisions left to test after this (roughly 10 steps)
[16:21:15 CEST] <truexfan81> [5ce02f4c555a4ca03486bc8f59b52a78c5f9e961] Merge commit '47a795727f5433f5238a8a244cf181f61ea5af2c'
[16:21:39 CEST] <DHE> truexfan81: repeat until it's out of revisions to test and gives you a definitive answer
[16:21:46 CEST] <DHE> also yeah, the config.log it tells you about
[16:23:24 CEST] <truexfan81> i must be doing something woring cause revisions left to test is not getting smaller
[16:25:40 CEST] <truexfan81> config log https://pastebin.com/YkVNMikK
[16:26:03 CEST] <furq> ./configure: line 882: gcc: command not found
[16:26:13 CEST] <furq> i can't help but think this might be the problem
[16:27:13 CEST] <truexfan81> $ pacman -Ss gcc
[16:27:14 CEST] <truexfan81> mingw32/mingw-w64-i686-gcc 6.3.0-3 (mingw-w64-i686-toolchain) [installed]
[16:28:01 CEST] <truexfan81> perhaps the configure script just needs to know where to find it?
[16:28:16 CEST] <furq> can you run it from that prompt
[16:29:28 CEST] <truexfan81> furq: run which?
[16:29:33 CEST] <furq> gcc
[16:29:55 CEST] <truexfan81> lol command not found okie
[16:30:22 CEST] <furq> welcome to the wonderful world of msys
[16:30:34 CEST] <truexfan81> installing
[16:31:00 CEST] <truexfan81> it must have gotten removed when i removed something else
[16:31:08 CEST] <truexfan81> dep chains are fun
[17:11:22 CEST] <Guest25915> I have a libpostproc-52.so which is dependent of libutil-52.so, how can i setup libpostproc to look for libavutil-52.so and not libavutil.so.52.XX.XX.XX
[17:13:20 CEST] <BtbN> 52 is old, you sh ould update.
[17:13:34 CEST] <BtbN> And it will looks for libavutil.so.52, not the full version.
[17:13:39 CEST] <kepstin> Guest25915: and why (and how?) are you getting libraries with those names?
[17:13:53 CEST] <BtbN> Wild guess: Android. Does not support sonames.
[17:14:00 CEST] <Guest25915> I need to get ffmpeg libs to work on Android
[17:14:03 CEST] <BtbN> Most shitty linker I have ever seen.
[17:14:26 CEST] <Guest25915> I have the same problems with the newest version
[17:14:49 CEST] <Guest25915> every time a lib is called by an other on, Dllimport fails (on Unity3d)
[17:16:19 CEST] <BtbN> if you are really using version 52: Update it.
[17:16:23 CEST] <BtbN> That's a couple years old.
[17:16:52 CEST] <Guest25915> Ill give it a shot, but I have the same problem last time i tried with ffmpeg 3.3
[17:24:45 CEST] <kepstin> sure, but if you're solving the same problem, you might as well start with the newer library
[17:24:55 CEST] <Guest25915> wow it worked
[17:25:16 CEST] <Guest25915> thanks a lot, struggling with this for days
[19:02:32 CEST] <dannysmc95> Hey guys, is there a library that will allow me to do this command: ffmpeg -f avfoundation -framerate 30 -video_size 640x480 -pix_fmt uyvy422 -i "0:1" -f mpegts -codec:v mpeg1video -s 640x480 -b:v 1000k -bf 0 http://localhost:8081/<secret> but within nodejs, so I can parse the output etc?
[19:02:33 CEST] <__raven__> hi
[19:04:33 CEST] <__raven__> i am converting a pal (i25) to 50p with half vertical resolution using -filter_complex "[0]field=top[t];[0]field=bottom[b];[b][t]interleave" - do you know what the reverse option would be?
[19:08:35 CEST] <ChocolateArmpits> __raven__, look up tinterlace, it has several options there
[19:16:25 CEST] <__raven__> ChocolateArmpits: yes i think mode0 is the right one but i need to change the input field order
[19:16:52 CEST] <ChocolateArmpits> __raven__, you mean shift the fields ?
[19:16:59 CEST] <__raven__> ChocolateArmpits: yes
[19:17:00 CEST] <ChocolateArmpits> there's a "field" filter for that
[19:17:05 CEST] <ChocolateArmpits> wait
[19:17:07 CEST] <ChocolateArmpits> not that
[19:17:51 CEST] <ChocolateArmpits> fieldorder
[19:17:53 CEST] <ChocolateArmpits> that one
[19:22:50 CEST] <__raven__> sorry that was misleading. i need to change the INPUT order of the tinterlace
[19:26:24 CEST] <dannysmc95> Can anyone help: http://stackoverflow.com/questions/44075597/how-to-successfully-parse-the-output-of-ffmpeg-in-nodejs
[19:27:16 CEST] <__raven__> ChocolateArmpits: or perhaps i dont and i need mode7 but i have no mode 7
[19:27:47 CEST] <c_14> dannysmc95: ffmpeg always logs on stderr, that's normal. as for output parsing it's not really meant to be parsed, it's not stable or anything
[19:27:58 CEST] <c_14> you can try the -progress callback
[19:28:05 CEST] <c_14> depending on what you want
[19:29:24 CEST] <dannysmc95> c_14: thanks for that, I just need the bitrate, size and fps
[19:29:57 CEST] <c_14> probably try -progress I think it has that. not sure anymore though
[19:30:38 CEST] <dannysmc95> Where do I put the flag? at the end?
[19:30:53 CEST] <dannysmc95> c_14: ^^ Just so I know where
[19:30:55 CEST] <c_14> before the output and after the input probably
[19:33:02 CEST] <dannysmc95> c_14: It seems to want me to post it to a URL? :/
[19:33:31 CEST] <dannysmc95> It says -progress url (global)
[19:33:58 CEST] <dannysmc95> And says it sends it to the url every second, but I don't really wish to be spamming a URL with updates? Is there anyway to catch it do you think?
[19:34:27 CEST] <c_14> you're in node, can't you just spawn a http listener?
[19:34:53 CEST] <dannysmc95> c_14:  Hmmm that's not a bad idea, is a post request?
[19:35:18 CEST] <c_14> yeah
[19:35:22 CEST] <c_14> chunked post afair
[19:36:27 CEST] <dannysmc95> hmm okay, will have a go.
[19:38:01 CEST] <c_14> Oh, url doesn't need to be a url though. a file or pipe will work too
[19:38:38 CEST] <c_14> output looks like https://pb.c-14.de/t/kng.ROmJjN
[19:38:56 CEST] <dannysmc95> Can you give me an example sorry?
[19:38:58 CEST] <c_14> (bitrate and size aren't listed because I used the null output, it should be there for you)
[19:39:11 CEST] <c_14> ffmpeg -f lavfi -i testsrc -f null /dev/null -progress progress_file
[19:39:24 CEST] <c_14> you should also be able to use -progress pipe:fd or so
[19:39:37 CEST] <c_14> if you open a pipe in node beforehand
[19:39:47 CEST] <c_14> (or pipe to stdout, that should be open already)
[19:39:50 CEST] <__raven__> any way to achieve tinterlace=7 manually? i hav no mode 7 in this lib :/
[19:40:15 CEST] <dannysmc95> I am super nooby at nodejs, I am still learning it, how would I open  a pipe for it to take the data?
[19:40:25 CEST] <dannysmc95> I am not very good with pipes and streams etc
[19:40:28 CEST] <dannysmc95> c_14: ^
[19:40:41 CEST] <c_14> dannysmc95: just use stdout for now, should work just fine (pipe:1)
[19:41:08 CEST] <dannysmc95> c_14: Sorry to be a pain, I am not sure what you mean?
[19:41:23 CEST] <dannysmc95> do I add -progress pipe:1
[19:41:26 CEST] <c_14> yes
[19:41:37 CEST] <c_14> then just use your stdout.on to process the output
[19:41:49 CEST] <dannysmc95> Will it always be pipe:1?
[19:41:53 CEST] <c_14> yes
[19:42:06 CEST] <dannysmc95> How come? as I am planning to add this to a larger program
[19:42:17 CEST] <c_14> because 1 is always stdout
[19:42:41 CEST] <dannysmc95> but what if there was another process running that was using stdout?
[19:42:51 CEST] <c_14> each process has its own stdout
[19:42:58 CEST] <c_14> and you're listening on the stdout from ffmpeg
[19:43:07 CEST] <dannysmc95> Ohhhhhh, I see, okay that makes sense
[19:43:11 CEST] <c_14> so even if your program is doing things with its stdout, ffmpegs will work fine
[19:43:47 CEST] <dannysmc95> c_14: I see thank you! So I think I should be able to split that via \n ?
[19:44:02 CEST] <c_14> yeah
[19:44:22 CEST] <c_14> each block should end with a progress=line, after that is a new block with updated values
[19:44:31 CEST] <c_14> *progress= line
[19:44:53 CEST] <dannysmc95> Ahh okay, I haven't been able to understand how buffers, and streams work yet. and yeah I see progress=continue
[19:48:39 CEST] <dannysmc95> Nice one c_14, thank you for this, has been a huge help, been so lost haha.
[19:49:00 CEST] <thebombzen> speaking of progress, is there a way to  have ffmpeg output its stats in an easily parseable way (like JSON or flat or something)
[19:49:24 CEST] <thebombzen> or at least, more machine parseable than how it currently is
[19:52:31 CEST] <dannysmc95> thebombzen: I had help from c_14 and was able to get it to work
[19:52:42 CEST] <thebombzen> unrelated question
[19:52:44 CEST] <thebombzen> to yours
[19:52:48 CEST] <thebombzen> or rather inspirted by yours
[19:52:53 CEST] <thebombzen> inspired*
[19:53:03 CEST] <c_14> thebombzen: you mean what's output when it's finished encoding?
[19:53:53 CEST] <thebombzen> I mean the stats that are printed by -stats like this stuff: frame= 7134 fps=4454 q=20.1 Lsize=    7168kB time=00:04:45.32 bitrate= 205.8kbits/s speed= 178x
[19:54:30 CEST] <c_14> there isn't, but some of that is output by -progress
[19:56:29 CEST] <thebombzen> ah I see. it appears that I can do what I want with -progress pipe:2 -v error
[21:18:00 CEST] <__raven__> any idea?
[22:57:43 CEST] <durandal_1707> __raven__: doubleweave filter, just get new version
[23:12:13 CEST] <carrot> Hi folks. I read about -row-mt support on your website for libvpx-vp9 and tried to use it, but I'm getting "Unrecognized option 'row-mt'". Tried both 3.3.1 and HEAD (git-2017-05-19-0cc6dd1). This is the line I'm using: https://gist.github.com/CarrotCodes/f31dfe396e65691feeada535c7593d48 - works fine with tile-columns (which is was using previously) but I was getting abysmal performance
[23:12:27 CEST] <carrot> Entirely possible that I'm messing something simple up but not seeing it myself
[23:13:14 CEST] <DHE> it's also dependent on your version of VPX having the feature
[23:13:18 CEST] <DHE> which may be your problem
[23:14:39 CEST] <carrot> interesting, how might I find that? using macOS rather than Linux
[23:14:43 CEST] <kepstin> looks like you need libvps 1.6.2 or later, if using a release version
[23:14:49 CEST] <kepstin> libvpx*
[23:17:01 CEST] <kepstin> which given that there doesn't actually seem to be a 1.6.2 release yet, means that you have to use a git snapshot, i guess
[23:17:06 CEST] <carrot> aha, found a --HEAD option for libvpx so I'll try that
[23:17:58 CEST] <kepstin> (I personally use git snapshots of libvpx that correspond to whatever google included in the most recent chrome release; which is newer than the standalone libvpx releases)
[23:18:21 CEST] <carrot> yeah, seems like brew points to "https://chromium.googlesource.com/webm/libvpx"
[23:22:27 CEST] <carrot> that worked!
[23:22:35 CEST] <carrot> wow, it's considerably faster
[23:22:48 CEST] <carrot> struggled to get literally 1 fps with tile-columns previously
[23:22:52 CEST] <carrot> now cruising at 14
[23:23:17 CEST] <carrot> and it's actually using all my cores, so that's nice
[00:00:00 CEST] --- Sat May 20 2017

More information about the Ffmpeg-devel-irc mailing list