[Ffmpeg-devel-irc] ffmpeg.log.20170522

burek burek021 at gmail.com
Tue May 23 03:05:01 EEST 2017

[11:27:36 CEST] <k_sze> ffmpeg doesn't use libjpeg at all?
[11:27:47 CEST] <k_sze> (even for jpeg file or mjpeg support)?
[11:34:10 CEST] <BtbN> It can optionally use libopenjpeg
[11:35:36 CEST] <BtbN> Which seems to be jpeg2k though
[12:01:32 CEST] <Nacht> Hi, I'm having some issues with the exec plugin. I'm running a .sh script located in /usr/local/bin which outputs in JSON. When I run telegraf with -test it just says: Plugin: inputs.exec, Collection 1. I even tried just making a simple .sh script which echos the example as given in README.md. But none of it shows any output
[12:02:10 CEST] <Nacht> I have data_format = "json"
[13:43:55 CEST] <BtbN> And that's related to ffmpeg in what way?
[14:43:26 CEST] <SolidusAbi> Hi to everyone, can someone help with a smooth streaming? Im tringin to generate the .ism and .ismc but i have not found the ismindex operator.
[15:08:24 CEST] <DHE> SolidusAbi: you're best off asked a specific question and waiting patiently
[15:16:50 CEST] <zerodefect> Does the H.264 (libx264) support YUV422P?  I could swear that on Friday I had it working with YUV422P, but now in avcodec_open2() it errors with "Specified pixel format YUV422P is invalid or not supported".
[15:19:49 CEST] <zerodefect> I've tried changing the profile HIGH_422 but still.  It makes me think I've changed something in the code which has broken it.
[15:20:09 CEST] <zerodefect> "the code" being my code :)
[15:20:54 CEST] <zerodefect> Other thing I'm wondering is if my package manager (Ubuntu Zesty) has pulled down a new version of the API
[15:21:28 CEST] <BtbN> Debian/Ubuntu system packages stick to a stable version
[15:21:58 CEST] <DHE> 422 is supported in the current version of ffmpeg and x264. did you actually set a profile that accepts 422 input though?
[15:22:04 CEST] <zerodefect> Yeah, that's what I thought
[15:23:33 CEST] <zerodefect> DHE: Yeah, I tried 'FF_PROFILE_H264_HIGH_422' but I'm only encoding PAL SD.  Not sure if there are constrains on resolution with that profile?
[15:23:54 CEST] <DHE> no resolution constraints on profiles. but there are resolution constaints if you set a 'level'
[15:24:05 CEST] <zerodefect> Presumably, I only need to set that in the AVCodecContext?
[15:24:08 CEST] <zerodefect> Ah ok
[15:25:27 CEST] <microchip_> can't build ffmpeg with latest libx265 - this is what I get in config.log https://teambelgium.net/h5ai/files/text/
[15:25:34 CEST] <microchip_> sorry, libx264
[15:26:09 CEST] <microchip_> peeps of x264 added AVX512 support and that is causing issues with ffmpeg git
[15:26:16 CEST] <DHE> wow, something's wrong with your copy of x264
[15:26:33 CEST] <DHE> that's not ffmpeg's fault. you're missing a symbol in x264 itself. that normally wouldn't happen...
[15:26:47 CEST] <microchip_> ok, i'll try again
[15:27:41 CEST] <DHE> oh, that's new in x264. I'm gonna try this
[15:28:01 CEST] <microchip_> same thing
[15:29:45 CEST] <BtbN> That's probably the worst paste-site possible. It puts a scroll bar at the bottom, and then opens something on top of it when you hover, so you can't reach it
[15:30:11 CEST] <BtbN> And also does not allow me to select text to copy it, or to scroll it that way
[15:30:25 CEST] <bencoh> :]
[15:30:34 CEST] <microchip_> i'll put it elsewhere
[15:30:50 CEST] <DHE> noscript + open in browser makes it tolerable.
[15:31:31 CEST] <zerodefect> Found something interesting. I call avformat_alloc_output_context2 with an output format of "rtp_mpegts". It seems to be using MPEG4 part 2 (AV_CODEC_ID_MPEG4). That isn't part 10, is it?
[15:31:32 CEST] <microchip_> https://pastebin.com/QrTSMus8
[15:32:19 CEST] <DHE> zerodefect: no, part 2 is also known as "DivX", or XviD compatbile
[15:32:25 CEST] <DHE> part 10 is H264
[15:32:42 CEST] <BtbN> microchip_, yeah, that looks to me like that x264 is miscompiled in some way
[15:33:01 CEST] <BtbN> it's missing symbols from itself
[15:33:06 CEST] <microchip_> hmm
[15:34:16 CEST] <DHE> kinda odd because x264.exe wouldn't be built successfully either if that happened.
[15:34:32 CEST] <zerodefect> DHE: does AV_CODEC_ID_MPEG4 refer to part 10 then?
[15:35:59 CEST] <DHE> zerodefect: no, you want AV_CODEC_ID_H264
[15:39:28 CEST] <JEEB> zerodefect: "mpeg4" in FFmpeg vocabulary when talking of video formats (not containers) is mpeg-4 part 2
[15:39:51 CEST] <zerodefect> Thanks for the clarification
[15:40:51 CEST] <DHE> at this point in history mpeg4 [part 2] is a footnote nobody really talks about anymore. h264 has replaced it and not much in terms of hardware plays mpeg4 but not h264
[15:43:26 CEST] <zerodefect> When I call 'avformat_alloc_output_context2' should I specify an output context (currently the paramters is NULL) and force the video codec to H.264?  What is the correct way?
[16:00:38 CEST] <zerodefect> Using the format of "mpegts" gives a video codec of H.264.  No RTP though; that will do for now. Thanks for the help.
[16:04:47 CEST] <BtbN> if you do not specify a codec, ffmpeg will use a default based on the container. Which for mpegts happens to be mpeg4
[16:04:53 CEST] <BtbN> feel free to override
[16:07:34 CEST] <bencoh> which is kinda odd, but anyway :)
[16:08:26 CEST] <furq> it's mpeg2video here
[16:08:31 CEST] <bencoh> (I guess it gives better results than mpeg2 while still being builtin - library-independant, but ...)
[16:08:40 CEST] <furq> at least in ffmpeg it is
[16:08:53 CEST] <bencoh> furq: that's what I had in mind back then as well
[16:09:08 CEST] <furq> neither of which are as weird as nut using mpeg4 by default
[16:10:50 CEST] <zerodefect> BtbN: Where/how exactly would I override the codec?
[16:12:57 CEST] <BtbN> When creating the encoder
[16:13:07 CEST] <BtbN> Or just with -c as an output option, when using ffmpeg.c
[16:13:58 CEST] <zerodefect> Ok. Thanks. I'll give that a try.
[17:14:39 CEST] <momomo> hello, any here. need urgent help
[17:14:49 CEST] <momomo> I have this ffmpeg command ... it's fully working
[17:15:39 CEST] <momomo> it generates hls files ... but it also transcode, scales and compresses using crf 23 ... however the source is already compressed so basically I only need to split it into segment files
[17:15:50 CEST] <momomo> * and scale
[17:16:10 CEST] <momomo> ooh forgot to post the link: https://hastebin.com/ojovacumim.swift
[17:16:45 CEST] <momomo> what should I remove to enable less cpu power being used since I don't need to change anything
[17:17:51 CEST] <momomo> here is a better formatted one: https://hastebin.com/ramikaragu.diff
[17:19:00 CEST] <momomo> also, do I need to use preset .. and if I have to ... what would be the difference compared to ultrafast since there is no manipulation ... would the hls segment files still end up bigger?
[17:37:08 CEST] <alexpigment> i'm trying to build an LGPL build of ffmpeg, but i'm having trouble telling if it actually worked
[17:37:32 CEST] <alexpigment> if i type ffmpeg -L , should that give me a type of license?
[17:39:54 CEST] <c_14> It lists license text here
[17:43:40 CEST] <alexpigment> ok, i'm seeing it now. for some reason it was saying --enable-gpl before
[17:43:58 CEST] <c_14> probably executed the wrong binary?
[17:57:52 CEST] <alexpigment> possibly
[18:35:13 CEST] <cmpscabral> hi everyone. I have this stream https://pastebin.com/gzpM9fEZ playing fine using vlc or vlc-plugin (firefox). my question is, is it possible to downscale and convert this stream with ffmpeg and output something a <video> element (native) or flash plugin would play in a browser?
[18:36:58 CEST] <teratorn> cmpscabral: yes
[18:41:02 CEST] <cmpscabral> @teratorn tks for your reply. do I need anything besides ffmpeg?
[18:41:14 CEST] <cmpscabral> (to do the stream part)
[18:41:48 CEST] <teratorn> cmpscabral: probably not
[18:44:21 CEST] <cmpscabral> ok, thanks
[18:55:24 CEST] <momomo> guys I am connecting using ffmpeg to stream ... but then I get this message mid through:
[18:55:30 CEST] <momomo> 217247	: 1002352814	: [https @ 0x4b679e0] Stream ends prematurely at 29071192
[18:57:38 CEST] <momomo> Then it tries 10 times and gives up. However, i am not sure it is actually retrying correctly.
[18:58:01 CEST] <momomo> and the process dies
[18:58:46 CEST] <momomo> when I had -reconnect_stream 1 then it didnt die, but it kept looping the error ... it jumped back to the stream, and then it got into the same error it appears, then jumps back ...
[18:58:56 CEST] <momomo> so using -reconnect_stream 1 is not an option
[18:59:27 CEST] <momomo> but is there a way to have a higher error tolerance ... it continues until its ready again
[19:16:31 CEST] <ChocolateArmpits> momomo, how are you executing your stream ?
[19:22:45 CEST] <Tatsh> i have been unable to use my GPU's MJPEG decoding capabilities
[19:22:56 CEST] <Tatsh> i get an error
[19:24:16 CEST] <Tatsh> crap, what are the ffmpeg hot keys?
[19:24:24 CEST] <Tatsh> besides q; i hit h and i don't know how to go back
[19:24:33 CEST] <Tatsh> pressing h again shows a hex dump
[19:34:01 CEST] <ChocolateArmpits> Tatsh, just click the same hotkey again
[19:38:51 CEST] <Tatsh> where are the hotkeys documented?
[19:47:23 CEST] <nyuszika7h> when I do `ffmpeg -i in.mkv -i in.mka -filter_complex '[0:v:0][1:s:0]overlay[vid]' -map '0:a:0' -c:v h264_qsv -c:a aac -b:a 128k out.mkv -y`, I get this error despite having not specified any rate control mode explicitly:
[19:47:34 CEST] <nyuszika7h> [h264_qsv @ 0000000002749a20] Selected ratecontrol mode is not supported by the QSV runtime. Choose a different m
[19:47:35 CEST] <nyuszika7h> Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect para
[19:47:36 CEST] <nyuszika7h> such as bit_rate, rate, width or height
[19:47:42 CEST] <nyuszika7h> (also how do I use CRF or something similar with h264_qsv?)
[19:48:49 CEST] <nyuszika7h> er, add a -map '[vid]' before -map '0:a:0'
[19:48:54 CEST] <nyuszika7h> is my actual command
[19:59:51 CEST] <OzgrK> hi, i'd like to report that native aac encoder produces glitches for low frequency sine waves, at least in my case. is this known? you may reproduce it with...
[19:59:53 CEST] <OzgrK> ffmpeg -f lavfi -i aevalsrc="sin(32*2*PI*t):s=48000:d=1800" -c:a aac -b:a 384 -f matroska pipe:1 | ffplay -
[20:10:00 CEST] <Tatsh> nyuszika7h, the options are never the same as libx264
[20:10:15 CEST] <durandal_170> atomnuker: ^^
[20:10:18 CEST] <Tatsh> so you have to trial and error with qmin/qmax
[20:10:22 CEST] <nyuszika7h> I didn't specify any options related to that though
[20:10:25 CEST] <Tatsh> if that's available
[20:10:37 CEST] <nyuszika7h> except the filter which is not specific to the video codec I'd think
[20:17:06 CEST] <Tatsh> nyuszika7h, filters are usually limited
[20:17:08 CEST] <Tatsh> for hardware
[20:17:55 CEST] <Tatsh> ffmpeg -h encoder=h264_qsv
[20:17:59 CEST] <Tatsh> will show all options
[20:18:36 CEST] <Tatsh> for me with CUVID there's no -crf, you have to use -cq instead which is a different scale and you have to trial and error with these sort of things
[20:18:44 CEST] <Tatsh> see what quality/bitrate is acceptable to you
[20:18:51 CEST] <atomnuker> nyuszika7h: the bitrate is insanely low
[20:19:02 CEST] <atomnuker> 384 bytes per second
[20:19:21 CEST] <furq> you mean OzgrK
[20:19:59 CEST] <Tatsh> btw is h264_qsv for decoding or encoding or both?
[20:20:06 CEST] <Tatsh> i don't have it on my CPU afaik
[20:20:09 CEST] <furq> qsv is for encoding
[20:20:14 CEST] <atomnuker> set it to 384k and it'll be right
[20:20:52 CEST] <furq> quicksync itself has hardware decoding features but it's accessed through vaapi iirc
[20:21:28 CEST] <Tatsh> well i must not have it built in
[20:21:36 CEST] <furq> which cpu
[20:21:51 CEST] <Tatsh> Intel(R) Core(TM) i7-5930K CPU @ 3.50GHz GenuineIntel
[20:21:58 CEST] <furq> that should definitely have quicksync
[20:22:28 CEST] <nyuszika7h> Tatsh: only used for encoding because it threw errors when trying to decide Hi10P
[20:22:29 CEST] <Tatsh> yea but i don't have it in my build of ffmpeg on gentoo
[20:22:33 CEST] <Tatsh> and there's no USE flag for it
[20:22:40 CEST] <furq> you should be able to use h264_vaapi for encoding now
[20:22:41 CEST] <Tatsh> unless that USE flag is vaapi
[20:22:53 CEST] <furq> qsv isn't recommended any more afaik
[20:23:14 CEST] <nyuszika7h> I just want it to accelerate temporary transcodes to burn in PGS subtitles
[20:23:50 CEST] <nyuszika7h> And it seems I can't use CUVID on my laptop with dual graphics, even if I tell it to run ffmpeg.exe on the NVIDIA GPU
[20:24:13 CEST] <nyuszika7h> h264_cuvid just gives me the exact same fps as libx264
[20:24:35 CEST] <furq> i don't think any hwdec stuff will work with hi10p
[20:24:53 CEST] <Tatsh> 1080 has it
[20:24:57 CEST] <Tatsh> i think
[20:25:02 CEST] <furq> for avc?
[20:25:06 CEST] <Tatsh> i only have a 980 so i lose
[20:25:11 CEST] <furq> newer stuff has hevc main10 support
[20:25:15 CEST] <furq> but that's not the same
[20:25:16 CEST] <Tatsh> yes hevc
[20:25:26 CEST] <Tatsh> my GPU lacks decoding support for main10
[20:25:28 CEST] <Tatsh> but 1080 has it
[20:26:59 CEST] <Tatsh> i'm only finding the hardware acceleration stuff useful for lack of time
[20:27:25 CEST] <Tatsh> although for 4K it's almost unreasonable to use CPU for anything longer than a few minutes
[20:27:37 CEST] <furq> if your build has vaapi then use that instead
[20:35:34 CEST] <ArsenArsen> Hello! Is there any examples/documentation on how to use FFMpeg in C/C++ code in order to do screen recording on Linux, Windows, and Mac OS X? Thanks in advance :)
[20:37:27 CEST] <c_14> probably not, you'd have to use different input devices on each anyway (xcbgrab on linux, avfoundation on linux and one of the options on windows)
[20:38:07 CEST] <ArsenArsen> I've done some reading up on it, I knew about x11grab already, and GDI, but I have no idea what's actually used on OS X.
[20:38:43 CEST] <c_14> I think it's avfoundation on osx, I accidentally wrote linux
[20:38:46 CEST] <BtbN> Just use OBS
[20:39:06 CEST] <ArsenArsen> Can I even do that in my program?
[20:39:24 CEST] <BtbN> It has a library, so I'd assume so
[20:39:44 CEST] <BtbN> The ffmpeg screen capture methods are rather slow and not optimal for anything but a simple screencast
[20:39:51 CEST] <ArsenArsen> Oh, it does? But, still, I think it'd be an overkill to be honest
[20:40:02 CEST] <ArsenArsen> Wait doesn't OBS use ffmpeg?
[20:41:08 CEST] <BtbN> for encoding and decoding, yes.
[20:41:32 CEST] <ArsenArsen> Ahhhh I see
[20:41:32 CEST] <OzgrK> atomnuker: it was k, 384 when i tried, i have missed "k" while writing here, sorry, even for 384k and even for 800k (not sure it is valid though:)) it produces glitches. you may reproduce it with...
[20:41:41 CEST] <OzgrK> ffmpeg -f lavfi -i aevalsrc="sin(32*2*PI*t):s=48000:d=1800" -c:a aac -b:a 800k -f matroska pipe:1 | ffplay -
[20:41:54 CEST] <Tatsh> furq, cool
[20:42:00 CEST] <Tatsh> seems i could use vaapi for a faster deinterlace
[20:42:05 CEST] <Tatsh> and scale
[20:43:56 CEST] <Tatsh> me hating the blurriness of my phone's camera is making me want to buy a pro camera
[20:44:00 CEST] <Tatsh> for both video and photo
[20:45:08 CEST] <atomnuker> OzgrK: if it bothers you and you really want to encode just sine waves you can use -aac_coder anmr
[20:45:30 CEST] <furq> OzgrK: it's  not valid but it just clamps to the maximum valid bitrate
[20:45:35 CEST] <ArsenArsen> At first I wanted to use Qt to capture the screen but came across a few QObject related limitations (such as the non thread safety) of QPixmaps and similar. I could achieve ~100FPS with conversion to RGBA8 though.
[20:45:44 CEST] <atomnuker> else the defaults (not just for aac but really encoders in general) are good enough for music and speech, not sine waves
[21:05:49 CEST] <OzgrK> atomnuker: i confirm that -aac_coder anmr works fine, even with down to -ab 1k :) however i just wanted to report the issue with native aac encoder, since it is not declared experimental anymore but just requires fine tuning for some sound characteristics
[22:07:56 CEST] <grren_flag> evening, I need some help with live freetoair  dvb-t streams going out of sync converted from astra->ffmpeg.  I have 6 streams running and they can play fine for hours, then one wor two will drop out of sync. any help appreciated
[22:10:41 CEST] <grren_flag> ffmpeg -i -vcodec libx264 -preset superfast -s 640x360 -b:v 950k -b:a 96k -ar 44100 -bufsize 1900k -f flv rtmp://
[22:12:17 CEST] <grren_flag> i have noticed watching the raw stream that with the signal in our area it will get the odd glitch and resume to normal but not sure if that is the cause of the stream going out of sync
[22:14:18 CEST] <dystopia_> dvb-t and astra ?
[22:14:29 CEST] <dystopia_> astra runs satellites
[22:14:29 CEST] <grren_flag> cesbo astra
[22:14:33 CEST] <dystopia_> ahh
[22:15:20 CEST] <dystopia_> the transmission glitching is probably what throws it out of sync yes
[22:15:40 CEST] <dystopia_> can happen on a normal encode too
[22:15:46 CEST] <grren_flag> sorry i have a TBS dvbt/c tuner and use cesbo astra to convert to http and then run through ffmpeg
[22:16:40 CEST] <grren_flag> I was wondering if there was something i could put in to either use timestamp or similar to put the stream back into sync
[22:17:04 CEST] <dystopia_> probably best to restart the steam periodically
[22:17:11 CEST] <dystopia_> perhaps at the start of every hour
[22:18:19 CEST] <grren_flag> that is how i originally did things, made a crontab to kill and start ffmpeg every few hours, but it can happen anytime
[22:18:45 CEST] <grren_flag> that and became annoying the stream stopping for a short time every hour
[22:18:57 CEST] <dystopia_> if you run it from a script you could do this https://paste.ofcode.org/R89n9C9Pv9tTLEnze7Pvmx
[22:19:15 CEST] <dystopia_> should only be a couple of seconds
[22:20:12 CEST] <grren_flag> i went the fancy route and installed monit and ran a script to check every 10 seconds if stream died, but that wasnt really a fix as the stream itself stayed solid
[22:21:34 CEST] <grren_flag> do you think changing output from rtmp to mpegts would help or is that not relevant ?
[22:22:04 CEST] <dystopia_> you can try but i don't think it would matter
[22:22:32 CEST] <dystopia_> you could also try not encoding audio and just doing -acodec copy
[22:22:42 CEST] <dystopia_> i doubt it would inflate stream size much
[22:22:48 CEST] <dystopia_> 192k vs 96k
[22:22:56 CEST] <grren_flag> good idea
[22:23:34 CEST] <grren_flag> at least thats one thing to try
[22:24:39 CEST] <furq> i doubt that'll work if you're going from dvb-t to rtmp
[22:24:50 CEST] <furq> dvb-t audio is usually either mp2 or ac3
[22:24:54 CEST] <furq> neither of which are supported in flv iirc
[22:26:05 CEST] <grren_flag> ok so mpegts  supported ?
[22:26:14 CEST] <furq> not by rtmp
[22:26:29 CEST] <grren_flag> source is ac3
[22:26:41 CEST] <furq> mpegts supports ac3, but rtmp doesn't support mpegts
[22:26:44 CEST] <furq> it's flv only
[22:27:44 CEST] <grren_flag> well i only ouput to rtmp as thats all i have tried
[22:28:01 CEST] <grren_flag> its not a requirement
[22:28:17 CEST] <furq> i take it you have a good reason for not just watching the source stream
[22:28:45 CEST] <grren_flag> yes mainly for watching over 3/4g
[22:29:42 CEST] <grren_flag> and we have a holiday apartment we are planning to use
[22:31:26 CEST] <grren_flag> just very frustrating seeing ffmpeg working really well for our needs and the sync issue ruining the whole experience
[22:31:41 CEST] <furq> well yeah rtsp supports ac3 audio but i couldn't tell you a worthwhile rtsp server
[22:31:46 CEST] <furq> and also i doubt it'll fix the issue
[22:31:57 CEST] <furq> in my experience ffmpeg tends to have worse sync issues when copying streams
[22:33:23 CEST] <grren_flag> what i can say is thata while back I replicated the whole process from a fta sat stream using an old hauppage card I had and it worked a charm, ran for about 2 weeks with no sync issues
[22:33:43 CEST] <grren_flag> using the eact same ffmpeg comamnd
[22:34:03 CEST] <furq> yeah it wouldn't surprise me if transmission errors were throwing it out of sync
[22:34:30 CEST] <furq> ffmpeg isn't very robust when things go wrong
[22:34:49 CEST] <grren_flag> just my luck that the 6 channels we watch arenet available on sat
[22:35:13 CEST] <grren_flag> yes ive seen that, but on other hand when things are right its also very robust
[22:35:56 CEST] <furq> you could maybe try adding -xerror to the command
[22:36:19 CEST] <furq> that'll quit as soon as an error happens
[22:36:24 CEST] <furq> i'm not sure if a decode error will trigger it though
[22:36:36 CEST] <grren_flag> ok reading up now on xerror
[22:37:10 CEST] <grren_flag> i agree i think that if ffmpeg saw the error id expect the stream to drop and monit to restart the stream
[22:37:23 CEST] <grren_flag> but from monit los the streams never drop
[22:37:25 CEST] <furq> well you could just run it in a shell loop if that works
[22:37:35 CEST] <furq> decoder errors normally show up as warnings though
[22:38:19 CEST] <grren_flag> how do you mean shell loop ?
[22:38:25 CEST] <furq> while 1; do ffmpeg ...; done
[22:38:40 CEST] <grren_flag> right
[22:39:59 CEST] <grren_flag> i'll give xerror a go anyway, do I just put that at the end of the commad ?
[22:40:07 CEST] <grren_flag> after the rtmp output ?
[22:40:13 CEST] <furq> probably before the output
[22:40:50 CEST] <grren_flag> ffmpeg -i -vcodec libx264 -preset superfast -s 640x360 -b:v 950k -b:a 96k -ar 44100 -bufsize 1900k -xerror  -f flv rtmp://
[22:40:53 CEST] <grren_flag> look right ?
[22:40:56 CEST] <furq> yeah
[22:41:00 CEST] <grren_flag> ok thanks
[22:41:06 CEST] <furq> it's a global option so it might work after the output, i forget
[22:41:09 CEST] <furq> it'll definitely work before though
[22:41:32 CEST] <grren_flag> ok ill give it a go and report later on findings. really appreciate the help
[22:41:55 CEST] <grren_flag> dystopia also, thanks
[22:43:24 CEST] <OzgrK> I have a question about vp9 decoding in ff*. i made a video using  -i https://upload.wikimedia.org/wikipedia/commons/c/c4/PM5544_with_non-PAL_signals.png -vf loop=size=1:loop=-1,hue=h=t*360/57600 -t 57600
[22:43:28 CEST] <OzgrK>  and encoded it as lossless vp9 using -pixel_format yuv420p -c:v libvpx-vp9 -lossless 1
[22:43:36 CEST] <OzgrK> the resulting videos decodes "wrong?" with ffplay. I'll explain what i mean by "wrong?" but vlc, and even firefox and chrome decodes "right". since the video is decoded "wrong" in ff*, ffmpeg encodes what it decodes and my transcodes to other encoders are also "wrong?".
[22:43:56 CEST] <OzgrK> by saying "wrong" i mean that the colors in the second columns from each side of the test chart in input https://upload.wikimedia.org/wikipedia/commons/c/c4/PM5544_with_non-PAL_signals.png are gone and those columns are just gray when ff* decodes.
[22:44:07 CEST] <OzgrK> There are tiny vertical color lines in the original image as you can see in the png image in the link above. vlc, firefox and chrome decodes as the input png image, but ff* plays "wrong?" and also mplayer(smplayer) decodes the same as ff*. Any idea? Is there a problem with decoding vp9 in ff*? thanks
[00:00:00 CEST] --- Tue May 23 2017

More information about the Ffmpeg-devel-irc mailing list