[Ffmpeg-devel-irc] ffmpeg.log.20170523

burek burek021 at gmail.com
Wed May 24 03:05:01 EEST 2017

[00:01:15 CEST] <lystra> Hi. I am trying to burn in Arabic subtitles to a video I created. I can do this for the English subtitles but the Arabic subtitles are not displaying correctly. I used Aegisub to create the subtitles, am using the Scheherazade Arabic font, and have the encoding in Aegisub set to "178 - Arabic". The subtitles are appearing as https://imagebin.ca/v/3NO5qw3AH8j9. My ffmpeg command and output is at https://pastebin.com/iwaJJy07. Any ideas?
[00:01:15 CEST] <lystra> I tried playing around with -metadata:s:s:0 language=ara,-metadata:s:s:0 language=arb, and -sub_charenc ARABIC as well.
[00:01:48 CEST] <Tatsh> the guy says 'shshshshshshshs'
[00:01:52 CEST] <Tatsh> :)
[00:03:32 CEST] <furq> lystra: it's probably an issue with libass
[00:03:48 CEST] <furq> afaik it needs to have harfbuzz and fribidi support
[00:03:55 CEST] <Tatsh> yes
[00:04:03 CEST] <Tatsh> i have that stuff built on my machine everywhere
[00:04:09 CEST] <Tatsh> fribidi global USE flag on gentoo
[00:05:21 CEST] <lystra> On my system, ffmpeg links to /usr/lib/x86_64-linux-gnu/libass.so.5 which is linked to harfbuzz and fribidi.
[00:05:39 CEST] <lystra> I am running Mint 18.
[00:06:11 CEST] <Tatsh> o
[00:06:14 CEST] <Tatsh> i'm getting the same output
[00:06:30 CEST] <Tatsh> all shin and and the vowel marks show
[00:06:36 CEST] <Tatsh> the ! is on the left side though for me
[00:06:58 CEST] <Tatsh> could it be the font?
[00:07:11 CEST] <lystra> I am using this font in LaTeX to display Arabic text fine.
[00:07:58 CEST] <Tatsh> amiri font works
[00:08:45 CEST] <Tatsh> it shows correctly at 3.3: marhaban baina
[00:08:57 CEST] <lystra> I could easily switch the font force_style but I doubt it would matter.
[00:08:59 CEST] <Tatsh> but it's like !marhaban baina :P
[00:09:10 CEST] <Tatsh> make sure you get those order markers in however you can
[00:09:14 CEST] <Tatsh> it's confusing as hell
[00:09:35 CEST] <Tatsh> braina*
[00:09:56 CEST] <Tatsh> lystra, try the amiri font if that is an acceptable font
[00:09:56 CEST] <lystra> Tatsh: I'll try Amiri. No idea why it would work.
[00:10:12 CEST] <Tatsh> http://www.amirifont.org/
[00:10:17 CEST] <Tatsh> it's a bit old school
[00:10:28 CEST] <Tatsh> and i don't see any of those straight fonts available for free much
[00:11:07 CEST] <lystra> Debian provides that font in the fonts-hosny-amiri package.
[00:11:28 CEST] <Tatsh> i don't see why amiri works and not the other
[00:11:49 CEST] <Tatsh> with my fontconfig, amiri is my default arabic-script font
[00:12:17 CEST] <lystra> Tatsh: Amiri works. Odd. Trying the new Dubai font.
[00:14:19 CEST] <lystra> Well, the new Dubai font mostly works though some characters aren't being displayed. Something else seems amiss here.
[00:16:44 CEST] <lystra> Amiri Quran doesn't work. I get boxes like with Scheherazade.
[00:21:51 CEST] <Tatsh> hmm very weird
[00:24:40 CEST] <lystra> Tatsh: Thanks.
[00:25:18 CEST] <Tatsh> fontconfig is involved with libass
[00:25:23 CEST] <Tatsh> so try and adjust mine
[00:25:54 CEST] <Tatsh> https://gist.github.com/Tatsh/ca2b0cd61cf6ffb5c0e4
[00:26:26 CEST] <Tatsh> 219 covers arabic
[00:50:07 CEST] <lystra> Tatsh: Ok, thanks.
[01:41:09 CEST] <pqatsi> Hello! Can I get help here about GPAC? If not, where can I ask a question?
[02:36:50 CEST] <hellfar_> Hi everyone :) !
[02:36:50 CEST] <hellfar_> I came here because I have a log that proposes me to expose my problem here on this chanel.
[02:36:50 CEST] <hellfar_> I am trying to install ffmpeg, but can't `configure` it.
[02:36:50 CEST] <hellfar_> My command:
[02:36:50 CEST] <hellfar_> `./configure --enable-gpl --enable-postproc --enable-swscale --enable-avfilter --enable-libmp3lame --enable-libvorbis --enable-libtheora --enable-libx264 --enable-libspeex --enable-shared --enable-pthreads`
[02:37:11 CEST] <hellfar_> I was following this instructions:
[02:37:11 CEST] <hellfar_> https://www.assetbank.co.uk/support/documentation/install/ffmpeg/
[02:37:57 CEST] <hellfar_> And the configure script return me the following message:
[02:37:57 CEST] <hellfar_> "ERROR: speex not found using pkg-config"
[02:38:08 CEST] <furq> what does config.log say
[02:39:03 CEST] <hellfar_> ```
[02:39:04 CEST] <hellfar_> check_pkg_config speex speex/speex.h speex_decoder_init -lspeex
[02:39:04 CEST] <hellfar_> pkg-config --exists --print-errors speex
[02:39:04 CEST] <hellfar_> Package speex was not found in the pkg-config search path.
[02:39:04 CEST] <hellfar_> Perhaps you should add the directory containing `speex.pc'
[02:39:05 CEST] <hellfar_> to the PKG_CONFIG_PATH environment variable
[02:39:07 CEST] <hellfar_> No package 'speex' found
[02:39:10 CEST] <hellfar_> ERROR: speex not found using pkg-config
[02:39:12 CEST] <hellfar_> ```
[02:40:29 CEST] <hellfar_> I do not really know if I installed the libspeex properly.
[02:40:29 CEST] <hellfar_> I made `sudo apt-get install speex` and it told me "speex is already the newest version.".
[02:40:42 CEST] <furq> install libspeex-dev
[03:14:12 CEST] <hellfar_> It worked :) !
[03:21:12 CEST] <hellfar_> But then after trying to `configure` again, this is now with `libx264` I having the same problem, `x264` passed.
[03:21:52 CEST] <DHE> same thing? x264-devel ?
[03:21:57 CEST] <DHE> err, dev
[03:22:00 CEST] <furq> libx264-dev
[03:22:35 CEST] <furq> or you know
[03:22:36 CEST] <furq> https://www.johnvansickle.com/ffmpeg/
[03:22:39 CEST] <furq> just install that
[04:40:20 CEST] <hellfar_> Thanks, I was having another issue finally compiling ffmpeg ^^
[04:40:20 CEST] <hellfar_> But with the builds you showed me the gem I was trying to use works now fine :)
[04:40:25 CEST] <hellfar_> Thanks a lot !
[05:22:57 CEST] <fullstack> is there a way to run ffmpeg to record a 720 IP camera that supports RTSP ONVIF?
[05:23:14 CEST] <fullstack> record rtsp to disk.
[05:34:20 CEST] <teratorn> fullstack: sure, ffmpeg -i rtsp://host:port/blah save.mp4, for example
[05:39:31 CEST] <npnth> Is there a way to strip all EXIF data from a jpg?  I'm looking for something like what `jhead -purejpg' does.
[05:40:08 CEST] <npnth> I've been trying things like `ffmpeg -i JF4_021962.jpg -map_metadata -1 -c:v copy JF4_021962_maybe_stripped.jpg', but this still leaves lots of information.
[05:41:22 CEST] <npnth> (Perhaps "EXIF" is the wrong term - maybe I should say "I want all removable metadata removed" or something.)
[08:23:36 CEST] <k_sze[work]> If I have a streaming source that is just a bunch of jpeg packets, is there an easy way to pipe it into ffmpeg and mux it as mjpeg?
[08:23:44 CEST] <k_sze[work]> (losslessly, of course)
[11:02:21 CEST] <Guest69723> Hello, I am trying to use ffmpeg in a Unity project, but I keep getting a segfault on sws_scale. Frames are decoded correctly (I saved them in a file and was able to print them) but sws_scale keeps segfaulting. Here is my code : https://pastebin.com/5fJFBCXy
[11:03:37 CEST] <Guest69723> If you can help me, I spent all my day yesterday trying to find this segfault, i'm using ffmpeg 3.3 and an C# wrapper
[12:39:09 CEST] <DHE> Guest69723: sws_ctx is global? second execution sws_ctx wont' be null and you won't allocate the output buffer
[12:39:16 CEST] <DHE> (not a C# programmer, may be missing more)
[12:40:41 CEST] <Guest69723> no, DecodeFrame is a method of a class, sws_ctx is a member of the class
[12:41:10 CEST] <Guest69723> I suspect the wrapper to have someproblems
[12:41:27 CEST] <Guest69723> i an currently switching to an older release, see if it fixes the problem
[12:42:40 CEST] <Guest69723> thanks for your answer x)
[12:43:44 CEST] <DHE> line 23 should not be inside that if(){} block
[12:43:53 CEST] <DHE> that's what I'm seeing
[13:24:20 CEST] <thebombzen> fullstack: if you're going to do that, I recommend using -c copy
[13:24:45 CEST] <thebombzen> as in ffmpeg -i rtsp://whatever -c copy save.mkv
[15:07:32 CEST] <rofl____> more cpu cores or cpu with intel quicksync for encoding/decoding with ffmpeg?
[15:07:38 CEST] <rofl____> intel quicksync cpus have 4 cores at most
[15:08:35 CEST] <Mavrik> If you want good quality you don't use quicksync anyway
[15:10:00 CEST] <rofl____> oh, right
[15:25:40 CEST] <OT2_> Hello, I an Unity app using ffmpeg, it has to work on android and windows. I got the avcodec-57.dll and so on prebuild and they are working great. I finaly managed to build the android lib.so equivalents. but i noticed that the android libs are looking for each other using symbolic links : for example libavcodec-57.so looks for libavutil-55.so by using the symbolic link libavutil.so. Is there a way to compile ffmpegs libs so that they look directly for libs
[15:25:40 CEST] <OT2_> without using symbolic links ?
[15:27:04 CEST] <JEEB> OT2_: I'm pretty sure if you configure FFmpeg so that it notices it's android, then it disables SONAMEs
[15:27:22 CEST] <JEEB> might only happen with install target so set --prefix according to where your linker is looking
[15:27:34 CEST] <JEEB> and then `make insta`
[15:27:37 CEST] <JEEB> *install
[15:28:28 CEST] <OT2_> i build it for android with --target-os=android and --arch=arm
[15:29:13 CEST] <OT2_> but I have to include my libsavcodec-57.so and a copy of them without the version for it to work
[15:29:26 CEST] <JEEB> yes, so you are not running the install target :P
[15:29:36 CEST] <JEEB> as that should disable SONAMEs at that point
[15:29:40 CEST] <OT2_> what do you mean ?
[15:30:03 CEST] <JEEB> it removes the SONAMEs when it installs the libraries into your prefer
[15:30:04 CEST] <OT2_> should i past you my ./configure command ?
[15:30:04 CEST] <JEEB> *prefix
[15:30:33 CEST] <JEEB> for example I would do it --prefix=/home/user/armv7_prefix
[15:30:45 CEST] <JEEB> and then make install would put the headers and libraries there under include/lib
[15:31:10 CEST] <JEEB> you're not supposed to use the files from the build tree as-is
[15:31:42 CEST] <OT2_> you mean i am not supposed to get the libs from ffmpegfolder/libavcodec/libavcodec-57.so
[15:31:58 CEST] <OT2_> wait a moment I check what I did, thanks
[15:31:59 CEST] <JEEB> yes.
[15:32:11 CEST] <JEEB> you set a prefix and do make install
[15:32:27 CEST] <OT2_> I do have set a prefix
[15:32:28 CEST] <JEEB> that way you get things and a pkg-config file set correctly :P
[15:32:41 CEST] <OT2_> but the folder is empty after compile
[15:32:43 CEST] <JEEB> OT2_: hopefully not the default /usr/local
[15:33:14 CEST] <OT2_> no its /mnt/e/ffmpegbuild (im using ubuntu bash for windows)
[15:33:15 CEST] <JEEB> OT2_: well make install is the step does the final changes putting things into the configured prefix
[15:33:21 CEST] <OT2_> oh ahah
[15:33:25 CEST] <OT2_> i did not make install
[15:33:26 CEST] <OT2_> my bad
[15:33:45 CEST] <OT2_> idk I always assumed it was to imstall ffmpeg executable file
[15:34:02 CEST] <JEEB> it also installs that under bin/ :P
[15:34:19 CEST] <JEEB> if you build it that is
[15:35:02 CEST] <OT2_> nice
[15:35:11 CEST] <OT2_> seems to do what i expect
[15:35:31 CEST] <OT2_> but is it possible to have them called libavcodec-57.so instead of libavcodec.so
[15:35:50 CEST] <JEEB> android doesn't support SONAMEs
[15:35:53 CEST] <OT2_> as my windows .dll have the version in it
[15:35:56 CEST] <JEEB> that's why they get removed
[15:36:24 CEST] <OT2_> i dont mean libavcodec.so.57 i mean libavcodec-57.so
[15:36:48 CEST] <OT2_> and that they look for each others with this syntax
[15:37:22 CEST] <JEEB> anyways, no.
[15:38:13 CEST] <OT2_> Okay i will figure a way to get it working in the C# wrapper. thank you, helped a lot
[15:45:57 CEST] <OT2_> one more question : when I compile ffmpeg it say pkg-config not found (seems like not included in android-ndk) and WARNING : using x264 without pkg-config
[15:46:18 CEST] <OT2_> can i ignore those warnings ?
[15:48:11 CEST] <JEEB> yes as long as your build works OK. and yea, NDK doesn't have pkg-config, you can usually utilize the pkg-config that comes with your distro.
[15:48:56 CEST] <JEEB> just make a shell script with the NDK cross-prefix that sets PKG_CONFIG_LIBDIR to /path/to/prefix/lib/pkgconfig
[15:49:28 CEST] <JEEB> and then the script just runs `exec pkg-config "$@"` after setting PKG_CONFIG_LIBDIR
[15:50:00 CEST] <JEEB> in my case the script is called arm-linux-androideabi-pkg-config
[15:50:09 CEST] <JEEB> as I build for armv7
[15:54:57 CEST] <OT2_> Build worked so I will not worry about, for the moment x)
[16:58:07 CEST] <james999> NDK = Nvidia Development Kit?
[16:59:06 CEST] <Mihaylov> Hello
[16:59:16 CEST] <Mihaylov> "ffmpeg -i in.mkv -f segment -segment_time 10 -segment_format_options movflags=+faststart out%03d.mp4"
[16:59:27 CEST] <Mihaylov> -segment_time X is in seconds?
[16:59:48 CEST] <Mihaylov> -segment_time 600 splits the video in 20 minutes which I see no relation
[17:00:03 CEST] <sfan5> james999: it's referring to the Android NDK (Native Development Kit) in that case
[17:01:20 CEST] <Mihaylov> i tought it was seconds so i put 1200  for 20 minutes and it splited the video in 40 minutes, its logical that if 1200 40 min, then 600 = 20 min but that value makes no sense
[17:01:37 CEST] <Mihaylov> what unit is the -segment_time parameter?
[17:14:09 CEST] <kepstin> Mihaylov: it is in seconds, but whether or not it can split at the desired times depends on keyframe locations. That said, it being almost exactly double what you set is really strange& is this a really low fps video?
[17:14:31 CEST] <furq> do the segments play back correctly
[17:15:01 CEST] <dystopia_> 50fps played back at 25fps for maybe?
[17:15:26 CEST] <Mihaylov> They do play correctly
[17:16:09 CEST] <furq> well yeah that should work
[17:16:26 CEST] <furq> could you pastebin the ffprobe output for the input and one of the segments
[17:21:30 CEST] <Mihaylov> input: https://pastebin.com/TAyPAcND
[17:22:23 CEST] <Mihaylov> segment: https://pastebin.com/aM4qXspp
[17:35:48 CEST] <dystopia_> Duration: 00:10:01.28, start: 0.000000, bitrate: 4543 kb/s
[17:36:03 CEST] <dystopia_> it's 10min's long or 600sec's
[17:36:22 CEST] <dystopia_> also it is 50fps, maybe your media player was trying to play it back at 25fps
[17:36:55 CEST] <Mihaylov> oops i sent the last segment
[17:37:00 CEST] <Mihaylov> wich is 10 because no more video
[17:37:45 CEST] <Mihaylov> im using vlc
[17:38:08 CEST] <Mihaylov> ah no my bad, i sent you the right fragment
[17:39:27 CEST] <Mihaylov> You are right, its 10 min and vlc is playing it at 20 min
[17:40:31 CEST] <Mihaylov> weird the audio is perfect
[17:42:41 CEST] <Mihaylov> Tools >>> Codec information says 50 fps
[17:43:53 CEST] <dystopia_> i am unsure
[17:44:05 CEST] <dystopia_> it's an issue with vlc and not ffmpeg though
[17:44:12 CEST] <dystopia_> if you are on windows, try mpc
[17:54:30 CEST] <Mihaylov> dystopia_ I just made a test, played the video for 10 min, even when it shows that the total duration is 20 min
[17:54:50 CEST] <Mihaylov> it finished at 10 min
[18:04:43 CEST] <Mihaylov> got to go, thanks for the enlightment
[18:44:50 CEST] <alexpigment> hey guys. i'm trying to build a LGPL version of ffmpeg on Mac, and I've historically built with Homebrew
[18:45:25 CEST] <alexpigment> I need to access the configure file prior to building/installing, but I have no idea where this is saved
[18:45:34 CEST] <alexpigment> does it save a git somewhere before installing?
[18:47:02 CEST] <DHE> configure will set up everything for building based on what you want. if you want lgpl, do NOT specify --enable-gpl to it
[18:47:54 CEST] <alexpigment> am i right in thinking that what you're suggesting is incompatible with Homebrew?
[18:48:23 CEST] <sfan5> why do you need access to the configure file?
[18:48:35 CEST] <sfan5> also this sounds like something you should be asking the homebrew people instead
[18:49:00 CEST] <alexpigment> because i'm going to be commercially licensing x264, and so I need to include x264 but still create an LGPL build of ffmpeg
[18:49:05 CEST] <DHE> I don't know the specifics or homebrew. if you don't redistribute what you build you're allowed to do whatever you want with it
[18:49:11 CEST] <DHE> oh... well then...
[18:49:55 CEST] <DHE> this is a known issue where libx264 support doesn't properly handle the situation of where you buy an x264 license. you would have to hack it to override the GPL requirement
[18:50:01 CEST] <alexpigment> i'm just a real novice with compilation, and I've got a build script for compiling on Windows via Linux, and I've got that fully configured as necessary. i just don't know how to replicate that for an OS X build
[18:50:24 CEST] <sfan5> you will need to take a look at the instructions brew runs to build ffmpeg and edit those
[18:50:28 CEST] <alexpigment> DHE: done and done with my Windows builds. I just have no idea what I'm doing on macOS
[18:50:39 CEST] <alexpigment> k
[18:50:48 CEST] Action: alexpigment digs into things he clearly doesn't understand ;)
[18:54:31 CEST] <Fare> Weird. I'm trying to use ffmpeg to record myself doing a presentation. I can record either the sound or the video just fine, but trying to do both results in garbled sound.
[18:57:33 CEST] <furq> alexpigment: it looks like you can run preinstall commands with brew edit
[18:57:47 CEST] <furq> so i guess just call sed before configure
[19:04:50 CEST] <alexpigment> furq: thanks for the info. i'm having to google things to actually process what you're saying, but i'll get back to you once i have a basic understanding of sed
[19:05:55 CEST] <furq> sed -i '1504d' configure
[19:06:27 CEST] <furq> obviously you'll need to change the line every time configure is updated
[19:06:53 CEST] <alexpigment> is 1504d the current build?
[19:07:05 CEST] <furq> line 1504
[19:07:07 CEST] <furq> the one you want to remove
[19:07:51 CEST] <alexpigment> ok
[19:07:56 CEST] <alexpigment> apologies, i'm just really lost here
[19:08:14 CEST] <alexpigment> a) i can't find a configure file on my computer - so that may be problem #1
[19:08:34 CEST] <alexpigment> b) if i try to use brew edit in the termal, i get this interface where i have to choose a directory
[19:08:41 CEST] <furq> if brew builds it on your machine then i assume it downloads that when you install it
[19:08:51 CEST] <alexpigment> i assume so too
[19:09:08 CEST] <alexpigment> i just don't know how to get it to download, let me edit, then finish the build process
[19:09:32 CEST] <furq> are you doing `brew edit ffmpeg`
[19:10:21 CEST] <alexpigment> no, i wasn't, but i'm doing that now
[19:10:33 CEST] <alexpigment> and when i do it, i get the ffmpeg.rb file which i already was able to manually edit
[19:10:55 CEST] <alexpigment> in this file, i can delete --enable-gpl , but then i get an error that x264 is gpl only
[19:11:08 CEST] <furq> right, that's why you need to remove a line from configure
[19:11:19 CEST] <alexpigment> so i really need to get access to the configure file to edit its list of GPL packages
[19:11:27 CEST] <furq> https://github.com/FFmpeg/FFmpeg/blob/master/configure#L1504
[19:11:28 CEST] <alexpigment> right, and that's what i'm not sure of how to do
[19:12:25 CEST] <furq> i assume you just add system("sed", "-i" "1504d", "configure") just before configure is invoked
[19:13:05 CEST] <alexpigment> ok, does this make sense to you?
[19:13:13 CEST] <alexpigment> i typed in sed -i '1504d' configure
[19:13:38 CEST] <alexpigment> and terminal says "sed: 1: "configure": command c expects \ followed by text
[19:14:17 CEST] <furq> oh right i forgot bsd sed requires an argument to -i
[19:14:24 CEST] <furq> sed -i '' '1504d' configure
[19:15:05 CEST] <alexpigment> no such file or directory
[19:15:11 CEST] <furq> tbh you should probably do that using regex given that this is a ruby script
[19:15:19 CEST] <furq> but i'd rather not remember how to use ruby
[19:15:26 CEST] <alexpigment> ok
[19:15:31 CEST] <furq> where are you running that
[19:15:42 CEST] <alexpigment> i'm just in terminal
[19:15:47 CEST] <furq> oh
[19:15:56 CEST] <furq> well yeah it won't exist until brew downloads it
[19:16:00 CEST] <alexpigment> right
[19:16:01 CEST] <alexpigment> :)
[19:16:18 CEST] <alexpigment> sorry, i tried to make that clear earlier, but i didn't do a good enough job
[19:16:27 CEST] <alexpigment> configure doesn't exist on my computer yet
[19:16:58 CEST] <alexpigment> so i'm really looking for a way for homebrew to start its thing, download git, PAUSE so i can edit the configure file, then go along its merry way
[19:17:14 CEST] <furq> https://github.com/Homebrew/brew/blob/master/docs/Formula-Cookbook.md#grab-the-url
[19:17:36 CEST] <furq> add `system("sed", "-i" "1504d", "configure")` at the top of `def install`
[19:18:03 CEST] <alexpigment> got it
[19:18:04 CEST] <alexpigment> 1 sec
[19:18:05 CEST] <alexpigment> btw
[19:18:19 CEST] <alexpigment> what am i doing with line 1504 with this command?
[19:18:21 CEST] <alexpigment> just deleting it?
[19:18:23 CEST] <furq> yeah
[19:18:25 CEST] <alexpigment> because i think i need to be moving it
[19:18:34 CEST] <alexpigment> to the non-gpl list
[19:18:47 CEST] <alexpigment> is there a move command?
[19:19:51 CEST] <furq> oh right
[19:20:15 CEST] <furq> 1504d,1550ilibx264
[19:20:32 CEST] <furq> this isn't a particularly good solution anyway because it breaks if the line numbers change
[19:20:38 CEST] <alexpigment> ok, so that's literally inserting the line text
[19:20:41 CEST] <alexpigment> right
[19:20:41 CEST] <furq> yeah
[19:20:58 CEST] <alexpigment> let's hope the order of this is chronological
[19:21:08 CEST] <alexpigment> because otherwise we might tear the fabric of space and time
[19:21:12 CEST] <alexpigment> ;)
[19:23:27 CEST] <alexpigment> just to clarify, should it be "1504d,1550ilibx264", "configure"
[19:23:33 CEST] <furq> yeah
[19:23:40 CEST] <alexpigment> or should each command be in its own quote?
[19:29:49 CEST] <alexpigment> ok, the syntax fails, and i've edited it several times to no avail. is it easier to put a line in there that manually replaces the configure file with one either on my system or on a webserver?
[19:30:05 CEST] <furq> maybe
[19:30:37 CEST] <alexpigment> ok, i'm going to see what i can do here
[19:34:24 CEST] <alexpigment>  man, wish i just knew where the hell the files were being downloaded to. macOS is so bad about obscuring things like this
[19:34:44 CEST] <alexpigment> i can't even watch the date modified changes to follow the folders
[19:53:24 CEST] <alexpigment> furq: well, it turns out it's easier to just create my own tarball and reference that as the download
[19:53:39 CEST] <alexpigment> thanks for your help on this, as it ultimately led me to a solution
[19:53:50 CEST] <alexpigment> even if i was confused as hell there for a bit :)
[20:05:59 CEST] <fullstack>    Active: failed (Result: exit-code) since Tue 2017-05-23 08:50:01 PDT; 2h 15min ago
[20:06:02 CEST] <fullstack>   Process: 22132 ExecStop=/usr/bin/zmpkg.pl stop (code=exited, status=1/FAILURE)
[20:10:49 CEST] <fullstack> [Note] Aborted connection 642142 to db: 'zm' user: 'zmuser' host: 'localhost' (Got an error reading communication packets)
[20:11:01 CEST] <fullstack> that's in the mysql log like 10x per second continously
[20:18:03 CEST] <blue_misfit> hey guys! I'm doing something like -ss 5000 -i file.mov -to 30 to extract 30 second chunks from a big ProRes MOV file and _sometimes_ the output is out of sync
[20:18:08 CEST] <blue_misfit> any suggestions on how to debug / troubleshoot?
[20:18:52 CEST] <c_14> fullstack: doesn't seem related to ffmpeg
[20:19:05 CEST] <fullstack> c_14 thanks
[20:20:31 CEST] <blue_misfit> this looks kinda suspicious: [mov @ 000000000262a740] timecode: tbc=24000/1 invalid, fallback on 24000/1001
[20:36:47 CEST] <ChocolateArmpits> blue_misfit, is the output out of sync when you seek after the input?
[20:37:27 CEST] <blue_misfit> like, if I take the output file and play it, and seek around inside, does it stay out of sync?
[20:37:39 CEST] <ChocolateArmpits> I mean place -ss after the input
[20:37:45 CEST] <blue_misfit> oh
[20:38:29 CEST] <ChocolateArmpits> it'll take longer to seek, but solves quite a few common problems
[20:38:46 CEST] <blue_misfit> interesting
[20:39:02 CEST] <blue_misfit> problem is it's a 200 GB file which is in cloud storage which we're addressing via https so it will have to read the whole file, huh?
[20:39:12 CEST] <blue_misfit> I'm pulling it down locally to test anyway
[20:40:49 CEST] <ChocolateArmpits> -ss when used as an input option skips the stream, when used as an output option decodes everything prior to the point
[20:41:34 CEST] <blue_misfit> right
[20:42:10 CEST] <blue_misfit> seems like ss for the input option is ideal for our case, and it usually works fine but some files are problematic like this
[20:42:21 CEST] <blue_misfit> any words of wisdom for identifying the root cause of that?
[20:43:07 CEST] <ChocolateArmpits> first thing  make sure you are using latest ffmpeg
[20:43:22 CEST] <blue_misfit> k
[20:43:34 CEST] <blue_misfit> will start with latest zeranoe build on windows
[20:44:39 CEST] <ChocolateArmpits> Does the sync issue happen for specific files or is it random? If for example you skipped a problematic file at a different point does the sync issue still occur ?
[20:45:01 CEST] <blue_misfit> it does, I pulled a chunk from earlier in the file and it's still out of sync, just less so
[20:45:51 CEST] <ChocolateArmpits> are you doing stream copy or reencoding too ?
[20:46:33 CEST] <blue_misfit> for this test it's all stream copy
[20:46:42 CEST] <blue_misfit> but in the real workflow we transcode with libx264
[20:46:55 CEST] <blue_misfit> split and stitch scale-out cloud transcoding workflow, pretty standard
[20:54:57 CEST] <ChocolateArmpits> blue_misfit, pretty hard to say, but there are a few things you can play with. try using -r as an input option, try transcoding the audio while the video stream is left to be copied, check out -copyts, -copytb. Try rewriting timestamps using asetpts/setpts
[20:55:10 CEST] <ChocolateArmpits> try any of them
[21:16:26 CEST] <blue_misfit> ChocolateArmpits, thank you :) I will do some testing
[21:23:01 CEST] <blue_misfit> ChocolateArmpits, turns out this was just a bad source file LOL but thanks regardless
[21:23:11 CEST] <ChocolateArmpits> np
[21:39:26 CEST] <OzgrK> Hi, the following command gives "error marking filters as finished" error filling the ram and putting the system in unstable position for version N-86175-g64ea4d1 however it works fine for one of the previous versions, version N-82324-g872b358. Any ideas?
[21:39:33 CEST] <OzgrK> ffmpeg -f lavfi -i aevalsrc="sin((1000-t*0.0086805)*2*PI*t):s=48000:d=9" -i https://upload.wikimedia.org/wikipedia/commons/c/c4/PM5544_with_non-PAL_signals.png -vf loop=size=1:loop=-1,hue=h=t*360/57600 -t 9 -pixel_format yuv420p -c:v libvpx-vp9 -lossless 1 -c:a libvorbis -qscale:a 10 test1.webm
[22:56:04 CEST] <faLUCE> is there any wrapper library for ffplay ?
[23:03:51 CEST] <kepstin> no, ffplay is basically a demo implementation of a player using the ffmpeg libraries
[23:04:46 CEST] <faLUCE> kepstin: I'm searching for a shorter code than ffplay.c, in order to see a http mpegts stream
[23:05:14 CEST] <teratorn> OzgrK: you're saying that command causes errors to be printed, and it leaks memory until your system becomes unstable?
[23:05:41 CEST] <kepstin> faLUCE: why can't you just use an existing player, e.g. mpv?
[23:05:56 CEST] <faLUCE> kepstin: because I have to optimize the latency
[23:06:04 CEST] <faLUCE> (when receiving the http stream)
[23:06:48 CEST] <teratorn> OzgrK: if I wanted to track it down to the commit that introducted the problem I would probably use git bisect
[23:06:53 CEST] <kepstin> hmm, if you can't do it with configuring mpv, then I guess you are gonna have to write your own player :/
[23:08:11 CEST] <faLUCE> kepstin: I tried the dranger tutorial:  http://dranger.com/ffmpeg/tutorial04.html. It works for video only, but doesn't work, with the 3.x version of ffmpeg, for audio+video
[23:21:20 CEST] <james999> dranger tutorial? you mean your tutorial faLUCE?
[23:24:17 CEST] <ChocolateArmpits> faLUCE,  have you tried suggested settings for mpv here (wm4's answer)? https://github.com/mpv-player/mpv/issues/4213
[23:25:44 CEST] <faLUCE> ChocolateArmpits: no, mpv has bad support for http-mpegts
[23:25:52 CEST] <ChocolateArmpits> so that's another issue
[23:25:56 CEST] <faLUCE> james999: I mean dranger tutorial
[23:26:17 CEST] <OzgrK> teratorn: yes, it prints "error marking filters as finished" and leaks memory until i quit ffmpeg and sometimes causes the system crash totally and reboot. but for version N-86175-g64ea4d1, not for version N-82324-g872b358, for example. i had no problem until i upgraded ffmpeg
[23:28:08 CEST] <teratorn> OzgrK: well if it is still broken on git master, I would try to git bisect to find the commit that introduced the regression
[23:28:32 CEST] <teratorn> OzgrK: then use the mailing list to try and get it fixed
[23:31:07 CEST] <OzgrK> i will report it to user e-mail, i am not technically capable, thanx
[23:51:50 CEST] <asmand> Hello there, I have a problem with dvb_subtitle stream copying to mkv. The problem manifests itself as unreadable subtitle stream (reported by VLC). Input file is mpegts, a straight copy of the streams I want, to output format mpegts works as expected. Output https://pastebin.com/Mfdqw2JN
[23:53:00 CEST] <asmand> If I change the output container to mkv, however, the subtitle track is unrecognized, and we see something odd in the output: https://pastebin.com/V7hwnmyr
[23:54:21 CEST] <asmand> The key differences is that with mpegts, the output metadata says "Stream #0:2(fin): Subtitle: dvb_subtitle ([6][0][0][0] / 0x0006)", while the same line for matroska says "Stream #0:2(fin): Subtitle: dvb_subtitle ([255][255][255][255] / 0xFFFFFFFF)"
[23:57:36 CEST] <asmand> overlaying/burning in the subtitles works (-filter_complex "[0:0][0:2]overlay"), so that would suggest that the input file is ok, and that the subtitles can be read properly
[00:00:00 CEST] --- Wed May 24 2017

More information about the Ffmpeg-devel-irc mailing list