[Ffmpeg-devel-irc] ffmpeg.log.20170525

burek burek021 at gmail.com
Fri May 26 03:05:02 EEST 2017

[00:17:30 CEST] <Ozgr> BtbN, one way to limit bitrate with x264 is to specify a level. the options are limited though with the max bitrates defined by avc/h264 for each level
[00:18:36 CEST] <BtbN> you can just give it a maxrate, that's not a problem at all
[00:18:43 CEST] <BtbN> just not a minrate
[00:18:54 CEST] <BtbN> if it's just showing a still image, it won't use much/any
[00:53:59 CEST] <Gazoo> I'm trying to convert an FFV1 encoded file to x264 (or any other lossy modern format), but the blacks in my original video become this lighter saturated gray :( The other colors seem less affected. I'm wondering if this is something I can work to avoid...?
[01:08:47 CEST] <Threads> stop paying the blacks
[01:14:45 CEST] <Gazoo> ... O_o
[01:16:33 CEST] <c_14> Gazoo: is your ffv1 source rgb?
[01:17:40 CEST] <Gazoo> According to VLC, yes. It says Decoded format: 32 bits RGB under codec info
[01:17:51 CEST] <Gazoo> Is there another way to check that perhaps?
[01:17:56 CEST] <c_14> ffprobe filename
[01:24:39 CEST] <Gazoo> will do - just a sec
[01:25:17 CEST] <Gazoo> Stream #0:0: Video: ffv1 (FFV1 / 0x31564646), bgr0, 384x272, 4255 kb/s, 50.12 fps, 50.12 tbr, 50.12 tbn, 50.12 tbc
[01:25:31 CEST] <Gazoo> So... I suppose 'bgr0' is the color codec?
[01:25:38 CEST] <Gazoo> wait - no - color space?
[01:26:11 CEST] <c_14> pixel format/colorspace yeah
[01:27:06 CEST] <c_14> The rgb -> yuv conversion is probably what's messing with your blacks, I'd recommend trying to use the colorspace filter or the zscale filter to do the conversion instead and see if that's better
[01:27:22 CEST] <Gazoo> So when I ffprobe the output it indeed says yuv444p
[01:27:51 CEST] <Gazoo> I'll google colorspace filter / zscale filter re. ffmpeg. You don't happen to have a flag you'd recommend of the top of your head?
[01:28:14 CEST] <c_14> with zscale it'd be -vf zscale,format=pix_fmt=yuv444p
[01:32:04 CEST] <Gazoo> I'll give that a shot
[01:32:22 CEST] <Gazoo> Regardless of whether or not it works, I very, very much appreciate you engaging me and helping me with some advice c_14
[01:32:30 CEST] <Gazoo> Thank you - a lot!
[01:33:02 CEST] <brian___> hi, i'm calling libavcodec/libavformat from some code i'm writing, and i've noticed that when i call avformat_find_stream_info(container, NULL);, it allocates a 688KiB buffer that isn't cleaned up after calling avformat_close_input. is there possibly another free/close call i'm missing? and more broadly, is there a guide on which free/close to use for any given alloc?
[01:36:49 CEST] <brian___> the process of which thing is supposed to own which pointer is hard to follow :(
[01:40:37 CEST] <brian___> ah nevermind, seems i just need to do av_free on my aviocontext->buffer
[01:40:47 CEST] <Gazoo> c_14 - It seems the pix_fmt option is not enjoyed by the zscale filter
[01:41:21 CEST] <c_14> the zscale filter doesn't have a pix_fmt option, the format filter should (though it might be called pix_fmts)
[01:42:00 CEST] <Gazoo> ah. Let me give that a try
[01:42:31 CEST] <brian___> im somewhat confused why avio->buffer = buf; av_free(avio->buffer); av_free(avio); succeeds but avio->buffer = buf; av_free(avio); av_free(buf); fails
[01:42:47 CEST] <brian___> does av_free walk the thing it's freeing, looking for pointers?
[01:43:37 CEST] <c_14> brian___: no, av_free is just a wrapper around free() or _aligned_free()
[01:44:10 CEST] <brian___> ohhh i bet i know what's going on
[01:44:15 CEST] <brian___> i bet avio reallocs its buffer
[01:44:20 CEST] <brian___> meaning the pointer im holding is now invalid
[01:44:26 CEST] <c_14> possible
[01:45:07 CEST] <c_14> Also, I don't think you need anything besides avformat_close_input after avformat_find_stream_info
[01:45:08 CEST] <Gazoo> c_14 - It executes, but with quite a few 'code 3074: no path between colorspaces' messages and a 1kb output file. I tried just enforcing the bgr0 colorspace for h264, but that's apparently incompatible with h264
[01:45:10 CEST] <brian___> that's rather strange, i wonder why it accepts a buffer pointer at all
[01:45:43 CEST] <brian___> c_14: good to know. thanks! i am seeing now that freeing the avio->buffer takes care of the leak, seems calling avformat_find_stream_info caused the avio->buffer to grow
[01:45:56 CEST] <c_14> Gazoo: x264 doesn't support bgr0. If you don't care much about support you can use libx264rgb (as the encoder)
[01:46:08 CEST] <c_14> (Support as in decoding support in various players)
[01:46:28 CEST] <iive> what is bgr0 ?
[01:46:41 CEST] <c_14> pixel format
[01:46:54 CEST] <brian___> actually it seems i can just safely give it a NULL ptr and 0 size and it just goes
[01:47:05 CEST] <iive> with 0 bits?
[01:47:34 CEST] <c_14> bgr0 vs bgra
[01:47:38 CEST] <c_14> there's no alpha channel in bgr0
[01:47:43 CEST] <iive> aha
[01:48:09 CEST] <iive> bgrx
[01:48:46 CEST] <Gazoo> c_14 - It does indeed produce a file VLC can handle and the blacks are just as black as they're supposed to be
[01:49:34 CEST] <Gazoo> The end goal is decoding via an application in Windows Media Foundation, so let me see how it likes it :o
[01:49:45 CEST] <Gazoo> sorry - using WMF, not in WMF
[01:54:36 CEST] <Gazoo> Ok... It likes neither the x264 encoded one, nor the x264rgb encoded one. I wonder if it's because I removed the audiotrack
[01:54:45 CEST] <Gazoo> Perhaps WMF dislikes 0 audio
[01:56:40 CEST] <c_14> or it just can't handle bgr/yuv444
[01:57:39 CEST] <Gazoo> Or maybe it can't handle x264, but can handle h264
[01:57:45 CEST] <c_14> https://msdn.microsoft.com/en-us/library/windows/desktop/dd797815(v=vs.85).aspx
[01:57:45 CEST] <furq> they're the same thing
[01:57:46 CEST] <Gazoo> Let me start by verifying that...
[01:57:52 CEST] <c_14> 4:2:0 chroma or monochrome
[01:57:57 CEST] <Gazoo> x264 is the same as h264?
[01:58:01 CEST] <furq> x264 is an h264 encoder
[01:58:19 CEST] <Gazoo> ah
[01:58:29 CEST] <furq> and yeah a lot of bad decoders can only handle yuv420p
[01:58:43 CEST] <Gazoo> Well it seems to me that the easiest thing here is just to narrow it down for me. I'll take it one step at a time.
[01:59:08 CEST] <furq> read what c_14 just said
[01:59:14 CEST] <c_14> so you'll have to use yuv420p as an output pixel format for ffmpeg
[01:59:19 CEST] <furq> yeah
[01:59:34 CEST] <furq> i've actually had the same issue trying to get zscale to go from rgb to yuv
[01:59:40 CEST] <furq> i never did figure out why it wouldn't do it
[02:03:53 CEST] <Gazoo> You're saying yuv420p is the only thing WMF is likely to chew?
[02:04:41 CEST] <c_14> not likely, according to the docs it's the only thing it will take
[02:04:48 CEST] <Gazoo> ok
[02:09:32 CEST] <Gazoo> Do it seems the only way forward - if possible - is to find some sort of conversion between bgr0 and the color space in yuv420p
[02:09:35 CEST] <Gazoo> So even
[02:09:54 CEST] <brian___> why is it that avcodec_close inverts avcodec_open2 but doesnt free the context, while avformat_close_input inverts the open and does close the context?
[02:11:03 CEST] <c_14> brian___: @note Do not use this function. Use avcodec_free_context() to destroy a codec context (either open or closed). Opening and closing a codec context multiple times is not supported anymore -- use multiple codec contexts instead.
[02:11:26 CEST] <c_14> older api where you could open and close a context multiple times
[02:11:28 CEST] <c_14> *remnant of a
[02:11:46 CEST] <brian___> oh wow, i didnt even notice. theres no deprecation warning
[02:11:48 CEST] <brian___> thank you
[02:12:21 CEST] <brian___> if libavcodec/format had a guide to how to free things that'd be super handy :D
[02:12:38 CEST] <furq> Gazoo: just -pix_fmt yuv420p will do that
[02:12:39 CEST] <brian___> im now only leaking 80 bytes of memory per video open/read :D
[02:12:44 CEST] <furq> but obviously it's not doing a good job of the conversion
[02:13:04 CEST] <c_14> Gazoo: yeah, you could try the colorspace filter with -vf colorspace=iall=bt709:all=bt709:format=yuv420p, but that's making the assumption that your input matches bt709 in transfer, properties and primaries. If it doesn't it might look worse (but there's really no harm in trying)
[02:13:22 CEST] <brian___> oh wait, i think avcodec_free_context cleaned up the last 80 bytes
[02:13:28 CEST] <brian___> c_14: you are amazing :)
[02:13:39 CEST] <Gazoo> Yeah I guess I was implying find a better conversion. But I think the issue is also perhaps the brightness of my main monitor as I don't see the 'issue' as apparently on my alternate screen
[02:14:01 CEST] <furq> Gazoo: try -vf scale=in_range=full:out_range=tv:out_color_matrix=bt709,format=yuv420p
[02:14:34 CEST] <Gazoo> I will - gotta get some food in me
[02:16:36 CEST] <Gazoo> I've run into some issues of getting the output to be in an mp4 container (as opposed to mkv) and I need to fix that in order to get the file loading at all via WMF
[02:16:53 CEST] <furq> what issue
[02:17:16 CEST] <c_14> probably codec related
[02:17:30 CEST] <furq> yeah i'm guessing the audio codec is wrong
[02:20:41 CEST] <Gazoo> Yes - most likely. Is there a default audio codec that's preferrable for the mp4 container?
[02:21:27 CEST] <furq> aac or mp3
[02:21:42 CEST] <Gazoo> gotcha
[02:42:20 CEST] <Threads> Gazoo aac is the best to go with for mp4
[02:42:48 CEST] <Gazoo> Any particular reason?
[02:44:20 CEST] <Threads> i like to say mp3 is old as time
[02:44:39 CEST] <Threads> best todo tests with mp3 and aac and see what you like
[03:09:43 CEST] <JEEB> aac is what most devices are going to support
[03:16:43 CEST] <gurki> JEEB: id differ on that one. literally every device supports mp3
[03:16:48 CEST] <gurki> aac ... not so much
[03:18:31 CEST] <JEEB> gurki: ...in mp4
[03:19:06 CEST] <JEEB> (there was a discussion about that in the backlog)
[03:19:09 CEST] <gurki> if a device supports mp4 it is totally unlikely not to support either aac nor mp3
[03:19:13 CEST] <gurki> i read that.
[03:22:24 CEST] <furq> https://msdn.microsoft.com/en-us/library/windows/desktop/dd742784(v=vs.85).aspx
[03:25:54 CEST] <JEEB> gurki: i find things that don't parse mpeg-1 layer x audio from mp4
[03:26:03 CEST] <JEEB> but do parse aac
[03:26:35 CEST] <JEEB> that's why I noted that in that specific case aac works better
[04:20:37 CEST] <Masshuu_> So I don't know what i'm doing wrong. Basically ffmpeg stops outputing data randomly after ~280 franes
[04:21:56 CEST] <Masshuu_> this is a log that I have https://git.io/vHOo7
[04:22:49 CEST] <Masshuu_> right now I use a headless vlc but I was hoping to use ffmpeg
[04:32:28 CEST] <rrodriguez> is there a way to use ffprobe to get the video bitrate from an rtmp stream?
[04:37:13 CEST] <dystopia_> try add -re to your line Masshuu_
[04:37:53 CEST] <dystopia_> it's encoding faster than realtime from a live source, so maybe it's getting to the end of the input
[04:46:21 CEST] <marcurling> how can I tell a program or Desktop shortcut to launch on a certain monitor/display?
[04:47:12 CEST] <marcurling> ^wrong channel, sorry
[04:52:44 CEST] <Masshuu_> dystopia_:didn't work, still stops
[05:02:48 CEST] <Gazoo101> Before I forget, thanks again to c_14, furq, and Threads
[05:02:54 CEST] <Gazoo101> You guys have helped me understand a lot!
[05:09:51 CEST] <Masshuu_> https://pastebin.com/kzLN0xFf slightly more verbose?
[07:03:44 CEST] <thebombzen> LOL
[07:03:58 CEST] <thebombzen> so I just ran this year's worth of channel logs through a neural network gabbler
[07:04:46 CEST] <thebombzen> it generated a few pretty hilarious sentences
[07:04:55 CEST] <thebombzen> xtina Yeah, same settings I can't get ffmpeg working with desynced audio and video!
[07:05:58 CEST] <thebombzen> kepstin so output files from a YUV420P image which I want to rescale pts av_gettime_relative to date her furq you could have telecined then bobbed kerio it can potentially use try out that should possibly work?
[07:07:02 CEST] <thebombzen> oh sorry i don't really care that much in SDR land at home i am all about quantum mechanics
[07:08:00 CEST] <thebombzen> "Just start my own small hook and inject it into parts roughly 15 minutes long why do fast and trivial."
[07:08:26 CEST] <thebombzen> "what do you mean overruns?"
[07:08:42 CEST] <kepstin> of course I'm mentioned in something that talks about telecine :/
[07:09:22 CEST] <thebombzen> lol, it is based on the 2017 logs
[07:09:28 CEST] <thebombzen> of this channel I mean
[07:09:29 CEST] <thebombzen>  there ok finally found the least problematic way of demuxing packets
[07:11:26 CEST] <thebombzen> "just cross compile it on iDevices which definitely shouldn't hit the cpu being too slow"
[07:12:55 CEST] <thebombzen> "if you need to enable less cpu intensive stuff on stderr you should look fine"
[07:14:17 CEST] <thebombzen> "and the COMPLETE console output"
[09:28:45 CEST] <stdint> I have a problem with movenc, I want to record a offset of a data into the udata box, it works
[09:29:23 CEST] <stdint> but I use the avio_tell to get the offset, the offset don't match the offset in file result
[09:29:29 CEST] <stdint> any idea about that?
[09:56:51 CEST] <raboof> I found https://trac.ffmpeg.org/attachment/wiki/RemapFilter - it looks like projection.c only supports 'single fisheye' format, but AFAICS the samsung gear produces 'dual fisheye' output
[09:57:19 CEST] <raboof> the fact that that page also contains mappings for samsung gear suggests "projection.c" has been updated to support dual fisheye - where could I find this updated version?
[10:08:16 CEST] <thebombzen> raboof: if it's been updated it'll be on git master. if the way to use it isn't documented you'd have to actually open the source file projection.c and look at it
[10:08:34 CEST] <thebombzen> and if you figure it out and you are feeling nice submit a patch documenting it
[10:09:34 CEST] <raboof> doesn't seem to be in https://git.ffmpeg.org/ffmpeg.git (no projection.c and grepping for a couple of function names didn't turn up anything either)
[11:05:06 CEST] <professoroptics> when I cast my screen with compton, the resulting video has intense flickering. how do I get ffmpeg to play nice with compton?
[11:11:27 CEST] <styler2go> Hi. I am trying to convert a few files in a folder. I am using the command find and then -exec to use ffmpeg. Now ffmpeg is using the wrong filename and doesn't find the files. any ideas why?
[11:11:36 CEST] <styler2go> my command is: find . -iname "Counter*.mp4" -exec ffmpeg -i {} -strict -2 -b:v 10000k {}.smol \;
[11:12:03 CEST] <styler2go> it tried to use the .smol file as input.. but i've set it to output?
[11:13:30 CEST] <c_14> command output?
[11:14:16 CEST] <styler2go> it runs through the folder, calling ffmpeg, but ffmpeg ... oh i found the problem, ffmpeg doesn't know which format .smol is.. so i should add something like .smol.mp4 or so
[11:15:10 CEST] <c_14> or use -f mp4
[11:19:03 CEST] <styler2go> thanks, that worked too
[11:20:36 CEST] <professoroptics> how do I prevent video flickering in the output video when recording screen while compton is running?
[12:12:27 CEST] <Tehme> Hello. I am trying to use avcodec's CUVID decoder. I do the following:
[12:12:27 CEST] <Tehme> https://pastebin.com/iVv1Yc2w
[12:12:27 CEST] <Tehme> And I get this:
[12:12:27 CEST] <Tehme> Loaded lib: libnvcuvid.so.1
[12:12:27 CEST] <Tehme> Cannot load cuvidGetDecoderCaps
[12:12:28 CEST] <Tehme> I looked into nvcuvid.h from CUDA SDK 8, and there was no cuvidGetDecoderCaps() function. Why does ffmpeg try to load it then? What am I doing wrong?
[13:34:15 CEST] <smooth_penguin> hey, I'm using ffmpeg to concat multiple .ts files, it seems to work out fine,
[13:34:29 CEST] <smooth_penguin> except the video seems to be playing much quicker that the audio
[13:34:42 CEST] <smooth_penguin> the audio is playing at the normal rate
[13:34:53 CEST] <smooth_penguin> any clues on how I can fix this?
[13:35:35 CEST] <smooth_penguin> ffmpeg -f concat -i list.ts -c copy  workdir/all.ts
[13:35:40 CEST] <smooth_penguin> is what I used
[14:04:52 CEST] <thebombzen> smooth_penguin: I assume you mean list.txt. and with mpegts you can actually just cat them togther
[14:05:13 CEST] <thebombzen> cat first.ts second.ts third.ts fourth.ts >all.ts
[14:05:25 CEST] <thebombzen> like that actually works with mpegts
[14:25:39 CEST] <marquisor> furq: still struggling with the server setup
[14:26:12 CEST] <marquisor> furq: i btw have apache running
[14:27:33 CEST] <Tehme> Where should I ask avcodec related questions? Here or ffmpeg-devel?
[14:29:08 CEST] <iive> Tehme: if it is about using avcodec, ask here, if it is about fixing/improving avcodec then ask in devel
[14:31:11 CEST] <Tehme> Well, I'm not sure if this is using or fixing. I'll try there too. Thank you for your answer.
[15:16:03 CEST] <smooth_penguin> thebombzen: yeah, I tried that as well, the video still plays quicker than the audio
[16:15:36 CEST] <kepstin> smooth_penguin: is the audio/video in sync if you play each of the segments individually?
[16:15:54 CEST] <kepstin> because if that's wrong, concatenating them won't change anything...
[16:49:27 CEST] <SolidusAbi> Hi, im trying to generate a smooth streaming. Can someone help checking whether my commands are ok?
[16:49:54 CEST] <SolidusAbi> ffmpeg -i ../seg0.mov -s 1920x1080 -f ismv -c:v libx264 -movflags frag_keyframe -pix_fmt yuv420p -b:v 4.2M -map 0:v video.ismv -y
[16:50:15 CEST] <SolidusAbi> Im trying to generate a ismv file confied in h264
[16:50:56 CEST] <SolidusAbi> ffmpeg -i seg0.mov -vn -r:a 48000 -acodec mp3 audio.mp3
[16:51:04 CEST] <SolidusAbi> here i want to extract audio
[16:54:09 CEST] <SolidusAbi> the next step is generate a video in 720p and bitrate of 2.9M, inserting audio extratecd.
[16:55:17 CEST] <SolidusAbi> can someone help me?
[18:08:19 CEST] <professoroptics> how do i get ffmpeg to play nice with compton? it causes video flicker when screencasting
[18:11:28 CEST] <marquisor> finally got the damn nginx-rtmp-module working
[18:11:41 CEST] <marquisor> now i have jerky stream to clients...
[18:17:47 CEST] <marquisor> and disconnects
[18:17:52 CEST] <marquisor> from input stream
[18:47:12 CEST] <rjp421> marquisor, is the problem nginx or ffmpeg
[18:48:12 CEST] <marquisor> i really don't know yet
[18:48:38 CEST] <marquisor> maybe bandwidth or more a buffer issue also
[18:53:17 CEST] <lacrymology> how can I create, say, 10 seconds of white noise or something?
[18:55:47 CEST] <DHE> lacrymology: https://ffmpeg.org/ffmpeg-filters.html#aevalsrc  there's an example that generates random noise
[19:00:18 CEST] <lacrymology> DHE: while I'm looking at it, I found this in stackoverflow, the original was dumping to an mkv but I need an mp4
[19:00:24 CEST] <lacrymology> 13:58 $ ffmpeg -f rawvideo -video_size 1280x720 -pixel_format yuv420p -framerate 25 -i /dev/urandom -ar 48000 -ac 2 -f s16le -i /dev/urandom -codec:a copy -t 5 output.mkv
[19:00:49 CEST] <lacrymology> it's failing with 'Could not find tag for codec pcm_s16le in stream #1, codec not currently supported in container'
[19:01:42 CEST] <lacrymology> DHE: sorry, I'm trying to generate random video
[19:01:51 CEST] <lacrymology> although.. anything goes, really, I just need unique video files
[19:01:59 CEST] <furq> !filter noise
[19:02:00 CEST] <nfobot> furq: http://ffmpeg.org/ffmpeg-filters.html#noise
[19:02:02 CEST] <furq> !filter anoisesrc
[19:02:05 CEST] <furq> er
[19:02:09 CEST] <furq> !source anoisesrc
[19:02:09 CEST] <nfobot> furq: http://ffmpeg.org/ffmpeg-filters.html#anoisesrc
[19:02:11 CEST] <furq> use those
[19:02:28 CEST] <furq> and encode them to codecs that mp4 supports
[19:02:30 CEST] <furq> presumably h264 and aac
[19:02:36 CEST] <Mavrik> Hmm, is there any good way of detecting corrupted frames (the ones that reported "ac-tex damaged" etc. when decoding?
[19:02:41 CEST] <Mavrik> Via API?
[19:06:13 CEST] <rjp421> will videos using anoisesrc and amplitude 0 still all be unique?
[19:06:41 CEST] <furq> you can set the seed with noise
[19:06:44 CEST] <furq> idk about anoisesrc
[19:08:40 CEST] <furq> yeah you can set it with both
[19:09:10 CEST] <furq> lacrymology: ffmpeg -f lavfi -i color=black:s=1280x720:d=10,noise=alls=100:allf=t:seed=12345 -f lavfi -i anoisesrc=d=10:s=67890 -c:v libx264 -c:a aac out.mp4
[19:09:43 CEST] <furq> also this is pretty much the absolute worst-case scenario for x264 so it's going to take ages and be enormous
[19:11:50 CEST] <lacrymology> furq: where's the length defined?
[19:12:03 CEST] <furq> d=10
[19:12:48 CEST] <lacrymology> I thought that was colordepth somehow, thakns
[19:14:30 CEST] <lacrymology> 8M for 2 seconds damn
[19:14:48 CEST] <lacrymology> at 640x480
[19:16:42 CEST] <furq> if you just need unique files and you don't care about the fidelity of the noise then bump the crf up
[19:16:45 CEST] <furq> or set a max bitrate
[19:16:50 CEST] <furq> it'll be a horrible blocky mess but it'll still be unique
[19:21:51 CEST] <lacrymology> thanks
[19:21:57 CEST] <lacrymology> I need to learn the basics
[19:22:06 CEST] <lacrymology> I've used ffmpeg for a number of things, but I don't know the syntax
[19:25:58 CEST] <james999> lacrymology: would you appreciate a detailed tutorial and walkthrough
[19:26:06 CEST] <james999> complete with audio and video?
[19:26:29 CEST] <lacrymology> james999: sure would. Something that goes through the syntax, not just formulas, which is what I've used, historically
[19:26:52 CEST] <james999> well. i wonder why there isn't a youtube channel like that already
[19:26:55 CEST] Action: james999 jots it down for future reference
[19:27:27 CEST] <lacrymology> are you being ironic, and is there a very famous one I'm missing?
[19:28:02 CEST] <james999> no but you are right i'm being sort of tongue in cheek
[19:28:35 CEST] <james999> for example when I type linux ffmpeg tutorial into youtube I get mostly trash. one vid about basics of ubuntu; and this: https://www.youtube.com/watch?v=c9YLTNGVdPU
[19:35:04 CEST] <furq> that's me in that video
[19:35:07 CEST] <furq> i am "skate.avi"
[19:36:45 CEST] <james999> you are the speaker or the video file? :D
[19:38:40 CEST] <furq> i'm skate.avi
[19:40:20 CEST] <james999> ok
[19:42:51 CEST] <pbgswd> is it ok to talk about moviepy here?
[22:53:43 CEST] <xhip> I was trying to search a cvlc to ffmpeg convert.. but no luck
[22:54:04 CEST] <xhip> someone knows how can I convert this  cvlc -vvv v4l2:///dev/video1:chroma=mjpg :input-slave=alsa://hw:2,0 --sout "#transcode{vcodec=mp1v,vb=4096,acodec=mp3,ab=128,scale=2,channels=2}:rtp{dst=,port=1234,sdp=rtsp://}  .. to ffmpeg
[23:05:50 CEST] <xhip> I'm testing some commands.. ffmpeg -re -i /dev/video1 -f rtsp -muxdelay 0.1 rtsp://
[23:07:23 CEST] <kepstin> xhip: don't use -re when your input is realtime (e.g. a camera). It's only useful for if your source is e.g. a file or something
[23:07:34 CEST] <xhip> oh ok
[23:07:46 CEST] <xhip> make sense
[23:14:39 CEST] <xhip> I can't watch the stream on vlc :/
[23:15:08 CEST] <xhip> Im also geting this:
[23:15:11 CEST] <xhip> [mp3 @ 0x92e9c60] Format detected only with low score of 1, misdetection possible!
[23:15:12 CEST] <xhip> [mp3 @ 0x92ebb00] Header missing
[00:00:00 CEST] --- Fri May 26 2017

More information about the Ffmpeg-devel-irc mailing list