[Ffmpeg-devel-irc] ffmpeg.log.20170526

burek burek021 at gmail.com
Sat May 27 03:05:01 EEST 2017

[01:55:57 CEST] <iive> is it bug if ./configure --disable-programs --enable-ffmpeg ; keep ffmpeg disabled?
[02:17:26 CEST] <iive> wrong alarm... something else disables them
[02:17:30 CEST] <iive> it
[03:31:00 CEST] <CoJaBo> huh.. libx264 is encoding 10× slower than libvp9 at slowest settings.. is that supposed to happen lol
[03:31:51 CEST] <furq> no
[03:32:00 CEST] <furq> unless "slowest settings" is placebo in which case probably
[03:32:55 CEST] <CoJaBo> o, veryslow, in this case
[03:33:58 CEST] <CoJaBo> I tried placebo before. It spites me by actually making the file larger than veryslow
[03:44:26 CEST] <CoJaBo> Another rip in the universe, the higher the resolution, the smaller the filesize
[03:44:43 CEST] <furq> placebo being bigger than veryslow makes sense
[03:44:49 CEST] <furq> the resolution thing very much does not
[03:45:24 CEST] <CoJaBo> Trying to double-check I have the latest ffmpeg lol..
[03:45:59 CEST] <ylzkhan> Hello, I'm trying to remove comment metadata of multiple flac files and outputing them with the exact filename on ssh. If someone could help me out.
[03:46:16 CEST] <CoJaBo> I'm thinking it's setting constant bitrate instead of constant quality; or maybe I just typoed the commandline <_<
[03:46:47 CEST] <furq> CoJaBo: pastebin the command
[03:47:09 CEST] <furq> ylzkhan: you might be better off using metaflac
[03:47:19 CEST] <furq> ffmpeg isn't great at metadata editing
[03:47:42 CEST] <CoJaBo> ..actually, I've apperently not specified either setting. does vp9 default to CBR? That'd explain it <_<
[03:47:48 CEST] <furq> yes
[03:47:51 CEST] <furq> well no
[03:47:53 CEST] <furq> it defaults to abr
[03:47:57 CEST] <furq> at some stupid bitrate like 200kbps
[03:48:32 CEST] <ylzkhan> furq: i'll try out thanks i heard that overwriting files with different metadata is not possible with ffmpeg you need to create new files, is it true?
[03:48:37 CEST] <furq> yes
[03:48:51 CEST] <furq> although that's probably what most things do
[03:49:03 CEST] <furq> just those automate the atomic replace for you
[03:49:58 CEST] <CoJaBo> Ok, so I just suck at reading the debug output then
[03:53:28 CEST] <CoJaBo> ..wow, and who in their right mind encodes a file in 1150×640px :/
[04:38:06 CEST] <kepstin> I know, right? It should be 1152x640 so the width is a nice multiple of 8 and 16.
[04:42:46 CEST] <furq> how would you even get 1150 there
[04:42:52 CEST] <furq> unless the source was 1920*1068
[04:42:59 CEST] <furq> and what monster would do that
[05:36:36 CEST] <thebombzen> furq: someone who probably had a widescreen-like video that autocropped
[05:36:48 CEST] <thebombzen> or cropped black bars off the top and bottom I should say
[06:32:16 CEST] <james999> oh hey it's thebombzen
[06:32:36 CEST] <thebombzen> It is, in fact, me
[06:33:06 CEST] <james999> I'm contemplating trying out ffmpeg on my rpi 3
[06:33:17 CEST] <james999> just to see how fast it encodes. any standard video files i can use?
[07:23:09 CEST] <thebombzen> james999: you can try -f lavfi -i testsrc2
[07:23:24 CEST] <thebombzen> you could also try big buck bunny, I hear people like using that as a test
[07:27:24 CEST] <thebombzen> depends on what you're trying to encode you could also use jellyfish
[07:28:37 CEST] <thebombzen> you know, these: http://jell.yfish.us/
[07:28:41 CEST] <thebombzen> (warning: they're really big)
[08:40:29 CEST] <james999> that URL... lol thanks
[08:42:08 CEST] <thebombzen> james999: also try http://bbb3d.renderfarming.net/explore.html
[08:46:19 CEST] <james999> ah ok blender
[08:46:31 CEST] <james999> that explains all the stereoscopic 3d and anaglyph whatever stuff
[10:15:30 CEST] <cosven> I have a problem about the meaning of `tbr`, which is extracted from ffmpeg.
[10:15:39 CEST] <cosven> I found a explaination from stackoverflow:  tbr is guessed from the video stream and is the value users want to see when they look for the video frame rate
[10:16:12 CEST] <cosven> but in fact, the fps of this video is 30.
[10:16:39 CEST] <cosven> the `tbr` that ffmpeg show is 120
[10:16:57 CEST] <cosven> here is the original info ffmpeg prints: Stream #0:0(eng): Video: h264 (Baseline) (avc1 / 0x31637661), yuvj420p(pc, smpte170m), 640x360, 796 kb/s, SAR 1:1 DAR 16:9, 30 fps, 120 tbr, 90k tbn, 180k tbc (default)
[10:19:17 CEST] <Mavrik> H.264 isn't a constant frame rate codec anyway :)
[10:21:05 CEST] <cosven> the `tbr` here means maximum frame rate? fps means average frame rate?
[10:22:43 CEST] <thebombzen> cosven: it means the video is "variable framerate"
[10:23:06 CEST] <thebombzen> where frames have "timestamps" rather than assuming a constant framerate
[10:23:07 CEST] <Mavrik> cosven, I'd have to check the source on what exactly it reads
[10:23:18 CEST] <Mavrik> cosven, was that recorded on a small camera / mobile device?
[10:23:37 CEST] <thebombzen> what TBR is, it's the smallest framerate that's needed to perfectly recontruct the input variable framerate
[10:24:05 CEST] <thebombzen> for example, if the input video has some 24 fps and some 30 fps content, you need 120 fps to do those accurately (it's the LCM of 24 and 30 in this case)
[10:32:00 CEST] <cosven> I have upload the video to dropbox, here is the video link: https://www.dropbox.com/s/4ypkoq4dshqyv0y/tmp.unknown?dl=0
[10:33:37 CEST] <cosven> thebombzen: thanks for your explaination ~
[11:06:24 CEST] <mindw0rk> Hey guys, I'm trying to work with hls streams here. Everything seems to go smoothly, but for some reason AVCodecContext video dimensions are both 0.
[11:10:51 CEST] <BtbN> avcodec is not the one who deals with hls, that's avformat
[11:41:05 CEST] <SolidusAbi> HI, Im trying to convert a .mov to wmv but ffmpeg throws a error. My command is "ffmpeg -i seg0.mov -b:v 4M -s 1920x1080 -vcodec msmpeg4 -acodec wmav2 seg0.wmv"
[11:41:26 CEST] <SolidusAbi> The error says: Error initializing output stream 0:1 -- Error while opening encoder for output stream #0:1 - maybe incorrect parameters such as bit_rate, rate, width or height
[11:41:44 CEST] <SolidusAbi> Can someone explain me what it is happening¿?
[11:41:58 CEST] <JEEB> the actual error is usually before that
[11:44:57 CEST] <SolidusAbi> ffmpeg, just before the error, throws "[wmav2 @ 0x3323d20] too many channels: got 4, need 2 or fewer"
[11:47:38 CEST] <SolidusAbi> Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'seg0.mov':
[11:47:38 CEST] <SolidusAbi>   Metadata:
[11:47:38 CEST] <SolidusAbi>     major_brand     : qt
[11:47:38 CEST] <SolidusAbi>     minor_version   : 512
[11:47:38 CEST] <SolidusAbi>     compatible_brands: qt
[11:47:39 CEST] <SolidusAbi>     encoder         : Lavf57.65.100
[11:47:39 CEST] <SolidusAbi>     make            : Atomos
[11:47:40 CEST] <SolidusAbi>     make-eng        : Atomos
[11:47:40 CEST] <SolidusAbi>   Duration: 00:20:00.02, start: 0.000000, bitrate: 85599 kb/s
[11:47:40 CEST] <SolidusAbi>     Stream #0:0(eng): Audio: pcm_s24le (in24 / 0x34326E69), 48000 Hz, 4.0, s32 (24 bit), 4608 kb/s (default)
[11:47:41 CEST] <SolidusAbi>     Metadata:
[11:47:41 CEST] <SolidusAbi>       handler_name    : DataHandler
[12:07:33 CEST] <SolidusAbi> If someone give me a example in order to convert to wmv, i will be grateful
[12:07:57 CEST] <c_14> add -ac 2?
[12:14:48 CEST] <SolidusAbi> It works...
[12:14:56 CEST] <SolidusAbi> but.. i dont know why
[12:14:56 CEST] <SolidusAbi> xD
[12:15:05 CEST] <SolidusAbi> can you explain, c_14
[12:15:26 CEST] <c_14> wmav2 only supports 2 or less channels, your input is 4.0
[12:15:34 CEST] <c_14> just downmix to stereo
[12:16:22 CEST] <SolidusAbi> oooh, how can i check how many channels has a stream?
[12:16:37 CEST] <c_14> >Stream #0:0(eng): Audio: pcm_s24le (in24 / 0x34326E69), 48000 Hz, 4.0, s32 (24 bit), 4608 kb/s (default)
[12:16:39 CEST] <c_14> >4.0
[12:16:55 CEST] <SolidusAbi> aaah!
[12:17:05 CEST] <SolidusAbi> thanks, you has been helpful
[12:17:12 CEST] <SolidusAbi> have been*
[12:17:16 CEST] <SolidusAbi> xD
[12:35:14 CEST] <nuvo> hello everybody
[12:51:23 CEST] <nuvo> is there anybody here that is be able to develope a script for ffmpeg/osx to split 1 hours long movie into few clips? please send an email to: nuvolablux at gmail.com This is a payed project.
[12:52:54 CEST] <BtbN> That can be done with a single ffmpeg commandline, if you just want to split it into even segments. There is a muxer that does just that
[12:54:59 CEST] <nuvo> it is a bit more complicated than this: I will provide a txt page with time codes to split and names...
[12:55:43 CEST] <SolidusAbi> ffmpeg -i [movie] -f segment --segment_time_delta 1200 -f segment  [output_dir]\test%03d
[12:55:51 CEST] <SolidusAbi> nuvo, this must to work
[12:56:40 CEST] <SolidusAbi> it command will split the movie per 20 minutos ans save it in test0, test1,...
[12:56:49 CEST] <SolidusAbi> Is so easy...
[12:56:58 CEST] <nuvo>  The script will have to work on mac osx I recommend using ffmpeg as a video engine Input File: Apple prores422hq (or alternatively a sequence of consecutive numbered images) MOV files / text file containing time code and file names The script must be accurate to the frame, the time code in the EDL file is understood: HH: MM: SS: frames (1 second contains 25 frames - from 00 to 24 -) while ffmpeg uses different syntax:  FFMPEG Time unit s
[12:57:22 CEST] <nuvo> ote that you can use two different time unit formats: sexagesimal (HOURS: MM: SS.MICROSECONDS, as in 01: 23: 45.678), or in seconds. If a fraction is used, such as 02: 30.05, this is interpreted as "5 100ths of a second", not as frame 5. For example, 02: 30.5 would be 2 minutes, 30 seconds and half a second Would be the same as using 150.5 in seconds. The ffmpeg command to use is the copy, which provides a crop and not the file regenerati
[12:57:30 CEST] <nuvo> The script splits into two parts  SCRIPT A:
[12:57:39 CEST] <nuvo> Starting from a master file the script must be able to divide it into many files according to the time codes and names in the edl file.
[12:57:47 CEST] <nuvo> So, the goal would be to generate these files from an edl (see below) and the master video file: Look at the text of the file edl (see below) the script will have to: Generate video file called "Video Source.mov" from video master from time code 00: 00: 00: 00 to 00: 00: 11: 14
[12:57:54 CEST] <nuvo> Generate the second video file called "Video Source Copy 2.mov" from the video master file from 00: 00: 11: 14 to 00: 00: 23: 03 ...and so on...
[12:58:03 CEST] <nuvo> I have more than 1000 files to split and name, hence the need to automate this process.
[12:58:26 CEST] <nuvo> this is the edl file with time codes and names:
[12:58:33 CEST] <nuvo> TITLE: Video Source Copy FCM: NON-DROP FRAME  000001 001 V 00: 00: 00: 00 00: 00: 11: 14 00: 00: 00: 00 00: 00: 11: 14 * FROM CLIP NAME: Video Source.mov  000002 001 V C 00: 00: 00: 00 00: 00: 11: 14 00: 00: 11: 14 00: 00: 23: 03 * FROM CLIP NAME: Video Source Copy 2.mov  000003 001 V 00: 00: 00: 00 00: 00: 11: 14 00: 00: 23: 03 00: 00: 34: 17 * FROM CLIP NAME: Video Source copy 3.mov  000004 001 V C 00: 00: 00: 00 00: 00: 11: 14 00: 00: 
[12:58:42 CEST] <nuvo> 000005 001 V C 00: 00: 00: 00 00: 00: 11: 14 00: 00: 46: 06 00: 00: 57: 20 * FROM CLIP NAME: Video Source Copy 5.mov  000006 001 V C 00: 00: 00: 00 00: 00: 11: 14 00: 00: 57: 20 00: 01: 09: 09 * FROM CLIP NAME: Video Source Copy 6.mov  000007 001 V 00: 00: 00: 00 00: 00: 11: 14 00: 01: 09: 09 00: 01: 20: 23 * FROM CLIP NAME: Video Source Copy 7.mov  000008 001 V 00: 00: 00: 00 00: 00: 11: 14 00: 01: 20: 23 00: 01: 32: 12 * FROM CLIP NAME:
[12:58:49 CEST] <nuvo> ecc
[13:03:16 CEST] <SolidusAbi> Im a noob with ffmpeg, i enter here because a i need a help, but i think that you must to work with python in order to parse your "data files" and using ffmpeg commands later
[13:05:33 CEST] <SolidusAbi> python is very good for scripting
[13:05:39 CEST] <nuvo> I'm not a developer, I'm searching for a developer, I think here someone could be interested to a payed project
[13:06:53 CEST] <SolidusAbi> oooh, ok. I hope someone can help you
[13:08:22 CEST] <nuvo> is there a way to find someone interested on this project?
[13:10:35 CEST] <SolidusAbi> i dont know, maybe here someone answer you
[13:11:13 CEST] <nuvo> is there another place where to find ffmpeg developers?
[13:12:56 CEST] <SolidusAbi> maybe you can looking for in mail list of ffmpeg but... i dont sure
[13:14:16 CEST] <nuvo> ok
[13:14:17 CEST] <nuvo> thanks
[14:13:19 CEST] <marquisor> furq: ping
[14:21:11 CEST] <marquisor> JEEB: ping
[14:22:43 CEST] <marquisor> i need help with ssh tunnel for ffmpeg streaming :< i'm not sure if i have to make temporary file? with mkfifo? 512M size maybe. i could integrate a mp4 video with html5 on my website though, only need the stream now for it.
[14:30:08 CEST] <BtbN> you can't stream mp4
[14:30:44 CEST] <BtbN> need something like hls or dash for that, which can't be sent to a pipe, as it's multiple files
[14:31:09 CEST] <marquisor> any other compatible with simple html5 embedded video?
[14:31:17 CEST] <BtbN> no
[14:31:19 CEST] <marquisor> damn
[14:31:37 CEST] <BtbN> Even HLS is technically not compatible, but there are JavaScript libs to convert it on the fly
[14:32:28 CEST] <marquisor> i have to keep H264
[14:32:48 CEST] <BtbN> That's a codec, not a container.
[14:32:50 CEST] <marquisor> yes
[14:33:07 CEST] <marquisor> but i can't spare cpu power to reencode video
[14:33:10 CEST] <marquisor> just saying
[14:34:39 CEST] <marquisor> that conversion on the fly is just for the bitstream then?
[14:35:55 CEST] <marquisor> well i might screw it, no embedded video then. but at least want to provide a link for mplayer/vlc at least. is that possible with ssh tunnel?
[14:36:17 CEST] <BtbN> Why would you ever use a ssh tunnel in the first place?
[14:36:23 CEST] <BtbN> Just setup an nginx-rtmp
[14:36:26 CEST] <marquisor> because nginx-rtmp not working
[14:36:48 CEST] <BtbN> works for me
[14:36:49 CEST] <marquisor> yes i did, lots of framedrops and disconnects
[14:37:19 CEST] <BtbN> maybe your connection is too slow for what you are trying to stream
[14:37:34 CEST] <marquisor> if clients connect directly to the source it's working fine
[14:37:47 CEST] <marquisor> max bitrate is 15 mbit, i have an upstream of 50 mbit
[14:38:12 CEST] <marquisor> but i have to use a relay, because i want 5-6 people to watch it
[14:38:33 CEST] <BtbN> that's exactly what nginx-rtmp is designed for
[14:38:37 CEST] <marquisor> yeah
[14:38:52 CEST] <marquisor> can't imagine the rootserver can't handle incoming 15 mbit max.
[14:40:48 CEST] <marquisor> https://www.netcup.de/vserver/
[14:41:34 CEST] <marquisor> looking for a CLI speedtest now
[14:42:20 CEST] <marquisor> BtbN: do i have to setup a buffer in nginx-rtmp config or in my ffmpeg which i send to it?
[14:42:33 CEST] <BtbN> the defaults are fine
[14:42:51 CEST] <marquisor> k
[14:47:01 CEST] <marquisor> http://retrohd.com/fb/jdSc4o/
[14:47:07 CEST] <marquisor> ^ speedtest
[14:50:00 CEST] <marquisor> should be sufficient
[16:19:57 CEST] <Guest30290> Hello, I am using FFMPEG libs in an Unity project, it segfault on Android when avcodec_decode_video2 calls av_log_default_callback. I asked the question @ https://stackoverflow.com/questions/44203463/ffmpeg-libraries-segfault-on-android-c-sharp-unity . If you have some infos please let me know (here or on stackoverflow) thanks !
[16:21:09 CEST] <atomnuker> Guest30290: in your custom callback try copying the format string to some tmp buffer and then using that tmp buffer
[16:21:59 CEST] <BtbN> are you sure "ref AVCodecContext *ctx" is not a "AVCodecContext **ctx"?
[16:24:00 CEST] <Guest30290> typo error its " ref AVCodecContext ctx"
[16:25:44 CEST] <Guest30290> @atomnuker I don't get what custom callback you are talking about
[16:26:53 CEST] <atomnuker> Guest30290: don't you have a custom logging callback installed?
[16:27:15 CEST] <Guest30290> not that I know, I just Dllimport what I need and use it
[16:28:41 CEST] <Guest30290> Is it possible to disable the logging ?
[16:30:40 CEST] <atomnuker> no, you probably just set it to null somewhere
[16:35:40 CEST] <Guest30290> I didnt changed anything about it, I will try to make my own callback and just discard anything and see if it fixes the segfault
[17:16:55 CEST] <Ethereco> Hello, with the 2 options (--disable-swresample --disable-avfilter) i can't build ffmpeg - it is no longer under "Programs:" https://pastebin.com/W9JaB7Md
[17:17:29 CEST] <JEEB> possibly because ffmpeg.c utilizes both of those?
[17:17:34 CEST] <furq> Ethereco: https://github.com/FFmpeg/FFmpeg/blob/master/configure#L3222
[17:18:42 CEST] <JEEB> if you don't want to utilize them you will have to create your own simpler app that doesn't utilize them
[17:20:39 CEST] <Ethereco> oh - ok is there a list which options ffmpeg utilize? coudn't find any info about that
[17:20:49 CEST] <furq> it's the thing i just linked
[17:21:54 CEST] <DHE> you can disable a number of filters, but you can't disable the entire filtering library itself.
[17:22:09 CEST] <Ethereco> i think to code my own program i don't have enough skills - ffmpeg is a perfect tool
[17:22:29 CEST] <JEEB> lol
[17:22:36 CEST] <JEEB> please no
[17:22:44 CEST] <JEEB> > ffmpeg.c > perfect
[17:22:51 CEST] <JEEB> you can do surprisingly many things with ffmpeg.c
[17:22:56 CEST] <JEEB> and it might even work
[17:22:58 CEST] <DHE> if you only want a couple of filters, you can do this: ./configure --disable-filters --enable-filter="volume,scale,yadif"
[17:23:20 CEST] <DHE> (you should see how horrific my configure line is)
[17:23:57 CEST] <Ethereco> i have tried to disable filter but there where the same error. i'll test it again
[17:24:15 CEST] <JEEB> but at some point something in ffmpeg.c or so will drive you made (there's so many workarounds for weird things that aren't possibly necessary any more)
[17:25:06 CEST] <james999> JEEB: there's a management story about manure on horse saddles that refers to that
[17:25:17 CEST] <james999> the idea of continuing to do something that was long ago rendered unnecessary
[17:25:23 CEST] <DHE> can confirm, ffmpeg is good but not perfect. I have my own app to work around all kinds of issues
[17:28:10 CEST] <JEEB> james999: the best part is where you can't even easily test it after looking at the git log
[17:28:21 CEST] <JEEB> (no clear file based sample etc)
[17:29:36 CEST] <Ethereco> configure with --disable-filters: https://pastebin.com/vSNtb93W
[17:29:48 CEST] <james999> i feel like there should be some software principle at work here
[17:29:50 CEST] <furq> sounds like it's time for a fresh new start for ffmpeg
[17:29:50 CEST] <JEEB> and then there's the balance between supporting broken input and keeping the code clear
[17:29:55 CEST] <furq> perhaps with a new name
[17:30:06 CEST] <Ethereco> this is the minimum set of filters right?
[17:30:07 CEST] <furq> one that reflects that it's not just for mpeg, it's a general purpose a/v conversion tool
[17:30:07 CEST] <JEEB> furq: yea, and not trying to do everything with a single binary
[17:30:10 CEST] <james999> like, "specially note all the small things you have to fix cause of some stupid moron somewhere" + example file
[17:30:37 CEST] <james999> furq: libav sounds like a good all-purpose name to me!
[17:30:45 CEST] <furq> the punchline was avconv
[17:30:47 CEST] <furq> go and sit in the corner
[17:30:58 CEST] <james999> T_T
[17:31:10 CEST] <DHE> well it says it'll build you a copy of ffmpeg. but all it can do is remux mov into mkv and ogg....
[17:31:23 CEST] <DHE> I feel like this is an incredibly narrow use case, but it should compile pretty fast
[17:32:10 CEST] <furq> JEEB: tbf it would probably be difficult to separate ffmpeg's jobs into multiple binaries
[17:32:21 CEST] <furq> and it would almost certainly make the ui even more arcane
[17:32:38 CEST] <Ethereco> yes, it will be a little bit larger but i was shocked of the 60MB full binary size - i wan't create a smaller one - this binary is about 1MB or 380kb upx packed
[17:33:06 CEST] <DHE> Ethereco: you sure you just looked at the unstripped version? a stripped full ffmpeg build for me is about 21 megabytes.
[17:34:27 CEST] <DHE> (linux)
[17:35:09 CEST] <furq> yeah 60MB seems way too big
[17:35:14 CEST] <Ethereco> a ffmpeg-windows-build-helpers windows binary with non free is about 62MB :-( upx smaller but execute one command takes about 3 seconds for unpacking the large exe
[17:35:40 CEST] <furq> that's either unstripped or it has every external lib it's possible to have
[17:35:55 CEST] <DHE> well, can't comment on windows builds. 60 MB on linux with debug symbols is about right...
[17:36:09 CEST] <furq> i've got a windows build with quite a few libs which is 31MB
[17:36:12 CEST] <furq> and nothing disabled
[17:36:13 CEST] <DHE> or with my configure command, about half that. so ~10 megabytes after a strip.
[17:36:23 CEST] <DHE> wow...
[17:37:09 CEST] <DHE> that's fully loaded? lame, x264, x265, vpx, and all that?
[17:37:16 CEST] <Ethereco> yes, i have an old windows ffmpeg from 2013 this file was about 10mb
[17:37:42 CEST] <Ethereco> but all programs are very old and has less features
[17:37:43 CEST] <furq> DHE: http://sprunge.us/GNJU
[17:37:52 CEST] <furq> 32070656
[17:38:13 CEST] <Ethereco> i hope i can build a new one with all needed modern features under 10mb
[17:38:32 CEST] <furq> without external libs it should be about 15-20MB iirc
[17:38:37 CEST] <DHE> is LTO worth it? I thought it broke inline asm
[17:38:42 CEST] <furq> so if you disable a bunch of decoders/encoders you don't need, that should be fine
[17:38:47 CEST] <furq> DHE: i've not really benchmarked it
[17:38:50 CEST] <furq> it seemed faster with x264
[17:38:58 CEST] <furq> but like a couple of percent at most
[17:39:17 CEST] <furq> i left it on because it didn't seem to break anything
[18:03:13 CEST] <anchi> guys I have super strange proble
[18:03:16 CEST] <anchi> m
[18:03:44 CEST] <crziter> Does FFMPG support decode video frame into OpenGL texture?
[18:06:32 CEST] <atomnuker> crziter: see the get_buffer2() callback in avcodeccontext
[18:27:14 CEST] <drathir> hi all...
[18:28:04 CEST] Action: drathir wonder if there is any known issues with rtsp stream playing last times
[18:30:16 CEST] <crziter> atomnuker: thank you for your suggestion, let me give it a try
[21:32:33 CEST] <MacMog> hi, I'm trying to understand how ffmpeg calculates the start time for an MPEG-2 file (video & audio)
[21:32:46 CEST] <MacMog> for example, when I run ffprobe, I get this output:
[21:32:46 CEST] <MacMog> Input #0, mpeg, from 'file.mpg':
[21:32:47 CEST] <MacMog>   Duration: 00:00:11.06, start: 579.376000, bitrate: 10704 kb/s
[21:33:18 CEST] <MacMog> when I calculate the value by hand, or open the same file in Wireshark, I get different values from the first pack header and PES header
[21:33:30 CEST] <marquisor> re
[21:33:39 CEST] <marquisor> 6h ISP downtime :<
[21:34:37 CEST] <MacMog> first pack header gives me a system clock reference of 578.4, while first video PES header gives PTS = DTS = 579.4
[21:35:07 CEST] <MacMog> if I look at the first audio PES header, I get 579.375655555556, which is so close that it may be just a matter of doing math in the wrong mode (integer vs. floating-point)
[21:35:26 CEST] <MacMog> that would imply that ffmpeg takes the minimum value from all the PES headers, but I'm not confident about that
[21:35:45 CEST] <MacMog> I see in av_dump_format() the lines that calculate & output seconds (ic->start_time / AV_TIME_BASE) and microseconds (% instead of /), and am working backwards from there
[21:35:53 CEST] <MacMog> any information or pointers on where to look would be appreciated
[21:53:29 CEST] <aaa3> hi. i noticed ffmpeg.org https doesn't work on debian sid/testing any more because startcom cert has been distrusted
[21:53:45 CEST] <aaa3> is this a known issue?
[21:54:01 CEST] <aaa3> or should i do something with it, bug report, contact server admin etc?
[22:06:25 CEST] <BtbN> the cert should be old enough to still be valid
[22:06:30 CEST] <BtbN> it was only distrusted for new certs
[22:06:37 CEST] <furq> it fails here as well
[22:08:28 CEST] <BtbN> only certs after October 21st 2016 were distrusted
[22:08:34 CEST] <aaa3> old enough for browser half-distrust i guess, but debian kicked out startcom proper
[22:08:36 CEST] <BtbN> the ffmpeg one is from April
[22:10:18 CEST] <aaa3> can be seen here: https://packages.debian.org/sid/ca-certificates
[22:10:33 CEST] <aaa3> is in "Changelog"
[22:10:50 CEST] <aaa3> or "list of files"
[23:37:57 CEST] <ThugAim> hey guys, anybody here work in broadcast?
[23:45:09 CEST] <james999> no but I know NATO phonetics sort of and know pirate radio operators
[23:51:21 CEST] <rrodriguez> is there a way to use ffmpeg to generate an image of a stream every 5 seconds but also send the stream to ffprobe? I want to also generate some stats about the stream
[00:00:00 CEST] --- Sat May 27 2017

More information about the Ffmpeg-devel-irc mailing list