[Ffmpeg-devel-irc] ffmpeg.log.20170528

burek burek021 at gmail.com
Mon May 29 03:05:01 EEST 2017

[00:08:52 CEST] <zerodefect> Anyone developers here familiar with configuring a custom 'execute' method in AVFilterGraph? My custom execute is not being called.
[00:09:00 CEST] <zerodefect> *Any
[00:16:54 CEST] <Thomas> Hello
[00:17:23 CEST] <Guest99175> Hello
[02:21:54 CEST] <kevmitch> how do i get ffmpeg to drop "stereo_mode     : left_right" metadata and "stereo3d: side by side" side data when 2difying a h264/mkv with -vf stereo3d=sbs2l:ml
[02:22:19 CEST] <bob_twinkles> hrm, I think the performance degredation I was seeing was due to AWS deciding my instance was consuming too many CPU resources and effectively reducing the clock speed
[02:22:20 CEST] <bob_twinkles> not nice
[02:24:39 CEST] <kevmitch> ah, -metadata:s:v:0 stereo_mode="mono" got id of it, but now the aspect ratio is wrong
[02:24:50 CEST] <kevmitch> it is double wide
[02:27:48 CEST] <kevmitch> http://sprunge.us/aUiE
[02:29:20 CEST] <furq> kevmitch: remux it with -aspect 16:9
[02:30:01 CEST] <kevmitch> yeah, that did it thanks
[02:30:28 CEST] <kevmitch> so the million dollar question is why can't -vf stereo3d=sbs2l:ml take care of that (it seems to for ffplay)
[02:31:17 CEST] <furq> what, the aspect ratio?
[02:31:35 CEST] <furq> it might be worth filing a bug report tbh
[02:31:47 CEST] <furq> ffmpeg will normally try to keep the source aspect ratio, but obviously in this case that's never the right thing to do
[02:31:51 CEST] <kevmitch> well both the metadata and aspect ratio
[02:32:02 CEST] <furq> and the same thing with the metadata
[02:32:35 CEST] <furq> idk if you could actually specialcase the metadata based on a filter
[02:32:41 CEST] <furq> but the aspect ratio should certainly be possible
[02:38:15 CEST] <tdr> so ffmpeg can deal with sde by side 3d?   can it actually play it?
[02:38:28 CEST] <tdr> (i'd really like to use my 3d movies on linux)
[02:39:21 CEST] <kevmitch> well it can convert it to mono
[02:40:00 CEST] <kevmitch> not sure about actualy playing 3d
[02:40:24 CEST] <tdr> hrm... been waiting soooo long to stop needing to use the ps4 for movies
[02:47:46 CEST] <furq> do you have a 3d monitor
[02:48:57 CEST] <tdr> yeah 3d tv
[02:49:13 CEST] <tdr> thats what i use for the ps4 to play it
[02:49:23 CEST] <tdr> tower pc is hooked to it too
[02:50:13 CEST] <tdr> dvd drive supports 3d for the tower too, but nothing will play them.
[02:50:26 CEST] <tdr> (it had windows drives for it, but i'm not touching that)
[02:56:38 CEST] <VectorX> what do i use for webp ./configure  --enable-
[02:58:00 CEST] <VectorX> ./configure  --enable-libwebp  gives ERROR: libwebp not found using pkg-config
[02:59:43 CEST] <furq> do you have libwebp installed
[03:00:03 CEST] <furq> tdr: i'd have thought anything decent would just play 3d stuff
[03:00:06 CEST] <VectorX> i compiled it, per https://developers.google.com/speed/webp/docs/compiling
[03:00:28 CEST] <VectorX> and the two utilities on the page cwebp and dwebp work
[03:00:41 CEST] <furq> check config.log
[03:00:48 CEST] <tdr> furq, like vlc/mplayer etc .. they choke trying to do a 3d disc
[03:00:53 CEST] <furq> what about mpv
[03:01:00 CEST] <tdr> furq, havent trying mpv
[03:01:06 CEST] <furq> wait
[03:01:12 CEST] <kevmitch> tdr: you'll have to rip the disc
[03:01:14 CEST] <furq> when you say disc do you mean playing it off a bluray
[03:01:17 CEST] <kevmitch> at the very least
[03:01:19 CEST] <furq> because yeah that's a totally separate problem
[03:01:52 CEST] <kevmitch> playing a 2d blu-ray real time is dodgy enough
[03:02:00 CEST] <tdr> furq, i can get the key etc to make it readable using makemkv
[03:02:11 CEST] <furq> can you play the resulting mkvs
[03:02:26 CEST] <tdr> i can even convert it, it wont do it side by side tho
[03:02:42 CEST] <VectorX> http://viper-7.com/OD5JMH
[03:02:51 CEST] <kevmitch> yeah, last i checked makemkv didn't properly decode the stereo channel
[03:03:31 CEST] <furq> you can build mpv with libaacs
[03:03:34 CEST] <furq> which i think is what makemkv uses
[03:03:35 CEST] <tdr> ok so maybe mpv then huh?  i can buidl that
[03:03:51 CEST] <kevmitch> no makemkv replaces libaacs
[03:03:57 CEST] <furq> oh does it have its own implementation
[03:04:08 CEST] <furq> i'm glad i don't have a bd drive and i don't have to deal with this shit
[03:04:13 CEST] <furq> it sounds fucking awful
[03:04:19 CEST] <tdr> furq, yeah if i use makemkv it adds a key or whatever, and the disk is unlocked or whatever
[03:04:23 CEST] <kevmitch> (which only works on old blu rays - if you're drive didn't get blacklisted)
[03:04:42 CEST] <furq> is there anything other than makemkv that works with 3d/4k blurays
[03:04:45 CEST] <furq> on linux
[03:04:47 CEST] <VectorX> also tried after  apt-get install libwebp-dev   but same
[03:05:22 CEST] <kevmitch> there's nothing that decodes 4k blu rays other than hardware players last time i checked.
[03:05:24 CEST] <tdr> furq, i only use that open a disc once because it can fetch working keys
[03:07:43 CEST] <furq> VectorX: looks like you're missing cc1obj
[03:07:58 CEST] <furq> i think that's part of gobjc on debian
[03:11:39 CEST] <furq> actually nvm i don't think that error means anything
[03:12:01 CEST] <furq> it just can't find libwebp in your pkg-config path
[03:29:10 CEST] <VectorX> furq what can i do
[03:56:01 CEST] <james999> eh to play 4k bluray on linux... sounds like something i'd have to google for
[04:03:40 CEST] <furq> VectorX: make sure libwebp.pc is in the right place
[04:04:38 CEST] <klaxa> i had nothing but trouble with blurays on linux
[04:05:46 CEST] <VectorX> its already in /usr/lib/x86_64-linux-gnu/pkgconfig/libwebp.pc
[04:12:59 CEST] <VectorX> furq where should i copy the file to
[04:13:12 CEST] <furq> that's already the right place
[04:13:29 CEST] <furq> if you installed libwebp-dev then i don't know why that would be failing
[04:17:59 CEST] <klaxa> maybe pkg-config misconfigured? maybe add the path to the PKG_CONFIG_PATH variable?
[04:19:12 CEST] <furq> it shouldn't be on debian/ubuntu
[04:20:35 CEST] <klaxa> well, i know _I_ for one can break any system to unusability :)
[04:20:48 CEST] <klaxa> by accident too
[04:21:17 CEST] <furq> i don't know how you would even do that
[04:21:26 CEST] <klaxa> i wish i knew
[04:21:31 CEST] <furq> without recompiling pkg-config with a different hardcoded path
[04:21:49 CEST] <furq> and there's a very specific amount of drunk you'd have to be to be capable of doing that but incapable of remembering
[04:21:54 CEST] <furq> that i don't think anyone has ever achieved
[04:24:38 CEST] <VectorX> klaxa same result after PKG_CONFIG_PATH=/usr/lib/x86_64-linux-gnu/pkgconfig
[04:24:49 CEST] <furq> yeah it can't possibly be that
[04:25:00 CEST] <furq> that path is hardcoded
[04:25:30 CEST] <VectorX> this is so annoying
[04:25:32 CEST] <furq> check that the headers and libs are in the right place and that the .pc is actually correct
[04:25:57 CEST] <furq> also fwiw i always found cwebp to be much less hassle
[04:26:11 CEST] <furq> but i guess if you're not just encoding png to webp then it's not really a good answer
[04:26:41 CEST] <VectorX> yeah i need to make a animated webp into a mp4
[04:26:47 CEST] <VectorX> not even sure if it could do that
[04:26:54 CEST] <furq> yeah that ought to work
[04:27:26 CEST] <furq> er
[04:27:35 CEST] <furq> which debian are you on
[04:27:44 CEST] <furq> ffmpeg from the stretch repos has libwebp enabled
[04:28:56 CEST] <furq> if you're on stable you might as well upgrade, stretch is due to be released any day now
[04:29:24 CEST] <furq> wait nvm i forgot that ubuntu exists again
[04:30:14 CEST] <furq> same thing with new ubuntu though
[04:32:13 CEST] <VectorX> ubuntu
[04:32:46 CEST] <furq> https://www.johnvansickle.com/ffmpeg/
[04:32:50 CEST] <furq> these builds have libwebp as well
[04:38:26 CEST] <james999> i use debian but i don't remember what their bureacratic policy is
[04:38:47 CEST] <james999> something like, they freeze updates to stable. then sid becomes the new release... or something
[04:42:46 CEST] <furq> sid never becomes the new release
[04:42:57 CEST] <furq> they freeze updates to testing, then testing becomes the new stable
[04:43:11 CEST] <furq> which is what's happening now
[04:43:26 CEST] <furq> which is annoying because it means my supposedly rolling distro has only had security updates since february
[04:51:39 CEST] <james999> they've frozen testing since feb?
[04:53:26 CEST] <furq> yeah
[04:53:39 CEST] <furq> the official release schedule is "when it's ready"
[04:53:49 CEST] <furq> which sounds big and clever when you've not been stuck in a package freeze for three months
[05:04:12 CEST] <james999> i thought you were going to say i was an idiot for even suggesting that
[05:04:39 CEST] <james999> haha
[05:12:37 CEST] <VectorX> i also noticed, "WARNING: pkg-config not found, library detection may fail." how can i get that fixed
[05:14:23 CEST] <furq> er.
[05:14:31 CEST] <furq> well no wonder pkg-config can't find any libs if you don't have it installed
[05:14:34 CEST] <furq> so install it
[05:14:46 CEST] <VectorX> yup did that, config worked, that was the issue
[05:17:53 CEST] <VectorX> now i get [webp @ 0x1f3fe40] skipping unsupported chunk: ANIM
[05:18:05 CEST] <VectorX> ffmpeg -i 3add57529c64805ab3ed3d87ddeca805.webp a.mp4
[05:33:15 CEST] <VectorX> https://pasteboard.co/byYR8p6K8.png
[05:34:21 CEST] <VectorX> also tried with -analyzeduration 2147483647 -probesize 2147483647  but same
[05:50:46 CEST] <furq> https://trac.ffmpeg.org/ticket/4907
[05:50:47 CEST] <furq> oh
[05:59:06 CEST] <DSmateJ> i have $250,000 to invest  , what should i buy
[06:01:32 CEST] <furq> you could buy me a house
[06:02:07 CEST] <furq> in return, i will send you one (1) picture of me enjoying living in the house every week. i will not be nude
[06:02:37 CEST] <furq> not after last time
[06:24:25 CEST] <Kuukunen> for the rest of your life?!
[06:24:30 CEST] <Kuukunen> that's a big commitment
[06:51:48 CEST] <VectorX> furq thanks for the error, what can i do in this situation
[07:52:50 CEST] <tezogmix> follow-up from earlier: if combining all 4 examples together, then the "pause" would be right below the last command right? (so that I wouldn't have to be there to press any key to continue the next action found in the batch file)?
[07:53:02 CEST] <tezogmix> https://pastebin.com/3dG9uBzb > example
[07:53:45 CEST] <tezogmix> I was going to run a few different input files right before bed
[10:16:29 CEST] <jasom> is it possible to use gstreamer as an ffmpeg input?
[11:17:48 CEST] <crziter> Do I need to call sws_freeContext to free context from sws_getContext?
[12:08:56 CEST] <dreamon> hello using ’ avconv -ss 00:36:00 -i Pak2_1.mkv -vcodec copy -acodec copy Out.mkv ’ to cut a movie ’ but ’ [matroska @ 0x2deafa0] failed to avoid negative pts -62 in stream 1.’ Try -avoid_negative_ts 1 as a possible workaround.
[12:09:21 CEST] <BtbN> avconv is not an ffmpeg tool.
[12:09:55 CEST] <dreamon> sorry .. same on ffmpeg
[12:10:26 CEST] <dreamon> ffmpeg -ss 00:36:00 -avoid_negative_ts -i Pak2_1.mkv -vcodec copy -acodec copy Out.mkv
[12:10:40 CEST] <dreamon> Output file #0 does not contain any stream
[12:11:13 CEST] <BtbN> Is the input file even that long?
[12:11:36 CEST] <BtbN> also, you're missing the parameter to -avoid_neg_ts
[12:12:08 CEST] <dreamon> fmpeg -i VTS_01_2.mkv -vcodec copy -acodec copy -t 00:31:44 VTS_Out.mkv ’ works fine
[12:12:22 CEST] <BtbN> Also, just use -c copy
[12:12:29 CEST] <BtbN> acodec/vcodec are old
[12:16:01 CEST] <dreamon> BtbN, This works. Is there a gui tool for ffmpeg that make handling it easier?
[12:16:07 CEST] <BtbN> no
[12:16:35 CEST] <BtbN> Also, what do you mean, this works? -c copy is just the modern syntax for -a/vcodec copy
[12:16:43 CEST] <BtbN> Is should not change functionality in any way
[12:17:12 CEST] <dreamon> BtbN, I used the wrong input file.. that wasnt long enough. an I was 100% sure it was the right one
[12:19:14 CEST] <dreamon> BtbN, Thank you
[12:37:58 CEST] <userdr> Media Player Classic not running
[14:08:47 CEST] <fps> i'm trying my luck with delaying audio: ffmpeg  -y -i 03_replaced_audio_put2.mp4 -itsoffset 20.0 -i 03_replaced_audio_put2.mp4 -map 0:0 -map 1:1 -vcodec copy -acodec copy 03_replaced_audio_delayed_put2.mp4
[14:09:04 CEST] <fps> 20 secs give no delay at all. 30 secs gives 30 secs of delay. is that a key frame issue?
[14:31:51 CEST] <fps> ah drats, i'll just use sox to insert silence into the wav
[15:03:26 CEST] <faLUCE> I'm seeing that there is a code called "avplay.c", which is a player. Do you know what is the difference with ffplay and if it supported?
[15:03:37 CEST] <faLUCE> I'm seeing that there is a code called "avplay.c", which is a player. Do you know what is the difference with ffplay and if it is supported?
[15:07:39 CEST] <faLUCE> Do you know if is there a good library for making an audio/video player? I tried upipe but it's in a bad state, then I tried libmpv but it has a too small API, which doesn't allow to control many parameters... libvlc has the same problem as libmpv.
[15:08:01 CEST] <faLUCE> in addition libav requires too much code for making a player
[15:41:07 CEST] <userdr> i use autoit recently and i want to obtain a list of dshow devices i have trough devices DLL but i dont know how to interact with parameters when calling the DLL
[19:03:09 CEST] <ppw> what would be the proper command to mix 5.1 channel audio down to 2?
[19:03:24 CEST] <furq> -ac 2
[19:03:58 CEST] <ppw> uh, I don't think that respects the Dolby Digital 5.1 mixdown matrix
[19:05:44 CEST] <ppw> https://ffmpeg.zeranoe.com/forum/viewtopic.php?t=1851
[19:11:43 CEST] <furq> in that case i guess you want -ac 2 -af aresample=matrix_encoding=dolby
[19:11:59 CEST] <furq> or dplii for the prologic 2 matrix
[19:12:26 CEST] <ppw> niiice
[19:16:28 CEST] <lengtche> I'm using command `ffmpeg.exe -i '.\aaa.flac' -codec:a libmp3lame -q:a 0 aaa.mp3` to convert FLAC to MP3 v0 using the LAME plugin. Whenever I play this music in foobar2000 (for example), I see the quality as VBR instead of VBR v0. But if I do the same conversion using LAME's binary, I get the correct quality shown. Why is that?
[19:16:48 CEST] <furq> ffmpeg doesn't write the xing header the same as the lame binary
[19:17:06 CEST] <furq> the files should be identical, it'll just show up differently with stuff that reads that header
[19:17:38 CEST] <furq> iirc there's an outstanding bug report for it but it's not exactly a critical feature
[19:28:49 CEST] <lengtche> furq: Thanks for the prompt reply. :D
[20:00:10 CEST] <thebombzen> furq: is there any remuxing workaround of some variation of ffmpeg -i foo.mp3 -c copy bar.mp3
[20:00:33 CEST] <jasom> is it possible to use gstreamer as an ffmpeg input?
[20:01:57 CEST] <teratorn> jasom: since gstreamer has an ffmpeg plugin, probably
[20:02:23 CEST] <furq> thebombzen: for what
[20:02:44 CEST] <thebombzen> about the tags from before
[20:02:49 CEST] <teratorn> jasom: but I'm guessing you would use gstreamer, not ffmpeg, as the front-end
[20:02:52 CEST] <thebombzen> ffmpeg not writing the vbr correctly
[20:03:02 CEST] <furq> no?
[20:03:09 CEST] <furq> it's specifically the ffmpeg mp3 muxer that doesn't do that
[20:03:34 CEST] <furq> lame is the only thing that does it, it's not part of any standard
[20:03:52 CEST] <furq> obviously, since it's writing the lame vbr profile
[20:05:02 CEST] <jasom> teratorn: composing a gst-launch command hurts my brain, but gstreamer has a v4l2 bugfix for years that's languished in the ffmpeg bugtracker :(
[20:06:39 CEST] <teratorn> jasom: link?
[20:07:31 CEST] <jasom> teratorn: https://trac.ffmpeg.org/ticket/4988
[20:09:14 CEST] <jasom> though I suppose the patch was only posted 9 months ago, so not too terrible.  I suppose I could apply the patch locally as well.
[20:11:36 CEST] <teratorn> jasom: so it's a work-around for a v4l2 driver bug?
[20:12:00 CEST] <teratorn> I think I would make sure that hasn't been fixed upstream, too
[20:15:44 CEST] <jasom> teratorn: I'm not convinced it's a driver bug per-se.  at least the gstreamer bug discussion seemed to be unsure.
[20:17:01 CEST] <teratorn> jasom: does the thing about reloading the driver help you?
[20:17:12 CEST] <jasom> for about 30 seconds
[20:17:51 CEST] <teratorn> well, ffmpeg is starting up fresh each time, so the persistent issue must be on the driver side, right?
[20:18:23 CEST] <jasom> actually each time I restart ffmpeg it works fine, since the fix for #4030 is in
[20:19:13 CEST] <jasom> The merge commit describes the behavior of the driver thusly: "This allow skipping buffer flagged with ERROR that has no payload.  This is typical behaviour when a recovererable error occured during capture in the driver, but that no valid data was ever written into that buffer."
[20:19:42 CEST] <teratorn> I see - webcams and usb are terrible
[20:20:35 CEST] <jasom> yes, though this seems to be most common with Magewell UVC devices.  Possibly just because they generate so much more data than the typical webcam
[20:21:23 CEST] <jasom> (In this case uncompressed 4:2:0 1080p30 video)
[20:21:54 CEST] <Munt> Hey folks I'm doing a recursive encoding of all my MOV files (about 200).  I wish to archive them so they take up less space.  currently I am doing ffmpeg -i filein.mov -preset slow fileout.mp4       How does ffmpeg in this instance determine the bitrate of the output file ?
[20:22:59 CEST] <jasom> Munt: are you specifying a video codec at all?
[20:23:07 CEST] <teratorn> jasom: ~93MB/s is a lot, I guess :/
[20:23:32 CEST] <furq> Munt: it doesn't, it uses the libx264 defaults (assuming you have a build with libx264)
[20:23:35 CEST] <furq> which is -crf 23
[20:23:46 CEST] <Munt> jasom  : I thought adding the .mp4 on the output file specified h264 ?
[20:23:51 CEST] <furq> ^
[20:24:08 CEST] <jasom> Munt: to translate what furq says, it uses fixed-quality rather than fixed bitrate encoding
[20:24:26 CEST] <Munt> should I bump it up a little for my archives ?
[20:24:33 CEST] <furq> probably
[20:24:44 CEST] <Munt> the output files are very small and at around 4500kbps I can afford more space
[20:24:53 CEST] <furq> if it's for archival then you should probably just not reencode them
[20:24:59 CEST] <jasom> Munt: probably; are the .mov files lossy compressed already?
[20:25:27 CEST] <Munt> It varies widely.  Currently they take up over 600GB and I want to back them up to blueraydl
[20:25:40 CEST] <jasom> because compression artifacts are themselves hard to compress, and sometimes throw off the psy filter in h264
[20:25:58 CEST] <Munt> is there a way for ffmpeg to skip already compres files ?
[20:26:03 CEST] <furq> no
[20:26:16 CEST] <furq> mostly because they're all already compressed
[20:26:34 CEST] <Munt> what do you think a good -crf value for me would be ? (also how long is a piece of string :P)
[20:26:44 CEST] <furq> i use 20 for more or less everything
[20:27:02 CEST] <furq> 18-22 is pretty sensible
[20:27:43 CEST] <Munt> bigger is better i presume ?
[20:27:47 CEST] <furq> lower is better
[20:27:53 CEST] <jasom> Munt: There's no one-size-fits-all.  I was re-encoding a poorly mastered DVD and had to run some serious filtering on it to get acceptible quality at 18, though usually 18-22 is going to be unnoticable.
[20:28:15 CEST] <Munt> that's very valuable information folks thanks a lot <3
[20:28:51 CEST] <sfan5> you'd think with the amount of times this question has been asked here or elsewhere someone would've written a guide on how to chooce x264 encoding params...
[20:29:00 CEST] <jasom> there is a guide
[20:29:03 CEST] <jasom> on the ffmpeg wiki
[20:29:09 CEST] <furq> there's probably one on the wiki but i'd generally rather not link the wiki
[20:29:14 CEST] <furq> since so much of it is garbage
[20:29:40 CEST] <jasom> https://trac.ffmpeg.org/wiki/Encode/H.264
[20:29:59 CEST] <jasom> includes options for iOS compatibility even
[20:30:44 CEST] <Munt> I have been researching it. I'm also very indecisive :$    I really appreciate the advise thanks folk.
[20:30:56 CEST] <Munt> s/folk/folks
[20:31:28 CEST] <Munt> and apparently my reading comprehension leaves a lot to be desired >,<
[20:41:09 CEST] <Munt> do you think I'll gain much wuality on the slow setting at -crf 18  ?  Or am I better working a bit faster ?
[20:41:40 CEST] <sfan5> if you're doing this for archival i'd suggest keeping as much quality as you can afford
[20:42:04 CEST] <Munt> cool, thanks sfan5
[20:53:37 CEST] <[empty]>  i have $250,000 to invest  , what should i buy
[20:54:07 CEST] <durandal_1707> bitcoins
[20:54:14 CEST] <klaxa> monero maybe?
[20:54:31 CEST] <klaxa> or ripple, that's backed by the banks, make sure to sell before the whole banking system collapses though
[20:55:05 CEST] <[empty]> klaxa  is that a stock?
[20:55:18 CEST] <klaxa> crypto currencies
[20:55:54 CEST] <klaxa> i wouldn't be surprised if monero becomes the new bitcoin though
[20:56:08 CEST] <[empty]> klaxa so if you had $250,000.00 , you woulld really invest on cryptocurrency?
[20:56:18 CEST] <[empty]> all of it
[20:56:21 CEST] <klaxa> probably
[20:56:52 CEST] <klaxa> just look at the bitcoin course
[20:57:03 CEST] <klaxa> basically exponential growth for over two years
[20:57:07 CEST] <[empty]> klaxa do you trust 250k on  cryptocurrency exchange sites?
[20:57:13 CEST] <klaxa> no
[20:57:21 CEST] <[empty]> that's a problem then
[20:57:26 CEST] <klaxa> you can put it on your own wallet
[20:57:29 CEST] <[empty]> how do you expect to buy without using exchange sites
[20:57:38 CEST] <klaxa> that's the whole point of crypto currencies
[20:57:41 CEST] <klaxa> you don't trust anyone
[20:58:05 CEST] <klaxa> you can buy at an exchange and transfer it to your personal wallet
[20:58:08 CEST] <[empty]> klaxa you still have to trust somebody to buy coins
[20:58:15 CEST] <[empty]> since it has to be done by exchange sites
[22:39:30 CEST] <jasom> [empty]: VDMIX
[22:39:50 CEST] <[empty]> jasom is that mutual fund?
[22:40:52 CEST] <jasom> [empty]: eys
[22:41:39 CEST] <[empty]> how much are you invested with mdmix
[22:41:43 CEST] <[empty]> vd*
[22:41:47 CEST] <jasom> looks like VDMIX is closed; VTMGX is the similar fund
[22:42:12 CEST] <jasom> [empty]: I'd have to check since it's volatile, but probably around $200k
[22:42:21 CEST] <[empty]> wow that's alot
[22:43:23 CEST] <jasom> need to move some out now that I'm getting older actually; this is all retirement savings
[22:53:13 CEST] <jasom> [empty]: not as much if it's what you're planning on living off of soon...
[22:53:21 CEST] <[empty]> jasom no i am not
[22:53:30 CEST] <jasom> [empty]: was referrign to me
[22:53:48 CEST] <[empty]> oh
[22:58:46 CEST] <nadermx> Anyone know why when I make a mp4 to a mp3 with a thumbnail it works fine unless I send it to stdout in which case the thumbnail is not added but the rest of the metadata is?
[23:20:36 CEST] <ExeciN> I want to stream audio and video to another computer. I want to be listening so no port forwarding would be needed by the other computer
[23:20:49 CEST] <ExeciN> this is what I'm trying to use: ffmpeg -f avfoundation -framerate 15 -i "1:4" -vf scale=960:540 -vcodec libx264 -pix_fmt yuyv422 -tune zerolatency -preset ultrafast -f mpegts tcp:
[23:21:30 CEST] <klaxa> looks okay
[23:21:35 CEST] <ExeciN> can I use as my host and bind it everywhere?
[23:21:46 CEST] <klaxa> oh wait
[23:21:53 CEST] <ExeciN> also is this how I listen to connections?
[23:21:54 CEST] <klaxa> use tcp://
[23:22:31 CEST] <klaxa> not sure if ?listen is correct, i know that -listen 1 is definitely correct
[23:22:56 CEST] <klaxa> so: ffmpeg -f avfoundation -framerate 15 -i "1:4" -vf scale=960:540 -vcodec libx264 -pix_fmt yuyv422 -tune zerolatency -preset ultrafast -f mpegts -listen 1 tcp://
[23:23:32 CEST] <ExeciN> wow it finally works
[23:23:41 CEST] <ExeciN> I definitely had a malformed url
[23:28:39 CEST] <ExeciN> as it seems both -listen 1 and ?listen works but I think I'll use -listen 1 to make it a bit more clean
[00:00:00 CEST] --- Mon May 29 2017

More information about the Ffmpeg-devel-irc mailing list