[Ffmpeg-devel-irc] ffmpeg.log.20180804

burek burek021 at gmail.com
Sun Aug 5 03:05:02 EEST 2018

[00:02:17 CEST] <Case_Of> ah
[00:43:30 CEST] <Case_Of> atomnuker: made an ebuild for gentoo https://gist.github.com/CaseOf/e990438f5f0ebead41c70cab5f9fe58f
[00:47:34 CEST] <atomnuker> cool, thanks
[00:47:41 CEST] <atomnuker> they still mask 4.0, don't they?
[00:48:49 CEST] <Case_Of> yes they still
[00:49:17 CEST] <BtbN> Well, there's still a lot of software that breaks on 4.0
[00:49:27 CEST] <BtbN> so it's gonna stay marked as unstable for a while
[00:50:36 CEST] <Case_Of> at least i can do it on a VM for testing
[00:50:55 CEST] <Case_Of> i do not know it would handle /dev/sr0 though
[00:52:16 CEST] <Case_Of> i have a gentoo vm that i can test it on
[01:12:08 CEST] <Case_Of> the longest task was to copy the ebuild to the vm
[01:14:09 CEST] <Case_Of> about 2 minutes to build ffmpeg is nice
[01:35:04 CEST] <Case_Of> atomnuker: oops https://ptpb.pw/GCfH
[01:36:28 CEST] <Case_Of> atomnuker: it's screwed on gentoo then
[01:41:45 CEST] <Case_Of> atomnuker: should i set >=media-video/ffmpeg-9999 in dependencies?
[01:46:22 CEST] <Case_Of> i'm trying
[01:50:24 CEST] <Case_Of> it works with ffmpeg-9999
[01:57:53 CEST] <Case_Of> atomnuker: updated https://gist.github.com/CaseOf/e990438f5f0ebead41c70cab5f9fe58f
[02:30:44 CEST] <Case_Of> atomnuker: well& https://ptpb.pw/Jnvr
[02:31:56 CEST] <atomnuker> permissions?
[02:32:35 CEST] <Case_Of> it's running as root
[02:34:34 CEST] <atomnuker> not sure then, never tested it in a vm
[02:35:21 CEST] <Case_Of> that's why i was having doubt earlier about that test
[02:35:32 CEST] <Case_Of> [00:50:55] <Case_Of> i do not know it would handle /dev/sr0 though
[02:36:26 CEST] <Case_Of> at least, i've tested it's build process in the ebuild
[02:36:38 CEST] <Case_Of> to fix that ffmpeg dependency
[02:40:04 CEST] <Case_Of> oh well, when you search cyanrip gentoo on google, you already get my gist
[05:37:00 CEST] Action: botik101 greets everyones from simmering Zanzibar...he wishes he was there
[05:37:31 CEST] <botik101> Is there a pre-compiled ffmpeg out there that I can use with majority of features in for Ubuntu 160.04
[05:38:29 CEST] <botik101> only this?
[05:38:30 CEST] <botik101> https://johnvansickle.com/ffmpeg/
[05:41:24 CEST] <Cracki> sudo apt install ffmpeg
[05:41:28 CEST] <Cracki> have you tried that
[05:42:49 CEST] <botik101> Crack - yes...
[05:43:17 CEST] <botik101> Crack  - I have noticed that pre-compiled ffmpeg usually has better features
[05:43:34 CEST] <Cracki> you use that term wrong
[05:43:34 CEST] <botik101> Cracki: also, I was really hoping to find one that would be pre-compiled for NVIDIA GPU
[05:43:52 CEST] <Cracki> everything you don't have to compile on your own machine is "pre-compiled"
[05:43:59 CEST] <Cracki> wat
[05:44:04 CEST] <botik101> I tried on numerous occasions to use NVidia GPU and compile it and each time my subuntu wen to hell and destroyed other projects that were already using CUDA
[05:44:12 CEST] <Cracki> hardware acceleration for decoding and encoding depends on the system
[05:44:21 CEST] <Cracki> huh?
[05:44:52 CEST] <botik101> Cracki: I come from Windows background where I wrote a lot of drivers
[05:45:22 CEST] <Cracki> what does that mean?
[05:45:30 CEST] <Cracki> rather: what do you mean to say?
[05:45:30 CEST] <botik101> Cracki: all the way back to VxDs, and i find the concept that if I have Nvidia installed that I need to individually compile ffmpeg to enable -nvenc really frustrating
[05:45:47 CEST] <Cracki> uh...
[05:45:55 CEST] <Cracki> you have some misconceptions there
[05:46:35 CEST] <botik101> Cracki: I am not pretending to know how things work in Linux ... I am new. But, I just do not understand why we cannot have a dynamically linked library of some sort that would allow me to have ffmpeg working in an environment with Nvidia
[05:47:02 CEST] <botik101> Crackl I hope I do - please tell me - because I am going bald ripping my hairs out trying to compile ffmpeg for my Nvidia GPU
[05:47:28 CEST] <Cracki> pick any ffmpeg binary you have. ask it what build flags it was built with
[05:47:47 CEST] <botik101> Cracki: ok...
[05:47:55 CEST] <Cracki> then share those using a pastebin
[05:48:13 CEST] <Cracki> just running ffmpeg will/should print the build configuration switches
[05:49:04 CEST] <Cracki> while you're at it, skim https://trac.ffmpeg.org/wiki/HWAccelIntro
[05:49:28 CEST] <botik101> Cracki: https://paste.pound-python.org/show/gI13zF0tJooAExv9ESxp/
[05:50:16 CEST] <botik101> Cracki: thank you for your patience... I know it is frustrating to explain the most  obvious things here. I am being retrained by the company form mantaining our Windows drivers to completely new project and I have been struggling to say the least
[05:51:14 CEST] <botik101> Cracki: For twenty years I was keeping eye on our Windows drivers... This is a completely new beast to me. The world has changed a lot... Believe it or not I have been Using VS 4.2
[05:51:16 CEST] <Cracki> https://dwijaybane.wordpress.com/2017/07/19/ffmpeg-with-nvidia-acceleration-on-ubuntu-16-04-nvenc-sdk/
[05:51:22 CEST] <Cracki> you can stop highlighting me
[05:51:53 CEST] <Cracki> your past on windows matters very little (1) today (2) on linux
[05:52:01 CEST] <botik101> sorry.
[05:52:04 CEST] <Cracki> google is your best friend.
[05:52:15 CEST] <Cracki> you are never the first one to have your problem.
[05:52:27 CEST] <botik101> yes, thus I am tryng to learn as fast as I can. It is a compeltely different beast.
[05:53:30 CEST] <botik101> In the example you sent me, we are still required to compiled ffmpeg. Can someone please understand why it needs to be compiled. We don't compile windows projects per each ndividual platform. It feels as if we wee back in 1990s
[05:53:37 CEST] <Cracki> https://github.com/lutris/ffmpeg-nvenc
[05:53:58 CEST] <Cracki> DLLs are hard
[05:54:26 CEST] <botik101> cra: lol, they can be hard, but linux was alive for longer than recent windows.
[05:54:44 CEST] <Cracki> it also didn't have the commercial backing ;)
[05:54:55 CEST] <botik101> cra: I feel like it is like 1992 when I was compiling my ircserver to connect to the world
[05:55:38 CEST] <botik101> cea: very true, but judging at ffmpeg source code - people who are writing it are nothing short of geniuses. I know I am not capable of writing the same level even on Windows
[05:56:00 CEST] <botik101> cra: I would assume by now people woudl make things much more compatible. So strange.
[05:56:32 CEST] <Cracki> how much experience with linux do you have?
[05:56:40 CEST] <Cracki> do you know how many goddamned distributions there are?
[05:56:52 CEST] <Cracki> developing for linux is like developing for android
[05:57:05 CEST] <Cracki> as opposed to iphone, where you have a dozen iphones OVERALL
[05:57:35 CEST] <Cracki> nvidia seems to have made some more effort to create usable drivers for linux...
[05:57:45 CEST] <botik101> arghh/...dont mention iphone - hate that thing with passion - it may have been a good idea but it killed innovation
[05:58:28 CEST] <Cracki> https://developer.nvidia.com/ffmpeg
[05:59:05 CEST] <Cracki> https://ubuntuforums.org/showthread.php?t=2374338
[05:59:14 CEST] <botik101> Crack; but i am looking at ubuntu - it sure runs without compiling - it is simply incredible! I would assume that there are main baselines that objects can be precompiled for. I am looking at Lobre  Office - I installed it and it did not have to be compiled. There are ffmpeg pre-compiled. So why not have NVIDIA-enabled ffmpeg prevompiled? Nvidia is not standardized enough?
[05:59:43 CEST] <Cracki> seems not, I don't know
[05:59:56 CEST] <Cracki> better ask the ffmpeg developers/maintainers
[06:00:11 CEST] <Cracki> or rather the package maintainer for ubuntu
[06:00:27 CEST] <Cracki> it's the package maintainer's job to make the binaries
[06:00:48 CEST] <Cracki> what ffmpeg did you post the output of? package source? https://johnvansickle.com/ffmpeg/?
[06:02:54 CEST] <botik101> this: https://johnvansickle.com/ffmpeg/
[06:03:16 CEST] <botik101>   x86_64 build: ffmpeg-git-64bit-static.tar.xz
[06:03:27 CEST] <Cracki> you will come across "vdpau", which is an acceleration api for linux
[06:03:35 CEST] <Cracki> see the hwaccel wiki page
[06:03:42 CEST] <Cracki> https://video.stackexchange.com/questions/18490/how-to-get-vdpau-hardware-acceleration-using-ffmpeg
[06:03:46 CEST] <Cracki> try ffmpeg -hwaccels
[06:05:02 CEST] <Cracki> the problem with linux fanboys is that they are quite communist and reject any commercially important features (i.e. hw acceleration). the window builds of ffmpeg contain everything you can think of
[06:05:56 CEST] <Cracki> I don't know if there's a technical reason not to compile ffmpeg with acceleration interfaces for linux. I don't know if there are builds with that.
[06:06:56 CEST] <Cracki> not ubuntu, but informative https://wiki.archlinux.org/index.php/Hardware_video_acceleration
[06:08:05 CEST] <Cracki> https://askubuntu.com/questions/777616/how-to-get-vdpau-hardware-acceleration-using-ffmpeg-on-ubuntu
[06:10:08 CEST] <kepstin> note that with modern nvidia cards (and the closed source drivers), it might be preferable to use nvdec/nvenc instead of vdpau, at least for transcoding applications
[06:10:33 CEST] <kepstin> and with intel/ati hardware, the vaapi interface is used
[06:10:47 CEST] <friendofafriend> There's hardware acceleration in ffmpeg by NVENC/NVDEC, and h264_omx on the Raspberry Pi.
[06:11:02 CEST] <Cracki> kepstin, would you know why there don't seem to be ffmpeg binaries for linux that have some hardware support compiled into them?
[06:12:01 CEST] <kepstin> Cracki: not sure. I *think* the current nvenc/nvdec stuff in ffmpeg can be enabled now without creating a non-redistributable binary.
[06:12:05 CEST] <Cracki> (the only linuxes I have access to right now are headless boxes without graphics hw, or I would have checked the hwaccels availability)
[06:12:28 CEST] <Cracki> the build could not be completely static...
[06:12:50 CEST] <Cracki> so it would use dynamic linking to whatever driver is in the system. it could of course detect if that can be found or not.
[06:13:02 CEST] <kepstin> yes, that's how it would work.
[06:13:36 CEST] <kepstin> hmm. come to think of it, that might be why nobody has a static build with that stuff enabled
[06:14:05 CEST] <kepstin> I seem to remember something about how static executables can't use dlload()? could be wrong
[06:14:11 CEST] <kepstin> er, dlopen()
[06:14:17 CEST] <Cracki> uh that might be very strange
[06:14:32 CEST] <Cracki> possible...
[06:14:45 CEST] <Cracki> but I can't imagine such a silly restriction
[06:15:54 CEST] <Cracki> static linking is like including object files _you_ didn't have source for, so I see no reason why linking one thing statically and another dynamically should be impossible
[06:16:59 CEST] <Cracki> seems the compiler can get confused if you aren't precise about your wishes https://stackoverflow.com/questions/14289488/use-dlsym-on-a-static-binary
[06:17:17 CEST] <kepstin> static linking is creating a static executable, i.e. one that doesn't use the dynamic loader (ld.so)
[06:17:24 CEST] <kepstin> well
[06:17:27 CEST] <kepstin> that's not really right
[06:17:39 CEST] <Cracki> I knew linux and linking was weird...
[06:17:52 CEST] <kepstin> you can link individual library archives into a dynamic executable
[06:17:57 CEST] <kepstin> and that's also called static linking
[06:19:54 CEST] <Cracki> ah http://www.yolinux.com/TUTORIALS/LibraryArchives-StaticAndDynamic.html
[06:20:07 CEST] <kepstin> but the "static" ffmpeg builds available are generally built as static executables so they're not tied to specific versions of the standard c libraries (so e.g. you can use them on old linux), which means the dynamic loader isn't available
[06:20:55 CEST] <Cracki> ah, because that would require some standard library of the system to know this system and how to link stuff from it?
[07:51:43 CEST] <botik101> why print is telling me that timestamps are not / cannot be format(ed) for print? https://paste.pound-python.org/show/bGCfZG5vlFUs6rsn6BVw/
[13:10:45 CEST] <Case_Of> atomnuker: i did not got this idea earlier, but i could test it in a chroot
[15:30:22 CEST] <pi-> https://superuser.com/questions/1250900/freeze-last-frame-of-a-video-with-ffmpeg
[15:31:06 CEST] <pi-> I'm trying to do this, only I don't know in advance the characteristics of the source video
[15:31:17 CEST] <pi-> So '-i nullsrc=s=3840x2160:d=10:r=30' wouldn't work
[15:31:38 CEST] <pi-> How can I extract this data from the source video?
[15:32:37 CEST] <pi-> what are d and s?
[15:32:41 CEST] <pi-> r sorry
[15:32:46 CEST] <furq> duration and framerate
[15:32:58 CEST] <furq> you'd need to pull those values separately with ffprobe
[15:34:02 CEST] <pi-> Thanks!
[15:58:04 CEST] <pi-> How is the ffmpeg command in that URL actually working?
[15:58:16 CEST] <pi-> How is it freezing the last frame of the video?
[15:59:32 CEST] <pi-> '-f lavfi' what is this doing?  Where can I find the help?
[16:00:40 CEST] <durandal_1707> pi-: help is on www.ffmpeg.org
[16:02:53 CEST] <durandal_1707> -f lavfi instruct ffmpeg to use lavfi as input source, you then set input filter with -i
[16:07:38 CEST] <kubast2> Hey I have a .mkv file with audio stream ,I want to encode it into .mka without video into multiple streams with different encoders and different settings
[16:07:40 CEST] <kubast2> how do I do that?
[16:08:51 CEST] <DHE> ffmpeg -i input.mkv -map 0:a [output-audio-encoder-options] output.mka
[16:09:09 CEST] <kubast2> uses the settings of the last encoder on all streams
[16:09:25 CEST] <kubast2> I need to add somethin else right ?
[16:09:37 CEST] <DHE> I'm sorry, what?
[16:09:40 CEST] <kubast2> -map 0:a -c:a libopus -b:a 16k -map 0:a -c:a libopus -b:a 32k -map 0:a -c:a libopus -b:a 64k
[16:09:48 CEST] <kubast2> tried doing that probablly something stupid
[16:09:59 CEST] <kubast2> but yeah the resulting bitrate it encodes at is 256KBit
[16:10:06 CEST] <kubast2> and the audio files sound the same
[16:10:07 CEST] <DHE> you could make that work in a single command by putting an output filename after your options
[16:10:52 CEST] <DHE> ffmpeg -i input.mkv -map 0:a -c:a libopus -b:a 16l output-16k.mka -map 0:a -c:a libopus -b:a 32k output-32k.mka -map 0:a -c:a libopus -b:a 64k output-64k.mka
[16:11:03 CEST] <DHE> oops, I made some typos
[16:11:05 CEST] <furq> kubast2: do you want them all in the same file
[16:11:08 CEST] <kubast2> yes
[16:11:22 CEST] <DHE> ah
[16:11:27 CEST] <furq> -map 0:a -map 0:a -map 0:a -c:a libopus -b:a:0 16k -b:a:1 32k -b:a:2 64k
[16:11:46 CEST] <furq> obviously -c:a:0 etc if you want different codecs per stream
[16:40:35 CEST] <kubast2> furq, thanks a lot
[16:44:57 CEST] <jokoon> is there a command to convert a gif directly to a video?
[16:45:46 CEST] <jokoon> oh sorry my google search was bad
[16:52:06 CEST] <JEEB> 41
[20:05:44 CEST] <kubast2> Hey ,is there some way improve crf quality for vp9? Used this settings for h.264 encode and the other ones for vp9 encode ,they result in the same size of a file:
[20:05:54 CEST] <kubast2> libvpx-vp9 -threads 4 -row-mt 1 -tile-columns 1 -frame-parallel 0 -crf 40 ; -crf 26 -profile:v:0 high -preset slower -threads 4
[20:07:04 CEST] <kubast2> it doesn't need to be transparent ,size is a bit more important; they seem very similiar except places where h.264 "just" gets random scenes "right" and vp9 borks at first frame and slowlly but surerlly adjusts back to the right quality
[20:07:15 CEST] <kubast2> by first frame I mean first frame on scene change
[20:08:50 CEST] <kubast2> I can try -deadline best actually IIRC it does fix some places when vp9 borks at lowish bitrates on deadline good
[20:09:18 CEST] <kubast2> ah also yes there was -b:v 0 on vp9 encode
[20:09:30 CEST] <kubast2> I didn't copied it from commandline
[20:21:34 CEST] <kubast2> yeah
[20:22:30 CEST] <Cracki> rate adaption has some parameters you might be able to tune
[20:22:36 CEST] <Cracki> such as maximum rate of change
[20:34:20 CEST] <kubast2> -qmax and -qmin
[20:34:52 CEST] <Cracki> those limit the value, not its rate of change
[20:35:28 CEST] <Cracki> I suspect vp9 limits the change on its quantizer, and that you can unlock that
[23:19:56 CEST] <rrg> Do I need TBC (time base correction) hardware (like good S-VHS players) to record old family recordings on VHS cassettes in good quality? Or can ffmpeg while recording with a regular USB grabber (empia ...) do the same?
[23:21:29 CEST] <Cracki> I think you want to record it right, not postprocess it
[23:33:56 CEST] <rrg> does the used usb  grabber have to be special too or is it enough when the tbc hardware fixes the signal?
[23:42:30 CEST] <Cracki> you ask difficult questions
[23:43:16 CEST] <Cracki> from 5 seconds of googling I could gather that "tbc hardware" takes a fucked up signal and fixes some timing information in it, but don't ask me how it does that
[23:44:14 CEST] <Cracki> the A/D conversion of the signal, e.g. via a grabber that is attached via usb, would do its best to respect the timing info, no matter if it's bad or good
[23:44:55 CEST] <Cracki> how about you *try* something?
[00:00:00 CEST] --- Sun Aug  5 2018

More information about the Ffmpeg-devel-irc mailing list