[Ffmpeg-devel-irc] ffmpeg.log.20180820

burek burek021 at gmail.com
Tue Aug 21 03:05:01 EEST 2018

[01:45:40 CEST] <theemacsshibe> hello everyone
[01:46:02 CEST] <theemacsshibe> is there a reverse of image2pipe? i want to make a video into a PBM pipe to feed to a video processor
[01:46:23 CEST] <c_14> pretty sure -f pbm_pipe is a thing
[01:47:07 CEST] <theemacsshibe> ffmpeg tells me "Requested output format 'pbm_pipe' is not a suitable output format"
[01:48:01 CEST] <theemacsshibe> i tried "ffmpeg -i foo.mp4 -f pbm_pipe out.pbms"
[01:51:14 CEST] <c_14> -f image2pipe should work in any case
[01:51:50 CEST] <theemacsshibe> right
[01:58:02 CEST] <theemacsshibe> "ffmpeg -f image2pipe -i foo.mp4 -vcodec pbm out.pbm" is the closest i've gotten to.
[01:59:33 CEST] <theemacsshibe> got it
[01:59:53 CEST] <theemacsshibe> "ffmpeg -i foo.mp4 -f image2pipe -vcodec pbm out.pbms"
[01:59:56 CEST] <theemacsshibe> goodbye
[06:26:48 CEST] <hiihiii> ugh
[06:27:08 CEST] <hiihiii> I've been using ffmpeg for over a year now
[06:27:46 CEST] <hiihiii> stopped using most other video editor or tools out there
[06:28:26 CEST] <hiihiii> lately I've been using it on my phone through termux to resize images
[06:29:19 CEST] <hiihiii> for uplaod of course, cause the damn thing doesn't ship with an image resizer lol
[06:30:29 CEST] <hiihiii> I'm running ffmpeg -i image.jpg -vf "scale=-1:480" -an output.png
[06:32:35 CEST] <hiihiii> any image that is not landscape (ie portrait) gets rotated
[06:32:47 CEST] <hiihiii> I'm scratching my head now
[06:33:40 CEST] <hiihiii> tried using setsar but it did not work
[06:43:05 CEST] <furq> hiihiii: weird
[06:43:25 CEST] <furq> i assume this is an exif rotation metadata issue, but apparently the default is to just rotate the output accordingly
[06:43:38 CEST] <furq> so idk why that's not working
[06:43:56 CEST] <furq> you can try -autorotate anyway
[06:44:42 CEST] <furq> actually it looks like new ffmpeg only has -autorotate and no -noautorotate, so i guess the docs on the site are outdated
[06:44:49 CEST] <furq> so yeah that should be it
[06:44:51 CEST] <hiihiii> setdar=if(lt(in_w\,in_h)\,9\,16):if(lt(in_w\,in_h)\,16\,9)
[06:44:56 CEST] <furq> yeah don't do that
[06:44:58 CEST] <hiihiii> thx a bunch internet
[06:45:07 CEST] <furq> lol
[06:46:04 CEST] <hiihiii> most of the time when I'm here I just end up answering myself
[06:46:29 CEST] <hiihiii> but let me try -autorotate
[06:46:44 CEST] <hiihiii> I figured it would be the metadata
[06:46:59 CEST] <furq> yeah that used to be the default
[06:47:02 CEST] <furq> not sure why that changed
[06:47:44 CEST] <furq> bear in mind that'll rotate before scaling, so you'll probably need something smarter than -1:480
[06:48:05 CEST] <hiihiii> does it have arguments?
[06:48:16 CEST] <furq> not as far as i can tell
[06:51:26 CEST] <hiihiii> it's input option
[06:53:14 CEST] <hiihiii> -autorotate gives the same error when applied as an input/output option
[06:54:49 CEST] <hiihiii> I have to restart my phone to see the output files hhh samsung you nuts
[06:55:25 CEST] <hiihiii> folders do not have a refresh option?!
[06:56:24 CEST] <hiihiii> tried -noautorotate just for the hell of it, same issue
[06:56:39 CEST] <hiihiii> guess it's time for that dumb condition
[07:30:30 CEST] <hiihiii> the condition didn't work
[07:31:07 CEST] <hiihiii> I used -map_metadata 0 to copy metadata directly to the output but it didn't work either
[07:39:35 CEST] <furq> well png doesn't have exif so yeah
[07:39:48 CEST] <furq> if you encode to jpeg that'll probably work but i assume you don't want to do that
[07:40:38 CEST] <hiihiii> I did try jpg as output
[07:40:53 CEST] <hiihiii> I'm not that dumb
[07:40:59 CEST] <hiihiii> lel
[07:41:13 CEST] <hiihiii> going to rotate them manually
[07:41:16 CEST] <hiihiii> 2018
[07:43:08 CEST] <furq> oh wait is this iOS
[07:43:18 CEST] <furq> apparently iOS uses some custom rotate metadata that nothing else supports
[07:43:21 CEST] <hiihiii> andriod
[07:43:25 CEST] <furq> nvm them
[07:43:32 CEST] <furq> n
[07:44:18 CEST] <hiihiii> no big deal I the tedious task = 3 photos
[10:33:34 CEST] <mijofa_> Is it possible to do HLS encoding, but encode each segment on-demand? That is to somehow get the manifest ahead of time, then only transcode each segment as it's requested
[10:34:14 CEST] <JEEB> how would you still have access to the source at the request point?
[10:34:35 CEST] <JEEB> with live for example
[10:34:58 CEST] <mijofa_> I've tried doing so by manually creating my own manifest, and then using a combination of -ss and -t to set the timing, I've actually managed to get it to work in my web browser (Chrome) but I'm having odd issues with Chromecast
[10:35:15 CEST] <mijofa_> JEEB: I'm encoding it into HLS from a static-file on my filesystem
[10:35:28 CEST] <JEEB> ok, in that case for VOD you will have the source, yes
[10:35:41 CEST] <JEEB> but you will probably want to start using the API and also something that indexes your input
[10:37:03 CEST] <mijofa_> For API usage I've only really got experience with Python, but I've not been able to find Python bindings for ffmpeg/libav. :(
[10:37:16 CEST] <Mavrik> It sounds like you need a proper streaming server, not just ffmpeg
[10:39:52 CEST] <mijofa_> I've not been able to find anything that doesn't expect to have all the pre-encoded segments on the FS, or to at least start transcoding when the stream starts, and then continue sequentially along and hoping the client keeps up with the server's cleanup
[10:40:15 CEST] <mijofa_> Or doesn't jump ahead, at which point it just sits there "buffering" until the server catchs up
[10:40:57 CEST] <JEEB> well basically it'd be you making an nginx or apache module or so
[10:41:07 CEST] <JEEB> in any case the assets need to be first indexed
[10:41:15 CEST] <JEEB> and then using that index you can do frame-exact decoding
[10:41:41 CEST] <JEEB> also you need to keep in mind that f.ex. for HLS you need to keep the MPEG-TS muxing so that the stream is continuous with all the flags
[10:41:50 CEST] <JEEB> otherwise you will get discontinuities
[10:43:02 CEST] <mijofa_> Hmmm, ok, that is probably where I'm running into trouble. Chromecast seems to just give up and stop as soon as it downloads the 2nd segment, but if I set the -output_ts_offset to 1 second more than what I think it "should" be, Chromecast kinda continues, but struggles along in weird ways
[10:43:30 CEST] <JEEB> yea you will have to not only encode properly but also mux properly
[10:43:37 CEST] <mijofa_> Browser just continues along fine, but it's probably smarter than that
[10:43:47 CEST] <mijofa_> Or dumber and just playing it sequentially
[10:44:07 CEST] <JEEB> also using -ss and -t sounds really problematic. for a proper solution you will need to start using the APIs and having indexing of the input etc
[10:45:01 CEST] <mijofa_> Yeah, I figured the -ss and -t was flakey and needed improvement, but didn't seem to be the culprit
[10:46:02 CEST] <mijofa_> Ah, ok, maybe is part of the culprit. Running ffprobe on my manually generated segments indicates they're not *exactly* what I gave to -t, which means my math for the -output_ts_offset is wrong, also the math for me next -ss is wrong
[10:46:22 CEST] <mijofa_> Even though I said -accurate_seek, hmm, ok, thanks for the info, this helps me narrow things down significantly
[11:53:18 CEST] <gryffus> Hello, i have a problem playing some 4k UHD videos on my Samsung UE55MU6172 TV. Is it possible what is the difference between working and non-working videos? Here is comparison of MediaInfo of Working and non working videos: https://i.imgur.com/yu0a1zZ.png . Thanks for any clue.
[11:53:35 CEST] <gryffus> *possible to tell me
[12:12:48 CEST] <remlap> gryffus: maybe export them a txt and pastebin it?
[12:14:12 CEST] <gryffus> remlap: export what? export to who? I am not sure i understand you.
[12:15:10 CEST] <remlap> export the mediainfo to a txt file so its easier to read
[12:15:30 CEST] <gryffus> Oh, ok, i will try, give me a sec please
[12:15:53 CEST] <remlap> im sure the gui does that but not used in years
[12:19:41 CEST] <gryffus> remlap: working ones:
[12:19:42 CEST] <gryffus> https://paste.opensuse.org/82625931
[12:23:41 CEST] <gryffus> remlap: non-working ones: https://paste.opensuse.org/30794416
[12:26:28 CEST] <remlap> gryffus: that should help someone, have you tried playing them back in mpv?
[12:26:37 CEST] <remlap> that handles hdr very well from what I know
[12:26:57 CEST] <gryffus> remlap: mpv is able to play it
[12:26:59 CEST] <remlap> ah you're already in there
[12:27:50 CEST] <remlap> ah so you're trying to use the inbuilt player in the TV?
[12:28:07 CEST] <remlap> not passing through hdmi
[12:28:22 CEST] <gryffus> remlap: exactly
[12:29:06 CEST] <remlap> probably codec support its the AVC one that plays
[12:29:30 CEST] <gryffus> remlap: HEVC plays also
[12:29:31 CEST] <gryffus> some
[12:29:36 CEST] <gryffus> AVC also only some
[12:29:38 CEST] <remlap> SDR?
[12:30:44 CEST] <gryffus> dunno, is the SDR/HDR info listed in mediainfo output?
[12:31:54 CEST] <remlap> could also be Cinavia since but skimming they look like blu-ray rips
[12:32:19 CEST] <gryffus> remlap: this one does not play also: https://paste.opensuse.org/44041924
[12:32:34 CEST] <gryffus> AVC
[12:32:54 CEST] <remlap> seems to be picky codec support
[12:33:58 CEST] <gryffus> well but this last is AVC High at L3.1 and 1280 * 720 exactly... what is not standard with that?
[12:34:37 CEST] <remlap> tried a different container
[12:35:41 CEST] <gryffus> remlap: i am thinking to root the ******* TV and install Kodi or something on it :x
[12:36:23 CEST] <remlap> sounds like a plan if its doable, I would
[12:36:24 CEST] <gryffus> Or i will have to transcode all the UHD HDR titles, which will be PITA
[12:36:33 CEST] <remlap> or get a 4k streaming device from amazon
[12:37:27 CEST] <gryffus> remlap: i use minidlna server on my box, but it cannot do transcoding. I will try to find a software solution first
[12:38:18 CEST] <remlap> transcoding 4k would be beasty for the best of systems
[12:38:21 CEST] <gryffus> remlap: also, the minidlna is streaming via wifi, so more bandwidth-demanding videos are stuttering
[12:38:31 CEST] <remlap> I have converted 4K HDR to SDR for a few seconds of video and takes ages
[12:38:50 CEST] <gryffus> :(
[12:41:01 CEST] <remlap> https://giant.gfycat.com/ImaginativeKeenBrahmanbull.webm not exactly sfw but 4K HEVC HDR to 4K VP9 SDR
[12:41:41 CEST] <remlap> one I did as a test because I wanted to learn how it was done
[13:15:26 CEST] <Nacht> ll
[13:19:59 CEST] <Nacht> Quick question. A PTS should always be later then the corrosponding DTS, correct ?
[13:20:39 CEST] <Nacht> Resulting in FFMPEG saying: Invalid timestamps stream=1, pts=2074169040, dts=2074176240, size=33437
[13:26:49 CEST] <termos> av_opt_set(format->priv_data, "hls_flags", "append_list", AV_OPT_SEARCH_CHILDREN); is it correct by me to set it like this? It does not seem to be set
[15:00:32 CEST] <kepstin> Nacht: pts=dts is fine. What container/format is that?
[15:04:08 CEST] <Nacht> It's MPEG-TS
[15:06:03 CEST] <kerio> Nacht: wait, why
[15:06:11 CEST] <kerio> surely there's going to be some reordering
[15:06:45 CEST] <DHE> depends on the codecs and settings. keyframes will have pts==dts
[15:06:49 CEST] <kerio> if frames 1 2 3 are to be decoded in order 1 3 2 then frame with pts 2 will have a dts of 3
[15:16:28 CEST] <kepstin> oh, wait, i didn't look close enough at that. that is definitely pts < dts
[15:16:32 CEST] <kepstin> which is a problem
[15:17:37 CEST] <JEEB> I know some HLS streams will have that because people thought it was OK because Apple made some lolbroken files
[15:17:43 CEST] <JEEB> there's some funky logic in many JS HLS players for that
[15:18:10 CEST] <JEEB> (it seems like MOV/MP4 negative CTS offset timestamps got muxed as-is by apple into MPEG-TS, where they're invalid)
[15:18:40 CEST] <JEEB> I have reported such stupidity to at least one vendor, and got a lolbroken Apple sample as a response together with "will not fix"
[15:18:46 CEST] <JEEB> "it's OK because apple is doing it"
[15:38:47 CEST] <Nacht> The TS itself plays lovely on VLC, but the moment I convert it to MP4 it just stutters franticly
[15:39:05 CEST] <Nacht> Which isn't that weird if all the PTS and DTS go all over the palce
[15:39:36 CEST] <Nacht> It's like Apple excists solely to screw around everything basic there is the be found in the video world ;/
[15:53:30 CEST] <ozette> isn't ts used for streaming?
[15:54:13 CEST] <Nacht> Yes
[16:10:55 CEST] <ozette> i feel like it's an end product and shouldn't be converted again
[23:59:03 CEST] <barhom> Hey, anyone know anything about the dash muxer? I am using fmp4 with HLS, but afaik I should be able to create dash mpd's out of the same segments. Can I do that with 1 ffmpeg command?
[00:00:00 CEST] --- Tue Aug 21 2018

More information about the Ffmpeg-devel-irc mailing list