[Ffmpeg-devel] Prefix for img_* functions
Panagiotis Issaris
takis
Sat Mar 3 22:40:37 CET 2007
Baptiste Coudurier schreef:
> Panagiotis Issaris wrote:
>
>> Michael Niedermayer schreef:
>>
>>> On Thu, Mar 01, 2007 at 05:16:43PM +0100, Panagiotis Issaris wrote:
>>>
>>>> Michael Niedermayer schreef:
>>>>
>>>>> On Mon, Feb 26, 2007 at 03:27:10AM +0100, Panagiotis Issaris wrote:
>>>>>
>>>>>> Shouldn't the img_crop, img_copy and img_pad functions get av_ prefixes?
>>>>>>
>>>>> yes but the old should stay available under #if version something and
>>>>> with deprecated attribute
>>>>>
>>>> How would you prefer having the old versions available? Using #define's,
>>>> duplicate code or the old functions calling the new ones? Or some other way?
>>>>
>>> #defines seem best after 5sec of thoughts
>>>
>> The attached patch adds the prefixes to img_crop, img_copy and img_pad.
>>
> [...]
> While we are at it, why not av_picture_pad/copy/crop ? Those funcs take
> AVPicture as arg.
>
Thanks for the suggestion. I've sent an updated patch.
With friendly regards,
Takis
More information about the ffmpeg-devel
mailing list