[FFmpeg-devel] [PATCH] Function to parse Dirac sequence header
Diego Biurrun
diego
Thu Nov 6 11:15:47 CET 2008
On Wed, Nov 05, 2008 at 11:22:01PM -0500, David Conrad wrote:
>
> This will be useful for both the dirac parser and ogg demuxer (and
> future native dirac decoder of course.)
> Adapted from the soc repository.
>
> --- /dev/null
> +++ b/libavcodec/dirac.c
> @@ -0,0 +1,259 @@
> + /* framerate */
> + if (get_bits1(gb)) {
> + source->frame_rate_index = svq3_get_ue_golomb(gb);
This function is used in svq3.c, rv30.c, rv40.c and now dirac.c.
Clearly, the svq3_ prefix is misleading and it should be renamed.
Does anybody have a suggestion for a better name?
> --- /dev/null
> +++ b/libavcodec/dirac.h
> @@ -0,0 +1,110 @@
> +
> +typedef struct {
> +
> +typedef struct
> +{
inconsistent brace placement
Diego
More information about the ffmpeg-devel
mailing list