[FFmpeg-devel] [PATCH] Add RTP hinting to the mov muxer

Martin Storsjö martin
Thu Apr 22 12:36:42 CEST 2010


Hi Baptiste,

Thanks for the review!

On Thu, 22 Apr 2010, Baptiste Coudurier wrote:

> Well, can you please merge the patches related to the muxer ?
> It's hard for me to review all the separated changes.

Ok, merged most of patches that add new functionality.

> Also I find MKTAG('a','b','c','d') without the spaces between the ','
> easier to read.

Done. Or do you want me to use AV_RL32("abcd") in the places where 
feasible, even though it's a little less consistent with the rest of the 
file?

> The tref atom function should be mov_write_tref_tag, MOVTrack should contain
> tref_id and tref_tag to make it generic because it is used for chapters as
> well.

Done - these patches now are written on top of David's patches for writing 
qt chapters (that still are pending re-review iirc)?

> Also the code writing stss atom should be generic, ie not dependent of the
> source track being a video track. Either the track has keyframes or only
> keyframes, the current code should behave correctly and the condition should
> be basically: tag == "rtp " || codec == VIDEO

Fixed.

> Also the hint_track and src_track fields confuses me, either it is an index or
> a track, but I'm tired atm ;)

Fixed, both are indices now.

> Finally, do use av_new_stream for the hint tracks, add them internally, this
> will have side effects on the interleaving when muxing.

I guess you meant "do not use" here. Fixed, by creating only a new 
internal MOVTrack, just like the qt chapters patch does, without any 
corresponding AVStream.

// Martin
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-Make-ff_sdp_write_media-a-lavf-internal-function.patch
Type: text/x-diff
Size: 2953 bytes
Desc: 
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20100422/cac14ede/attachment.patch>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0002-Add-a-flag-for-enabling-RTP-hinting.patch
Type: text/x-diff
Size: 2141 bytes
Desc: 
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20100422/cac14ede/attachment-0001.patch>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0003-Move-the-mov-muxer-structures-to-a-separate-header.patch
Type: text/x-diff
Size: 5728 bytes
Desc: 
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20100422/cac14ede/attachment-0002.patch>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0004-Make-mov_write_packet-non-static-add-ff_-prefix.patch
Type: text/x-diff
Size: 3403 bytes
Desc: 
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20100422/cac14ede/attachment-0003.patch>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0005-Add-initial-support-for-RTP-hinting-in-the-mov-muxer.patch
Type: text/x-diff
Size: 21032 bytes
Desc: 
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20100422/cac14ede/attachment-0004.patch>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0006-Use-a-heuristic-for-describing-the-RTP-packets-using.patch
Type: text/x-diff
Size: 11685 bytes
Desc: 
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20100422/cac14ede/attachment-0005.patch>



More information about the ffmpeg-devel mailing list