[FFmpeg-devel] [PATCH] Move sample format definitions from libavcodec to libavcore.
Stefano Sabatini
stefano.sabatini-lala
Tue Oct 26 05:12:43 CEST 2010
On date Monday 2010-10-25 14:53:59 +0200, Michael Niedermayer encoded:
> On Sun, Oct 24, 2010 at 11:38:20PM -0700, Stefano Sabatini wrote:
> > ---
> > libavcodec/avcodec.h | 27 +++++++++++++++------------
> > libavcore/Makefile | 1 +
> > libavcore/samplefmt.h | 35 +++++++++++++++++++++++++++++++++++
> > 3 files changed, 51 insertions(+), 12 deletions(-)
> > create mode 100644 libavcore/samplefmt.h
[...]
> > --- /dev/null
> > +++ b/libavcore/samplefmt.h
>
> do we really want a header per enum ?
No, I'm also planning to move there these functions from
libavcodec/audioconvert.h (with some renamings):
void avcodec_sample_fmt_string(char *buf, int buf_size, int sample_fmt);
const char *avcodec_get_sample_fmt_name(int sample_fmt);
enum SampleFormat avcodec_get_sample_fmt(const char* name);
const char *avcodec_get_channel_name(int channel_id);
int64_t avcodec_get_channel_layout(const char *name);
void avcodec_get_channel_layout_string(char *buf, int buf_size, int nb_channels, int64_t channel_layout);
int64_t avcodec_guess_channel_layout(int nb_channels, enum CodecID codec_id, const char *fmt_name);
int avcodec_channel_layout_num_channels(int64_t channel_layout);
suggest a better name for the file or place where to move them.
--
FFmpeg = Frightening & Fabulous Mere Pure Explosive Geisha
More information about the ffmpeg-devel
mailing list