[FFmpeg-devel] [PATCH] ffplay: rename decode_thread to read_thread, parse_tid to read_tid
Stefano Sabatini
stefano.sabatini-lala at poste.it
Fri Apr 22 12:04:35 CEST 2011
The new names are less misleading and more reciprocally consistent.
Signed-off-by: Stefano Sabatini <stefano.sabatini-lala at poste.it>
---
ffplay.c | 10 +++++-----
1 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/ffplay.c b/ffplay.c
index eb5b278..c080cc0 100644
--- a/ffplay.c
+++ b/ffplay.c
@@ -126,7 +126,7 @@ enum {
};
typedef struct VideoState {
- SDL_Thread *parse_tid;
+ SDL_Thread *read_tid;
SDL_Thread *video_tid;
SDL_Thread *refresh_tid;
AVInputFormat *iformat;
@@ -1271,7 +1271,7 @@ static void stream_close(VideoState *is)
int i;
/* XXX: use a special url_shutdown call to abort parse cleanly */
is->abort_request = 1;
- SDL_WaitThread(is->parse_tid, NULL);
+ SDL_WaitThread(is->read_tid, NULL);
SDL_WaitThread(is->refresh_tid, NULL);
/* free all pictures */
@@ -2369,7 +2369,7 @@ static int decode_interrupt_cb(void)
}
/* this thread gets the stream from the disk or the network */
-static int decode_thread(void *arg)
+static int read_thread(void *arg)
{
VideoState *is = arg;
AVFormatContext *ic;
@@ -2642,8 +2642,8 @@ static VideoState *stream_open(const char *filename, AVInputFormat *iformat)
is->subpq_cond = SDL_CreateCond();
is->av_sync_type = av_sync_type;
- is->parse_tid = SDL_CreateThread(decode_thread, is);
- if (!is->parse_tid) {
+ is->read_tid = SDL_CreateThread(read_thread, is);
+ if (!is->read_tid) {
av_free(is);
return NULL;
}
--
1.7.2.3
More information about the ffmpeg-devel
mailing list