[FFmpeg-devel] [Patch] Add input swap functionality to movie filter (src_movie.c)
Clément Bœsch
u at pkh.me
Wed May 4 13:52:14 CEST 2016
On Wed, May 04, 2016 at 12:15:26AM +0000, Felt, Patrick wrote:
> Afternoon all,
> I apologize if this isn’t right way to submit a patch.
You're supposed to git commit and use git format-patch.
[...]
> +/* libavfilter documentation says that filter init will be called only once. ffmpeg calls the init twice to enable it to validate
> + * the complex filtering has the right input and output pads. this allows us to bypass the first call if we've specified a stream
> + * specifier string */
> +static int initRun=0;
> +static int uninitRun=0;
You're not allowed to do this, it belongs in the local context.
> +
> typedef struct MovieStream {
> AVStream *st;
> AVCodecContext *codec_ctx;
> int done;
> + int64_t lastPts; /* this is used exclusively by the reset code */
> + int64_t basePts; /* idem */
Here and many times below, keep the naming convention.
[...]
--
Clément B.
More information about the ffmpeg-devel
mailing list