[FFmpeg-devel] [RFC][PATCH] libavformat: add librist protocol
Lynne
dev at lynne.ee
Tue Dec 22 22:15:16 EET 2020
Dec 22, 2020, 19:09 by onemda at gmail.com:
> Signed-off-by: Paul B Mahol <onemda at gmail.com>
> +
> +const URLProtocol ff_librist_protocol = {
> + .name = "rist",
> + .url_open = librist_open,
> + .url_read = librist_read,
> + .url_write = librist_write,
> + .url_close = librist_close,
> + .url_get_file_handle = librist_get_file_handle,
> + .priv_data_size = sizeof(RISTContext),
> + .flags = URL_PROTOCOL_FLAG_NETWORK,
> + .priv_data_class = &librist_class,
> +};
>
I think this will be affected by the rtmp/librtmp issue we had, where both
protocols shared a name and so couldn't be used alongside. So "librist"
would be better as a name.
More information about the ffmpeg-devel
mailing list