[FFmpeg-devel] [PATCH 13/14] h264dec: rename flush_dpb()
Anton Khirnov
anton at khirnov.net
Fri Mar 27 14:57:47 EET 2020
The name is misleading, this function does a lot more than just flushing
the DPB.
---
libavcodec/h264dec.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/libavcodec/h264dec.c b/libavcodec/h264dec.c
index 67a9cb5438..7679567548 100644
--- a/libavcodec/h264dec.c
+++ b/libavcodec/h264dec.c
@@ -485,8 +485,7 @@ void ff_h264_flush_change(H264Context *h)
h->mmco_reset = 1;
}
-/* forget old pics after a seek */
-static void flush_dpb(AVCodecContext *avctx)
+static void h264_decode_flush(AVCodecContext *avctx)
{
H264Context *h = avctx->priv_data;
int i;
@@ -1063,7 +1062,7 @@ AVCodec ff_h264_decoder = {
},
.caps_internal = FF_CODEC_CAP_INIT_THREADSAFE | FF_CODEC_CAP_EXPORTS_CROPPING |
FF_CODEC_CAP_ALLOCATE_PROGRESS,
- .flush = flush_dpb,
+ .flush = h264_decode_flush,
.update_thread_context = ONLY_IF_THREADS_ENABLED(ff_h264_update_thread_context),
.profiles = NULL_IF_CONFIG_SMALL(ff_h264_profiles),
.priv_class = &h264_class,
--
2.25.1
More information about the ffmpeg-devel
mailing list