[FFmpeg-devel] [PATCH 2/2] avcodec/mpegvideo: cosmetics
lance.lmwang at gmail.com
lance.lmwang at gmail.com
Tue May 12 03:13:53 EEST 2020
On Mon, May 11, 2020 at 06:59:15PM +0200, Michael Niedermayer wrote:
> On Sun, May 10, 2020 at 11:39:30PM +0800, lance.lmwang at gmail.com wrote:
> > From: Limin Wang <lance.lmwang at gmail.com>
> >
> > Signed-off-by: Limin Wang <lance.lmwang at gmail.com>
> > ---
> > libavcodec/mpegvideo.c | 27 ++++++++++++++++++---------
> > 1 file changed, 18 insertions(+), 9 deletions(-)
> >
> > diff --git a/libavcodec/mpegvideo.c b/libavcodec/mpegvideo.c
> > index 561062f..b993813 100644
> > --- a/libavcodec/mpegvideo.c
> > +++ b/libavcodec/mpegvideo.c
> > @@ -725,12 +725,18 @@ static int init_context_frame(MpegEncContext *s)
> >
> > if (s->encoding) {
> > /* Allocate MV tables */
> > - FF_ALLOCZ_OR_GOTO(s->avctx, s->p_mv_table_base, mv_table_size * 2 * sizeof(*s->p_mv_table_base), fail)
> > - FF_ALLOCZ_OR_GOTO(s->avctx, s->b_forw_mv_table_base, mv_table_size * 2 * sizeof(*s->b_forw_mv_table_base), fail)
> > - FF_ALLOCZ_OR_GOTO(s->avctx, s->b_back_mv_table_base, mv_table_size * 2 * sizeof(*s->b_back_mv_table_base), fail)
> > - FF_ALLOCZ_OR_GOTO(s->avctx, s->b_bidir_forw_mv_table_base, mv_table_size * 2 * sizeof(*s->b_bidir_forw_mv_table_base), fail)
> > - FF_ALLOCZ_OR_GOTO(s->avctx, s->b_bidir_back_mv_table_base, mv_table_size * 2 * sizeof(*s->b_bidir_back_mv_table_base), fail)
> > - FF_ALLOCZ_OR_GOTO(s->avctx, s->b_direct_mv_table_base, mv_table_size * 2 * sizeof(*s->b_direct_mv_table_base), fail)
> > + FF_ALLOCZ_OR_GOTO(s->avctx, s->p_mv_table_base,
> > + mv_table_size * 2 * sizeof(*s->p_mv_table_base), fail)
> > + FF_ALLOCZ_OR_GOTO(s->avctx, s->b_forw_mv_table_base,
> > + mv_table_size * 2 * sizeof(*s->b_forw_mv_table_base), fail)
> > + FF_ALLOCZ_OR_GOTO(s->avctx, s->b_back_mv_table_base,
> > + mv_table_size * 2 * sizeof(*s->b_back_mv_table_base), fail)
> > + FF_ALLOCZ_OR_GOTO(s->avctx, s->b_bidir_forw_mv_table_base,
> > + mv_table_size * 2 * sizeof(*s->b_bidir_forw_mv_table_base), fail)
> > + FF_ALLOCZ_OR_GOTO(s->avctx, s->b_bidir_back_mv_table_base,
> > + mv_table_size * 2 * sizeof(*s->b_bidir_back_mv_table_base), fail)
> > + FF_ALLOCZ_OR_GOTO(s->avctx, s->b_direct_mv_table_base,
> > + mv_table_size * 2 * sizeof(*s->b_direct_mv_table_base), fail)
> > s->p_mv_table = s->p_mv_table_base + s->mb_stride + 1;
> > s->b_forw_mv_table = s->b_forw_mv_table_base + s->mb_stride + 1;
> > s->b_back_mv_table = s->b_back_mv_table_base + s->mb_stride + 1;
>
> I this this is more readable before the change
the line is too long so I split two line. Now have updated with new macro, please
review whether it's OK for you. I'm not keep the patch with same thread for the title
different.
>
>
> [...]
> --
> Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB
>
> While the State exists there can be no freedom; when there is freedom there
> will be no State. -- Vladimir Lenin
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at ffmpeg.org
> https://ffmpeg.org/mailman/listinfo/ffmpeg-devel
>
> To unsubscribe, visit link above, or email
> ffmpeg-devel-request at ffmpeg.org with subject "unsubscribe".
--
Thanks,
Limin Wang
More information about the ffmpeg-devel
mailing list