[FFmpeg-devel] [PATCH 1/7] avformat/mov_chan: rename mov_get_channel_label() to better reflect its purpose
James Almer
jamrial at gmail.com
Tue Apr 5 15:20:44 EEST 2022
On 3/28/2022 8:24 PM, James Almer wrote:
> This function turns a mov channel label into a lavf native bitmask.
>
> Signed-off-by: James Almer <jamrial at gmail.com>
> ---
> libavformat/mov_chan.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/libavformat/mov_chan.c b/libavformat/mov_chan.c
> index f52239d347..4607540297 100644
> --- a/libavformat/mov_chan.c
> +++ b/libavformat/mov_chan.c
> @@ -485,7 +485,7 @@ static uint64_t mov_get_channel_layout(uint32_t tag, uint32_t bitmap)
> return layout_map[i].layout;
> }
>
> -static uint32_t mov_get_channel_label(uint32_t label)
> +static uint32_t mov_get_channel_mask(uint32_t label)
> {
> if (label == 0)
> return 0;
> @@ -590,7 +590,7 @@ int ff_mov_read_chan(AVFormatContext *s, AVIOContext *pb, AVStream *st,
> avio_rl32(pb); // mCoordinates[2]
> size -= 20;
> if (layout_tag == 0) {
> - uint32_t mask_incr = mov_get_channel_label(label);
> + uint32_t mask_incr = mov_get_channel_mask(label);
> if (mask_incr == 0) {
> label_mask = 0;
> break;
Will apply set.
More information about the ffmpeg-devel
mailing list