[FFmpeg-devel] [PATCH] fftools/ffplay: split filters & show modes cycling into separate keys
Zhao Zhili
quinkblack at foxmail.com
Tue Dec 19 04:45:12 EET 2023
> On Dec 19, 2023, at 10:02, Ondřej Fiala <ofiala at airmail.cc> wrote:
>
> ---
> It's annoying to have to go through the audio visualization modes when you
> just want to switch back-and-forth between two video filters. It also makes
> the code simpler.
>
> doc/ffplay.texi | 5 ++++-
> fftools/ffplay.c | 10 ++++------
> 2 files changed, 8 insertions(+), 7 deletions(-)
>
> diff --git a/doc/ffplay.texi b/doc/ffplay.texi
> index 93f77eeece..91d138a974 100644
> --- a/doc/ffplay.texi
> +++ b/doc/ffplay.texi
> @@ -241,8 +241,11 @@ Cycle subtitle channel in the current program.
> @item c
> Cycle program.
>
> + at item d
> +Cycle show modes.
> +
> @item w
> -Cycle video filters or show modes.
> +Cycle video filters.
>
> @item s
> Step to the next frame.
> diff --git a/fftools/ffplay.c b/fftools/ffplay.c
> index 873ee8cc74..2eb616a88a 100644
> --- a/fftools/ffplay.c
> +++ b/fftools/ffplay.c
> @@ -3370,14 +3370,12 @@ static void event_loop(VideoState *cur_stream)
> case SDLK_t:
> stream_cycle_channel(cur_stream, AVMEDIA_TYPE_SUBTITLE);
> break;
> + case SDLK_d:
> + toggle_audio_display(cur_stream);
> + break;
> case SDLK_w:
> - if (cur_stream->show_mode == SHOW_MODE_VIDEO && cur_stream->vfilter_idx < nb_vfilters - 1) {
> - if (++cur_stream->vfilter_idx >= nb_vfilters)
> - cur_stream->vfilter_idx = 0;
> - } else {
> + if (++cur_stream->vfilter_idx >= nb_vfilters)
> cur_stream->vfilter_idx = 0;
> - toggle_audio_display(cur_stream);
> - }
Now it could be simplified as cur_stream->vfilter_idx = (cur_stream->vfilter_idx + 1) % nb_vfilters.
> break;
> case SDLK_PAGEUP:
> if (cur_stream->ic->nb_chapters <= 1) {
> --
> 2.43.0
>
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at ffmpeg.org
> https://ffmpeg.org/mailman/listinfo/ffmpeg-devel
>
> To unsubscribe, visit link above, or email
> ffmpeg-devel-request at ffmpeg.org with subject "unsubscribe".
More information about the ffmpeg-devel
mailing list