[FFmpeg-devel] Subject: [PATCH 1/3] lvac/dnxhdenc: add ff_dnxhdenc_init

Anton Khirnov anton at khirnov.net
Wed Dec 20 11:51:04 EET 2023


Quoting flow gg (2023-12-20 09:39:57)
> 
> 
> From 3f8adabeac408ada6048a1e2ac472534f970364e Mon Sep 17 00:00:00 2001
> From: sunyuechi <sunyuechi at iscas.ac.cn>
> Date: Wed, 20 Dec 2023 16:17:32 +0800
> Subject: [PATCH 1/3] lvac/dnxhdenc: add ff_dnxhdenc_init

typo in 'lavc'

> 
> This is for clarity and use in testing, consistent with other parts of the code.
> ---
>  libavcodec/dnxhdenc.c | 6 ++++++
>  libavcodec/dnxhdenc.h | 1 +
>  2 files changed, 7 insertions(+)
> 
> diff --git a/libavcodec/dnxhdenc.c b/libavcodec/dnxhdenc.c
> index f52a2e9918..1ac8116f53 100644
> --- a/libavcodec/dnxhdenc.c
> +++ b/libavcodec/dnxhdenc.c
> @@ -1377,3 +1377,9 @@ const FFCodec ff_dnxhd_encoder = {
>      .p.profiles     = NULL_IF_CONFIG_SMALL(ff_dnxhd_profiles),
>      .caps_internal  = FF_CODEC_CAP_INIT_CLEANUP,
>  };
> +
> +void ff_dnxhdenc_init(DNXHDEncContext *ctx) {

Brace should be on its own line

> +#if ARCH_X86
> +    ff_dnxhdenc_init_x86(ctx);
> +#endif
> +}
> diff --git a/libavcodec/dnxhdenc.h b/libavcodec/dnxhdenc.h
> index e581312ce4..95aea83d28 100644
> --- a/libavcodec/dnxhdenc.h
> +++ b/libavcodec/dnxhdenc.h
> @@ -111,6 +111,7 @@ typedef struct DNXHDEncContext {
>                                 const uint8_t *pixels, ptrdiff_t line_size);
>  } DNXHDEncContext;
>  
> +void ff_dnxhdenc_init(DNXHDEncContext *ctx);

Shouldn't it actually replace the existing ff_dnxhdenc_init_x86() call
in dnxhdenc.c?

-- 
Anton Khirnov


More information about the ffmpeg-devel mailing list