[FFmpeg-devel] [PATCH] lavu: add AVVideoHint API

Lynne dev at lynne.ee
Sun Jul 9 16:10:58 EEST 2023


Jul 9, 2023, 13:05 by anton at khirnov.net:

> From: Elias Carotti <eliascrt _at_ amazon _dot_ it>
>
> Add side data type to provide hint to the video encoders about unchanged
> portions of each frame.
>
> Signed-off-by: Anton Khirnov <anton at khirnov.net>
> ---
> I've made couple small changes:
> * rebased against current master
> * consistently refer to rectangles or AVVideoRect, not blocks
> * use size_t instead of int for AVVideoHint.nb_rects
> * build unconditionally -- this is public API, it must always be
>  available regardless of what encoders are or are not available
> * tweaked documentation
>
> If you have no objections to the changes, I'll push this in a few days.
> ---
>  doc/APIchanges         |   3 ++
>  libavutil/Makefile     |   2 +
>  libavutil/frame.h      |  10 ++++
>  libavutil/version.h    |   2 +-
>  libavutil/video_hint.c |  82 +++++++++++++++++++++++++++++++
>  libavutil/video_hint.h | 108 +++++++++++++++++++++++++++++++++++++++++
>  6 files changed, 206 insertions(+), 1 deletion(-)
>  create mode 100644 libavutil/video_hint.c
>  create mode 100644 libavutil/video_hint.h
>

AVVideoHint is a bad name for something like this.
Could you borrow some wording from graphics and call it
AVVideoDamagedHint or maybe AVVideoChangedAreaHint
or a combination of both?
I'd prefer the former, damage is standard language in graphics
circles about what has changed since the last frame.


More information about the ffmpeg-devel mailing list