[FFmpeg-devel] [PATCH] fftools/ffmpeg_mux_init: avoid invalid reads in forced keyframe parsing

Anton Khirnov anton at khirnov.net
Sun Mar 12 10:30:55 EET 2023


Quoting Zhao Zhili (2023-03-11 12:45:30)
> 
> 
> > -----Original Message-----
> > From: ffmpeg-devel <ffmpeg-devel-bounces at ffmpeg.org> On Behalf Of Anton Khirnov
> > Sent: 2023年3月11日 18:37
> > To: 'FFmpeg development discussions and patches' <ffmpeg-devel at ffmpeg.org>
> > Subject: Re: [FFmpeg-devel] [PATCH] fftools/ffmpeg_mux_init: avoid invalid reads in forced keyframe parsing
> > 
> > Quoting Zhao Zhili (2023-03-10 15:44:56)
> > >
> > > > From: ffmpeg-devel <ffmpeg-devel-bounces at ffmpeg.org> On Behalf Of Anton Khirnov
> > > > Sent: 2023年3月10日 21:46
> > > > To: ffmpeg-devel at ffmpeg.org
> > > > Subject: [FFmpeg-devel] [PATCH] fftools/ffmpeg_mux_init: avoid invalid reads in forced keyframe parsing
> > > >
> > > > Fixes #10243
> > > > ---
> > > >  fftools/ffmpeg_mux_init.c | 2 +-
> > > >  1 file changed, 1 insertion(+), 1 deletion(-)
> > > >
> > > > diff --git a/fftools/ffmpeg_mux_init.c b/fftools/ffmpeg_mux_init.c
> > > > index b3cc502fdd..09d24ba8e5 100644
> > > > --- a/fftools/ffmpeg_mux_init.c
> > > > +++ b/fftools/ffmpeg_mux_init.c
> > > > @@ -2063,7 +2063,7 @@ static void parse_forced_key_frames(KeyframeForceCtx *kf, const Muxer *mux,
> > > >          if (next)
> > > >              *next++ = 0;
> > > >
> > > > -        if (!memcmp(p, "chapters", 8)) {
> > > > +        if (strstr(p, "chapters") == p) {
> > >
> > > Does strncmp() more efficient in this case?
> > 
> > I don't see the point of optimizing this code for speed. A strncmp call
> > is longer and less readable IMO.
> 
> This is a case for the need of a strstarts(). strncmp is more intuitive than strstr()
> for this job.

Yes, having a "string starts with" function in stdlib would have been
nice. But as it's not there, we have to make do with what we have.

-- 
Anton Khirnov


More information about the ffmpeg-devel mailing list