[FFmpeg-devel] [PATCH 36/36] fftools/ffmpeg_dec: rename decode_video() to video_frame_process()

Anton Khirnov anton at khirnov.net
Wed May 17 13:20:29 EEST 2023


This function does not do any decoding anymore.
---
 fftools/ffmpeg_dec.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/fftools/ffmpeg_dec.c b/fftools/ffmpeg_dec.c
index c8f9ba0f0c..b541d30214 100644
--- a/fftools/ffmpeg_dec.c
+++ b/fftools/ffmpeg_dec.c
@@ -179,7 +179,7 @@ static int64_t video_duration_estimate(const InputStream *ist, const AVFrame *fr
     return FFMAX(ist->last_frame_duration_est, 1);
 }
 
-static int decode_video(InputStream *ist, AVFrame *frame)
+static int video_frame_process(InputStream *ist, AVFrame *frame)
 {
     // The following line may be required in some cases where there is no parser
     // or the parser does not has_b_frames correctly
@@ -458,7 +458,7 @@ int dec_packet(InputStream *ist, const AVPacket *pkt, int no_eof)
 
             audio_ts_process(ist, frame);
         } else {
-            ret = decode_video(ist, frame);
+            ret = video_frame_process(ist, frame);
             if (ret < 0) {
                 av_log(NULL, AV_LOG_FATAL, "Error while processing the decoded "
                        "data for stream #%d:%d\n", ist->file_index, ist->st->index);
-- 
2.39.2



More information about the ffmpeg-devel mailing list