[FFmpeg-devel] [PATCH 2/2] avcodec/ccaption_dec: use consistent naming convention of Closed Captions

Stefano Sabatini stefasab at gmail.com
Sun Mar 10 16:12:11 EET 2024


On date Saturday 2024-03-09 12:39:56 -0600, Marth64 wrote:
> Signed-off-by: Marth64 <marth64 at proxyid.net>
> ---
>  libavcodec/ccaption_dec.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/libavcodec/ccaption_dec.c b/libavcodec/ccaption_dec.c
> index d03413265a..faf058ce97 100644
> --- a/libavcodec/ccaption_dec.c
> +++ b/libavcodec/ccaption_dec.c
> @@ -948,7 +948,7 @@ static const AVOption options[] = {
>  };
>  
>  static const AVClass ccaption_dec_class = {
> -    .class_name = "Closed caption Decoder",
> +    .class_name = "Closed Captions Decoder",
>      .item_name  = av_default_item_name,
>      .option     = options,
>      .version    = LIBAVUTIL_VERSION_INT,
> @@ -956,7 +956,7 @@ static const AVClass ccaption_dec_class = {
>  
>  const FFCodec ff_ccaption_decoder = {
>      .p.name         = "cc_dec",
> -    CODEC_LONG_NAME("Closed Caption (EIA-608 / CEA-708)"),
> +    CODEC_LONG_NAME("Closed Captions (EIA-608 / CEA-708)"),
>      .p.type         = AVMEDIA_TYPE_SUBTITLE,
>      .p.id           = AV_CODEC_ID_EIA_608,
>      .p.priv_class   = &ccaption_dec_class,
> -- 
> 2.34.1

Will apply, thanks.


More information about the ffmpeg-devel mailing list