[FFmpeg-devel] [PATCH 6/7 v4] avcodec/decode: make the AVFrameSideData helper wrappers not depend on frames
Anton Khirnov
anton at khirnov.net
Thu Mar 28 13:40:03 EET 2024
Quoting James Almer (2024-03-28 12:36:37)
> On 3/28/2024 8:32 AM, Anton Khirnov wrote:
> > Quoting James Almer (2024-03-28 04:12:09)
> >> They will be useful to fill arrays stored in other structs.
> >>
> >> Signed-off-by: James Almer <jamrial at gmail.com>
> >> ---
> >> libavcodec/av1dec.c | 7 +--
> >> libavcodec/cri.c | 3 +-
> >> libavcodec/decode.c | 99 +++++++++++++++++++++++++++--------------
> >> libavcodec/decode.h | 28 ++++++------
> >> libavcodec/dpx.c | 3 +-
> >> libavcodec/h2645_sei.c | 4 +-
> >> libavcodec/h264_slice.c | 3 +-
> >> libavcodec/hevcdec.c | 6 ++-
> >> libavcodec/libdav1d.c | 7 +--
> >> libavcodec/libjxldec.c | 3 +-
> >> libavcodec/mjpegdec.c | 3 +-
> >> libavcodec/mpeg12dec.c | 11 +++--
> >> libavcodec/pngdec.c | 8 ++--
> >> libavcodec/qsvdec.c | 4 +-
> >> libavcodec/tiff.c | 3 +-
> >> libavcodec/webp.c | 3 +-
> >> 16 files changed, 120 insertions(+), 75 deletions(-)
> >
> > Extra churn in all the decoders, longer and harder to read lines.
> > Why not make ff_frame_new_side_data_from_buf() a wrapper for a new
> > function instead?
>
> Can you elaborate? I'm making all the decode.h side data wrappers take
> pointers to AVFrameSideData instead of AVFrames so they're not limited
> to the latter.
I mean:
* add new function(s) that work with AVFrameSideData;
* keep signatures for existing function the same, but change their
implementation into a wrapper for the above
this way the decoders do not need to be changed.
--
Anton Khirnov
More information about the ffmpeg-devel
mailing list