[MPlayer-cvslog] r20493 - in trunk: libass/Makefile libass/ass.c libass/ass.h libass/ass_library.c libass/ass_library.h libass/ass_mp.c libass/ass_mp.h libass/ass_render.c libass/ass_types.h libmpcodecs/vf_ass.c libmpcodecs/vf_vo.c libmpdemux/demux_mkv.c mplayer.c

Reimar Döffinger Reimar.Doeffinger at stud.uni-karlsruhe.de
Sun Oct 29 09:48:45 CET 2006

On Sun, Oct 29, 2006 at 02:19:00AM +0400, Evgeniy Stepanov wrote:
> On Saturday 28 October 2006 20:09, Reimar Döffinger wrote:
> > On Sat, Oct 28, 2006 at 05:07:18PM +0200, eugeni wrote:
> > > Libass interface reworked:
> > > - ass_instance_t renamed to ass_renderer_t
> >
> > renaming is a cosmetic change and _must_ _always be done seperately.
> Right. Sorry. Should I re-commit ?

I don't know. As ugly as it was I'm still missing cvs admin a bit. The
SVN ways always leave a bit of a mess.

> > > - ass_library_t introduced
> > > - use of mplayer-specific global variables limited to ass_mp.c
> >
> > In general, do not apply unrelated things together, you are no longer
> > the only one both caring about and being responsible for that code.
> The second one is not a separate change, but a consequence of the first one. 
> It could be applied as maybe 10 separate commits (one for each global 
> variable), but I think it's not worth the effort.

No, separating for each variable would not be any better to understand
(which is the end goal). I would probably write such a commit message
like "introduce ass_library_t which also limits mplayer-specific global
variables to ass_mp.c" or some such (no idea if that's really correct in
this case, didn't check closely), gives nobody a reason to complain *g*

Reimar Döffinger

More information about the MPlayer-cvslog mailing list