[MPlayer-cvslog] r31456 - in trunk/loader: module.c qt_comp.h qt_comp_template.c
diego
subversion at mplayerhq.hu
Thu Jun 17 12:17:37 CEST 2010
Author: diego
Date: Thu Jun 17 12:17:37 2010
New Revision: 31456
Log:
Rename loader/qt_comp.h --> loader/qt_comp_template.c.
It is not a header file but rather a template that is #included multiple
times with different DECL_COMPONENT macro definitions.
All other similar files follow the _template.c suffix naming scheme.
Added:
trunk/loader/qt_comp_template.c
- copied, changed from r31454, trunk/loader/qt_comp.h
Deleted:
trunk/loader/qt_comp.h
Modified:
trunk/loader/module.c
Modified: trunk/loader/module.c
==============================================================================
--- trunk/loader/module.c Thu Jun 17 12:10:00 2010 (r31455)
+++ trunk/loader/module.c Thu Jun 17 12:17:37 2010 (r31456)
@@ -701,7 +701,7 @@ static int dump_component(char* name, in
return dump_component(name,type,real_ ## sname, params, glob); \
}
-#include "qt_comp.h"
+#include "qt_comp_template.c"
#undef DECL_COMPONENT
@@ -1042,7 +1042,7 @@ FARPROC MODULE_GetProcAddress(
fprintf(stderr,name "dispatcher catched -> %p\n",retproc); \
real_ ## sname = retproc; retproc = fake_ ## sname; \
}
-#include "qt_comp.h"
+#include "qt_comp_template.c"
#undef DECL_COMPONENT
#endif
Copied and modified: trunk/loader/qt_comp_template.c (from r31454, trunk/loader/qt_comp.h)
==============================================================================
--- trunk/loader/qt_comp.h Thu Jun 17 11:59:31 2010 (r31454, copy source)
+++ trunk/loader/qt_comp_template.c Thu Jun 17 12:17:37 2010 (r31456)
@@ -1,6 +1,3 @@
-#ifndef MPLAYER_QT_COMP_H
-#define MPLAYER_QT_COMP_H
-
DECL_COMPONENT(sorenson3,"SMD_ComponentDispatch",1)
DECL_COMPONENT(sorenson,"SorensonYUV9Dispatcher",1)
DECL_COMPONENT(sorenson1,"SVD_ComponentDispatch",1)
@@ -28,5 +25,3 @@ DECL_COMPONENT(mace3d,"Mace3DecompDispat
DECL_COMPONENT(prores,"IcpDecompressorComponentDispatch",0)
//DECL_COMPONENT(,"",0)
-
-#endif /* MPLAYER_QT_COMP_H */
More information about the MPlayer-cvslog
mailing list