[MPlayer-dev-eng] Re: -of mpeg
Diego Biurrun
diego at biurrun.de
Tue Oct 14 16:02:15 CEST 2003
Andriy N. Gritsenko writes:
> Sometime (on Monday, October 13 at 18:24) I've received something...
> >Sure you can. It does not come from help_mp-*.h, that is just the
> >translation. The message comes from mencoder.c, just grep for
> >AVIHeader and AVIIndex. This should be generalized a bit more now
> >that MEncoder can mux to more than just AVI. Could you send a patch
> >for this?
>
> Do you mean in mencoder.c:
>
> printf(MSGTR_WritingAVIHeader);
>
> But that define MSGTR_WritingAVIHeader comes from help_mp-*.h so if I
> make a patch for English, Ukrainian and Russian ones then anyway all
> other translators have to translate new messages.
Yes, all other translators will have to make some changes, but that is
not a problem. You only need to patch help_mp-en.h, but patches for
translations are welcome, of course.
> Ok, let's discuss what we want for replace. Will that below be ok?
>
> #define MSGTR_WritingAVIHeader "Writing output file header...\n"
> #define MSGTR_WritingAVIIndex "\nWriting output file footer...\n"
> #define MSGTR_FixupAVIHeader "Fixing output file header...\n"
Umm, no, the message should be renamed and the obsolete one removed
from all help_mp-*.h files.
I would suggest something like
#define MSGTR_WritingFileHeader "Writing output file header...\n"
#define MSGTR_WritingFileIndex "\nWriting output file footer...\n"
#define MSGTR_FixupFileHeader "Fixing output file header...\n"
or
#define MSGTR_WritingAVIHeader "Writing AVI header...\n"
#define MSGTR_WritingMPEGHeader "Writing MPEG header...\n"
etc
This scheme would have to be updated each time we support a new
format, though, so the above should be OK.
> > > -// printf ("Added video stream %d\n", muxer->num_videos);
> > > + mp_msg (MSGT_MENCODER, MSGL_DBG2, "Added video stream %d, ckid=%X\n", muxer->num_videos, s->ckid);
>
> >Shouldn't the messages from mp_msg calls be put into help/help_mp-en.h
> >so they can be translated?
>
> I think debug messages don't need to be translated. :)
Yes, Albeu already said so, I guess you are right.
Diego
More information about the MPlayer-dev-eng
mailing list