Re : [MPlayer-dev-eng][PATCH]-vofile option (ENGLISH)

Reimar Döffinger Reimar.Doeffinger at stud.uni-karlsruhe.de
Tue Nov 16 23:33:17 CET 2004


Hi,
> >here is a little patch which add a -vofile option to override the  
> >default
> >filename employed by -vo yuv4mpeg.

I think it would be better to add a driver suboption instead of yet
another option that works for only one driver...
But you will have to rework the current suboption parsing (in preinit
function, line 480).
You might want to have a look at CVS versions of vo_gl.c, line 551 and
ao_alsa, line 348, those parsing routines have been redone lately and
should work better then some others you might find...

I'm not sure what the documentation guys think, but I'd prefer it if
you'd leave the translations to them. First of all because it makes the
patch harder to read because I have skip lots of (to me) irrelevant
parts and also the synced-with tags for the translations would have to be
adjusted when applying...

> +	if(!vo_outputfilename) {
> +		vo_outputfilename = strdup("stream.yuv");
> +	}

I don't think assigning to configuration variables isn't such a good
idea, they are global variables and you never can know what is done with
them (e.g. whether they are freed or not).

> +	yuv_out = fopen(vo_outputfilename, "wb");

I'd suggest (vo_outputfilename) ? vo_outputfilename : "stream.yuv". Or
use a temporary variable, if you dislike the ?: operator ;-)

Greetings,
Reimar Döffinger




More information about the MPlayer-dev-eng mailing list