[MPlayer-dev-eng] [PATCH] replacement for internal mpg123 fork (mp3lib), what is performance?
Diego Biurrun
diego at biurrun.de
Sun May 30 10:30:21 CEST 2010
On Sun, May 30, 2010 at 02:08:52AM +0200, Thomas Orgis wrote:
>
> --- libmpcodecs/ad_mpg123.c (Revision 0)
> +++ libmpcodecs/ad_mpg123.c (Revision 0)
> @@ -0,0 +1,565 @@
> + while(need > 0)
> + {
> + if(con->packleft > 0)
> + {
> + }
> + else
> + {
> + if (con->packleft <= 0)
> + break; /* Apparently that's it. EOF. */
Please consistently use K&R style: space between keyword and (,
{ on the same line as the keyword.
more below
> + if (pts != MP_NOPTS_VALUE) {
> + sh->pts = pts;
> + sh->pts_bytes = 0;
align
> +static int decode_a_bit(sh_audio_t * sh, unsigned char *buf, int count)
*sh, more below
> +#ifdef AD_MPG123_CALLBACK
This was introduced in which version of mpg123?
> + if (++con->mean_count > ((unsigned int)-1)/2)
> + con->mean_count = ((unsigned int)-1)/4;
Spaces around operators would make this more readable.
There are some long lines that you could easily break.
Diego
More information about the MPlayer-dev-eng
mailing list