[Mplayer-users] FAQ entry concerning gcc 2.96

Arpi arpi at thot.banki.hu
Fri Oct 5 10:13:18 CEST 2001


> This FAQ entry is inaccurate:
> Q: What's the problem with gcc 2.96 ?
> A:  gcc  2.96  is  RedHat's UNOFFICIAL (it can be found only on RedHat
> sites,  or  RedHat  distributions)  and BUGGY gcc release. gcc 2.96 is
> TOTALLY  unsupported by MPlayer, because it simply SKIPS MMX codes, it
> just  does  not compile it. Important: this is NOT an MPlayer-specific
> problem,  numerous  other projects (DRI, avifile, etc..) have problems
> with this shit too.
> ** DO NOT USE gcc 2.96 !!! **
> This "MMX asm codes are skipped" problem has been fixed for ages, since
> June 2001 as far as I remember. So the FAQ maintainer should probably come
> up with a new real problem (3DNOW! compile errors would do for the moment,
> till someone fixes that as well ;) or remove the whole Q/A altogether.

Not really. Most users still use the old, buggy version comes with the
distro. Maybe a note can be added telling that latest version fixes some of
the problems.

A'rpi / Astral & ESP-team

mailto:arpi at thot.banki.hu

Mplayer-users mailing list
Mplayer-users at lists.sourceforge.net

More information about the MPlayer-users mailing list