[MPlayer-users] "Couldn't open /dev/3dfx"

Mark Zealey mark at zealos.org
Wed Apr 24 20:37:01 CEST 2002

On Wed, Apr 24, 2002 at 01:57:05PM -0400, Geoff Stanbury wrote:

> Ok, I built tdfxfb as a module and compiled MPlayer using --with-tdfxfb.  To be on the safe side, I did "modprobe tdfxfb" (which, incidentally, did some weird stuff to my screen while in console--see bottom).  MPlayer is still not working, though--when I try to open a movie by running "mplayer -vo tdfxfb filename", it says "tdfxfb: can't open /dev/fb0: Permission denied."  This despite the fact that my login is in the group that /dev/fb0 is in.
> I tried opening a movie in the same way while logged in as root, but again it fails, saying "tdfxfb: can't open /dev/fb0: No such device" which is incorrect:

No, no need for the kernel module, I just use the plain framebuffer kernel, it
just needs /dev/fb0.

> geoff:~$ ls -l /dev/fb0
> crw--w--w-    1 root     tty       29,   0 Dec 27 21:05 /dev/fb0

should be rw..


Mark Zealey (aka JALH on irc.openprojects.net: #zealos and many more)
mark at zealos.org; mark at itsolve.co.uk

UL++++>$ G!>(GCM/GCS/GS/GM) dpu? s:-@ a17! C++++>$ P++++>+++++$ L+++>+++++$
!E---? W+++>$ !w--- r++ !t---?@ !X---?  !R- !tv b+ G+++ e>+++++ !h++* r!-- y--

More information about the MPlayer-users mailing list