[MPlayer-users] sharing sound device

Erick Calder e at arix.com
Thu Nov 7 07:22:01 CET 2002

I want to be able to run mpg123 and mplayer at the same time so it was
suggested to me that using ESD would allow me to do this.

I thus ran the ESD daemon and tried "-ao sdl:esd" but I get:

> DL: using esd audio driver
> SDL: Unable to open audio: No available audio device
> couldn't open/init audio device -> no sound
> Audio: no sound!!!

I see that section 5.4 of the FAQ states:

"A: Are you running KDE or GNOME with the arts or esd sound daemon? Try
disabling the sound daemon, or use the -ao arts switch to make MPlayer use

since I seem to need to disable the ESD daemon then I gather it should not
be running... I shut it down and again tried "-ao sdl:esd" with the same
result... so I get taht error whether I'm running esd or not... wtf?

I've also tried -ao arts with same result.

if I am not running the ESD daemon and run "mplayer myfile" it works fine.
I get audio...  what am I missing here?

I've also done searches on Google for an answer but find zilch.

thx - erick

More information about the MPlayer-users mailing list