[MPlayer-users] mga_vid shows only green area

tdc tdc at phreaker.net
Wed Oct 9 00:35:03 CEST 2002

I have problem running videos on my Matrox G400DH card using "-vo mga". 
Every video I try to play shows only green rectangle over console and 
nothing more (sound goes ok). When I switch to use vesa, vesa:vidix, 
fbdev or fbdev:vidix, everything is ok (TV-Out works with fbdev and 
fbdev:vidix, but it looks kinda slow, even on Celeron 1GHz). I've 
followed all DOCS (which are sometimes a bit unclear in this) how to 
setup both kernel and mplayer to work with mga_vid, but still no 
success. I've tried both compiled in main matroxfb and matroxfb as 
modules. Other matrox specific parts (matroxfb_crtc2 and matroxfb_maven) 
were always as modules.

Output of mplayer when using 'mplayer -vo mga -double -fs file.avi':
Playing file.avi
Detected AVI file format!
VIDEO:  [div3]  640x272  24bpp  25.00 fps  888.4 kbps (108.4 kbyte/s)
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 16000->192000 (128.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffdivx] vfm:ffmpeg (FFmpeg DivX ;-) (MS MPEG-4 v3))
AO: [oss] 48000Hz 2ch Signed 16-bit (Little-Endian)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Start playing...
VDec: vo config request - 640 x 272 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [mga] 640x272 => 640x272 Planar YV12  [fs]
vo_mga aspect(): resized to 640x290
[mga] Using 3 buffers.
vo: uninit!   3.6 A-V:  0.000 ct:  0.024   91/ 91  16%  0%  2.0% 0 0 0%
Exiting... (Quit)

Now the required info:
Linux distro: a bit updated and modified MDK8.2
Kernel: Linux phobos 2.4.18 #5 Tue Oct 8 01:21:45 CEST 2002 i686 unknown
Libc: 1275300 Mar 7 2002 /lib/libc-2.2.4.so*
X: XFree86 Version 4.2.0 / X Window System
(actually, I don't use X on that system)
gcc: gcc version 3.0.4 (Mandrake Linux 8.2 3.0.4-2mdk)
ld: GNU ld version 20011121
as: GNU assembler 20011121

lsmod (the usefull part):
Module                  Size  Used by    Not tainted
agpgart                21120   0  (autoclean) (unused)
mga_vid                 8288   0
matroxfb_maven          9216   0  (unused)
matroxfb_crtc2          6848   0
i2c-matroxfb            3200   0  (unused)
i2c-algo-bit            7724   3  [i2c-matroxfb]
matroxfb_base          17952  63  [matroxfb_crtc2 i2c-matroxfb]
matroxfb_DAC1064        5636   0  [matroxfb_crtc2 matroxfb_base]
matroxfb_accel          9216   0  [matroxfb_base matroxfb_DAC1064]
matroxfb_misc          12192   0  [matroxfb_maven matroxfb_crtc2 
i2c-matroxfb matroxfb_base matroxfb_DAC1064 matroxfb_accel]
i2c-proc                6752   0  [w83781d eeprom adm1021]
i2c-core               15296   0  [matroxfb_maven i2c-algo-bit w83781d 
eeprom adm1021 i2c-isa i2c-i801 i2c-proc]

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 11
model name      : Intel(R) Celeron(TM) CPU                1000MHz
stepping        : 1
cpu MHz         : 1015.315
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge 
mca cmov pat pse36 mmx fxsr sse
bogomips        : 2025.06

Video card:
Matrox G400 DH 32MB SGRAM
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP 
(rev 04) (prog-if 00 [VGA])
Subsystem: Matrox Graphics, Inc. Millennium G400 Dual Head 16Mb
Flags: bus master, medium devsel, latency 32, IRQ 9
Memory at d4000000 (32-bit, prefetchable) [size=32M]
Memory at d6000000 (32-bit, non-prefetchable) [size=16K]
Memory at d7000000 (32-bit, non-prefetchable) [size=8M]
Expansion ROM at <unassigned> [disabled] [size=64K]
Capabilities: [dc] Power Management version 2
Capabilities: [f0] AGP version 2.0

SB Live! OEM, standard kernel drivers (emu10k1)

If anything else is required, I'll supply it upon request


More information about the MPlayer-users mailing list