[MPlayer-users] Trouble compiling, ldt_keeper?

Torinthiel torinthiel at megapolis.pl
Tue Oct 26 21:28:32 CEST 2004

On Tue, Oct 26, 2004 at 03:08:20PM +0000, Todd ... wrote:
> Greetings all. Having trouble compiling mplayer. I do run Gentoo, but I 
> downloaded the mplayer source from the mplayer web site and manually tried 
> to compile it, which resulted in the same error. Hope someone here has an 
> idea of whats going on.

Strange, should work (TM) ;)
Now, more seriously. You are running Linux, are you? What kernel
version? Reading through the file I guessed that modify_ldt_ldt_s
(type that fails) is declared in kernel headers, more specific in
asm/ldt.h. And that if you have kernel newer than 2.5.xx(*) renamed this
to user_desc.
(*) Comment mentions 2.5.xx+. But check just below uses 2.5.47. Maybe
that can help.
If that doesn't help then try forcing the structure definition present in file
(ex. copy it to the beginning) and see if that helps. And post the
results here, as this is just narrowing the problem.
And btw does the CVS version still have this bug? Maybe we are hunting
what has already been hunted.

 Waclaw "Torinthiel" Schiller       GG#: 542916, 3073512
   gpg: B06901F1 fpr: FAA3 559F CAE9 34DE CDC8  7346 2B6E 39F2 B069 01F1
 "No classmates may be used during this examination"
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/mplayer-users/attachments/20041026/0b1e7436/attachment.pgp>

More information about the MPlayer-users mailing list