[MPlayer-users] Problems playing with vdr streams.

Josef Wolf jw at raven.inka.de
Tue Oct 26 23:29:45 CEST 2004


I have problems playing streams from vdr.  After about two minutes, the
cache fill rate (the last number on the status line) goes down to zero
and video starts humbling.  Some time after that mplayer exits completely.

I have tried to increase cache, but with little success.  I have also
tried to use the -autosync option (with values up to 300).

When I try TS instead of PS withhin the URL, mplayer don't play at all.
OTOH, xine plays the TS without problems (but with poor deinterlace :()

Any ideas?

Here is mplayer's output:

jw at raven:$ mplayer -vfm ffmpeg -autosync 30 -cache 512 -fstype none -vf pp=md http://vdr1:3000/PS/36
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/local/share/locale

MPlayer dev-CVS-041015-06:00-3.3.1 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
Reading config file /usr/local/etc/mplayer/mplayer.conf: Datei oder Verzeichnis nicht gefunden
Reading config file /home/jw/.mplayer/config: Ist kein Verzeichnis
Reading /home/jw/.mplayer/codecs.conf: Can't open '/home/jw/.mplayer/codecs.conf': Ist kein Verzeichnis
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': Datei oder Verzeichnis nicht gefunden
Using built-in default codecs.conf.
font: can't open file: /home/jw/.mplayer/font/font.desc
Font /usr/local/share/mplayer/font/font.desc loaded successfully! (206 chars)
Failed to open /dev/rtc: Keine Berechtigung (it should be readable by the user.)
Using nanosleep() timing
Can't open input config file /home/jw/.mplayer/input.conf: Ist kein Verzeichnis
Can't open input config file /usr/local/etc/mplayer/input.conf: Datei oder Verzeichnis nicht gefunden
Falling back on default (hardcoded) input config
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Keine Berechtigung
Failed to open LIRC support.
You will not be able to use your remote control.

Playing http://vdr1:3000/PS/36.
Resolving vdr1 for AF_INET6...
Couldn't resolve name for AF_INET6: vdr1
Resolving vdr1 for AF_INET...
Connecting to server vdr1[]:3000 ...
Cache size set to 512 KBytes
Connected to server: vdr1
Cache fill:  0,00% (0 bytes)    MPEG-PS file format detected.
VIDEO:  MPEG2  704x576  (aspect 2)  25,000 fps  7000,0 kbps (875,0 kbyte/s)
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 24000->192000 (192,0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0" => local display)
Disabling DPMS
Opening video filter: [pp=md]
Trying to force video codec driver family ffmpeg...
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffmpeg2] vfm:ffmpeg (FFmpeg MPEG 2)
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 704 x 576 (preferred csp: Planar YV12)
[PP] Using external postprocessing filter, max q = 6.
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1,33:1 - prescaling to correct movie aspect.
VO: [xv] 704x576 => 768x576 Planar YV12
A:45238,4 V:45238,4 A-V:  0,000 ct: -0,799  5517/5517  12% 19% 35,3% 1098 0 2%
Too many video packets in the buffer: (4096 in 7757126 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Broken frame at 0x597598

Please visit and sign and http://www.ffii.org
-- Josef Wolf -- jw at raven.inka.de --

More information about the MPlayer-users mailing list