[MPlayer-users] SVN compile error undefined reference to `FT_GlyphSlot_Oblique'

Rinaldi J. Montessi montessir at bellsouth.net
Sun Nov 26 00:49:35 CET 2006

mplayer-users-request at mplayerhq.hu wrote:

> Message-ID: <200611252147.17306.eugeni.stepanov at gmail.com>
> Content-Type: text/plain;  charset="iso-8859-15"
> On Saturday 25 November 2006 19:14, Rinaldi J. Montessi wrote:
>> SVN compile error  undefined reference to `FT_GlyphSlot_Oblique'
>> Checked out revision 21221. (this AM)
>> I've tried to compile with freetype 2.1.9 and 2.1.10 (my research tells
>> me this is a libfreetype problem) but no joy with either version.  Have
>> I missed something?
>> libass/libass.a(ass_render.o)(.text+0x325d): In function `get_glyph':
>> : undefined reference to `FT_GlyphSlot_Oblique'
>> collect2: ld returned 1 exit status
>> make: *** [mplayer] Error 1
> This function is only used when compiling with freetype >= 2.1.10. If you are 
> getting the error with 2.1.9, there must be something wrong with your 
> freetype installation. Could it be that headers from 2.1.10 are used in both 
> cases ?
> There were similar problems with freetype 2.1.9 in FC4 (they were the reason 
> to limit using of FT_GlyphSlot_Oblique to freetype >= 2.1.10). What 
> distribution are you using ? Have you tried compiling freetype from source ?

Using slackware 11.0/Current.

Apparently mplayer compile uses the /usr/X11R6/lib's when compiling as 
opposed to /usr/lib.  And the package install does not overwrite those 
in X11R6, so you were correct.

Now compile is failing here:

/usr/bin/ld: cannot find -lfontconfig
collect2: ld returned 1 exit status
make: *** [mencoder] Error 1

even though configure finds fontconfig

Checking for fontconfig ... yes

I have fontconfig-2.4.1 installed.


More information about the MPlayer-users mailing list